Cannot write in NTFS partition in the latest release of Garuda Linux

Hello.
I cannot mount the NTFS partition with permission to write. Originally I mount it via Caja(Mate's File Manager,) but it didn't work, so I tried to add an /etc.fstab entry but still no luck. Could anyone tell me how to fix this?

Here is my fstab entry:

UUID=???????????????????        			  /mnt/Data      ntfs-3g   umask=0022,dmask=022,fmask=133,uid=1000,gid=1000 0 0 

And this is my inxi:

System:    Kernel: 5.15.6-zen2-1-zen x86_64 bits: 64 compiler: gcc v: 11.1.0
           parameters: BOOT_IMAGE=/@/boot/vmlinuz-linux-zen
           root=UUID=0c2a80f9-b872-4dfa-9e46-15cdf21d243e rw [email protected] quiet splash
           rd.udev.log_priority=3 vt.global_cursor_default=0 systemd.unified_cgroup_hierarchy=1
           loglevel=3
           Desktop: MATE 1.26.0 info: mate-panel wm: marco 1.26.0 vt: 7 dm: LightDM 1.30.0
           Distro: Garuda Linux base: Arch Linux
Machine:   Type: Desktop System: SYSTEM_ product: SYSTEM_PRODUCT_NAME v: N/A
           serial: <superuser required>
           Mobo: N/A model: N/A serial: <superuser required> UEFI: American Megatrends LLC.
           v: 5.19 date: 07/15/2021
Battery:   ID-1: BAT0 charge: 35.1 Wh (97.0%) condition: 36.2/39.7 Wh (91.2%) volts: 8.4
           min: 7.7 model: Intel SR 1 SR Real Battery type: Unknown serial: <filter>
           status: Discharging
CPU:       Info: Quad Core model: 11th Gen Intel Core i5-1130G7 bits: 64 type: MT MCP
           arch: Tiger Lake family: 6 model-id: 8C (140) stepping: 1 microcode: 88 cache:
           L1: 320 KiB L2: 5 MiB L3: 8 MiB
           flags: avx avx2 ht lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx bogomips: 28876
           Speed: 1172 MHz min/max: 400/4000 MHz Core speeds (MHz): 1: 1200 2: 1172 3: 1159
           4: 1156 5: 1201 6: 1160 7: 1180 8: 1149
           Vulnerabilities: Type: itlb_multihit status: Not affected
           Type: l1tf status: Not affected
           Type: mds status: Not affected
           Type: meltdown status: Not affected
           Type: spec_store_bypass mitigation: Speculative Store Bypass disabled via prctl
           Type: spectre_v1 mitigation: usercopy/swapgs barriers and __user pointer sanitization
           Type: spectre_v2 mitigation: Enhanced IBRS, IBPB: conditional, RSB filling
           Type: srbds status: Not affected
           Type: tsx_async_abort status: Not affected
Graphics:  Device-1: Intel driver: i915 v: kernel bus-ID: 00:02.0 chip-ID: 8086:9a40
           class-ID: 0300
           Display: x11 server: X.Org 1.21.1.1 compositor: marco v: 1.26.0 driver: loaded: intel
           unloaded: modesetting,vesa alternate: fbdev display-ID: :0 screens: 1
           Screen-1: 0 s-res: 2560x1600 s-dpi: 96 s-size: 677x423mm (26.7x16.7")
           s-diag: 798mm (31.4")
           Monitor-1: eDP1 res: 2560x1600 hz: 60 dpi: 722 size: 90x150mm (3.5x5.9")
           diag: 175mm (6.9")
           OpenGL: renderer: Mesa Intel Xe Graphics (TGL GT2) v: 4.6 Mesa 21.2.5
           direct render: Yes
Audio:     Device-1: Intel Tiger Lake-LP Smart Sound Audio driver: snd_hda_intel v: kernel
           alternate: snd_sof_pci_intel_tgl bus-ID: 00:1f.3 chip-ID: 8086:a0c8 class-ID: 0403
           Sound Server-1: ALSA v: k5.15.6-zen2-1-zen running: yes
           Sound Server-2: sndio v: N/A running: no
           Sound Server-3: JACK v: 1.9.19 running: no
           Sound Server-4: PulseAudio v: 15.0 running: no
           Sound Server-5: PipeWire v: 0.3.40 running: yes
Network:   Device-1: Intel Wi-Fi 6 AX201 driver: iwlwifi v: kernel bus-ID: 00:14.3
           chip-ID: 8086:a0f0 class-ID: 0280
           IF: wlo1 state: up mac: <filter>
           IF-ID-1: anbox0 state: down mac: <filter>
Bluetooth: Device-1: Intel AX201 Bluetooth type: USB driver: btusb v: 0.8 bus-ID: 3-10:2
           chip-ID: 8087:0026 class-ID: e001
           Report: bt-adapter ID: hci0 rfk-id: 1 state: up address: <filter>
Drives:    Local Storage: total: 953.87 GiB used: 106.42 GiB (11.2%)
           SMART Message: Required tool smartctl not installed. Check --recommends
           ID-1: /dev/nvme0n1 maj-min: 259:0 model: One-Netbook PCI-E 01TB SSD size: 953.87 GiB
           block-size: physical: 512 B logical: 512 B speed: 31.6 Gb/s lanes: 4 type: SSD
           serial: <filter> rev: EDFMB0.5 temp: 27.9 C scheme: GPT
Partition: ID-1: / raw-size: 150 GiB size: 150 GiB (100.00%) used: 42.91 GiB (28.6%) fs: btrfs
           dev: /dev/nvme0n1p4 maj-min: 259:4
           ID-2: /boot/efi raw-size: 300 MiB size: 299.4 MiB (99.80%) used: 576 KiB (0.2%)
           fs: vfat dev: /dev/nvme0n1p10 maj-min: 259:10
           ID-3: /home raw-size: 150 GiB size: 150 GiB (100.00%) used: 42.91 GiB (28.6%)
           fs: btrfs dev: /dev/nvme0n1p4 maj-min: 259:4
           ID-4: /var/log raw-size: 150 GiB size: 150 GiB (100.00%) used: 42.91 GiB (28.6%)
           fs: btrfs dev: /dev/nvme0n1p4 maj-min: 259:4
           ID-5: /var/tmp raw-size: 150 GiB size: 150 GiB (100.00%) used: 42.91 GiB (28.6%)
           fs: btrfs dev: /dev/nvme0n1p4 maj-min: 259:4
Swap:      Kernel: swappiness: 133 (default 60) cache-pressure: 100 (default)
           ID-1: swap-1 type: zram size: 15.36 GiB used: 0 KiB (0.0%) priority: 100
           dev: /dev/zram0
Sensors:   System Temperatures: cpu: 43.0 C mobo: N/A
           Fan Speeds (RPM): N/A
Info:      Processes: 320 Uptime: 6m wakeups: 0 Memory: 15.36 GiB used: 3.91 GiB (25.5%)
           Init: systemd v: 249 tool: systemctl Compilers: gcc: 11.1.0 clang: 13.0.0
           Packages: 1688 pacman: 1669 lib: 421 flatpak: 19 Shell: fish v: 3.3.1 default: Zsh
           v: 5.8 running-in: alacritty inxi: 3.3.09
 already attempted to solve your problem.***
2 Likes

Welcome to the forum, should also post from the terminal:

lsblk
1 Like

Hi there, here is my lsblk

NAME         MAJ:MIN RM   SIZE RO TYPE MOUNTPOINTS
loop0          7:0    0 442.6M  1 loop /var/lib/anbox/rootfs
zram0        254:0    0  15.4G  0 disk [SWAP]
nvme0n1      259:0    0 953.9G  0 disk
├─nvme0n1p1  259:1    0   100M  0 part
├─nvme0n1p2  259:2    0   128M  0 part
├─nvme0n1p3  259:3    0   150G  0 part
├─nvme0n1p4  259:4    0   150G  0 part /var/lib/anbox/rootfs/data
│                                      /var/lib/anbox/rootfs/cache
│                                      /var/tmp
│                                      /var/log
│                                      /var/cache
│                                      /home
│                                      /root
│                                      /.snapshots
│                                      /srv
│                                      /
├─nvme0n1p5  259:5    0 151.6G  0 part
├─nvme0n1p6  259:6    0   300M  0 part
├─nvme0n1p7  259:7    0   300M  0 part
├─nvme0n1p8  259:8    0   300M  0 part
├─nvme0n1p9  259:9    0   300M  0 part
├─nvme0n1p10 259:10   0   300M  0 part /boot/efi
├─nvme0n1p11 259:11   0   643M  0 part
└─nvme0n1p12 259:12   0   500G  0 part /mnt/Data

Also need

cfdisk /dev/nvme0n1

Make sure not to make any changes, just need to find out where your windows data is.
Select quit after you copy and paste the info.

1 Like

Is this ntfs drive part of an actual Windows machine? If so Windows may have not cleared the dirty bit (which is common) when it assumes it's being rebooted.

Post:

sudo blkid -o list
1 Like

I am not sure about it, my Windows is installed on nvme0n1p3 with BitLocker on so I never bothered to mount it. I'm trying to mount nvme0n1p12 (without BitLocker) where my steam library sits.

device             fs_type  label     mount point            UUID
--------------------------------------------------------------------------------------------------
/dev/nvme0n1p9     vfat               (not mounted)          E236-C0B7
/dev/nvme0n1p11    ntfs               (not mounted)          01D7E2FAED29A5F0
/dev/nvme0n1p7     vfat               (not mounted)          8D0F-4420
/dev/nvme0n1p5     btrfs              (not mounted)          2ea21b03-8e6c-4a37-a582-92fc51c2e684
/dev/nvme0n1p3     BitLocker          (not mounted)
/dev/nvme0n1p1     vfat     SYSTEM    (not mounted)          0447-D562
/dev/nvme0n1p12    ntfs     Data      /mnt/Data              01D7E2FAEC78F390
/dev/nvme0n1p8     vfat               (not mounted)          A6ED-8A10
/dev/nvme0n1p10    vfat               /boot/efi              C286-D0FA
/dev/nvme0n1p6     vfat               (not mounted)          6EB6-6800
/dev/nvme0n1p4     btrfs              (in use)               0c2a80f9-b872-4dfa-9e46-15cdf21d243e
/dev/nvme0n1p2                        (not mounted)
/dev/loop0         squashfs           /var/lib/anbox/rootfs
/dev/zram0         swap     zram0     [SWAP]                 fdf71125-036f-4f22-8dd6-1c232c381f21

If the drive is regularly mounted on a real windows install ensure you shut down rather than reboot other wise Windows will leave all its drives set as dirty and Linux will always mount read only because the drive is marked as dirty and unsafe to write to.

3 Likes

Holy S! thank you XD
That's so dirty for Micro$oft. I just booted into windows and made a proper shutdown, then booted into Garuda, and now I have the permission to write!

2 Likes

If you persist with dual-booting with Windows in contrary to the wishes of Garuda Linux developers, turn-off Windows fast startup. That way, you lessen issues with drives.

2 Likes

1 Like

Just to clarify, the distro does not condemn users if they wish to dual boot with Windows. We simply inform users that if they go down that road they should be prepared to be self supporting. Windows can create many issues when dual booting. It is simply felt that the distro devs have enough support issues without having to deal with Windows issues as well. The position of the distro is simply that if you dual boot there can be no expectation of official support from distro devs.

6 Likes

Windows can create many issues with single booting...if you drift my catch :wink:

1 Like

Yes a proper shutdown on Windows fixes the problem... but you could also just do:

sudo umount /dev/${DRIVE}
sudo ntfsfix /dev/${DRIVE}
sudo mount -a

https://wiki.archlinux.org/title/NTFS-3G

Damaged NTFS filesystems

If an NTFS filesystem has errors on it, NTFS-3G will mount it as read-only. To fix an NTFS filesystem, load Windows and run its disk checking program, chkdsk.

Note that ntfsfix can only repair some errors. If it fails, chkdsk will probably succeed.

To fix the NTFS file system, the device must already be unmounted. For example, to fix an NTFS partition residing in /dev/sda2:

# umount /dev/sda2
# ntfsfix /dev/sda2
Mounting volume... OK
Processing of $MFT and $MFTMirr completed successfully.
NTFS volume version is 3.1.
NTFS partition /dev/sda2 was processed successfully.
# mount /dev/sda2

If all went well, the volume will now be writable.

3 Likes

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.