Cannot update/launch for thunderbird-appmenu

run sudo pacman -Syu
firedragon and some other programms were not updated.
tried updating them manually one by one
while updating thunderbird-appmenu, error occurs. decided to reinstall later
updated everything else
tried to install thunderbird-appmenu
output:

resolving dependencies...
warning: cannot resolve "libicui18n.so=70-64", a dependency of "thunderbird-appmenu"
warning: cannot resolve "libicuuc.so=70-64", a dependency of "thunderbird-appmenu"

:: The following package cannot be upgraded due to unresolvable dependencies:

(0/0) thunderbird-appmenu
error: failed to prepare transaction (could not satisfy dependencies) 

:: unable to satisfy dependency 'libicui18n.so=70-64' required by thunderbird-appmenu


:: unable to satisfy dependency 'libicuuc.so=70-64' required by thunderbird-appmenu

cannot launch firedragon.

(i've uncommented XferCommand = /usr/bin/curl -L -C - -f -o %o %u /etc/pacman.conf because i was facing maximum size limit error previously. i don't think that has to do anything with this error)

inxi -faz: Carrot inxi -Faz

I had something similar happen.

  1. Are you using the chaotic-aur version?

  2. Try refreshing the repos or hit the system upgrade button in Garuda's Welcome app and try updating again.

Here is my thread for reference;

1 Like
  1. yeah, tried installing from octopi. that is listed as chaotic-aur version
  2. already uninstalled this package, updating wont work :frowning:

RodneyCK remind me about garuda welcome. well, i removed that, using garuda assistant for everything now actually.
and i found that from garuda assistant pacman mirrorlist doesn't get updated. it says updated but if i open that again, i see the previous list.

Garuda Welcome is a way to get to all the Garuda apps, including Garuda Assistant, which is what you want in this case.

As far as the mirrorlist not getting updated, that is odd. There is a separate app in Garuda Assistant for refreshing mirrorlist, 'Refresh MIrrorlist (Reflector-Simple),' try that, then pull up a terminal and type 'update', then enter.

1 Like

i am working around manually from etc/pacman.d/mirrorlist
the app you mention is the same app that pops up while working in garuda assistant.

Haven't a clue what you mean here.

the app you mention is the same app that pops up while working in garuda assistant.

So, have you tried selecting different countries? What are getting, an error???

Edit to add: I am seeing a lot of recent post with different 'libicuiXXX" errors. I am assuming (no expert) that the recent update has caused this and maybe it is the maintainers of various apps that have not pushed an update out yet which is causing all these issues? :man_shrugging:

1 Like
  1. i mean i solved that issue by editing mirrorlist manually
  2. no error shown
  3. yeah, i think it is a dev side issue. waiting lets see what happens.
1 Like

There is an app 'garuda-update' that fixed it.

In terminal use 'update'

Only on KDE, for me, Kate crash and more?, i3wm is fine.

1 Like

Thanks, and yes, several posts in the last few hours, all different apps and different versions of libicuiXXX causing issues. Hopefully they all hit the update again.

2 Likes
pacman -Qi garuda-update
Name                     : garuda-update
Version                  : 1.4.0-1
Beschreibung             : The Garuda Linux update command, in a separate package to allow separate updating
Architektur              : any
URL                      : Nichts
Lizenzen                 : GPL
Gruppen                  : Nichts
Stellt bereit            : Nichts
Hängt ab von             : coreutils  sed  awk  pacman  wget
Optionale Abhängigkeiten : Nichts
Benötigt von             : garuda-common-settings
Optional für             : Nichts
In Konflikt mit          : Nichts
Ersetzt                  : Nichts
Installationsgröße       : 2,74 KiB
Packer                   : Chaotic-AUR Wild Bear Node <[email protected]>
Erstellt am              : Fr 19 Nov 2021 17:39:41 CET
Installiert am           : Fr 19 Nov 2021 21:07:22 CET
Installationsgrund       : Installiert als Abhängigkeit eines anderen Pakets
Installations-Skript     : Nein
Verifiziert durch        : Signatur

well, it seems when i tried it, i actually fixed my main issue, lmao. so i retried to install and everything is fine again. thank you both. :smiley:

1 Like

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.