Cannot mix incompatible Qt library x with this library y

Hey there,
I'm facing some trouble with a few Qt programs (bauh, Raven Reader): When I try to launch them, they crash with the error Cannot mix incompatible Qt library x with this library y If e.g. x is 5.15.3 and y is 5.15.4, the crash is understandable, though if I then downgrade qt5-base to 5.15.3 the error now shows x being 5.15.4 and y being 5.15.3 - HUH? Like what?
Can someone explain this to me?
Thanks!

System:
  Kernel: 5.17.7-zen1-1-zen arch: x86_64 bits: 64 compiler: gcc v: 12.1.0
    parameters: BOOT_IMAGE=/@/boot/vmlinuz-linux-zen
    root=UUID=6e6211b4-cfb4-44c0-8970-5e4a826e0c5e rw [email protected]
    quiet splash rd.udev.log_priority=3 vt.global_cursor_default=0
    systemd.unified_cgroup_hierarchy=1 loglevel=3 sysrq_always_enabled=1
    iommu=soft
  Desktop: wayfire v: 0.8.0-94f15048 info: waybar vt: 1 dm: SDDM
    Distro: Garuda Linux base: Arch Linux
Machine:
  Type: Desktop System: Gigabyte product: AX370-Gaming 3 v: N/A
    serial: <superuser required>
  Mobo: Gigabyte model: AX370-Gaming 3-CF v: x.x
    serial: <superuser required> UEFI: American Megatrends v: F50a
    date: 11/27/2019
CPU:
  Info: model: AMD Ryzen 5 2600X bits: 64 type: MT MCP arch: Zen+
    family: 0x17 (23) model-id: 8 stepping: 2 microcode: 0x800820D
  Topology: cpus: 1x cores: 6 tpc: 2 threads: 12 smt: enabled cache:
    L1: 576 KiB desc: d-6x32 KiB; i-6x64 KiB L2: 3 MiB desc: 6x512 KiB
    L3: 16 MiB desc: 2x8 MiB
  Speed (MHz): avg: 3605 high: 4180 min/max: 2200/3600 boost: enabled
    scaling: driver: acpi-cpufreq governor: performance cores: 1: 3359 2: 4048
    3: 2614 4: 2436 5: 4056 6: 4180 7: 3860 8: 4112 9: 2791 10: 3514 11: 4144
    12: 4151 bogomips: 86228
  Flags: avx avx2 ht lm nx pae sse sse2 sse3 sse4_1 sse4_2 sse4a ssse3 svm
  Vulnerabilities:
  Type: itlb_multihit status: Not affected
  Type: l1tf status: Not affected
  Type: mds status: Not affected
  Type: meltdown status: Not affected
  Type: spec_store_bypass
    mitigation: Speculative Store Bypass disabled via prctl
  Type: spectre_v1
    mitigation: usercopy/swapgs barriers and __user pointer sanitization
  Type: spectre_v2
    mitigation: Retpolines, IBPB: conditional, STIBP: disabled, RSB filling
  Type: srbds status: Not affected
  Type: tsx_async_abort status: Not affected
Graphics:
  Device-1: AMD Baffin [Radeon RX 550 640SP / 560/560X] vendor: ASUSTeK
    driver: amdgpu v: kernel pcie: gen: 3 speed: 8 GT/s lanes: 8 ports:
    active: DVI-D-1,HDMI-A-1 empty: DP-1 bus-ID: 08:00.0 chip-ID: 1002:67ff
    class-ID: 0300
  Device-2: Logitech Webcam C270 type: USB driver: snd-usb-audio,uvcvideo
    bus-ID: 1-2:3 chip-ID: 046d:0825 class-ID: 0102 serial: <filter>
  Display: wayland server: X.org v: 1.21.1.3 with: Xwayland v: 22.1.1
    compositor: wayfire v: 0.8.0-94f15048 driver: X: loaded: amdgpu
    unloaded: modesetting alternate: fbdev,vesa gpu: amdgpu d-rect: 3600x1200
    display-ID: 1
  Monitor-1: DVI-D-1 pos: right res: 1920x1200 size: N/A modes: N/A
  Monitor-2: HDMI-A-1 pos: primary,left res: 1680x1050 size: N/A modes: N/A
  OpenGL: renderer: AMD Radeon RX 560 Series (polaris11 LLVM 13.0.1 DRM
    3.44 5.17.7-zen1-1-zen)
    v: 4.6 Mesa 22.0.3 direct render: Yes
Audio:
  Device-1: AMD Baffin HDMI/DP Audio [Radeon RX 550 640SP / 560/560X]
    vendor: ASUSTeK driver: snd_hda_intel v: kernel pcie: gen: 3 speed: 8 GT/s
    lanes: 8 bus-ID: 08:00.1 chip-ID: 1002:aae0 class-ID: 0403
  Device-2: AMD Family 17h HD Audio vendor: Gigabyte driver: snd_hda_intel
    v: kernel pcie: gen: 3 speed: 8 GT/s lanes: 16 bus-ID: 0a:00.3
    chip-ID: 1022:1457 class-ID: 0403
  Device-3: Logitech Webcam C270 type: USB driver: snd-usb-audio,uvcvideo
    bus-ID: 1-2:3 chip-ID: 046d:0825 class-ID: 0102 serial: <filter>
  Device-4: C-Media USB Microphone type: USB
    driver: hid-generic,snd-usb-audio,usbhid bus-ID: 3-4:4 chip-ID: 0d8c:9700
    class-ID: 0300 serial: <filter>
  Sound Server-1: ALSA v: k5.17.7-zen1-1-zen running: yes
  Sound Server-2: sndio v: N/A running: no
  Sound Server-3: PulseAudio v: 15.0 running: no
  Sound Server-4: PipeWire v: 0.3.51 running: yes
Network:
  Device-1: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet
    vendor: Gigabyte driver: r8169 v: kernel pcie: gen: 1 speed: 2.5 GT/s
    lanes: 1 port: f000 bus-ID: 03:00.0 chip-ID: 10ec:8168 class-ID: 0200
  IF: eno1 state: up speed: 1000 Mbps duplex: full mac: <filter>
Bluetooth:
  Device-1: Broadcom BCM20702A0 Bluetooth 4.0 type: USB driver: btusb v: 0.8
    bus-ID: 1-3:4 chip-ID: 0a5c:21e8 class-ID: fe01 serial: <filter>
  Report: bt-adapter ID: hci0 rfk-id: 3 state: up address: <filter>
Drives:
  Local Storage: total: 2.96 TiB used: 1.09 TiB (36.9%)
  SMART Message: Unable to run smartctl. Root privileges required.
  ID-1: /dev/sda maj-min: 8:0 vendor: Samsung model: SSD 860 EVO 1TB
    size: 931.51 GiB block-size: physical: 512 B logical: 512 B speed: 6.0 Gb/s
    type: SSD serial: <filter> rev: 4B6Q scheme: GPT
  ID-2: /dev/sdb maj-min: 8:16 vendor: Samsung model: SSD 860 EVO 250GB
    size: 232.89 GiB block-size: physical: 512 B logical: 512 B speed: 6.0 Gb/s
    type: SSD serial: <filter> rev: 1B6Q scheme: GPT
  ID-3: /dev/sdc maj-min: 8:32 vendor: Western Digital
    model: WD20EFRX-68EUZN0 size: 1.82 TiB block-size: physical: 4096 B
    logical: 512 B speed: 6.0 Gb/s type: HDD rpm: 5400 serial: <filter>
    rev: 0A82 scheme: GPT
Partition:
  ID-1: / raw-size: 195.03 GiB size: 195.03 GiB (100.00%)
    used: 140.39 GiB (72.0%) fs: btrfs dev: /dev/sda1 maj-min: 8:1
  ID-2: /boot/efi raw-size: 301 MiB size: 300.4 MiB (99.79%)
    used: 576 KiB (0.2%) fs: vfat dev: /dev/sda2 maj-min: 8:2
  ID-3: /home raw-size: 736.18 GiB size: 736.18 GiB (100.00%)
    used: 172.61 GiB (23.4%) fs: btrfs dev: /dev/sda3 maj-min: 8:3
  ID-4: /var/log raw-size: 195.03 GiB size: 195.03 GiB (100.00%)
    used: 140.39 GiB (72.0%) fs: btrfs dev: /dev/sda1 maj-min: 8:1
  ID-5: /var/tmp raw-size: 195.03 GiB size: 195.03 GiB (100.00%)
    used: 140.39 GiB (72.0%) fs: btrfs dev: /dev/sda1 maj-min: 8:1
Swap:
  Kernel: swappiness: 133 (default 60) cache-pressure: 100 (default)
  ID-1: swap-1 type: zram size: 31.3 GiB used: 2.24 GiB (7.2%)
    priority: 100 dev: /dev/zram0
Sensors:
  System Temperatures: cpu: N/A mobo: N/A gpu: amdgpu temp: 46.0 C
  Fan Speeds (RPM): N/A gpu: amdgpu fan: 1504
Info:
  Processes: 412 Uptime: 11h 8m wakeups: 21 Memory: 31.3 GiB
  used: 10.94 GiB (34.9%) Init: systemd v: 250 tool: systemctl Compilers:
  gcc: 12.1.0 clang: 13.0.1 Packages: 2136 apt: 0 pacman: 2120 lib: 532
  flatpak: 16 Shell: Zsh v: 5.8.1 running-in: alacritty inxi: 3.3.15
Garuda (2.6.3-2):
  System install date:     2021-12-28
  Last full system update: 2022-05-15 ↻
  Is partially upgraded:   No
  Relevant software:       NetworkManager
  Windows dual boot:       No/Undetected
  Snapshots:               Snapper
  Failed units:

Ah crap - Qt5 5.15.4 its on repos, and after update, Qt apps doesnt work (I added the artix mirrors because of archlinux-tweak-tool

This is weird

Restored a backup. I wish garuda update had an option to ignore packages, if it forces me to update anyways.

I literally can't update my system, even after disabling the mirror, because of the dumb sweet theme dependency problem

If you use

garuda-update

it will do it for you automatically.

:: sweet-theme-full-git and sweet-kde-git are in conflict (sweet-kde). Remove sweet-kde-git? [y/N] y
:: sweet-theme-full-git and sweet-cursor-theme-git are in conflict. Remove sweet-cursor-theme-git? [y/N] y
:: sweet-theme-full-git and kvantum-theme-sweet-git are in conflict. Remove kvantum-theme-sweet-git? [y/N] y
:: sweet-theme-full-git and sweet-gtk-theme-dark are in conflict. Remove sweet-gtk-theme-dark? [y/N] y
:: sweet-theme-full-git and plasma5-theme-sweet-git are in conflict. Remove plasma5-theme-sweet-git? [y/N] y

Please do not post like you are in a chat room. You can edit your post as long as no one replies.

And use search function first.

I did read that forum post a while ago. The dumb part is, that garuda-update forces me to install stuff that inevitably breaks my system, but updating without it also does the same thing, apparently.
I solved the dependency problem with pacman -Sdd sweet-theme-full-git (all the garuda tools apart from the assistant are broken on wayfire anyways. Cool stuf, but hella useless like this) to avoid garuda update. That worked, but apparently garuda-update is required for the new grub-silent (Why tho, I want to see grub, I need it for backups) package to install properly...

I am stuck, I have no clue what the right approach is now.

Actually we might add a switch for packages to ignore @TNE :eyes:

3 Likes

You mean Rdd, right?

Sdd, the packages were merged into one I think

aaaa, one of these 200 packages breaks sddm so it crashes upon boot. I don't know which it is, but it's probably qt related. this is dumb - See https://termbin.com/slplo

Help me, IDK this Sdd

https://wiki.archlinux.de/title/Pacman#Pacman-Datenbank

Not in the S list :slight_smile:

@UltraBlack I highly encourage you to follow the following steps:

  1. Restore a snapshot from before your funny little -Sdd adventure, which I'm sureeee also totally didn't involve doing --overwrite at all :stuck_out_tongue:
  2. Reboot
  3. Delete the snapshot restore btrfs subvolume, you don't want it to start using up space over time because it doesn't get automatically deleted.
  4. Add the package you want to ignore to /etc/pacman.conf's ignore statement
  5. garuda-update

But then, you should be asking yourself if ignoring package updates is really a solution to your problem in the first place.

Take a look at the pacman man page, paying special attention to the following linked section: pacman man page

I meannnn I guess? But I don't really want to encourage this kinda stuff, because this just results in a partial upgrade.

5 Likes

This may or may not apply to you, maybe your issue was indeed the sweet themes, and you may in any case need to reinstall the distro or restore a snapshot.

However, but I'm just wondering if the original reason for that "incompatible Qt library" error message was something much simpler, in view of the fact that you appear from your posts to favour ignoring some upgrades.

I had a similar message appear in my Manjaro XFCE install when I tried to open qmplay2 (AUR).

Originally I thought it had something to do with qmplay2 being built on a newer qt5 base and maybe Manjaro Stable was still on an older qt version in between its 3-weekly updates (since I had no problems in Artix or Anarchy), but checking all the dependencies showed it was not the case. Once I realised that Manjaro Settings Manager (native to Manjaro) was also affected, I knew that could not be the reason.

Turns out the simple cause of it was that qt5-styleplugins [used in my old Manjaro install to theme/set the environment for qt apps] was no longer maintained by Arch/Manjaro and had been pushed to AUR, and Manjaro was theming Qt apps on their gtk desktops a different way going forward. I had been too lazy to update it from AUR or remove it, since I mistakenly thought it was no longer needed and not in use.

Once I updated it, all the Qt applications had no issues opening again.

So the question is: Are you ignoring the update of some package, AUR or otherwise (how about from the artix repo you enabled)? Do you perhaps have a setup where theming of Qt apps is based on an older qt base?

PS. I would also advise against partial upgrades.

2 Likes

I didn't actually. Sdd ignores package dependencies, not conflicts. I am not stupid.

I tried that, but the update still causes the same behavior. I am gonna update once more, but this time I am gonna use LY, and see if it's just a problem with SDDM

EDIT: Did a reboot, and tried LY, again the error from above. Seems like sddm crashed because of that.

Yeah, this is definitely the case. Something breaks so badly, that nothing works afterwards.

I'm not ignoring any package from artix currently. As I said, I am only using it for the archlinux-tweak-tool (which refuses to open because I am on wayland, bruh)

I have no idea, how I would check if I am using non-qt5 or qt6 theming, but I had qt5-styleplugins installed already. I tried uninstalling that, but it didn't help at all.

I am gonna try clearing the package cache, because that might be breaking the updates, even without the artix mirrors, and then update again. Wish me luck I guess.

EDIT 2: No wonder nothing is helping, qt5-base is also borked in the official repos:

EDIT3: Success! (Kinda) - I added qt5* to the ignorepkg list and this allowed me to update without any problems. I will keep it like this for a while and just check on qt5 from time to time, but until this is resolved or I run into other issues, I am gonna keep it like this. I know that this is a very bad and not recommended solution, but it's my best bet at the moment, to finally allow more updates again. I will keep this thread open in case something else happens (If I mark this as solved, the bot will lock it way sooner than otherwise - Tell me if I should just open a new thread, or if that will be ignored, because of the partial update problem)
Just to round this up, here is my optinion on QT: I hate it. it refuses to theme properly on non-big-DEs, it's clunky, unreliable on wayland (Please rewrite your tools in gtk, I literally can't open them, apart from garuda-assistant). Sadly a lot of programs depend on it, so this is a bad situation. If I could, I would just completely remove it from my system.
Thanks to all of you, who tried to help me. I will probably be back in a while :wink:

Noticed that qt5-base got updated to 146 finally so I updated that and had no problems at all

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.