Cannot make network printing work on latest Garuda installation

I have had my Garuda Dragonized installation work flawlessly before in every regard, including network printing. In for the it was the only Arch distro where this worked otb. The beginner distros (Mint, Zorin, etc, worked easily).

Now I am having the same issue printing to my network printer (HP 4250). The add-printer function discovers the printer, but all of the drivers suggested the 4250 end up giving the same error the "printer busy" or "cannot communicate with the printer". I have the HP device manager installed and have followed the same procedures as the last time when everything worked.

I'm a Linux noob of the lowest degree, but the CUPS thing has always been a topic I have heard about issues with. I am over my head and pay grade here.

Don't know if there is any way to give remote access into my system, but would pay for that kind of help.

Any kind of help would be appreciated!

Vincent

Hello.

Post your terminal/konsole in- and output as text (no pictures) from:

inxi -Faz

Without it, you will not receive any help from the Garuda team or your topic is likely to be closed without notice.

Before you open a new help request, read relevant sections of the Arch and Garuda wiki.
Thoroughly search your issue and any error messages in the forum and on the web.

Report everything you have already attempted to solve your problem.

Is there something about this you don't understand?

3 Likes

Make sure you have printer-support installed

sudo Pacman -Syu printer-support
3 Likes

I installed printer support during the initial installation. When I try to add a network printer the system sees it and recommends the specific (4) different drivers for it.

None of them will print but return errors.

Here is the terminal output after trying the command you recommended..

╭─[email protected] in ~
╰─λ sudo Pacman -Syu printer-support
[sudo] password for watchman:
sudo: Pacman: command not found
McFly: Importing shell history for the first time. This may take a minute or two...done.

pacman not Pacman, just a typo.

It was already installed: see (12/36)

:: Running pre-transaction hooks...
(1/1) Performing snapper pre snapshots for the following configurations...
==> root: 39
:: Processing package changes...
( 1/36) upgrading libldap [------------------------------------] 100%
( 2/36) upgrading krb5 [------------------------------------] 100%
( 3/36) upgrading audit [------------------------------------] 100%
( 4/36) upgrading qpdf [------------------------------------] 100%
( 5/36) upgrading cryptsetup [------------------------------------] 100%
( 6/36) upgrading libelf [------------------------------------] 100%
( 7/36) upgrading cups-filters [------------------------------------] 100%
( 8/36) upgrading ldb [------------------------------------] 100%
( 9/36) upgrading smbclient [------------------------------------] 100%
(10/36) upgrading gnupg [------------------------------------] 100%
(11/36) upgrading samba [------------------------------------] 100%
(12/36) reinstalling printer-support

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.