Cannot change resolution for my screen

Hello , i installed the garuda KDE Dragonized today . All things work perfect, i have 2 monitor but i cant change the resolution from laptop screen. This laptop have AMD RADEON GPU and a NVIDIA GPU.

╭─colmanetti@colmanetti in ~
╰─λ garuda-inxi

System:
Kernel: 6.4.3-zen1-1-zen arch: x86_64 bits: 64 compiler: gcc v: 13.1.1
parameters: BOOT_IMAGE=/@/boot/vmlinuz-linux-zen
root=UUID=9fe5b891-e398-4778-b740-75e43cc85451 rw rootflags=subvol=@
quiet quiet rd.udev.log_priority=3 vt.global_cursor_default=0
resume=UUID=7d21ad9f-b352-4f9b-9ed6-b3b3c9d7d642 loglevel=3 ibt=off
Desktop: KDE Plasma v: 5.27.6 tk: Qt v: 5.15.10 wm: kwin_x11 vt: 2
dm: SDDM Distro: Garuda Linux base: Arch Linux
Machine:
Type: Laptop System: ASUSTeK product: ROG Zephyrus G15 GA503RM_GA503RM
v: 1.0 serial: <superuser required>
Mobo: ASUSTeK model: GA503RM v: 1.0 serial: <superuser required>
UEFI: American Megatrends LLC. v: GA503RM.307 date: 03/28/2022
Battery:
ID-1: BAT1 charge: 66.3 Wh (76.3%) condition: 86.9/90.2 Wh (96.3%)
volts: 16.9 min: 15.9 model: ASUS A32-K55 type: Li-ion serial: N/A
status: charging
Device-1: hidpp_battery_0 model: Logitech G604 Wireless Gaming Mouse
serial: <filter> charge: 55% (should be ignored) rechargeable: yes
status: discharging
CPU:
Info: model: AMD Ryzen 9 6900HS with Radeon Graphics bits: 64 type: MT MCP
arch: Zen 3+ gen: 4 level: v3 note: check built: 2022 process: TSMC n6 (7nm)
family: 0x19 (25) model-id: 0x44 (68) stepping: 1 microcode: 0xA404101
Topology: cpus: 1x cores: 8 tpc: 2 threads: 16 smt: enabled cache:
L1: 512 KiB desc: d-8x32 KiB; i-8x32 KiB L2: 4 MiB desc: 8x512 KiB
L3: 16 MiB desc: 1x16 MiB
Speed (MHz): avg: 1650 high: 3300 min/max: 1600/4934 boost: enabled
scaling: driver: acpi-cpufreq governor: schedutil cores: 1: 1600 2: 1589
3: 1733 4: 1401 5: 1600 6: 3300 7: 1389 8: 1366 9: 1393 10: 1397 11: 1600
12: 1600 13: 1600 14: 1600 15: 1637 16: 1600 bogomips: 105409
Flags: avx avx2 ht lm nx pae sse sse2 sse3 sse4_1 sse4_2 sse4a ssse3 svm
Vulnerabilities: <filter>
Graphics:
Device-1: NVIDIA GA106M [GeForce RTX 3060 Mobile / Max-Q] vendor: ASUSTeK
driver: nvidia v: 535.54.03 alternate: nouveau,nvidia_drm non-free: 535.xx+
status: current (as of 2023-07) arch: Ampere code: GAxxx
process: TSMC n7 (7nm) built: 2020-22 pcie: gen: 4 speed: 16 GT/s lanes: 8
link-max: lanes: 16 bus-ID: 01:00.0 chip-ID: 10de:2520 class-ID: 0300
Device-2: AMD Rembrandt [Radeon 680M] vendor: ASUSTeK driver: amdgpu
v: kernel arch: RDNA-2 code: Navi-2x process: TSMC n7 (7nm) built: 2020-22
pcie: gen: 4 speed: 16 GT/s lanes: 16 ports: active: DP-2,eDP-1
empty: DP-1, DP-3, DP-4, DP-5, DP-6, DP-7, DP-8 bus-ID: 06:00.0
chip-ID: 1002:1681 class-ID: 0300 temp: 42.0 C
Device-3: IMC Networks USB2.0 HD UVC WebCam driver: uvcvideo type: USB
rev: 2.0 speed: 480 Mb/s lanes: 1 mode: 2.0 bus-ID: 5-1:2 chip-ID: 13d3:56eb
class-ID: fe01 serial: <filter>
Device-4: Realtek USB Camera driver: uvcvideo type: USB rev: 2.0
speed: 480 Mb/s lanes: 1 mode: 2.0 bus-ID: 7-1.2.3.1.2:12 chip-ID: 0bda:5844
class-ID: 0e02 serial: <filter>
Display: x11 server: X.Org v: 21.1.8 with: Xwayland v: 23.1.2
compositor: kwin_x11 driver: X: loaded: amdgpu,nvidia
unloaded: modesetting,nouveau alternate: fbdev,nv,vesa dri: radeonsi
gpu: amdgpu display-ID: :0 screens: 1
Screen-1: 0 s-res: 6000x1440 s-dpi: 96 s-size: 1587x381mm (62.48x15.00")
s-diag: 1632mm (64.26")
Monitor-1: DP-2 mapped: DisplayPort-1 pos: primary,right
model: LG (GoldStar) ULTRAWIDE serial: <filter> built: 2023 res: 3440x1440
hz: 85 dpi: 109 gamma: 1.2 size: 800x334mm (31.5x13.15")
diag: 867mm (34.1") modes: max: 3440x1440 min: 640x480
Monitor-2: eDP-1 mapped: eDP pos: left model: BOE Display 0x0a07
built: 2021 res: 2560x1440 hz: 165 dpi: 189 gamma: 1.2
size: 344x194mm (13.54x7.64") diag: 395mm (15.5") ratio: 16:9
modes: 2560x1440
API: OpenGL v: 4.6 Mesa 23.1.3 renderer: AMD Radeon Graphics (rembrandt
LLVM 15.0.7 DRM 3.52 6.4.3-zen1-1-zen) direct-render: Yes
Audio:
Device-1: NVIDIA GA106 High Definition Audio vendor: ASUSTeK
driver: snd_hda_intel v: kernel pcie: gen: 4 speed: 16 GT/s lanes: 8
link-max: lanes: 16 bus-ID: 01:00.1 chip-ID: 10de:228e class-ID: 0403
Device-2: AMD Rembrandt Radeon High Definition Audio vendor: ASUSTeK
driver: snd_hda_intel v: kernel pcie: gen: 4 speed: 16 GT/s lanes: 16
bus-ID: 06:00.1 chip-ID: 1002:1640 class-ID: 0403
Device-3: AMD ACP/ACP3X/ACP6x Audio Coprocessor vendor: ASUSTeK
driver: snd_pci_acp6x v: kernel alternate: snd_pci_acp3x, snd_rn_pci_acp3x,
snd_pci_acp5x, snd_acp_pci, snd_rpl_pci_acp6x, snd_pci_ps,
snd_sof_amd_renoir, snd_sof_amd_rembrandt pcie: gen: 4 speed: 16 GT/s
lanes: 16 bus-ID: 06:00.5 chip-ID: 1022:15e2 class-ID: 0480
Device-4: AMD Family 17h/19h HD Audio vendor: ASUSTeK
driver: snd_hda_intel v: kernel pcie: gen: 4 speed: 16 GT/s lanes: 16
bus-ID: 06:00.6 chip-ID: 1022:15e3 class-ID: 0403
Device-5: Generalplus Usb MIC driver: hid-generic,snd-usb-audio,usbhid
type: USB rev: 1.1 speed: 12 Mb/s lanes: 1 mode: 1.1 bus-ID: 7-1.2.3.1.1:9
chip-ID: 1b3f:2008 class-ID: 0300
Device-6: C-Media Blue Snowball driver: hid-generic,snd-usb-audio,usbhid
type: USB rev: 1.1 speed: 12 Mb/s lanes: 1 mode: 1.1 bus-ID: 7-1.2.3.4:13
chip-ID: 0d8c:0005 class-ID: 0300 serial: <filter>
API: ALSA v: k6.4.3-zen1-1-zen status: kernel-api tools: N/A
Server-1: PipeWire v: 0.3.73 status: active with: 1: pipewire-pulse
status: active 2: wireplumber status: active 3: pipewire-alsa type: plugin
4: pw-jack type: plugin tools: pactl,pw-cat,pw-cli,wpctl
Network:
Device-1: Realtek RTL8125 2.5GbE vendor: ASUSTeK driver: r8169 v: kernel
pcie: gen: 2 speed: 5 GT/s lanes: 1 port: e000 bus-ID: 02:00.0
chip-ID: 10ec:8125 class-ID: 0200
IF: eno1 state: down mac: <filter>
Device-2: MEDIATEK MT7922 802.11ax PCI Express Wireless Network Adapter
vendor: Foxconn driver: mt7921e v: kernel pcie: gen: 2 speed: 5 GT/s
lanes: 1 bus-ID: 03:00.0 chip-ID: 14c3:0616 class-ID: 0280
IF: wlp3s0 state: up mac: <filter>
Device-3: Realtek RTL8152 Fast Ethernet Adapter driver: r8152 type: USB
rev: 2.0 speed: 480 Mb/s lanes: 1 mode: 2.0 bus-ID: 7-1.2.4:6
chip-ID: 0bda:8152 class-ID: 0000 serial: <filter>
IF: enp7s0f3u1u2u4 state: up speed: 100 Mbps duplex: full mac: <filter>
Bluetooth:
Device-1: Foxconn / Hon Hai Wireless_Device driver: btusb v: 0.8 type: USB
rev: 2.1 speed: 480 Mb/s lanes: 1 mode: 2.0 bus-ID: 3-3:2 chip-ID: 0489:e0e2
class-ID: e001 serial: <filter>
Report: bt-adapter ID: hci0 rfk-id: 0 state: up address: <filter>
Drives:
Local Storage: total: 931.51 GiB used: 18.57 GiB (2.0%)
SMART Message: Unable to run smartctl. Root privileges required.
ID-1: /dev/nvme0n1 maj-min: 259:0 vendor: Western Digital
model: WD Green SN350 1TB size: 931.51 GiB block-size: physical: 512 B
logical: 512 B speed: 31.6 Gb/s lanes: 4 tech: SSD serial: <filter>
fw-rev: 33006000 temp: 53.9 C scheme: GPT
Partition:
ID-1: / raw-size: 888.85 GiB size: 888.85 GiB (100.00%)
used: 18.57 GiB (2.1%) fs: btrfs dev: /dev/nvme0n1p2 maj-min: 259:2
ID-2: /boot/efi raw-size: 300 MiB size: 299.4 MiB (99.80%)
used: 576 KiB (0.2%) fs: vfat dev: /dev/nvme0n1p1 maj-min: 259:1
ID-3: /home raw-size: 888.85 GiB size: 888.85 GiB (100.00%)
used: 18.57 GiB (2.1%) fs: btrfs dev: /dev/nvme0n1p2 maj-min: 259:2
ID-4: /var/log raw-size: 888.85 GiB size: 888.85 GiB (100.00%)
used: 18.57 GiB (2.1%) fs: btrfs dev: /dev/nvme0n1p2 maj-min: 259:2
ID-5: /var/tmp raw-size: 888.85 GiB size: 888.85 GiB (100.00%)
used: 18.57 GiB (2.1%) fs: btrfs dev: /dev/nvme0n1p2 maj-min: 259:2
Swap:
Kernel: swappiness: 133 (default 60) cache-pressure: 100 (default)
ID-1: swap-1 type: partition size: 42.37 GiB used: 0 KiB (0.0%)
priority: -2 dev: /dev/nvme0n1p3 maj-min: 259:3
ID-2: swap-2 type: zram size: 38.52 GiB used: 0 KiB (0.0%) priority: 100
dev: /dev/zram0
Sensors:
System Temperatures: cpu: 51.2 C mobo: N/A gpu: amdgpu temp: 46.0 C
Fan Speeds (RPM): cpu: 1900
Info:
Processes: 453 Uptime: 4m wakeups: 5 Memory: total: 40 GiB note: est.
available: 38.52 GiB used: 4.57 GiB (11.9%) Init: systemd v: 253
default: graphical tool: systemctl Compilers: gcc: 13.1.1 Packages:
pm: pacman pkgs: 1333 libs: 343 tools: octopi,pamac,paru pm: appimage
pkgs: 0 Shell: fish v: 3.6.1 default: Zsh v: 5.9 running-in: konsole
inxi: 3.3.28
Garuda (2.6.16-1):
System install date:     2023-07-12
Last full system update: 2023-07-12 ↻
Is partially upgraded:   No
Relevant software:       snapper NetworkManager dracut nvidia-dkms
Windows dual boot:       Probably (Run as root to verify)
Failed units:

Just for the record the problem as a bug in the nvidia driver with the new driver relaese resolve the problem

2 Likes

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.