Can we disable the blur only for specific app?

I tried do it in setting>workplace behaviour but it disables the whole thing.I want to disable blur only for one app.
Is there a way to do it?

Welcome :slight_smile:

? Which ?

Why you do not post your inxi?


From template:

Post terminal in- and output from

inxi -Fza

as text!

Even if you personally think it is unnecessary.

1 Like

I am almost a newbie,so could u explain what happens with that?

You post nothing about your system or what desktop environment you use, in inxi we can read this and a little more.
Also, you do not answer my question.
None of those helping are psychic or looking over their shoulder at their monitor.

Kristallkugel-02-sgs

2 Likes
System:    Kernel: 5.13.6-zen1-1-zen x86_64 bits: 64 compiler: gcc v: 11.1.0  
parameters: BOOT_IMAGE=/@/boot/vmlinuz-linux-zen root=UUID=78959370-4cf4-4fbb-90fc-a7d8aec52d4b  
rw [email protected] quiet splash rd.udev.log_priority=3 vt.global_cursor_default=0
systemd.unified_cgroup_hierarchy=1 resume=UUID=2dd80801-8559-438b-883d-4a4cc0f3c30d loglevel=3
Desktop: KDE Plasma 5.22.4 tk: Qt 5.15.2 info: latte-dock wm: kwin_x11 vt: 1 dm: SDDM  
Distro: Garuda Linux base: Arch Linux  
Machine:   Type: Laptop System: Acer product: Acer one 14 Z422 v: N/A serial: <filter> Chassis: type: 10  
serial: <filter>  
Mobo: Acer model: Acer one 14 Z422 serial: <filter> BIOS: American Megatrends v: 1.01  
date: 07/20/2017  
Battery:   ID-1: BAT0 charge: 38.9 Wh (100.0%) condition: 38.9/47.5 Wh (81.8%) volts: 12.5 min: 10.8  
model: standard type: Li-ion serial: <filter> status: Full  
Device-1: hidpp_battery_0 model: Logitech Wireless Keyboard K230 serial: <filter>  
charge: 100% (should be ignored) rechargeable: yes status: Discharging  
CPU:       Info: Quad Core model: AMD A6-7310 APU with AMD Radeon R4 Graphics bits: 64 type: MCP  
arch: Puma family: 16 (22) model-id: 30 (48) stepping: 1 microcode: 7030105 cache: L2: 2 MiB  
flags: avx lm nx pae sse sse2 sse3 sse4_1 sse4_2 sse4a ssse3 svm bogomips: 15968  
Speed: 1994 MHz min/max: 1000/2000 MHz boost: enabled Core speeds (MHz): 1: 1994 2: 1958  
3: 1649 4: 1996  
Vulnerabilities: Type: itlb_multihit status: Not affected  
Type: l1tf status: Not affected  
Type: mds status: Not affected  
Type: meltdown status: Not affected  
Type: spec_store_bypass mitigation: Speculative Store Bypass disabled via prctl and seccomp  
Type: spectre_v1 mitigation: usercopy/swapgs barriers and __user pointer sanitization  
Type: spectre_v2 mitigation: Full AMD retpoline, STIBP: disabled, RSB filling  
Type: srbds status: Not affected  
Type: tsx_async_abort status: Not affected  
Graphics:  Device-1: AMD Mullins [Radeon R4/R5 Graphics] vendor: Holco Enterprise Co /Shuttle  
driver: radeon v: kernel alternate: amdgpu bus-ID: 00:01.0 chip-ID: 1002:9851 class-ID: 0300  
Device-2: Chicony USB 2.0 Camera type: USB driver: uvcvideo bus-ID: 2-1.3:4 chip-ID: 04f2:b539  
class-ID: 0e02 serial: <filter>  
Display: x11 server: X.Org 1.20.13 compositor: kwin_x11 driver: loaded: ati,radeon  
unloaded: modesetting alternate: fbdev,vesa display-ID: :0 screens: 1  
Screen-1: 0 s-res: 1366x768 s-dpi: 96 s-size: 361x203mm (14.2x8.0") s-diag: 414mm (16.3")  
Monitor-1: eDP res: 1366x768 hz: 60 dpi: 112 size: 309x173mm (12.2x6.8") diag: 354mm (13.9")  
OpenGL: renderer: AMD KABINI (DRM 2.50.0 5.13.6-zen1-1-zen LLVM 12.0.1) v: 4.5 Mesa 21.1.6  
direct render: Yes  
Audio:     Device-1: AMD Kabini HDMI/DP Audio vendor: Holco Enterprise Co /Shuttle driver: snd_hda_intel  
v: kernel bus-ID: 00:01.1 chip-ID: 1002:9840 class-ID: 0403
Device-2: AMD FCH Azalia vendor: Holco Enterprise Co /Shuttle driver: snd_hda_intel v: kernel
bus-ID: 00:14.2 chip-ID: 1022:780d class-ID: 0403
Sound Server-1: ALSA v: k5.13.6-zen1-1-zen running: yes
Sound Server-2: JACK v: 1.9.19 running: no
Sound Server-3: PulseAudio v: 15.0 running: no
Sound Server-4: PipeWire v: 0.3.32 running: yes
Network:   Device-1: Realtek RTL8723BE PCIe Wireless Network Adapter vendor: AzureWave driver: rtl8723be
v: kernel port: e000 bus-ID: 01:00.0 chip-ID: 10ec:b723 class-ID: 0280
IF: wlp1s0 state: up mac: <filter>
Device-2: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet
vendor: Holco Enterprise Co /Shuttle driver: r8169 v: kernel port: d000 bus-ID: 02:00.1
chip-ID: 10ec:8168 class-ID: 0200
IF: enp2s0f1 state: down mac: <filter>
Bluetooth: Device-1: IMC Networks Bluetooth Radio type: USB driver: btusb v: 0.8 bus-ID: 2-1.2:3
chip-ID: 13d3:3416 class-ID: e001 serial: <filter>
Report: bt-adapter ID: hci0 rfk-id: 0 state: up address: <filter>
Drives:    Local Storage: total: 232.89 GiB used: 41.55 GiB (17.8%)
SMART Message: Unable to run smartctl. Root privileges required.
ID-1: /dev/sda maj-min: 8:0 vendor: Crucial model: CT250MX500SSD1 size: 232.89 GiB block-size:
physical: 512 B logical: 512 B speed: 6.0 Gb/s type: SSD serial: <filter> rev: 023 scheme: MBR
Partition: ID-1: / raw-size: 74.6 GiB size: 74.6 GiB (100.00%) used: 24.27 GiB (32.5%) fs: btrfs
dev: /dev/sda2 maj-min: 8:2
ID-2: /boot/efi raw-size: 512 MiB size: 511 MiB (99.80%) used: 4 KiB (0.0%) fs: vfat
dev: /dev/sda1 maj-min: 8:1
ID-3: /home raw-size: 74.6 GiB size: 74.6 GiB (100.00%) used: 24.27 GiB (32.5%) fs: btrfs
dev: /dev/sda2 maj-min: 8:2
ID-4: /var/log raw-size: 74.6 GiB size: 74.6 GiB (100.00%) used: 24.27 GiB (32.5%) fs: btrfs
dev: /dev/sda2 maj-min: 8:2
ID-5: /var/tmp raw-size: 74.6 GiB size: 74.6 GiB (100.00%) used: 24.27 GiB (32.5%) fs: btrfs
dev: /dev/sda2 maj-min: 8:2
Swap:      Kernel: swappiness: 133 (default 60) cache-pressure: 100 (default)
ID-1: swap-1 type: partition size: 7.81 GiB used: 0 KiB (0.0%) priority: -2 dev: /dev/sda3
maj-min: 8:3
ID-2: swap-2 type: zram size: 3.64 GiB used: 1.88 GiB (51.6%) priority: 100 dev: /dev/zram0
Sensors:   System Temperatures: cpu: 63.6 C mobo: N/A gpu: radeon temp: 67.0 C
Fan Speeds (RPM): N/A
Info:      Processes: 235 Uptime: 3h 13m wakeups: 13 Memory: 3.64 GiB used: 3.19 GiB (87.7%) Init: systemd
v: 249 tool: systemctl Compilers: gcc: 11.1.0 clang: 12.0.1 Packages: pacman: 1544 lib: 459
Shell: fish v: 3.3.1 default: Bash v: 5.1.8 running-in: konsole inxi: 3.3.06

this was the o/p
i was not able to understand your qn, so couldn't answer(i was not trying to be rude)

Me too, but which app is the specific app?

I move it from #issues-assistance to #issues-assistance:kde

1 Like

o its glava-its a visualizer app
i put command

glava --desktop

but due to blur,it kind off looks aweful,so i wanted to diasable blur only for this app

1 Like

First, try disabling kvantum.

1 Like

in the workplace behaviour?? Could you please guide me with the step!! Plz

No, it is application, kvantum manager

1 Like

How to do it?

Firstly, Change to any theme and see if desired application changes.

No,didn't work

So, I don't think that there is a way to do what you want, at least I don't know.

But there might be a workaround. You can create a script that disables that blur and another one, to enable that. Then, assign shortcut to both of them, and use it, when you use the application.

2 Likes

Well,anyway thanks.
Will try your short method.
Again thanx :blush:

If you are using Kvantum Application style (check in Settings => Appearance), then maybe.
Kvantum has a feature called Applications themes. You can customize a theme removing blur (if possible...), and assign this theme to your application to modify. It could be your current theme with added modifications for blur.

I am not sure (never done it for blur) you may disable blur, but there are similar configuration settings/hacks to change and test if it worksm as expected.
Experiment and give feedback how you did it :wink:

2 Likes

BTW did some search in the settings and found a trick.It works but not sure if its a solution.

System setting>Window Management>KWin Scripts>Force Blur(it was already there ,if not, u might click on get new script and add Force Blur)>configure

and in the box ,write the class name of app u want to exclude from blur.
Click on blur all excpet matching.
Restart

I don't know if its the solution,but it works for me

1 Like

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.