Can’t Install ISO

Just trying to download KDE Dragonized Gaming Edition but it doesn’t download. When I go to download it I click on it but nothing happens. No error messages or anything just doesn’t react. Every other download here works just fine just not the gaming edition one. I tried using my IPhone, windows PC and Linux PC to download this but same result. The download button seems to be broken :disappointed:

I see. I am sure the devs will eventually resolve that. Meanwhile you can try the “normal” kde dr460nized version of garuda and use garuda gamer a pre-installed utility to download everything that the gaming edition has. Welcome to the community. :+1:


Thank you for your comment. I’ll try that since it sounds simple enough to do

Hi @maxeypad91711 ! , actually i got the same issue (cause i disable JS anyway :slight_smile: )
So for The gaming version Click here to download


Click here for torrent

if you want to see other Desktop Environments ISOs (or every thing actually ) :

1 Like

Yay! Thank you :pray:t2:

1 Like

Or just use and click on ISO builds.
Not all DE are tested, but KDE seems fine.
“Latest” are a little bit old in moment :smiley:

Please mark it as a solution so other can benefit for now .

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.