Can not update or upgrade sudo

Just tried to update and upgrade sudo,I keep getting a bad command .I did install chatotic 32 bit drivers to see if i can get steam games to launch .I then tried to update sudo and i got the bad command.

         ```       .8Xxd                8X:.         OS: Garuda Linux x86_64
              .8Xx;                    8x:.       Kernel: 5.10.12-116-tkg-bmq
            .tt8x          .d            x88;     Uptime: 1 min
         [email protected];          .db:              [email protected];
       ,tSXX°          [email protected];  Packages: 1583 (pacman)
     .SXxx            bBBBBBBBBBBBBBBBBBBBbSBX8;  Shell: fish
   ,888S                                     pd!  Resolution: 1920x1080
  8X88/                                       q   Terminal: Alacritty
  GBB.
   x%88        [email protected]@[email protected]@[email protected]@[email protected]@[email protected]@X.        CPU: AMD Ryzen 7 4800H with Radeon Graphics (16) @ 2.9GHz
     dxXd    dB8b8b8B8B08bB88b998888b88x.         Memory: 1849MiB / 15484MiB (11%)
      dxx8o                      [email protected]@;.
        dx88                   [email protected]
          d:[email protected]
            .d988999889889899dd.
╭─rob at rob-tufgamingfa506iifx506ii in ⌁
╰─λ inxi -Fxxxza
System:    Kernel: 5.10.12-116-tkg-bmq x86_64 bits: 64 compiler: gcc v: 10.2.1
           parameters: intel_pstate=passive BOOT_IMAGE=/@/boot/vmlinuz-linux-tkg-bmq
           root=UUID=2688f1ac-d69b-454d-bac8-5daf39bea098 rw [email protected] quiet splash
           rd.udev.log_priority=3 vt.global_cursor_default=0 systemd.unified_cgroup_hierarchy=1
           loglevel=3
           Desktop: KDE Plasma 5.20.5 tk: Qt 5.15.2 info: latte-dock wm: kwin_x11 dm: SDDM
           Distro: Garuda Linux
Machine:   Type: Laptop System: ASUSTeK product: TUF Gaming FA506II_FX506II v: 1.0
           serial: <filter>
           Mobo: ASUSTeK model: FA506II v: 1.0 serial: <filter> UEFI: American Megatrends
           v: FA506II.309 date: 07/02/2020
Battery:   ID-1: BAT1 charge: 37.5 Wh condition: 39.0/48.2 Wh (81%) volts: 3.9/11.9
           model: ASUS A32-K55 type: Li-ion serial: N/A status: Unknown
CPU:       Info: 8-Core model: AMD Ryzen 7 4800H with Radeon Graphics bits: 64 type: MT MCP
           arch: Zen 2 family: 17 (23) model-id: 60 (96) stepping: 1 microcode: 8600104
           L2 cache: 4 MiB
           flags: avx avx2 lm nx pae sse sse2 sse3 sse4_1 sse4_2 sse4a ssse3 svm bogomips: 92708
           Speed: 1359 MHz min/max: 1400/2900 MHz boost: disabled Core speeds (MHz): 1: 1359
           2: 1919 3: 1286 4: 1286 5: 1609 6: 1556 7: 2889 8: 2895 9: 1326 10: 1347 11: 2387
           12: 1354 13: 1352 14: 1397 15: 1283 16: 1286
           Vulnerabilities: Type: itlb_multihit status: Not affected
           Type: l1tf status: Not affected
           Type: mds status: Not affected
           Type: meltdown status: Not affected
           Type: spec_store_bypass
           mitigation: Speculative Store Bypass disabled via prctl and seccomp
           Type: spectre_v1 mitigation: usercopy/swapgs barriers and __user pointer sanitization
           Type: spectre_v2 mitigation: Full AMD retpoline, IBPB: conditional, IBRS_FW, STIBP:
           conditional, RSB filling
           Type: srbds status: Not affected
           Type: tsx_async_abort status: Not affected
Graphics:  Device-1: NVIDIA TU117M [GeForce GTX 1650 Ti Mobile] vendor: ASUSTeK driver: N/A
           alternate: nouveau bus ID: 01:00.0 chip ID: 10de:1f95
           Device-2: AMD Renoir vendor: ASUSTeK driver: amdgpu v: kernel bus ID: 05:00.0
           chip ID: 1002:1636
           Device-3: IMC Networks USB2.0 HD UVC WebCam type: USB driver: uvcvideo bus ID: 1-4:2
           chip ID: 13d3:56a2 serial: <filter>
           Display: x11 server: X.Org 1.20.10 compositor: kwin_x11 driver: loaded: amdgpu
           unloaded: modesetting alternate: ati,fbdev,vesa display ID: :0 screens: 1
           Screen-1: 0 s-res: 1920x1080 s-dpi: 96 s-size: 508x285mm (20.0x11.2")
           s-diag: 582mm (22.9")
           Monitor-1: eDP res: 1920x1080 hz: 144 dpi: 142 size: 344x194mm (13.5x7.6")
           diag: 395mm (15.5")
           OpenGL: renderer: AMD RENOIR (DRM 3.40.0 5.10.12-116-tkg-bmq LLVM 11.0.1)
           v: 4.6 Mesa 20.3.4 direct render: Yes
Audio:     Device-1: AMD vendor: ASUSTeK driver: snd_hda_intel v: kernel bus ID: 05:00.1
           chip ID: 1002:1637
           Device-2: AMD Raven/Raven2/FireFlight/Renoir Audio Processor driver: N/A
           alternate: snd_pci_acp3x, snd_rn_pci_acp3x bus ID: 05:00.5 chip ID: 1022:15e2
           Device-3: AMD Family 17h HD Audio vendor: ASUSTeK driver: snd_hda_intel v: kernel
           bus ID: 05:00.6 chip ID: 1022:15e3
           Sound Server: ALSA v: k5.10.12-116-tkg-bmq
Network:   Device-1: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet vendor: ASUSTeK
           driver: r8169 v: kernel port: e000 bus ID: 02:00.0 chip ID: 10ec:8168
           IF: enp2s0 state: down mac: <filter>
           Device-2: Realtek RTL8822CE 802.11ac PCIe Wireless Network Adapter vendor: AzureWave
           driver: rtw_8822ce v: N/A modules: rtw88_8822ce port: d000 bus ID: 03:00.0
           chip ID: 10ec:c822
           IF: wlp3s0 state: up mac: <filter>
Drives:    Local Storage: total: 476.94 GiB used: 123.3 GiB (25.9%)
           SMART Message: Unable to run smartctl. Root privileges required.
           ID-1: /dev/nvme0n1 maj-min: 259:0 vendor: Kingston model: OM8PCP3512F-AB
           size: 476.94 GiB block size: physical: 512 B logical: 512 B speed: 31.6 Gb/s lanes: 4
           serial: <filter> rev: ECFK52.3 temp: 43.9 C
Partition: ID-1: / raw size: 476.64 GiB size: 476.64 GiB (100.00%) used: 123.3 GiB (25.9%)
           fs: btrfs dev: /dev/nvme0n1p2 maj-min: 259:2
           ID-2: /boot/efi raw size: 300 MiB size: 299.4 MiB (99.80%) used: 560 KiB (0.2%)
           fs: vfat dev: /dev/nvme0n1p1 maj-min: 259:1
           ID-3: /home raw size: 476.64 GiB size: 476.64 GiB (100.00%) used: 123.3 GiB (25.9%)
           fs: btrfs dev: /dev/nvme0n1p2 maj-min: 259:2
           ID-4: /var/log raw size: 476.64 GiB size: 476.64 GiB (100.00%)
           used: 123.3 GiB (25.9%) fs: btrfs dev: /dev/nvme0n1p2 maj-min: 259:2
           ID-5: /var/tmp raw size: 476.64 GiB size: 476.64 GiB (100.00%)
           used: 123.3 GiB (25.9%) fs: btrfs dev: /dev/nvme0n1p2 maj-min: 259:2
Swap:      Kernel: swappiness: 10 (default 60) cache pressure: 75 (default 100)
           ID-1: swap-1 type: zram size: 967.8 MiB used: 0 KiB (0.0%) priority: 32767
           dev: /dev/zram0
           ID-2: swap-2 type: zram size: 967.8 MiB used: 0 KiB (0.0%) priority: 32767
           dev: /dev/zram1
           ID-3: swap-3 type: zram size: 967.8 MiB used: 0 KiB (0.0%) priority: 32767
           dev: /dev/zram2
           ID-4: swap-4 type: zram size: 967.8 MiB used: 0 KiB (0.0%) priority: 32767
           dev: /dev/zram3
           ID-5: swap-5 type: zram size: 967.8 MiB used: 0 KiB (0.0%) priority: 32767
           dev: /dev/zram4
           ID-6: swap-6 type: zram size: 967.8 MiB used: 0 KiB (0.0%) priority: 32767
           dev: /dev/zram5
Sensors:   System Temperatures: cpu: 74.1 C mobo: N/A gpu: amdgpu temp: 52.0 C
           Fan Speeds (RPM): N/A
Info:      Processes: 349 Uptime: 1m wakeups: 1 Memory: 15.12 GiB used: 3.18 GiB (21.0%)
           Init: systemd v: 247 Compilers: gcc: 10.2.0 Packages: pacman: 1583 lib: 491
           Shell: fish v: 3.1.2 running in: alacritty inxi: 3.2.02

It would be helpful if you posted the exact command you tried to run to "update and upgrade sudo". Welcome to the forum!

2 Likes

Apologies i thought i did lol thanks for your reply sudo

sudo apt update
sudo apt upgrade

Ah yes, this will not work. :rofl:

apt is a package manager used on Debian and Debian-based systems, like 'Buntu.

Here on Arch, and Arch-based distros, we use pacman, the Arch Linux package manager. The proper way to update your system is

sudo pacman -Syu

On Garuda, you will also have yay installed. So you can update just by running (without sudo!):

yay

Less typing and it will update both the repo packages and the packages from the AUR.

5 Likes

Ohhhhhhhhhhh thanks so much fantastic .so please do i just run yay as above ?Less typing ??

Yes. Just type yay and hit Enter.

It will ask for your user password (the same you use for sudo) and then just let it update.

3 Likes

Fantastic thanks so much for your help .Can you help with my steam post please lol .Should i have installed the chatotic drivers .im a bit confused as i have amd and nvidia.i only want to run nvidia as default .but i get confused when googling information

1 Like

Sorry, I don't know anything about Steam or the chaotic AUR, but I'm fairly optimistic someone will reply to that post with the correct solution, there is a bunch of knowledgeable people here willing to help.

2 Likes

Anyway many thanks for your help have a great day .There is one more question im sure you can help me with .So now in Garuda terminal we do not need to enter $. ?

Hi there i dont think this looks good .I had a power blackout now ive run yay .PrivateBin
PrivateBin

Can someone help me please with the posts i sent to private bin as im now having to boot from the snapshots not sure what ive done but it dosnt look good

Hi again Rob.

After reading your logs and your profile one thing becomes aparrent. Being as the internet speeds overall in Australia aren't that great for many users, I'd suggest for your lifestyle Garuda is absolutely the wrong fit. Garuda requires very frequent updates and this requires adequate speeds and lots of bandwidth to perform these updates.

Your logs indicate you either need to rank your mirrors properly, or your internet connection is inadequate. Roaming about living in a tent downunder sounds awesome, but this isn't really suited to a distro that requires very regular updates. Updating a rolling distro can use quite a lot of monthly data. Your situation is not really suited to using a rolling distro with substandard connections.

As already mentioned by myself and other moderators you would probably be better served using a non-rolling distro such as Linux Mint. These static types of distro do not require require lots of monthly bandwidth for performing updates as they only do important security updates. This minimizes the monthly amount of data required simply for system updates. I really think this is what you should be using with your current lifestyle.

You cannot avoid doing updates with Garuda as this is required. Your best alternative would be to use a static distro more targeted towards new Linux users such as Ubuntu or Linux Mint.

This should help minimize the problems you are regularly experiencing.

Best of luck my friend.

6 Likes

You should try clearing pacman's cache

sudo pacman -Sc

Find a fast mirror for you location

sudo reflector-simple

Then try to update again

sudo pacman -Syyu

If it spits another error about one or two packages you can "ignore" them until after the update. For example:

sudo pacman -Syyu --ignore=garuda-setup-assistant

Then you can move on to updating AUR packages with

yay -Syu

Then report back here.

4 Likes

Thanks dear friends of Garuda and thanks so much for taking the time to read my logs ,and the professional information you have provided will be very useful for me.
.i have since done a fresh install and i have upgraded our monthly data to 500gb a month for 4 of us so i hope this will be enough .After the fresh install i can now play all Steam games on Steam play.As i only surf the net and play games im happy to learn Garuda.Cheers everyone i will not drain your brains anymore lol

1 Like

Cheers Bog for your reply and your information i have since done a fresh install and all is fine so far lol.How often do i perform this task please.I wish a garuda guru would post a tute of maintenance things to do when using Garuda .it seems theres very limited information .I know its only a new distro and these things take time .
One question at the end of the update message says check and merge.I just close the terminal is this were im making the mistake ?

https://bin.garudalinux.org/?95498f209cb14087#Dce4U3a5DotmBdKbrdw5NwoBCrK3NZj5JSJj39Sc6q1p

Those *.pacnew files are configuration changes that failed to automatically apply. Technically you should review them and merge changes, but it's (imo) usually safe to ignore them. I tend to let them pile up for a week or two, then go see what I think might be important enough to address.

1 Like

For easy management and comparison use

sudo -H DIFFPROG=meld pacdiff

install

sudo pacman -Syu meld

if meld is missing.
Make an alias for the terminal.

2 Likes

or you can use pacmerge for *.pacnew files .

2 Likes

if meld is missing.
Make an alias for the terminal.
Hmmm sorry i have no idea what you mean .thanks for your reply .