Built In Speakers Not Working Properly After Testing HDMI

I have had Garuda Installed for a little while now, and everything was working fine. I went to test the HDMI port yesterday, and changed my audio settings to play through the TV speakers. Ever since, my laptop speakers don’t want to play anything. If i use the Garuda Live Disc, the audio there works fine, and if I hit restart from there and boot into the actual install the audio will continue to work, but if I shut down instead of restart, the audio will once again not work once I boot up again. I’ve tried just about any audio setting I can think of. Any help would be greatly appreciated. Thanks

System:
Kernel: 6.6.3-zen1-1-zen arch: x86_64 bits: 64 compiler: gcc v: 13.2.1
clocksource: tsc available: acpi_pm
parameters: BOOT_IMAGE=/@/boot/vmlinuz-linux-zen
root=UUID=653346b0-e41e-4682-af8a-c8daab7c68bd rw rootflags=subvol=@
quiet loglevel=3 ibt=off
Desktop: KDE Plasma v: 5.27.9 tk: Qt v: 5.15.11 wm: kwin_wayland vt: 1
dm: SDDM Distro: Garuda Linux base: Arch Linux
Machine:
Type: Laptop System: Apple product: MacBookPro12,1 v: 1.0
serial: <superuser required> Chassis: type: 9 v: Mac-E43C1C25D4880AD6
serial: <superuser required>
Mobo: Apple model: Mac-E43C1C25D4880AD6 v: MacBookPro12,1
serial: <superuser required> UEFI: Apple v: 486.0.0.0.0 date: 08/03/2023
Battery:
ID-1: BAT0 charge: 61.5 Wh (100.0%) condition: 61.5/74.8 Wh (82.3%)
volts: 12.9 min: 11.4 model: SMP bq20z451 type: Li-ion serial: N/A
status: full cycles: 336
CPU:
Info: model: Intel Core i5-5287U bits: 64 type: MT MCP arch: Broadwell
gen: core 5 level: v3 note: check built: 2015-18 process: Intel 14nm
family: 6 model-id: 0x3D (61) stepping: 4 microcode: 0x2F
Topology: cpus: 1x cores: 2 tpc: 2 threads: 4 smt: enabled cache:
L1: 128 KiB desc: d-2x32 KiB; i-2x32 KiB L2: 512 KiB desc: 2x256 KiB
L3: 3 MiB desc: 1x3 MiB
Speed (MHz): avg: 2902 high: 2904 min/max: 500/3300 scaling:
driver: intel_cpufreq governor: schedutil cores: 1: 2904 2: 2902 3: 2900
4: 2903 bogomips: 23199
Flags: avx avx2 ht lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx
Vulnerabilities: <filter>
Graphics:
Device-1: Intel Iris Graphics 6100 vendor: Apple driver: i915 v: kernel
arch: Gen-8 process: Intel 14nm built: 2014-15 ports: active: eDP-1
empty: DP-1, DP-2, HDMI-A-1, HDMI-A-2 bus-ID: 00:02.0 chip-ID: 8086:162b
class-ID: 0300
Display: wayland server: X.org v: 1.21.1.9 with: Xwayland v: 23.2.2
compositor: kwin_wayland driver: X: loaded: modesetting
alternate: fbdev,intel,vesa dri: iris gpu: i915 display-ID: 0
Monitor-1: eDP-1 res: 2133x1333 size: N/A modes: N/A
API: EGL v: 1.5 hw: drv: intel iris platforms: device: 0 drv: iris
device: 1 drv: swrast surfaceless: drv: iris wayland: drv: iris x11:
drv: iris inactive: gbm
API: OpenGL v: 4.6 compat-v: 4.5 vendor: intel mesa v: 23.2.1-arch1.2
glx-v: 1.4 direct-render: yes renderer: Mesa Intel Iris Graphics 6100 (BDW
GT3) device-ID: 8086:162b memory: 15.16 GiB unified: yes display-ID: :1.0
API: Vulkan v: 1.3.269 layers: 7 device: 0 type: integrated-gpu name: Intel
Iris Graphics 6100 (BDW GT3) driver: mesa intel v: 23.2.1-arch1.2
device-ID: 8086:162b surfaces: xcb,xlib,wayland device: 1 type: cpu
name: llvmpipe (LLVM 16.0.6 256 bits) driver: mesa llvmpipe
v: 23.2.1-arch1.2 (LLVM 16.0.6) device-ID: 10005:0000
surfaces: xcb,xlib,wayland
Audio:
Device-1: Intel Broadwell-U Audio vendor: Apple driver: snd_hda_intel
v: kernel bus-ID: 00:03.0 chip-ID: 8086:160c class-ID: 0403
Device-2: Intel Wildcat Point-LP High Definition Audio
driver: snd_hda_intel v: kernel bus-ID: 00:1b.0 chip-ID: 8086:9ca0
class-ID: 0403
Device-3: Broadcom 720p FaceTime HD Camera driver: N/A pcie: gen: 2
speed: 5 GT/s lanes: 1 bus-ID: 02:00.0 chip-ID: 14e4:1570 class-ID: 0480
API: ALSA v: k6.6.3-zen1-1-zen status: kernel-api
tools: alsactl,alsamixer,amixer
Server-1: PipeWire v: 1.0.0 status: active with: 1: pipewire-pulse
status: active 2: wireplumber status: active 3: pipewire-alsa type: plugin
4: pw-jack type: plugin tools: pactl,pw-cat,pw-cli,wpctl
Network:
Device-1: Broadcom BCM43602 802.11ac Wireless LAN SoC vendor: Apple
driver: brcmfmac v: kernel pcie: gen: 1 speed: 2.5 GT/s lanes: 1
bus-ID: 03:00.0 chip-ID: 14e4:43ba class-ID: 0280
IF: wlp3s0 state: up mac: <filter>
Bluetooth:
Device-1: Apple Bluetooth Host Controller driver: btusb,hid-generic,usbhid
type: USB rev: 2.0 speed: 12 Mb/s lanes: 1 mode: 1.1 bus-ID: 1-3:2
chip-ID: 05ac:8290 class-ID: fe01
Report: btmgmt ID: hci0 rfk-id: 0 state: up address: <filter> bt-v: 4.2
lmp-v: 8 status: discoverable: no pairing: no class-ID: 7c010c
Drives:
Local Storage: total: 233.76 GiB used: 67.82 GiB (29.0%)
SMART Message: Unable to run smartctl. Root privileges required.
ID-1: /dev/sda maj-min: 8:0 vendor: Apple model: SSD SM0256G
size: 233.76 GiB block-size: physical: 4096 B logical: 512 B speed: 6.0 Gb/s
tech: SSD serial: <filter> fw-rev: 3A0Q scheme: GPT
Partition:
ID-1: / raw-size: 233.46 GiB size: 233.46 GiB (100.00%)
used: 67.82 GiB (29.1%) fs: btrfs dev: /dev/sda2 maj-min: 8:2
ID-2: /boot/efi raw-size: 300 MiB size: 299.4 MiB (99.80%)
used: 576 KiB (0.2%) fs: vfat dev: /dev/sda1 maj-min: 8:1
ID-3: /home raw-size: 233.46 GiB size: 233.46 GiB (100.00%)
used: 67.82 GiB (29.1%) fs: btrfs dev: /dev/sda2 maj-min: 8:2
ID-4: /var/log raw-size: 233.46 GiB size: 233.46 GiB (100.00%)
used: 67.82 GiB (29.1%) fs: btrfs dev: /dev/sda2 maj-min: 8:2
ID-5: /var/tmp raw-size: 233.46 GiB size: 233.46 GiB (100.00%)
used: 67.82 GiB (29.1%) fs: btrfs dev: /dev/sda2 maj-min: 8:2
Swap:
Kernel: swappiness: 133 (default 60) cache-pressure: 100 (default) zswap: no
ID-1: swap-1 type: zram size: 15.52 GiB used: 0 KiB (0.0%) priority: 100
comp: zstd avail: lzo,lzo-rle,lz4,lz4hc,842 max-streams: 4 dev: /dev/zram0
Sensors:
System Temperatures: cpu: 89.0 C pch: 76.5 C mobo: N/A
Fan Speeds (rpm): N/A
Info:
Processes: 214 Uptime: 9m wakeups: 0 Memory: total: 16 GiB
available: 15.52 GiB used: 3.03 GiB (19.5%) Init: systemd v: 254
default: graphical tool: systemctl Compilers: gcc: 13.2.1 Packages:
pm: pacman pkgs: 1407 libs: 406 tools: octopi,pamac,paru,trizen,yay
Shell: fish v: 3.6.1 running-in: konsole inxi: 3.3.31
Garuda (2.6.19-2):
System install date:     2023-11-12
Last full system update: 2023-12-03 ↻
Is partially upgraded:   No
Relevant software:       snapper NetworkManager dracut
Windows dual boot:       No/Undetected
Failed units:

Try changing the sound card in alsamixer.

alsamixer

Press F6 to switch the sound card to whatever you laptop speakers are, then make sure it is unmuted.

Thank you for the reply, however that doesn’t seem to help either.

Let’s try this:

systemctl --user restart wireplumber pipewire pipewire-pulse

The ‘swish’ says you need to reboot since your last update. Nothing’s guaranteed to work right if you don’t reboot when needed. :smiley:

Thanks for the replies. I previously had rebooted as part of my attempts, then searched for updates once again hoping that would help. Just to rule that out i did once again try rebooting. I also tried

systemctl --user restart wireplumber pipewire pipewire-pulse

to no avail.

System:
Kernel: 6.6.3-zen1-1-zen arch: x86_64 bits: 64 compiler: gcc v: 13.2.1
clocksource: tsc available: acpi_pm
parameters: BOOT_IMAGE=/@/boot/vmlinuz-linux-zen
root=UUID=653346b0-e41e-4682-af8a-c8daab7c68bd rw rootflags=subvol=@
quiet loglevel=3 ibt=off
Desktop: KDE Plasma v: 5.27.9 tk: Qt v: 5.15.11 wm: kwin_wayland vt: 1
dm: SDDM Distro: Garuda Linux base: Arch Linux
Machine:
Type: Laptop System: Apple product: MacBookPro12,1 v: 1.0
serial: <superuser required> Chassis: type: 9 v: Mac-E43C1C25D4880AD6
serial: <superuser required>
Mobo: Apple model: Mac-E43C1C25D4880AD6 v: MacBookPro12,1
serial: <superuser required> UEFI: Apple v: 486.0.0.0.0 date: 08/03/2023
Battery:
ID-1: BAT0 charge: 54.2 Wh (88.3%) condition: 61.4/74.8 Wh (82.1%)
volts: 11.8 min: 11.4 model: SMP bq20z451 type: Li-ion serial: N/A
status: discharging cycles: 336
CPU:
Info: model: Intel Core i5-5287U bits: 64 type: MT MCP arch: Broadwell
gen: core 5 level: v3 note: check built: 2015-18 process: Intel 14nm
family: 6 model-id: 0x3D (61) stepping: 4 microcode: 0x2F
Topology: cpus: 1x cores: 2 tpc: 2 threads: 4 smt: enabled cache:
L1: 128 KiB desc: d-2x32 KiB; i-2x32 KiB L2: 512 KiB desc: 2x256 KiB
L3: 3 MiB desc: 1x3 MiB
Speed (MHz): avg: 1839 high: 2901 min/max: 500/3300 scaling:
driver: intel_cpufreq governor: schedutil cores: 1: 500 2: 2901 3: 1471
4: 2487 bogomips: 23200
Flags: avx avx2 ht lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx
Vulnerabilities: <filter>
Graphics:
Device-1: Intel Iris Graphics 6100 vendor: Apple driver: i915 v: kernel
arch: Gen-8 process: Intel 14nm built: 2014-15 ports: active: eDP-1
empty: DP-1, DP-2, HDMI-A-1, HDMI-A-2 bus-ID: 00:02.0 chip-ID: 8086:162b
class-ID: 0300
Display: wayland server: X.org v: 1.21.1.9 with: Xwayland v: 23.2.2
compositor: kwin_wayland driver: X: loaded: modesetting
alternate: fbdev,intel,vesa dri: iris gpu: i915 display-ID: 0
Monitor-1: eDP-1 res: 2133x1333 size: N/A modes: N/A
API: EGL v: 1.5 hw: drv: intel iris platforms: device: 0 drv: iris
device: 1 drv: swrast surfaceless: drv: iris wayland: drv: iris x11:
drv: iris inactive: gbm
API: OpenGL v: 4.6 compat-v: 4.5 vendor: intel mesa v: 23.2.1-arch1.2
glx-v: 1.4 direct-render: yes renderer: Mesa Intel Iris Graphics 6100 (BDW
GT3) device-ID: 8086:162b memory: 15.16 GiB unified: yes display-ID: :1.0
API: Vulkan v: 1.3.269 layers: 7 device: 0 type: integrated-gpu name: Intel
Iris Graphics 6100 (BDW GT3) driver: mesa intel v: 23.2.1-arch1.2
device-ID: 8086:162b surfaces: xcb,xlib,wayland device: 1 type: cpu
name: llvmpipe (LLVM 16.0.6 256 bits) driver: mesa llvmpipe
v: 23.2.1-arch1.2 (LLVM 16.0.6) device-ID: 10005:0000
surfaces: xcb,xlib,wayland
Audio:
Device-1: Intel Broadwell-U Audio vendor: Apple driver: snd_hda_intel
v: kernel bus-ID: 00:03.0 chip-ID: 8086:160c class-ID: 0403
Device-2: Intel Wildcat Point-LP High Definition Audio
driver: snd_hda_intel v: kernel bus-ID: 00:1b.0 chip-ID: 8086:9ca0
class-ID: 0403
Device-3: Broadcom 720p FaceTime HD Camera driver: N/A pcie: gen: 2
speed: 5 GT/s lanes: 1 bus-ID: 02:00.0 chip-ID: 14e4:1570 class-ID: 0480
API: ALSA v: k6.6.3-zen1-1-zen status: kernel-api with: aoss
type: oss-emulator tools: alsactl,alsamixer,amixer
Server-1: PipeWire v: 1.0.0 status: active with: 1: pipewire-pulse
status: active 2: wireplumber status: active 3: pipewire-alsa type: plugin
4: pw-jack type: plugin tools: pactl,pw-cat,pw-cli,wpctl
Network:
Device-1: Broadcom BCM43602 802.11ac Wireless LAN SoC vendor: Apple
driver: brcmfmac v: kernel pcie: gen: 1 speed: 2.5 GT/s lanes: 1
bus-ID: 03:00.0 chip-ID: 14e4:43ba class-ID: 0280
IF: wlp3s0 state: up mac: <filter>
Bluetooth:
Device-1: Apple Bluetooth Host Controller driver: btusb,hid-generic,usbhid
type: USB rev: 2.0 speed: 12 Mb/s lanes: 1 mode: 1.1 bus-ID: 1-3:2
chip-ID: 05ac:8290 class-ID: fe01
Report: btmgmt ID: hci0 rfk-id: 0 state: up address: <filter> bt-v: 4.2
lmp-v: 8 status: discoverable: no pairing: no class-ID: 7c010c
Drives:
Local Storage: total: 233.76 GiB used: 59.94 GiB (25.6%)
SMART Message: Unable to run smartctl. Root privileges required.
ID-1: /dev/sda maj-min: 8:0 vendor: Apple model: SSD SM0256G
size: 233.76 GiB block-size: physical: 4096 B logical: 512 B speed: 6.0 Gb/s
tech: SSD serial: <filter> fw-rev: 3A0Q scheme: GPT
Partition:
ID-1: / raw-size: 233.46 GiB size: 233.46 GiB (100.00%)
used: 59.94 GiB (25.7%) fs: btrfs dev: /dev/sda2 maj-min: 8:2
ID-2: /boot/efi raw-size: 300 MiB size: 299.4 MiB (99.80%)
used: 576 KiB (0.2%) fs: vfat dev: /dev/sda1 maj-min: 8:1
ID-3: /home raw-size: 233.46 GiB size: 233.46 GiB (100.00%)
used: 59.94 GiB (25.7%) fs: btrfs dev: /dev/sda2 maj-min: 8:2
ID-4: /var/log raw-size: 233.46 GiB size: 233.46 GiB (100.00%)
used: 59.94 GiB (25.7%) fs: btrfs dev: /dev/sda2 maj-min: 8:2
ID-5: /var/tmp raw-size: 233.46 GiB size: 233.46 GiB (100.00%)
used: 59.94 GiB (25.7%) fs: btrfs dev: /dev/sda2 maj-min: 8:2
Swap:
Kernel: swappiness: 133 (default 60) cache-pressure: 100 (default) zswap: no
ID-1: swap-1 type: zram size: 15.52 GiB used: 0 KiB (0.0%) priority: 100
comp: zstd avail: lzo,lzo-rle,lz4,lz4hc,842 max-streams: 4 dev: /dev/zram0
Sensors:
System Temperatures: cpu: 89.0 C pch: 82.5 C mobo: N/A
Fan Speeds (rpm): N/A
Info:
Processes: 212 Uptime: 3m wakeups: 0 Memory: total: 16 GiB
available: 15.52 GiB used: 2.76 GiB (17.8%) Init: systemd v: 254
default: graphical tool: systemctl Compilers: gcc: 13.2.1 Packages:
pm: pacman pkgs: 1410 libs: 406 tools: octopi,pamac,paru,trizen,yay
Shell: fish v: 3.6.1 running-in: konsole inxi: 3.3.31
Garuda (2.6.19-2):
System install date:     2023-11-12
Last full system update: 2023-12-03
Is partially upgraded:   No
Relevant software:       snapper NetworkManager dracut
Windows dual boot:       No/Undetected
Failed units:

It sounds like a bit of kernel nonsense. You haven’t mentioned trying other kernels. Have you?

2 Likes

I hadn’t prior to your response, but I tried the LTS Kernel after, and still nothing. I did discover that even if I select the main drive instead of the Live USB the speakers seem to work after booting.

  1. If you revert that, what happens?
  2. How are your HDMI cables/connections. Quality matters.
1 Like

Slightly off topic, but what should we have installed as a good “default” for Audio? I have PIpeWire support only, no ALSA. Reading the descriptions, it seems like it should be on or the other but I may be missing something.

Everybody needs ALSA, and either Pulseaudio (old), Pipewire (new), or JACK (for audiophiles).

Typically/normally, ALSA + Pipewire w/wireplumber as session manager would be what you’d want.

5 Likes

So I ended up backing up and reinstalling, and everything works fine now. I’m not entirely sure what the issue was, but thanks for the tips.

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.