Bug report. Keyboard layout and Cinnamon

Have setup the keyboard to CanadaFrench(default) via the GUI interface and via the terminal.

  1. sudo localectl set-keymap ca
  2. sudo localectl set-x11-keymap ca
    Did the same with the GUI, as root, as guest, and as my own logon.

The entered keys do not echo what was pressed.
It appears that the US English layout pervades.
With the keyboard layout selection, the exact keyboard layout is shown in the preview.

Sometimes, after repeated localectl set-keymap ca It wiil take hold, but if I exit from sudo su
the layout is lost. Back to something else.

Another issue.
when in terminal mode, if I enter a # as the first character, it is made nearly invisible and the rest of the line is not shown. I have to exit zsh and use bash.

My primary problem is the keyboard setting. If I can't set it up as Canadian French (default)
then I have to abandon Garuda.

Ibus is used to set input method

Change input method in ibus

2 Likes

Did you set Canadian French as your default during installation?

1 Like