Browsers forgetting login data (cookies and login info). Another couple of issues too

Rewriting this because it seems i deleted the paragraphs describing the actual problem. Sorry.

Hello, for now this issue has made me left Garuda as a i need my browsers to work for my job and I’ve been dealing with the problem for some time without being able to solve it.

I’m sad because Garuda is my favorite Linux distribution by faaaar. But it’s rough on the edges in some parts.

while this is the issue that made me left for now, I will comment a couple of other things at the end, just as side comments.

This is also not the first time I encounter this error.

Recently I reinstalled Garuda and i encountered this same problem at some point too. I was updating by installing individual applications from the software center which I thought could have corrupted something due to another issue: Garuda update always encountered it couldn’t download some stuff and then it ended up not updating anything.

The problem I refer to is my browsers (Firedragon, Opera, Vivaldi, and i think Brave too) begin at some point giving this error:

Free up space to continue

Some features on [website name] might not work until you clear data that other sites have stored on your device.

(there’s no need to free up space of course there’s plenty of free space and the disk seems to work alright, no other errors or problems. (has been formatted before reinstalling too))

They also become slow, and “forget” cookies and log in data. So i have to log in everyday to the sites I use. And trying to save new log in data doesn’t work.

Then eventually I get weird things happening with other apps i use, like telegram doesn’t open, and it crashes often. It’s weird because it takes a few days for all to happen. First The free up space error appears, then days later the cookies and the login db, they don’t work, then a few days later telegram crashes. It happened the same way the first time.

I first tried checking the permissions of the browsers folders as I read on some google chrome thread but they seemed to be fine. (they were owned by my user and could be read written to etc.)

After searching here I found a couple of threads of a person with a similar problem. One user replied with something about deactivating pdb. This did work to a degree and since then telegram doesn’t crash and two of my browsers do remember log in data and cookies. (firedragon and opera. Vivaldi still is the same i think)

I used this command:

╰─λ systemctl --user disable psd

While this kinda worked, I’m not sure if it’s a real solution. Isn’t pdb needed for other stuff? Then as I said, Vivaldi is still the same it seems. And there are other errors. Some browser extensions I also need don’t work anymore. They just stopped working.

So I’m going to try some other distro just for a while. I really want to go back to Garuda as soon as I can, as really i really prefer it to other distros.

The other issues I mention are also prevalent problems in Garuda, which I will point out now, just as a side note. I have mentioned them before here.

  1. When I try to update after the first update, I get the error that some things can’t be downloaded and no update is made. Well, I refresh keyrings and mirrorlist, adding also a few other mirrors apart from those of my country (Mexico), if I just leave those, the error appears again.

But then after the update is done, in the next update, the same problem appears again. (!) And I have to update mirrors and keyrings again

This isn’t really a problem, but I wonder if it means something else that needs to be corrected. Also, it can be a big thing for someone who doesn’t know a lot about linux. (Like me, lol.)

  1. After installation there seems to be no way of avoiding configuring kde wallet. Also it seems you have to choose blowfish when creating the wallet because PGP doesn’t work. Again something that I have encountered in my last two Garuda installs.

It’s not a big problem, but aagain, for someone who doesn’t know anything about kdewallet, encription, etc, this is very frustrating, specially as the wallet requirement appears out of nowhere after installation.

I also wonder if this has to do with the other problems with the browsers, extensions etc.

Here is my Garuda inxi:

´´´
System:
Kernel: 6.8.2-zen2-1-zen arch: x86_64 bits: 64 compiler: gcc v: 13.2.1
clocksource: tsc avail: hpet,acpi_pm
parameters: BOOT_IMAGE=/@/boot/vmlinuz-linux-zen
root=UUID=d03e3c1f-9c2e-43fb-899e-c40e1d82d931 rw rootflags=subvol=@
quiet resume=UUID=35b64325-de8c-4dd7-9b79-d10d16d3a8ac loglevel=3 ibt=off
Desktop: KDE Plasma v: 6.0.3 tk: Qt v: N/A info: frameworks v: 6.0.0
wm: kwin_wayland tools: avail: lxlock vt: 1 dm: SDDM Distro: Garuda
base: Arch Linux
Machine:
Type: Server System: BESSTAR TECH product: X500 v: N/A
serial: <superuser required>
Mobo: BESSTAR TECH model: ATB15 serial: <superuser required> part-nu: 0001
uuid: <superuser required> UEFI: American Megatrends v: ATB15016
date: 09/23/2021
CPU:
Info: model: AMD Ryzen 7 5700G with Radeon Graphics bits: 64 type: MT MCP
arch: Zen 3 gen: 4 level: v3 note: check built: 2021-22
process: TSMC n7 (7nm) family: 0x19 (25) model-id: 0x50 (80) stepping: 0
microcode: 0xA50000B
Topology: cpus: 1x cores: 8 tpc: 2 threads: 16 smt: enabled cache:
L1: 512 KiB desc: d-8x32 KiB; i-8x32 KiB L2: 4 MiB desc: 8x512 KiB
L3: 16 MiB desc: 1x16 MiB
Speed (MHz): avg: 3086 high: 3793 min/max: 400/4673 scaling:
driver: amd-pstate-epp governor: powersave cores: 1: 2551 2: 3793 3: 400
4: 3169 5: 2808 6: 3793 7: 3791 8: 2526 9: 3514 10: 3793 11: 2518 12: 3519
13: 3379 14: 3792 15: 2528 16: 3507 bogomips: 121370
Flags: avx avx2 ht lm nx pae sse sse2 sse3 sse4_1 sse4_2 sse4a ssse3 svm
Vulnerabilities: <filter>
Graphics:
Device-1: AMD Cezanne [Radeon Vega Series / Radeon Mobile Series]
driver: amdgpu v: kernel arch: GCN-5 code: Vega process: GF 14nm
built: 2017-20 pcie: gen: 3 speed: 8 GT/s lanes: 16 link-max: gen: 4
speed: 16 GT/s ports: active: DP-1,HDMI-A-1 empty: DP-2 bus-ID: 05:00.0
chip-ID: 1002:1638 class-ID: 0300 temp: 39.0 C
Display: wayland server: X.org v: 1.21.1.11 with: Xwayland v: 23.2.4
compositor: kwin_wayland driver: X: loaded: amdgpu unloaded: modesetting
alternate: fbdev,vesa dri: radeonsi gpu: amdgpu d-rect: 3200x2104
display-ID: 0
Monitor-1: DP-1 pos: bottom-l res: 1280x1024 size: N/A modes: N/A
Monitor-2: HDMI-A-1 pos: top-right res: 1920x1080 size: N/A modes: N/A
API: EGL v: 1.5 hw: drv: amd radeonsi platforms: device: 0 drv: radeonsi
device: 1 drv: swrast surfaceless: drv: radeonsi wayland: drv: radeonsi x11:
drv: radeonsi inactive: gbm
API: OpenGL v: 4.6 compat-v: 4.5 vendor: amd mesa v: 24.0.4-arch1.2
glx-v: 1.4 direct-render: yes renderer: AMD Radeon Graphics (radeonsi
renoir LLVM 17.0.6 DRM 3.57 6.8.2-zen2-1-zen) device-ID: 1002:1638
memory: 3.91 GiB unified: no display-ID: :1.0
API: Vulkan v: 1.3.279 layers: 13 device: 0 type: integrated-gpu name: AMD
Radeon Graphics (RADV RENOIR) driver: mesa radv v: 24.0.4-arch1.2
device-ID: 1002:1638 surfaces: xcb,xlib,wayland device: 1 type: cpu
name: llvmpipe (LLVM 17.0.6 256 bits) driver: mesa llvmpipe
v: 24.0.4-arch1.2 (LLVM 17.0.6) device-ID: 10005:0000
surfaces: xcb,xlib,wayland
Audio:
Device-1: AMD Renoir Radeon High Definition Audio driver: snd_hda_intel
v: kernel pcie: gen: 3 speed: 8 GT/s lanes: 16 link-max: gen: 4
speed: 16 GT/s bus-ID: 05:00.1 chip-ID: 1002:1637 class-ID: 0403
Device-2: AMD ACP/ACP3X/ACP6x Audio Coprocessor driver: N/A
alternate: snd_pci_acp3x, snd_rn_pci_acp3x, snd_pci_acp5x, snd_pci_acp6x,
snd_acp_pci, snd_rpl_pci_acp6x, snd_pci_ps, snd_sof_amd_renoir,
snd_sof_amd_rembrandt, snd_sof_amd_vangogh, snd_sof_amd_acp63 pcie: gen: 3
speed: 8 GT/s lanes: 16 link-max: gen: 4 speed: 16 GT/s bus-ID: 05:00.5
chip-ID: 1022:15e2 class-ID: 0480
Device-3: AMD Family 17h/19h HD Audio vendor: Conexant Systems
driver: snd_hda_intel v: kernel pcie: gen: 3 speed: 8 GT/s lanes: 16
link-max: gen: 4 speed: 16 GT/s bus-ID: 05:00.6 chip-ID: 1022:15e3
class-ID: 0403
API: ALSA v: k6.8.2-zen2-1-zen status: kernel-api with: aoss
type: oss-emulator tools: N/A
Server-1: PipeWire v: 1.0.4 status: active with: 1: pipewire-pulse
status: active 2: wireplumber status: active 3: pipewire-alsa type: plugin
4: pw-jack type: plugin tools: pactl,pw-cat,pw-cli,wpctl
Network:
Device-1: Realtek RTL8111/8168/8211/8411 PCI Express Gigabit Ethernet
driver: r8169 v: kernel pcie: gen: 1 speed: 2.5 GT/s lanes: 1 port: f000
bus-ID: 02:00.0 chip-ID: 10ec:8168 class-ID: 0200
IF: enp2s0 state: down mac: <filter>
Device-2: Realtek RTL8111/8168/8211/8411 PCI Express Gigabit Ethernet
driver: r8169 v: kernel pcie: gen: 1 speed: 2.5 GT/s lanes: 1 port: e000
bus-ID: 03:00.0 chip-ID: 10ec:8168 class-ID: 0200
IF: enp3s0 state: down mac: <filter>
Device-3: MEDIATEK MT7921K Wi-Fi 6E 80MHz driver: mt7921e v: kernel pcie:
gen: 2 speed: 5 GT/s lanes: 1 bus-ID: 04:00.0 chip-ID: 14c3:0608
class-ID: 0280
IF: wlp4s0 state: up mac: <filter>
Info: services: NetworkManager, smbd, systemd-timesyncd, wpa_supplicant
Bluetooth:
Device-1: MediaTek Wireless_Device driver: btusb v: 0.8 type: USB rev: 2.1
speed: 480 Mb/s lanes: 1 mode: 2.0 bus-ID: 3-1:2 chip-ID: 0e8d:0608
class-ID: e001 serial: <filter>
Report: btmgmt ID: hci0 rfk-id: 0 state: down bt-service: enabled,running
rfk-block: hardware: no software: yes address: <filter> bt-v: 5.2 lmp-v: 11
status: discoverable: no pairing: no
Drives:
Local Storage: total: 1.83 TiB used: 287.63 GiB (15.3%)
SMART Message: Unable to run smartctl. Root privileges required.
ID-1: /dev/nvme0n1 maj-min: 259:0 vendor: Kingston model: OM8PDP3512B-A01
size: 476.94 GiB block-size: physical: 512 B logical: 512 B speed: 31.6 Gb/s
lanes: 4 tech: SSD serial: <filter> fw-rev: EDFK0S03 temp: 38.9 C
scheme: GPT
ID-2: /dev/sda maj-min: 8:0 vendor: Samsung model: HM500JJ
size: 465.76 GiB block-size: physical: 512 B logical: 512 B speed: 3.0 Gb/s
tech: HDD rpm: 7200 serial: <filter> fw-rev: 0001 scheme: MBR
ID-3: /dev/sdb maj-min: 8:16 vendor: Seagate model: ST1000VM002-1ET162
size: 931.51 GiB block-size: physical: 4096 B logical: 512 B type: USB
rev: 3.0 spd: 5 Gb/s lanes: 1 mode: 3.2 gen-1x1 tech: HDD rpm: 5900
serial: <filter> fw-rev: 3202 scheme: MBR
Partition:
ID-1: / raw-size: 463.89 GiB size: 463.89 GiB (100.00%)
used: 65.15 GiB (14.0%) fs: btrfs dev: /dev/nvme0n1p2 maj-min: 259:2
ID-2: /boot/efi raw-size: 300 MiB size: 299.4 MiB (99.80%)
used: 584 KiB (0.2%) fs: vfat dev: /dev/nvme0n1p1 maj-min: 259:1
ID-3: /home raw-size: 463.89 GiB size: 463.89 GiB (100.00%)
used: 65.15 GiB (14.0%) fs: btrfs dev: /dev/nvme0n1p2 maj-min: 259:2
ID-4: /var/log raw-size: 463.89 GiB size: 463.89 GiB (100.00%)
used: 65.15 GiB (14.0%) fs: btrfs dev: /dev/nvme0n1p2 maj-min: 259:2
ID-5: /var/tmp raw-size: 463.89 GiB size: 463.89 GiB (100.00%)
used: 65.15 GiB (14.0%) fs: btrfs dev: /dev/nvme0n1p2 maj-min: 259:2
Swap:
Kernel: swappiness: 133 (default 60) cache-pressure: 100 (default) zswap: no
ID-1: swap-1 type: zram size: 11.59 GiB used: 1.73 GiB (14.9%)
priority: 100 comp: zstd avail: lzo,lzo-rle,lz4,lz4hc,842 max-streams: 16
dev: /dev/zram0
ID-2: swap-2 type: partition size: 12.75 GiB used: 0 KiB (0.0%)
priority: -2 dev: /dev/nvme0n1p3 maj-min: 259:3
Sensors:
System Temperatures: cpu: 49.8 C mobo: N/A gpu: amdgpu temp: 39.0 C
Fan Speeds (rpm): N/A
Info:
Memory: total: 12 GiB available: 11.59 GiB used: 8.85 GiB (76.4%)
Processes: 420 Power: uptime: 12h 11m states: freeze,mem,disk
suspend: deep avail: s2idle wakeups: 0 hibernate: platform avail: shutdown,
reboot, suspend, test_resume image: 4.63 GiB services: org_kde_powerdevil,
power-profiles-daemon, upowerd Init: systemd v: 255 default: graphical
tool: systemctl
Packages: pm: pacman pkgs: 2019 libs: 559 tools: octopi,pamac,paru
Compilers: gcc: 13.2.1 Shell: garuda-inxi default: fish v: 3.7.1
running-in: konsole inxi: 3.3.33
Garuda (2.6.23-1):
System install date:     2024-02-08
Last full system update: 2024-04-02
Is partially upgraded:   No
Relevant software:       snapper NetworkManager dracut
Windows dual boot:       No/Undetected
Failed units:            NetworkManager-wait-online.service nmb.service
´´´

Ty everyone. <3

  • ONE issue per topic.
    Please. :slight_smile:
3 Likes

Sorry the real issue is the one about the browsers the other two things are mostly like general comments in this context.
I edited the post a bit more. I can edit it even more to remove all the reference to the other two things if needed. ty.

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.