Browser goes back when focus

This is a very specific topic, and I hope someone has an idea of what could be happening.

I have my browser opened with different tabs. When I go to another application and do something and then I come back to the browser, by using alt + tab or by clicking on the window, the current tab goes back without me click on the go back button.

I feel this might be some kind of missing keyboard configuration but I am pretty new with Garuda and linux in general.

Thanks, looking forward to hearing from you guys.

System:
Kernel: 6.9.1-arch1-Adashima-T2-1-t2 arch: x86_64 bits: 64 compiler: gcc
v: 14.1.1 clocksource: tsc avail: acpi_pm
parameters: BOOT_IMAGE=/@/boot/vmlinuz-linux-t2
root=UUID=b544ae5e-24a5-4978-9b09-caeb29d2331d rw rootflags=subvol=@
quiet resume=UUID=0369782e-1330-4908-b808-2bc6d74d1e20 loglevel=3
intel_iommu=on iommu=pt pcie_ports=compact ibt=off
Desktop: KDE Plasma v: 6.0.4 tk: Qt v: N/A info: frameworks v: 6.2.0
wm: kwin_wayland vt: 1 dm: SDDM Distro: Garuda base: Arch Linux
Machine:
Type: Laptop System: Apple product: MacBookPro16,3 v: 1.0
serial: <superuser required> Chassis: type: 9 v: Mac-E7203C0F68AA0004
serial: <superuser required>
Mobo: Apple model: Mac-E7203C0F68AA0004 v: MacBookPro16,3
serial: <superuser required> uuid: <superuser required> UEFI: Apple
v: 2022.100.22.0.0 (iBridge: 21.16.4222.0.0,0) date: 02/14/2024
Battery:
ID-1: BAT0 charge: 48.1 Wh (98.0%) condition: 49.1/58.2 Wh (84.5%)
volts: 12.6 min: 11.4 model: SMP bq20z451 type: Li-ion serial: N/A
status: full cycles: 281
CPU:
Info: model: Intel Core i5-8257U bits: 64 type: MT MCP arch: Coffee Lake
gen: core 8 level: v3 note: check built: 2017 process: Intel 14nm family: 6
model-id: 0x8E (142) stepping: 0xA (10) microcode: 0xF4
Topology: cpus: 1x cores: 4 tpc: 2 threads: 8 smt: enabled cache:
L1: 256 KiB desc: d-4x32 KiB; i-4x32 KiB L2: 1024 KiB desc: 4x256 KiB
L3: 6 MiB desc: 1x6 MiB
Speed (MHz): avg: 2129 high: 3869 min/max: 400/3900 scaling:
driver: intel_pstate governor: powersave cores: 1: 3860 2: 400 3: 400
4: 3853 5: 3869 6: 3856 7: 400 8: 400 bogomips: 22412
Flags: avx avx2 ht lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx
Vulnerabilities: <filter>
Graphics:
Device-1: Intel Coffee Lake-U GT3 [Iris Plus Graphics 645] vendor: Apple
driver: i915 v: kernel arch: Gen-9.5 process: Intel 14nm built: 2016-20
ports: active: DP-1,eDP-1 empty: DP-2,HDMI-A-1,HDMI-A-2 bus-ID: 00:02.0
chip-ID: 8086:3ea6 class-ID: 0300
Device-2: Apple FaceTime HD Camera (Built-in) driver: uvcvideo type: USB
rev: 2.0 speed: 480 Mb/s lanes: 1 mode: 2.0 bus-ID: 5-2:3 chip-ID: 05ac:8514
class-ID: 0e02 serial: <filter>
Device-3: Apple Touch Bar Display driver: appletbdrm,hid-multitouch,usbhid
type: USB rev: 2.0 speed: 480 Mb/s lanes: 1 mode: 2.0 bus-ID: 5-6:7
chip-ID: 05ac:8302 class-ID: 1000 serial: <filter>
Display: wayland server: X.org v: 1.21.1.13 with: Xwayland v: 24.1.0
compositor: kwin_wayland driver: X: loaded: modesetting
alternate: fbdev,intel,vesa dri: iris gpu: i915 d-rect: 5809x3391
display-ID: 0
Monitor-1: DP-1 pos: primary,top-left res: 3840x2160 size: N/A modes: N/A
Monitor-2: eDP-1 pos: bottom-r res: 1969x1231 size: N/A modes: N/A
API: EGL v: 1.5 hw: drv: intel iris platforms: device: 0 drv: iris
device: 1 drv: swrast gbm: drv: iris surfaceless: drv: iris wayland:
drv: iris x11: drv: iris
API: OpenGL v: 4.6 compat-v: 4.5 vendor: intel mesa v: 24.0.7-arch1.3
glx-v: 1.4 direct-render: yes renderer: Mesa Intel Iris Plus Graphics 645
(CFL GT3) device-ID: 8086:3ea6 memory: 7.43 GiB unified: yes
display-ID: :1.0
API: Vulkan v: 1.3.279 layers: 4 device: 0 type: integrated-gpu name: Intel
Iris Plus Graphics 645 (CFL GT3) driver: mesa intel v: 24.0.7-arch1.3
device-ID: 8086:3ea6 surfaces: xcb,xlib,wayland device: 1 type: cpu
name: llvmpipe (LLVM 17.0.6 256 bits) driver: mesa llvmpipe
v: 24.0.7-arch1.3 (LLVM 17.0.6) device-ID: 10005:0000
surfaces: xcb,xlib,wayland
Audio:
Device-1: Intel Cannon Point-LP High Definition Audio driver: snd_hda_intel
v: kernel alternate: snd_soc_skl, snd_soc_avs, snd_sof_pci_intel_cnl
bus-ID: 00:1f.3 chip-ID: 8086:9dc8 class-ID: 0403
Device-2: Apple Audio driver: aaudio pcie: gen: 3 speed: 8 GT/s lanes: 4
bus-ID: 02:00.3 chip-ID: 106b:1803 class-ID: 0401
Device-3: Apple Touch Bar Display driver: appletbdrm,hid-multitouch,usbhid
type: USB rev: 2.0 speed: 480 Mb/s lanes: 1 mode: 2.0 bus-ID: 5-6:7
chip-ID: 05ac:8302 class-ID: 1000 serial: <filter>
API: ALSA v: k6.9.1-arch1-Adashima-T2-1-t2 status: kernel-api tools: N/A
Server-1: PipeWire v: 1.0.6 status: active with: 1: pipewire-pulse
status: active 2: wireplumber status: active 3: pipewire-alsa type: plugin
4: pw-jack type: plugin tools: pactl,pw-cat,pw-cli,wpctl
Network:
Device-1: Broadcom BCM4377b Wireless Network Adapter vendor: Apple
driver: brcmfmac v: kernel pcie: gen: 2 speed: 5 GT/s lanes: 1
bus-ID: 01:00.0 chip-ID: 14e4:4488 class-ID: 0280
IF: wlan0 state: up mac: <filter>
Device-2: Broadcom BRCM4377 Bluetooth vendor: Apple driver: hci_bcm4377
v: kernel pcie: gen: 2 speed: 5 GT/s lanes: 1 port: N/A bus-ID: 01:00.1
chip-ID: 14e4:5fa0 class-ID: 0280
IF-ID-1: enp2s0f1u1 state: up speed: 100 Mbps duplex: half mac: <filter>
Info: services: iwd, NetworkManager, smbd, systemd-timesyncd
Drives:
Local Storage: total: 465.92 GiB used: 45.94 GiB (9.9%)
SMART Message: Unable to run smartctl. Root privileges required.
ID-1: /dev/nvme0n1 maj-min: 259:0 vendor: Apple model: SSD AP0512N
size: 465.92 GiB block-size: physical: 4096 B logical: 4096 B
speed: 31.6 Gb/s lanes: 4 tech: SSD serial: <filter> fw-rev: 1306
temp: 45.9 C scheme: GPT
Partition:
ID-1: / raw-size: 456.78 GiB size: 456.78 GiB (100.00%)
used: 45.94 GiB (10.1%) fs: btrfs dev: /dev/nvme0n1p2 maj-min: 259:2
ID-2: /boot/efi raw-size: 300 MiB size: 299.3 MiB (99.76%)
used: 584 KiB (0.2%) fs: vfat dev: /dev/nvme0n1p1 maj-min: 259:1
ID-3: /home raw-size: 456.78 GiB size: 456.78 GiB (100.00%)
used: 45.94 GiB (10.1%) fs: btrfs dev: /dev/nvme0n1p2 maj-min: 259:2
ID-4: /var/log raw-size: 456.78 GiB size: 456.78 GiB (100.00%)
used: 45.94 GiB (10.1%) fs: btrfs dev: /dev/nvme0n1p2 maj-min: 259:2
ID-5: /var/tmp raw-size: 456.78 GiB size: 456.78 GiB (100.00%)
used: 45.94 GiB (10.1%) fs: btrfs dev: /dev/nvme0n1p2 maj-min: 259:2
Swap:
Kernel: swappiness: 133 (default 60) cache-pressure: 100 (default) zswap: no
ID-1: swap-1 type: zram size: 7.61 GiB used: 4.93 GiB (64.9%)
priority: 100 comp: zstd avail: lzo,lzo-rle,lz4,lz4hc,842 max-streams: 8
dev: /dev/zram0
ID-2: swap-2 type: partition size: 8.8 GiB used: 0 KiB (0.0%) priority: -2
dev: /dev/nvme0n1p3 maj-min: 259:3
Sensors:
System Temperatures: cpu: 61.0 C pch: 55.0 C mobo: N/A
Fan Speeds (rpm): cpu: 1809
Info:
Memory: total: 8 GiB available: 7.61 GiB used: 5.81 GiB (76.4%)
Processes: 360 Power: uptime: 1d 1h 7m states: freeze,mem,disk
suspend: deep avail: s2idle wakeups: 0 hibernate: platform avail: shutdown,
reboot, suspend, test_resume image: 2.98 GiB services: org_kde_powerdevil,
power-profiles-daemon, upowerd Init: systemd v: 255 default: graphical
tool: systemctl
Packages: 1695 pm: pacman pkgs: 1677 libs: 441 tools: gnome-software,
octopi, pamac, paru, yay pm: flatpak pkgs: 18 Compilers: gcc: 14.1.1
Shell: garuda-inxi default: fish v: 3.7.1 running-in: konsole inxi: 3.3.34
Garuda (2.6.26-1):
System install date:     2024-04-27
Last full system update: 2024-05-20 ↻
Is partially upgraded:   No
Relevant software:       snapper NetworkManager dracut
Windows dual boot:       No/Undetected
Failed units:

Its important to post garuda-inxi for tailored help.

You didn’t even mention the kind of browser you are using?
1. Does it happen on every browser
2. Does it happen on a specific browser e.g Edge?

I a simple hack would be to probably install the [num extension] have tab numbers and to quickly switch between tabs with ctrl + num if this happens.
You could also look up how to disable alt + tab action on your specific browser.

2 Likes

Sorry, when I posted this yesterday at night I was in my other computer. I updated the post with the inxi.

About the browser, yes, it happens with all of them. I try different browsers already, the FireDragon, Chrome and Brave so far.

I thought about shortcuts stuff, but this happens even if I use the mouse to select the window of the browser.

You say it happens when you press the alt + tab,
I assume the alt is probably read when now opening the browser in combination with mouse wheel

Maybe change mousewheel.with_alt.action = 2 to mousewheel.with_alt.action = 0
In firedragon about:config
More about this on:
https://support.mozilla.org/bm/questions/1358257

1 Like

It happens when I click the window too. Let’s say I am in the Konsole, and then the browser window is behind it, so I click to go to that window, then the go back happens.

have you tried the above? specifically for firedragon or firefox

So I discovered that only happens when I have a secondary monitor connected.

I will close my entry. It looks like after some updates, meaning running sudo garuda-update the issue stopped. I don’t know what exactly fixed it, but just for the record. I update to the latest update of the T2 Kernel because I am using a MacBook Pro.

1 Like

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.