Bringing back the menubar?

$ garuda-inxi
System:
  Kernel: 6.4.8-zen1-1-zen arch: x86_64 bits: 64 compiler: gcc v: 13.2.1
    parameters: BOOT_IMAGE=/@/boot/vmlinuz-linux-zen
    root=UUID=b89338b8-ae03-41ea-802e-d4bbd5f18be2 rw rootflags=subvol=@
    quiet quiet rd.udev.log_priority=3 vt.global_cursor_default=0
    resume=UUID=13bc6369-09d8-4413-ac98-e2023af565bc loglevel=3 ibt=off
  Desktop: KDE Plasma v: 5.27.7 tk: Qt v: 5.15.10 wm: kwin_x11 vt: 2
    dm: SDDM Distro: Garuda Linux base: Arch Linux
Machine:
  Type: Laptop System: Razer product: Blade 14 (2022) - RZ09-0427 v: 8.04
    serial: <superuser required> Chassis: type: 10 serial: <superuser required>
  Mobo: Razer model: PI480 v: 4 serial: <superuser required> UEFI: Razer
    v: 3.06 date: 01/15/2023
Battery:
  ID-1: BAT0 charge: 60.5 Wh (100.0%) condition: 60.5/61.6 Wh (98.1%)
    volts: 17.5 min: 15.4 model: Razer Blade type: Unknown serial: <filter>
    status: full
CPU:
  Info: model: AMD Ryzen 9 6900HX with Radeon Graphics bits: 64 type: MT MCP
    arch: Zen 3+ gen: 4 level: v3 note: check built: 2022 process: TSMC n6 (7nm)
    family: 0x19 (25) model-id: 0x44 (68) stepping: 1 microcode: 0xA404102
  Topology: cpus: 1x cores: 8 tpc: 2 threads: 16 smt: enabled cache:
    L1: 512 KiB desc: d-8x32 KiB; i-8x32 KiB L2: 4 MiB desc: 8x512 KiB
    L3: 16 MiB desc: 1x16 MiB
  Speed (MHz): avg: 3081 high: 3300 min/max: 1600/4934 boost: enabled
    scaling: driver: acpi-cpufreq governor: performance cores: 1: 3300 2: 3300
    3: 3300 4: 3300 5: 3300 6: 3300 7: 3300 8: 3300 9: 1748 10: 3300 11: 3300
    12: 1363 13: 3300 14: 3300 15: 3300 16: 3300 bogomips: 105400
  Flags: avx avx2 ht lm nx pae sse sse2 sse3 sse4_1 sse4_2 sse4a ssse3 svm
  Vulnerabilities: <filter>
Graphics:
  Device-1: NVIDIA GA106M [GeForce RTX 3060 Mobile / Max-Q] vendor: Razer USA
    driver: nvidia v: 535.86.05 alternate: nouveau,nvidia_drm non-free: 535.xx+
    status: current (as of 2023-07) arch: Ampere code: GAxxx
    process: TSMC n7 (7nm) built: 2020-22 pcie: gen: 1 speed: 2.5 GT/s
    lanes: 8 link-max: gen: 4 speed: 16 GT/s lanes: 16 bus-ID: 01:00.0
    chip-ID: 10de:2520 class-ID: 0300
  Device-2: AMD Rembrandt [Radeon 680M] vendor: Razer USA driver: amdgpu
    v: kernel arch: RDNA-2 code: Navi-2x process: TSMC n7 (7nm) built: 2020-22
    pcie: gen: 4 speed: 16 GT/s lanes: 16 ports: active: eDP-1 empty: DP-1,
    DP-2, DP-3, DP-4, DP-5, DP-6 bus-ID: 64:00.0 chip-ID: 1002:1681
    class-ID: 0300 temp: 48.0 C
  Device-3: IMC Networks Integrated RGB Camera driver: uvcvideo type: USB
    rev: 2.0 speed: 480 Mb/s lanes: 1 mode: 2.0 bus-ID: 5-1:2 chip-ID: 13d3:5279
    class-ID: 0e02 serial: <filter>
  Display: x11 server: X.Org v: 21.1.8 with: Xwayland v: 23.1.2
    compositor: kwin_x11 driver: X: loaded: amdgpu,nvidia
    unloaded: modesetting,nouveau alternate: fbdev,nv,vesa dri: radeonsi
    gpu: amdgpu display-ID: :0 screens: 1
  Screen-1: 0 s-res: 1920x1080 s-dpi: 96 s-size: 508x285mm (20.00x11.22")
    s-diag: 582mm (22.93")
  Monitor-1: eDP-1 mapped: eDP model: Sharp LQ140M1JW49 built: 2020
    res: 1920x1080 hz: 144 dpi: 158 gamma: 1.2 size: 309x174mm (12.17x6.85")
    diag: 355mm (14") ratio: 16:9 modes: max: 1920x1080 min: 640x480
  API: OpenGL v: 4.6 Mesa 23.1.5 renderer: AMD Radeon Graphics (rembrandt
    LLVM 15.0.7 DRM 3.52 6.4.8-zen1-1-zen) direct-render: Yes
Audio:
  Device-1: NVIDIA GA106 High Definition Audio vendor: Razer USA
    driver: snd_hda_intel v: kernel pcie: gen: 1 speed: 2.5 GT/s lanes: 8
    link-max: gen: 4 speed: 16 GT/s lanes: 16 bus-ID: 01:00.1
    chip-ID: 10de:228e class-ID: 0403
  Device-2: AMD Rembrandt Radeon High Definition Audio driver: snd_hda_intel
    v: kernel pcie: gen: 4 speed: 16 GT/s lanes: 16 bus-ID: 64:00.1
    chip-ID: 1002:1640 class-ID: 0403
  Device-3: AMD ACP/ACP3X/ACP6x Audio Coprocessor vendor: Razer USA
    driver: snd_pci_acp6x v: kernel alternate: snd_pci_acp3x, snd_rn_pci_acp3x,
    snd_pci_acp5x, snd_acp_pci, snd_rpl_pci_acp6x, snd_pci_ps,
    snd_sof_amd_renoir, snd_sof_amd_rembrandt pcie: gen: 4 speed: 16 GT/s
    lanes: 16 bus-ID: 64:00.5 chip-ID: 1022:15e2 class-ID: 0480
  Device-4: AMD Family 17h/19h HD Audio vendor: Razer USA
    driver: snd_hda_intel v: kernel pcie: gen: 4 speed: 16 GT/s lanes: 16
    bus-ID: 64:00.6 chip-ID: 1022:15e3 class-ID: 0403
  API: ALSA v: k6.4.8-zen1-1-zen status: kernel-api tools: N/A
  Server-1: PipeWire v: 0.3.77 status: active with: 1: pipewire-pulse
    status: active 2: wireplumber status: active 3: pipewire-alsa type: plugin
    4: pw-jack type: plugin tools: pactl,pw-cat,pw-cli,wpctl
Network:
  Device-1: Qualcomm QCNFA765 Wireless Network Adapter vendor: Lite-On
    driver: ath11k_pci v: kernel pcie: gen: 2 speed: 5 GT/s lanes: 1 link-max:
    gen: 3 speed: 8 GT/s bus-ID: 02:00.0 chip-ID: 17cb:1103 class-ID: 0280
  IF: wlp2s0 state: up mac: <filter>
Bluetooth:
  Device-1: Lite-On driver: btusb v: 0.8 type: USB rev: 1.1 speed: 12 Mb/s
    lanes: 1 mode: 1.1 bus-ID: 1-3:2 chip-ID: 04ca:3a24 class-ID: e001
  Report: bt-adapter ID: hci0 rfk-id: 0 state: up address: <filter>
Drives:
  Local Storage: total: 953.87 GiB used: 19.26 GiB (2.0%)
  SMART Message: Unable to run smartctl. Root privileges required.
  ID-1: /dev/nvme0n1 maj-min: 259:0 model: NVMe CA6-8D1024 size: 953.87 GiB
    block-size: physical: 512 B logical: 512 B speed: 63.2 Gb/s lanes: 4
    tech: SSD serial: <filter> fw-rev: ERA0906 temp: 38.9 C scheme: GPT
Partition:
  ID-1: / raw-size: 937.19 GiB size: 937.19 GiB (100.00%)
    used: 19.26 GiB (2.1%) fs: btrfs dev: /dev/nvme0n1p2 maj-min: 259:2
  ID-2: /boot/efi raw-size: 300 MiB size: 299.4 MiB (99.80%)
    used: 576 KiB (0.2%) fs: vfat dev: /dev/nvme0n1p1 maj-min: 259:1
  ID-3: /home raw-size: 937.19 GiB size: 937.19 GiB (100.00%)
    used: 19.26 GiB (2.1%) fs: btrfs dev: /dev/nvme0n1p2 maj-min: 259:2
  ID-4: /var/log raw-size: 937.19 GiB size: 937.19 GiB (100.00%)
    used: 19.26 GiB (2.1%) fs: btrfs dev: /dev/nvme0n1p2 maj-min: 259:2
  ID-5: /var/tmp raw-size: 937.19 GiB size: 937.19 GiB (100.00%)
    used: 19.26 GiB (2.1%) fs: btrfs dev: /dev/nvme0n1p2 maj-min: 259:2
Swap:
  Kernel: swappiness: 133 (default 60) cache-pressure: 100 (default)
  ID-1: swap-1 type: zram size: 14.89 GiB used: 216 MiB (1.4%) priority: 100
    dev: /dev/zram0
  ID-2: swap-2 type: partition size: 16.38 GiB used: 0 KiB (0.0%)
    priority: -2 dev: /dev/nvme0n1p3 maj-min: 259:3
Sensors:
  System Temperatures: cpu: 54.6 C mobo: N/A gpu: amdgpu temp: 49.0 C
  Fan Speeds (RPM): N/A
Info:
  Processes: 448 Uptime: 12h 37m wakeups: 52917 Memory: total: 16 GiB
  note: est. available: 14.89 GiB used: 8.39 GiB (56.3%) Init: systemd v: 254
  default: graphical tool: systemctl Compilers: gcc: 13.2.1 clang: 15.0.7
  Packages: pm: pacman pkgs: 1514 libs: 385 tools: octopi,paru Shell: Zsh
  v: 5.9 running-in: konsole inxi: 3.3.28
Garuda (2.6.16-1):
  System install date:     2023-08-04
  Last full system update: 2023-08-06 ↻
  Is partially upgraded:   No
  Relevant software:       snapper NetworkManager dracut nvidia-dkms
  Windows dual boot:       Probably (Run as root to verify)
  Failed units:

Question:

I was looking into how to bring back the menu bar on maximized windows in KDE.

I tried going through the KDE settings and Garuda's many windows and menus to see if I could find the option with no luck.

I was going through paru -Qe | rg garuda, and saw garuda-dr460nized, I tried removing it to see if the change for the menubar was there, and I saw no change.

I tried going through the themes folder in the Garuda GitLab with no luck either. I'm not a KDE or QT developer, so I'm having a tough time. One file that seemed like it might contain leads was this on But I think I'm looking in the wrong place.

Since I'm using the GruvBox theme (just a regular KDE theme), the menu bar is relatively important to me, I'm working around it by including the "Applications menu" button in System Settings (KDE) > Appearance > Global Theme > Window Decorations > Titlebar Buttons, not too sure what I'm doing.

You should have a global menu or apps menu widget on you main panel. Right click the pane, chose edit, mouseover thw widget and on the menu that pops up chose remove. Then you can run the below in Konsol and do a restart.

cd ~/.config
sed -i 's/MenuBar=Disabled/MenuBar=Enabled/' *rc

I love having the menubar embedded directly into the window titlebar.

Specifically this variant.

It's a window decoration theme.

2 Likes

If you had taken the time to search the forum you would of found that it's relatively simple to restore the menu bar. Matter of fact I just helped someone yesterday with it. Now do a proper search and find what I posted yesterday.

Well thank you for your earlier answer. I actually did look it up by looking for "menubar" in the reddit and in this forum, and I found a post from 2020 I believe that had that same solution, after I ran it I saw no change, and I tried cating all of the files which should have changed, and found no reference to these props. I just gave up since I had just installed it, and I needed access to the props so I just re-flashed my computer with the lite version because I didn't have the time and needed to use libreoffice.

Now here's the thing. Please remember that not all those who ask not having found an answer have not done a proper search. Please consider that maybe a person (because I'm a person too) could have missed it, specially since I've never used a forum with this interface. New interfaces confuse me like they do to anyone. To the next person that asks you about the menu bar, please at least give them a link, that's treating someone with respect. I don't want to use this forum any longer.

Lovely :smiley: I might try it out

1 Like

I'm sorry but if you had actually done a proper search you would of found several threads. That is why I did not post the link. I'm not the one that was disrespectful.

Please consider this one condescending response you have received is not representative of the entire community. @Locutus is not known for being friendly (no offense Locutus, a spade is a spade). Many of us do make an effort to provide helpful guidance, post links, encourage newcomers, et cetera, so to see the entire forum be dismissed because one person made a belittling comment is somewhat disappointing.

As for this comment:

I took a look and it appears the “help” being referenced here is actually just comment #2 in this very thread.

No need to post a link in this case, you can just scroll up a few lines. :face_with_hand_over_mouth:

@jaacko-torus can you please clarify if the issue has been resolved or not? I see there were a couple suggestions so far, but you didn’t specifically mention if your issue was addressed in a meaningful way.

5 Likes

There was nothing wrong with my response and you know it. Now let's please stay on subject.

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.