Brightness controls, a different behaviour between dragonized and qtile garuda distribution

brightness controls

different behaviour between dragonized and qtile garuda distribution

hi guys :slight_smile:
I just recently switched from garuda dragonized version to qtile version since i want to start a little bit more customization.
the installation was flawless as always but i encountered a bit of a different behaviour in qtile version

the issue

basically the brightness keys, the volume keys and the multimedia keys of my laptop are not working since i installed the qtile version (they did work on the dragonized one)

what i tried

i tried opening qtile config under ~/.config /qtile config.py in search for the keybindings and i found them (i'll take brightness ones as an example but i did it with the multimedia controls too)

Key([], "XF86MonBrightnessUp", lazy.spawn("xbacklight -inc 5")),
Key([], "XF86MonBrightnessDown", lazy.spawn("xbacklight -dec 5")),

so i started checking if it was a problem related to XF86MonBrightnessUp ecc... not correctly detecting the keypress by manually changing them to other keybinding:

 Key([], "F2", lazy.spawn("xbacklight -inc 5")),
 Key([], "F3", lazy.spawn("xbacklight -dec 5")),

this didnt resolve it (i tried even simpler key combination like mod 2 ecc...) so i thought about trying the xbacklight command in the command line to check if it works
i tried these 3 commands

xbacklight -inc 5
xbacklight -dec 5
xbacklight -set 50

sadly still no effect.

questions

At this point i am not sure how to proceed and a bit confused, does Dragonized and Qtile versions use different commands to achieve backlight and multimedia controls? Am i missing something?
i am a bit curious about the difference.

As always thank u all in advance :slight_smile:

inxi Faz:

System:    Kernel: 5.15.2-zen1-1-zen x86_64 bits: 64 compiler: gcc v: 11.1.0
           parameters: BOOT_IMAGE=/@/boot/vmlinuz-linux-zen root=UUID=5b9cbf72-8160-43f1-9d88-8466ea0d08f5 rw
           [email protected] quiet splash rd.udev.log_priority=3 vt.global_cursor_default=0
           systemd.unified_cgroup_hierarchy=1 loglevel=3
           Desktop: Qtile 0.18.1 wm: LG3D vt: 1 dm: SDDM Distro: Garuda Linux base: Arch Linux
Machine:   Type: Laptop System: HP product: HP Pavilion Power Laptop 15-cb0xx v: Type1ProductConfigId serial: <filter>
           Chassis: type: 10 serial: <filter>
           Mobo: HP model: 836B v: 46.21 serial: <filter> UEFI: Insyde v: F.10 date: 07/28/2017
Battery:   ID-1: BAT0 charge: 51.3 Wh (91.3%) condition: 56.2/56.2 Wh (100.0%) volts: 16.9 min: 15.4 model: HP Primary
           type: Li-ion serial: N/A status: Unknown
CPU:       Info: Quad Core model: Intel Core i7-7700HQ bits: 64 type: MT MCP arch: Kaby Lake family: 6 model-id: 9E (158)
           stepping: 9 microcode: EA cache: L2: 6 MiB
           flags: avx avx2 lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx bogomips: 44798
           Speed: 2413 MHz min/max: 800/2800 MHz Core speeds (MHz): 1: 2413 2: 2050 3: 2435 4: 2486 5: 1747 6: 2554 7: 2557
           8: 1718
           Vulnerabilities: Type: itlb_multihit status: KVM: VMX disabled
           Type: l1tf mitigation: PTE Inversion; VMX: conditional cache flushes, SMT vulnerable
           Type: mds mitigation: Clear CPU buffers; SMT vulnerable
           Type: meltdown mitigation: PTI
           Type: spec_store_bypass mitigation: Speculative Store Bypass disabled via prctl
           Type: spectre_v1 mitigation: usercopy/swapgs barriers and __user pointer sanitization
           Type: spectre_v2 mitigation: Full generic retpoline, IBPB: conditional, IBRS_FW, STIBP: conditional, RSB filling
           Type: srbds mitigation: Microcode
           Type: tsx_async_abort status: Not affected
Graphics:  Device-1: Intel HD Graphics 630 vendor: Hewlett-Packard driver: i915 v: kernel bus-ID: 00:02.0 chip-ID: 8086:591b
           class-ID: 0300
           Device-2: NVIDIA GP107M [GeForce GTX 1050 Mobile] vendor: Hewlett-Packard driver: nvidia v: 495.44
           alternate: nouveau,nvidia_drm bus-ID: 01:00.0 chip-ID: 10de:1c8d class-ID: 0300
           Device-3: Chicony HP Wide Vision HD Camera type: USB driver: uvcvideo bus-ID: 1-4:2 chip-ID: 04f2:b5d6
           class-ID: 0e02
           Display: x11 server: X.Org 1.21.1.1 compositor: picom v: git-c4107 driver: loaded: modesetting,nvidia
           display-ID: :0 screens: 1
           Screen-1: 0 s-res: 1920x1080 s-dpi: 96 s-size: 508x285mm (20.0x11.2") s-diag: 582mm (22.9")
           Monitor-1: eDP-1 res: 1920x1080 hz: 60 dpi: 142 size: 344x194mm (13.5x7.6") diag: 395mm (15.5")
           OpenGL: renderer: Mesa Intel HD Graphics 630 (KBL GT2) v: 4.6 Mesa 21.2.5 direct render: Yes
Audio:     Device-1: Intel CM238 HD Audio vendor: Hewlett-Packard driver: snd_hda_intel v: kernel bus-ID: 00:1f.3
           chip-ID: 8086:a171 class-ID: 0403
           Device-2: NVIDIA GP107GL High Definition Audio driver: snd_hda_intel v: kernel bus-ID: 01:00.1 chip-ID: 10de:0fb9
           class-ID: 0403
           Sound Server-1: ALSA v: k5.15.2-zen1-1-zen running: yes
           Sound Server-2: JACK v: 1.9.19 running: no
           Sound Server-3: PulseAudio v: 15.0 running: no
           Sound Server-4: PipeWire v: 0.3.40 running: yes
Network:   Device-1: Intel Wireless 7265 driver: iwlwifi v: kernel bus-ID: 04:00.0 chip-ID: 8086:095a class-ID: 0280
           IF: wlo1 state: up mac: <filter>
           Device-2: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet vendor: Hewlett-Packard driver: r8169 v: kernel
           port: 3000 bus-ID: 05:00.0 chip-ID: 10ec:8168 class-ID: 0200
           IF: eno1 state: down mac: <filter>
Bluetooth: Device-1: Intel Bluetooth wireless interface type: USB driver: btusb v: 0.8 bus-ID: 1-7:3 chip-ID: 8087:0a2a
           class-ID: e001
           Report: bt-adapter ID: hci0 rfk-id: 0 state: down bt-service: enabled,running rfk-block: hardware: no software: yes
           address: <filter>
Drives:    Local Storage: total: 1.03 TiB used: 12.09 GiB (1.2%)
           SMART Message: Required tool smartctl not installed. Check --recommends
           ID-1: /dev/nvme0n1 maj-min: 259:0 vendor: Toshiba model: N/A size: 119.24 GiB block-size: physical: 512 B
           logical: 512 B speed: 31.6 Gb/s lanes: 4 type: SSD serial: <filter> rev: 5KHA4102 temp: 39.9 C scheme: GPT
           ID-2: /dev/sda maj-min: 8:0 vendor: HGST (Hitachi) model: HTS721010A9E630 size: 931.51 GiB block-size:
           physical: 4096 B logical: 512 B speed: 6.0 Gb/s type: HDD rpm: 7200 serial: <filter> rev: A3T0 scheme: GPT
Partition: ID-1: / raw-size: 118.95 GiB size: 118.95 GiB (100.00%) used: 11.57 GiB (9.7%) fs: btrfs dev: /dev/nvme0n1p2
           maj-min: 259:2
           ID-2: /boot/efi raw-size: 300 MiB size: 299.4 MiB (99.80%) used: 576 KiB (0.2%) fs: vfat dev: /dev/nvme0n1p1
           maj-min: 259:1
           ID-3: /home raw-size: 118.95 GiB size: 118.95 GiB (100.00%) used: 11.57 GiB (9.7%) fs: btrfs dev: /dev/nvme0n1p2
           maj-min: 259:2
           ID-4: /var/log raw-size: 118.95 GiB size: 118.95 GiB (100.00%) used: 11.57 GiB (9.7%) fs: btrfs dev: /dev/nvme0n1p2
           maj-min: 259:2
           ID-5: /var/tmp raw-size: 118.95 GiB size: 118.95 GiB (100.00%) used: 11.57 GiB (9.7%) fs: btrfs dev: /dev/nvme0n1p2
           maj-min: 259:2
Swap:      Kernel: swappiness: 133 (default 60) cache-pressure: 100 (default)
           ID-1: swap-1 type: zram size: 15.51 GiB used: 0 KiB (0.0%) priority: 100 dev: /dev/zram0
Sensors:   System Temperatures: cpu: 49.0 C mobo: N/A
           Fan Speeds (RPM): N/A
Info:      Processes: 261 Uptime: 19m wakeups: 1 Memory: 15.51 GiB used: 2.71 GiB (17.5%) Init: systemd v: 249 tool: systemctl
           Compilers: gcc: 11.1.0 clang: 13.0.0 Packages: pacman: 1230 lib: 302 Shell: fish v: 3.3.1 running-in: kitty
           inxi: 3.3.08

Was the "working configuration" on the same kernel version?
I remember reading someone having troubles with brightness in kernel 5.15.
Could it be that the Dr460nized was before?
Maybe you could try installing the linux-lts now on qtile.

2 Likes

hi, i tried switching the kernel to linux-lts but it didnt resolve it.

You were right about the kernel difference tho, i checked zen versions and they were different 5.14.8(dragonized) 5.15.2(qtile current)

1 Like

Sorry, don't know much about qtile. We'll need someone more experienced.
If it was only e.g. about brightness, maybe it could worth digging somewhere, but since this occurs also for multimedia controls there must be some explanation.
For brightness e.g. I was checking here that brightnessctl could help to add udev rules to allow members of the video (or input) group to modify brightness, due to something I read here.
Also this could be an idea, but it is not specified with which cards it can help.
We'll see... Good luck!

4 Likes

actually i just tried brightnessctl and it works!!
i changed the keybinds to :

    Key([], "XF86MonBrightnessUp", lazy.spawn("brightnessctl s +5%")),
    Key([], "XF86MonBrightnessDown", lazy.spawn("brightnessctl s 5%-")),

and now they work perfectly
grazie!

i will still try to search for how to adjust the multimedia and volume keys :slight_smile:

quick edit: i forgot to mention i had to install it by sudo pacman -S brightnessctl

2 Likes

Prego...!!!

2 Likes

It might be worth implementing this in the default config if its universally applicable? @RohitSingh :thinking:

2 Likes

Maybe give a look here...

I just find out the problem with the audio keys
the problem was that the

alsa-utils

package was not installed but it was called by

    Key([], "XF86AudioMute", lazy.spawn("amixer -q set Master toggle")),
    Key([], "XF86AudioLowerVolume", lazy.spawn("amixer -q set Master 5%-")),
    Key([], "XF86AudioRaiseVolume", lazy.spawn("amixer -q set Master 5%+")),

since amixer is part of alsa-utils as it is said here

installing alsa-utils via:

sudo pacman -S alsa-utils

and then rebooting did the trick :).
is maybe alsa-utils not part of the qtile installation?

2 Likes

For completeness, I'll mark post #4 as Solution.
It is important to mark topics as "solved" for future users, when they search in the forum.
Don't hesitate to do otherwise if you prefer.
There are other aspects for the audio, but I think the most important aspect is the one above.

Yeah sure I will replace xbacklight with brightnessctl :slightly_smiling_face:

3 Likes

Earlier alsa-utils was dependency of pavucontrol(or dependency of its dependency) but it is no longer now.

Thanks for pointing I will make it dependency of qtile-setting

6 Likes

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.