Brave PWA icons grouped with Brave Instead of Having their own icon

System:
Kernel: 5.18.9-zen1-1-zen arch: x86_64 bits: 64 compiler: gcc v: 12.1.0
parameters: BOOT_IMAGE=/@/boot/vmlinuz-linux-zen
root=UUID=d74a47ce-c071-4684-aa64-3eb5cafdaff7 rw [email protected]
quiet quiet splash rd.udev.log_priority=3 vt.global_cursor_default=0
loglevel=3
Desktop: KDE Plasma v: 5.25.2 tk: Qt v: 5.15.5 info: latte-dock
wm: kwin_x11 vt: 1 dm: SDDM Distro: Garuda Linux base: Arch Linux
Machine:
Type: Desktop Mobo: ASRock model: B550 Phantom Gaming-ITX/ax
serial: <superuser required> UEFI: American Megatrends LLC. v: P2.20
date: 08/05/2021
CPU:
Info: model: AMD Ryzen 5 5500 bits: 64 type: MT MCP arch: Zen 3 gen: 4
built: 2021-22 process: TSMC n7 (7nm) family: 0x19 (25) model-id: 0x50 (80)
stepping: 0 microcode: 0xA50000C
Topology: cpus: 1x cores: 6 tpc: 2 threads: 12 smt: enabled cache:
L1: 384 KiB desc: d-6x32 KiB; i-6x32 KiB L2: 3 MiB desc: 6x512 KiB
L3: 16 MiB desc: 1x16 MiB
Speed (MHz): avg: 2990 high: 2994 min/max: 1400/4268 boost: enabled
scaling: driver: acpi-cpufreq governor: performance cores: 1: 2991 2: 2994
3: 2994 4: 2991 5: 2992 6: 2969 7: 2994 8: 2991 9: 2992 10: 2988 11: 2994
12: 2993 bogomips: 86242
Flags: avx avx2 ht lm nx pae sse sse2 sse3 sse4_1 sse4_2 sse4a ssse3 svm
Vulnerabilities:
Type: itlb_multihit status: Not affected
Type: l1tf status: Not affected
Type: mds status: Not affected
Type: meltdown status: Not affected
Type: mmio_stale_data status: Not affected
Type: spec_store_bypass
mitigation: Speculative Store Bypass disabled via prctl
Type: spectre_v1
mitigation: usercopy/swapgs barriers and __user pointer sanitization
Type: spectre_v2 mitigation: Retpolines, IBPB: conditional, IBRS_FW,
STIBP: always-on, RSB filling
Type: srbds status: Not affected
Type: tsx_async_abort status: Not affected
Graphics:
Device-1: NVIDIA TU106 [GeForce RTX 2060 SUPER] vendor: Micro-Star MSI
driver: nvidia v: 515.57 alternate: nouveau,nvidia_drm non-free: 515.xx+
status: current (as of 2022-06) arch: Turing process: TSMC 12nm
built: 2018-22 pcie: gen: 3 speed: 8 GT/s lanes: 16 bus-ID: 01:00.0
chip-ID: 10de:1f06 class-ID: 0300
Device-2: Creative Live! Cam Sync 1080p type: USB
driver: snd-usb-audio,uvcvideo bus-ID: 3-1.1:4 chip-ID: 041e:409f
class-ID: 0102 serial: <filter>
Display: x11 server: X.Org v: 21.1.3 with: Xwayland v: 22.1.2
compositor: kwin_x11 driver: X: loaded: nvidia unloaded: modesetting
alternate: fbdev,nouveau,nv,vesa gpu: nvidia display-ID: :0 screens: 1
Screen-1: 0 s-res: 1921x2160 s-dpi: 80 s-size: 610x686mm (24.02x27.01")
s-diag: 918mm (36.14")
Monitor-1: DP-2 pos: primary,bottom-l res: 1920x1080 dpi: 82
size: 598x336mm (23.54x13.23") diag: 686mm (27.01") modes: N/A
Monitor-2: HDMI-0 pos: top-right res: 1920x1080 hz: 60 dpi: 102
size: 480x270mm (18.9x10.63") diag: 551mm (21.68") modes: N/A
OpenGL: renderer: NVIDIA GeForce RTX 2060 SUPER/PCIe/SSE2
v: 4.6.0 NVIDIA 515.57 direct render: Yes
Audio:
Device-1: NVIDIA TU106 High Definition Audio vendor: Micro-Star MSI
driver: snd_hda_intel bus-ID: 3-1.1:4 v: kernel chip-ID: 041e:409f pcie:
gen: 3 class-ID: 0102 speed: 8 GT/s serial: <filter> lanes: 16
bus-ID: 01:00.1 chip-ID: 10de:10f9 class-ID: 0403
Device-2: AMD Renoir Radeon High Definition Audio driver: snd_hda_intel
v: kernel pcie: gen: 3 speed: 8 GT/s lanes: 16 link-max: gen: 4
speed: 16 GT/s bus-ID: 08:00.1 chip-ID: 1002:1637 class-ID: 0403
Device-3: AMD Family 17h/19h HD Audio vendor: ASRock
driver: snd_hda_intel v: kernel pcie: gen: 3 speed: 8 GT/s lanes: 16
link-max: gen: 4 speed: 16 GT/s bus-ID: 08:00.6 chip-ID: 1022:15e3
class-ID: 0403
Device-4: Creative Live! Cam Sync 1080p type: USB
driver: snd-usb-audio,uvcvideo
Device-5: C-Media Q9-1 type: USB driver: hid-generic,snd-usb-audio,usbhid
bus-ID: 3-1.2:5 chip-ID: 0d8c:0135 class-ID: 0300
Device-6: Corsair HS70 Pro Wireless Gaming Headset type: USB
driver: hid-generic,snd-usb-audio,usbhid bus-ID: 3-1.4:6 chip-ID: 1b1c:0a4f
class-ID: 0300
Sound Server-1: ALSA v: k5.18.9-zen1-1-zen running: yes
Sound Server-2: PulseAudio v: 16.1 running: no
Sound Server-3: PipeWire v: 0.3.54 running: yes
Network:
Device-1: Intel Ethernet I225-V driver: igc v: kernel pcie: gen: 2
speed: 5 GT/s lanes: 1 port: N/A bus-ID: 05:00.0 chip-ID: 8086:15f3
class-ID: 0200
IF: enp5s0 state: up speed: 1000 Mbps duplex: full mac: <filter>
Device-2: Intel Wi-Fi 6 AX200 driver: iwlwifi v: kernel pcie: gen: 2
speed: 5 GT/s lanes: 1 bus-ID: 06:00.0 chip-ID: 8086:2723 class-ID: 0280
IF: wlp6s0 state: down mac: <filter>
Bluetooth:
Device-1: Intel AX200 Bluetooth type: USB driver: btusb v: 0.8
bus-ID: 3-9:9 chip-ID: 8087:0029 class-ID: e001
Report: bt-adapter ID: hci0 rfk-id: 2 state: down
bt-service: enabled,running rfk-block: hardware: no software: yes
address: <filter>
Drives:
Local Storage: total: 1.87 TiB used: 20 GiB (1.0%)
SMART Message: Unable to run smartctl. Root privileges required.
ID-1: /dev/nvme0n1 maj-min: 259:1 vendor: Western Digital
model: WD BLACK SN770 1TB size: 931.51 GiB block-size: physical: 512 B
logical: 512 B speed: 63.2 Gb/s lanes: 4 type: SSD serial: <filter>
rev: 731030WD temp: 42.9 C scheme: GPT
ID-2: /dev/nvme1n1 maj-min: 259:0 vendor: Silicon Power
model: SPCC M.2 PCIe SSD size: 953.87 GiB block-size: physical: 512 B
logical: 512 B speed: 31.6 Gb/s lanes: 4 type: SSD serial: <filter>
rev: SN07151 temp: 41.9 C scheme: GPT
ID-3: /dev/sda maj-min: 8:0 type: USB vendor: PNY model: USB 2.0 FD
size: 28.91 GiB block-size: physical: 512 B logical: 512 B type: N/A
serial: <filter> rev: PMAP scheme: MBR
SMART Message: Unknown USB bridge. Flash drive/Unsupported enclosure?
Partition:
ID-1: / raw-size: 442.5 GiB size: 442.5 GiB (100.00%) used: 20 GiB (4.5%)
fs: btrfs dev: /dev/nvme0n1p2 maj-min: 259:3
ID-2: /boot/efi raw-size: 750 MiB size: 748.5 MiB (99.80%)
used: 608 KiB (0.1%) fs: vfat dev: /dev/nvme0n1p1 maj-min: 259:2
ID-3: /home raw-size: 442.5 GiB size: 442.5 GiB (100.00%)
used: 20 GiB (4.5%) fs: btrfs dev: /dev/nvme0n1p2 maj-min: 259:3
ID-4: /var/log raw-size: 442.5 GiB size: 442.5 GiB (100.00%)
used: 20 GiB (4.5%) fs: btrfs dev: /dev/nvme0n1p2 maj-min: 259:3
ID-5: /var/tmp raw-size: 442.5 GiB size: 442.5 GiB (100.00%)
used: 20 GiB (4.5%) fs: btrfs dev: /dev/nvme0n1p2 maj-min: 259:3
Swap:
Kernel: swappiness: 133 (default 60) cache-pressure: 100 (default)
ID-1: swap-1 type: zram size: 15.49 GiB used: 2 MiB (0.0%) priority: 100
dev: /dev/zram0
Sensors:
System Temperatures: cpu: N/A mobo: N/A gpu: nvidia temp: 43 C
Fan Speeds (RPM): N/A gpu: nvidia fan: 31%
Info:
Processes: 355 Uptime: 1h 5m wakeups: 0 Memory: 15.49 GiB
used: 4.87 GiB (31.4%) Init: systemd v: 251 default: graphical
tool: systemctl Compilers: gcc: 12.1.0 clang: 14.0.6 Packages: pacman: 1881
lib: 512 Shell: fish v: 3.4.1 default: Bash v: 5.1.16 running-in: konsole
inxi: 3.3.19
Garuda (2.6.4-2):
System install date:     2022-07-06
Last full system update: 2022-07-07 ↻
Is partially upgraded:   No
Relevant software:       NetworkManager
Windows dual boot:       Probably (Run as root to verify)
Snapshots:               Snapper
Failed units:

Hello! I've searched and searched with not really any luck with anything from this year or last year that works... I use Brave (Chromium based) to create PWA's of a lot of my favorite sites (Garuda Forum is one of them; I installed it, but others I click the three lines, click "More Tools", then click "Create Shortcut", and check the box "Open as Window"), and when I open them, the icons-only taskbar is grouping them with the standard Brave browser icon instead of them having their own icon as I've had work in the past. I've attempted to add flags as I saw mentioned in one post, I've changed icons to Breeze Dark (which worked in the past when I had this issue), and SO many other icons, but NOTHING will allow these icons to have their own! Is there a default baked into Garuda that forces the icons to be grouped together instead of having their own? Or is this a Plasma issue? If I left anything out, it wasn't intentional, just let me know! Still trying to learn. :slight_smile:

image

I forgot to attach this. This is what it does to the PWA icons instead of them having their own icon.

Maybe this one? I went through it very quickly, but despite the title and many mentioning of Wayland, it is also about Brave and X11:
https://bugs.kde.org/show_bug.cgi?id=358277

3 Likes

Yeah I ran across that, but that is from 2016, though it's the same issue. I've about torn my brain from my head trying to figure this out. It's the only thing from me having the perfect desktop!! Lol

Edit: I just saw the comments from 2022. Thank you!! I guess I'll have to wait until they send a fix down the pipeline.

I saw it was old, but it was reopened about one month ago.
Edit: I just saw your edit :wink:
Edit2: I see so many different brave packages and versions in the AUR: brave, brave-git, brave-bin, brave-beta-bin, brave-nightly-bin, brave-dev-git !!!
If it is really so important, maybe you could try some of them, maybe one older and one newer.
It should definitely be that KDE bug, but you never can say...

4 Likes

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.