Bootloader Installation Error

Welp, not the first time I'm having this, I'm starting to think this is related to my SSD ...
Trying to find an alternative for Manjaro Linux with KDE Plasma, I tried installing Garuda KDE Dr460nized Gaming Edition. Just when Calamares was about to finish, this error message came up:

Bootloader installation error
The bootloader could not be installed. The installation command
grub-install --target=x86_64-efi --efi-directory=/boot/efi --bootloader-id=Garuda --force
returned error code 1.

I had the same issue with Manjaro Linux before (though it seems quite inconsistent when I do get this error ...). I had been told that "error code 1 means no write permissions", or something along those lines, and I was told to run

sudo calamares

For Manjaro Linux, this had indeed fixed the error, however this does not do the job for Garuda Linux - I'm still getting the same error message.

As I'm not quite sure how to correctly do manual partitioning with Calamares, I am simply going for the standard "Erase Disk" option with a swap partition. Also, if that is relevant, I am booting the live image with Ventoy in UEFI mode.

Please advise.

There is no difference to the icon or launcher start, it shows in terminal the process.

Better use

sudo -E calamares

Check / set in calamares the correct /boot/efi partition sda, nvme ... in pull down menu.

Fine.

2 Likes

Welcome to the forum. I think the problem is not with the ssd, if it was the errors would be like block error : I/O problem or something like that. Try running a quick arch install via archfi script.

I tried this, and I am not seeing much of a difference. Knowing about the "preserve user environment" option is nice, so thanks for that, but it doesn't seem to help with the error. However, I had some output in Konsole that might be relevant: https://hatebin.com/lgdcgbhtcq

I actually thought of this as well, as there have been multiple instances, in several distros, where I have either overlooked or forgotten about setting the correct location for the bootloader. However, whether I run Calamares through the icon, with sudo, or with sudo -E, I do not have that option.

That being said ... curiously, once Calamares did not put out any error after launching it with sudo -E. However, the bootloader had been automatically installed on /dev/sda, which was not the target drive (now I gotta reinstall Windows 10, lol). So I tried to reinstall Garuda, with only the target drive attached, which is now /dev/sda, so I think that should work without issues.

However, regardless of what I do now with that SSD, I am again only met with the bootloader installation error. I have tried simply killing all partitions, I've tried setting up a completely new partition table, I even tried installing Garuda with no pre-existing partition table on the drive, and I always rebooted after I was done with KDE Partition Manager before going for another installation attempt. Nothing seems to help.

This is what I meant earlier with it seeming quite inconsistent when the error appears. I have no clue what causes it - sometimes it's there, and sometimes it's just gone.

Alright, now that the issue with my account has been resolved ...
I believe I have found the root of the problem.

TL;DR - Buggy firmware on my end + issues with Calamares & Ventoy appear to be the root of the issue.

The most important issue was that this problem was not a problem on Garuda's end and was not much of a user error either. The problem was on my Mainboard's end. The firmware was buggy as hell. I knew that it was buggy, however I didn't realise, until recently, how much of a problem that is. What is not new to me by any means is that this is the reason why a boot from a complete shutdown took more than 10 minutes. What was new to me, however, was that this was not only cause for a performance hit on Windows, but also the reason why I had to deal with all kinds of unexpected behaviours with pretty much any Linux distro.

The second issue, it seems to me, was either with Calamares or the bootable USB thumb drive. After trying out installing Garuda and other distros on other machines, I have noticed that I almost always run into problems with Calamares (though these were normally not major problems). I have never just incidentally come across someone reporting issues with Calamares, but I have also never incidentally come across someone recommending Ventoy for creating a bootable USB drive. That leads me to conclude that Calamares and Ventoy don't mix very well (I have not yet tried anything with Calamares without Ventoy), and that issue was amplified by my buggy firmware.

Please post your inxi -Faz for reference as to your mobo firmware issue.

Please post your inxi -Faz for reference as to your mobo firmware issue.

That'll be a negative, chief, by now I have a completely new computer and almost fully disassembled my old tower.

Oh well would have been nice to know the wonky mobo model at the minimum. Hope your new rig works out better.

Well, I can say this much:
The PC in question is an Acer Predator G3-605 that was purchased in 2014. I don't manage to figure out what exact Model the MB is by just looking at it, and I remember that cat /proc/cpuinfo as well as the GUI display of KDE couldn't tell me what model it is either. I found a sticker with a number on it, though, which leads me only here: https://www.servers4less.com/motherboards/system/acer-dbspx11001 (full number on the sticker is DBSPX1100142600086EE03).

What I can say is that I didn't have these firmware issues right from the start, but I had them for long enough that I do not recall what the source could've been. The only thing I remember that seems to be related to this was a partition manager on Windows.

1 Like

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.