Booting into the grub rescue after increasing the boot partition

I tried but didn't worked so I just had a fresh install of everything.

I used dd to copy an entire btrfs drive to another doing a swap out on an HDD to SSD upgrade and ended up with both drives having identical UUIDs and created a lot of chaos until I manually unplugged one of them and changed the UUID on it (and updated fstab and grub and .... and ... )

2 Likes

Hai if you have bootable garuda usb..boot into garuda linux...Go to gparted. select the harddrive where boot is located..you will receive error message saying your harddrive primary gpt parition file is corrupted, but back up is loaded...select the boot partition and do right click to get options.. in that select manage flag option...select "bios_grub" flag. you may see your harddrive getting mounted. shutdown , remove bootable usb and start into garuda linux...This worked for me. hope it works for you as well.

1 Like

Thanks for the suggestion, but I think this is definitely an abandoned thread.
Last update May '21, OP last seen July '21...
I'll close it here...

3 Likes