Boot & Timeshift Restore Problems

Hello there,
I am pretty new to linux, so I am kinda helpless.
However I recently updated my version with

sudo pacman -Syu

And after I rebooted the system and tried to login
into my account (loading screen) a popup came up
and asked for some password for a wallet (?). And so
I typed it in and then nothing happened anymore.
And it seems so the entire loading screen crashes.
So I decided, after trying it a few times without any
success, to boot into a snapshot. And now it seems so
that the entire system is broken or sth like that.
For example if I type help in the konsole, I get the
following output:

librewolf may be found in the following packages:
  chaotic-aur/librewolf 85.0.2-2                        	/usr/bin/librewolf
  chaotic-aur/librewolf-nightly r635305+.f43b90848afd+-1	/usr/bin/librewolf
/usr/share/fish/functions/ (line 204):
        $fish_browser $page_url
in function 'help'

Have you restored the snapshot using Timeshift?

Then do something like that to fix it...:crazy_face:
Not clear descriptions draw a lot of clouds inside my Magic Ball.
Please, blow the clouds away.


There is something going on I think, in the above linked thread kwin was still on 5.20 even though the system was fully updated :eyes:
It might be the same case here, the symptoms match at least :face_with_raised_eyebrow:


On my broken snapshots, I too was being asked for a wallet thing. Here's a pic I snapped of it earlier before opening a snapshot from last night.

I also had issues with the compositor needing to be reset, in fact my dock is back to being broke in the snapshot that I rolled back to, so before I had "fixed" it by resetting the compositor (window animations too).


1 Like

Uhm yea, I have now restored it with the time shift tool multiple times but if I dont
boot into a snapshot and instead just boot into "Garuda" in
the booting screen, I still get this wallet thingy and the screen
freezes every time. :skull_and_crossbones:


sudo pacman -Syu kwin

Remove kwin-lowlatency and install kwin, press y
Reboot after will be OK

How to use timeshift


Just to be clear since I was having the exact same problem as you were and I wasn't restoring correctly, here is a more verbose listing of the steps just in case it helps: @barna88hun just linked to the directions in the previous post too.

  1. Boot into the snapshot you know works
  2. Once it's booted, open Timeshift.
  3. Select the same snapshot you logged into that you know works
  4. Click restore
  5. REBOOT without selecting a snapshot this time, do not run any other pacman commands before rebooting

Thank you very much now its working again <3


I did that and now its working again. Thank you too <3

I've had to timeshift back, and all is well, but now when I boot up I see various new options for booting. Is there a way to get rid of those?

Hi there, welcome.
Please open a new topic for your issue.
This one is very old and probably unrelated to your problem, I'm going to close it stright away.
Remember to include as much information as possible, e.g. all is well, various new options...
And inxi -Faz, of course.