Boot hang after update

Hi, I updated my system with paru -Syu and by executing needrestart.
Now I rebooted and linux doesn't start and is stuck on boot, reporting the following lines:

:: Running early hook [udev]
:: Running early hook [plymouth]

Using ctrl+alt+del aborts the boot and restarts GRUB.
Restoring previous snapshot from GRUB result in the same boot hang.
I also tried using multiple kernels (linux-lts and linux-zen), same result.
I guess that needrestart is the problem, I haven't manually used it before (always used it via topgrade).

A lot of people, including me, have had problems with the recent sddm update. If you have the same problem then switching to sddm-git for the time being should help. Check this thread for more info: Last update of sddm caused black screen after plymouth


I can't start even a tty, how i can switch sddm version?

Check the information here:

or read the other threads.


Ok, just fixed it by removing "splash" from the boot config file as described here.
Thanks to everyone replied to my post.