Bluetooth not working properly

Ayye, i got a problem with Bluetooth on my Laptop with KDE Dragonized (kernel 5.11.1-zen1-zen-1) when connecting to a bluetooth device, it causes problems with the bluetooth service itself as well as the wifi -> bluetooth randomly breaks and restarts and also sometimes affecting wifi to restart as well

on other distros it works without any problems (ubuntu, budgie, lubuntu, mate ...)

if any hardware specific information is needed, please tell me how i can provide it

System:    Kernel: 5.11.1-zen1-1-zen x86_64 bits: 64 compiler: gcc v: 10.2.0 
           parameters: BOOT_IMAGE=/@/boot/vmlinuz-linux-zen root=UUID=9b5a94e9-9e02-48e4-a927-d3eb58423e22 
           rw [email protected] quiet splash rd.udev.log_priority=3 vt.global_cursor_default=0 
           systemd.unified_cgroup_hierarchy=1 resume=UUID=c80ba066-51f7-47c4-b5a0-e87b608a777a loglevel=3 
           Desktop: KDE Plasma 5.21.3 tk: Qt 5.15.2 info: latte-dock wm: kwin_x11 vt: 1 dm: SDDM 
           Distro: Garuda Linux base: Arch Linux 
Machine:   Type: Laptop System: Packard Bell product: Easynote ENTF71BM v: V1.10 serial: <filter> Chassis: 
           type: 10 serial: <filter> 
           Mobo: Packard Bell model: Easynote ENTF71BM v: V1.10 serial: <filter> UEFI: Packard Bell 
           v: 1.10 date: 09/15/2015 
Battery:   ID-1: BAT1 charge: 54.1 Wh (100.0%) condition: 54.1/53.4 Wh (101.4%) volts: 17.1 min: 15.0 
           model: SANYO PABAS0241231 type: Li-ion serial: <filter> status: Full 
CPU:       Info: Dual Core model: Intel Celeron N2830 bits: 64 type: MCP arch: Silvermont family: 6 
           model-id: 37 (55) stepping: 8 microcode: 838 cache: L2: 1024 KiB 
           flags: lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx bogomips: 8666 
           Speed: 2015 MHz min/max: 500/2416 MHz Core speeds (MHz): 1: 2015 2: 2190 
           Vulnerabilities: Type: itlb_multihit status: Not affected 
           Type: l1tf status: Not affected 
           Type: mds mitigation: Clear CPU buffers; SMT disabled 
           Type: meltdown mitigation: PTI 
           Type: spec_store_bypass status: Not affected 
           Type: spectre_v1 mitigation: usercopy/swapgs barriers and __user pointer sanitization 
           Type: spectre_v2 
           mitigation: Full generic retpoline, IBPB: conditional, IBRS_FW, STIBP: disabled, RSB filling 
           Type: srbds status: Not affected 
           Type: tsx_async_abort status: Not affected 
Graphics:  Device-1: Intel Atom Processor Z36xxx/Z37xxx Series Graphics & Display 
           vendor: Acer Incorporated ALI driver: i915 v: kernel bus-ID: 00:02.0 chip-ID: 8086:0f31 
           class-ID: 0300 
           Device-2: Chicony VGA Webcam type: USB driver: uvcvideo bus-ID: 1-4:3 chip-ID: 04f2:b47f 
           class-ID: 0e02 serial: <filter> 
           Display: x11 server: X.Org 1.20.10 compositor: kwin_x11 driver: loaded: intel 
           unloaded: modesetting alternate: fbdev,vesa display-ID: :0 screens: 1 
           Screen-1: 0 s-res: 1366x768 s-dpi: 96 s-size: 361x203mm (14.2x8.0") s-diag: 414mm (16.3") 
           Monitor-1: eDP1 res: 1366x768 hz: 60 dpi: 99 size: 350x190mm (13.8x7.5") diag: 398mm (15.7") 
           OpenGL: renderer: Mesa DRI Intel HD Graphics (BYT) v: 4.2 Mesa 20.3.4 compat-v: 3.0 
           direct render: Yes 
Audio:     Device-1: Intel Atom Processor Z36xxx/Z37xxx Series High Definition Audio 
           vendor: Acer Incorporated ALI driver: snd_hda_intel v: kernel bus-ID: 00:1b.0 
           chip-ID: 8086:0f04 class-ID: 0403 
           Sound Server-1: ALSA v: k5.11.1-zen1-1-zen running: yes 
           Sound Server-2: JACK v: 0.125.0 running: no 
           Sound Server-3: PulseAudio v: 14.2 running: yes 
           Sound Server-4: PipeWire v: 0.3.24 running: no 
Network:   Device-1: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet vendor: Acer Incorporated ALI 
           driver: r8169 v: kernel port: 1000 bus-ID: 01:00.0 chip-ID: 10ec:8168 class-ID: 0200 
           IF: enp1s0 state: down mac: <filter> 
           Device-2: Qualcomm Atheros QCA9565 / AR9565 Wireless Network Adapter vendor: Foxconn 
           driver: ath9k v: kernel port: 1000 bus-ID: 02:00.0 chip-ID: 168c:0036 class-ID: 0280 
           IF: wlp2s0 state: up mac: <filter> 
Bluetooth: Device-1: Foxconn / Hon Hai type: USB driver: btusb v: 0.8 bus-ID: 1-2.1:17 chip-ID: 0489:e078 
           class-ID: e001 
           Report: ID: hci0 state: down bt-service: enabled, running address: <filter> 
Drives:    Local Storage: total: 465.76 GiB used: 10.8 GiB (2.3%) 
           SMART Message: Unable to run smartctl. Root privileges required. 
           ID-1: /dev/sda maj-min: 8:0 vendor: Western Digital model: WD5000LPVX-22V0TT0 size: 465.76 GiB 
           block-size: physical: 4096 B logical: 512 B speed: 3.0 Gb/s rotation: 5400 rpm serial: <filter> 
           rev: 1A01 scheme: GPT 
Partition: ID-1: / raw-size: 457.32 GiB size: 457.32 GiB (100.00%) used: 10.8 GiB (2.4%) fs: btrfs 
           dev: /dev/sda2 maj-min: 8:2 
           ID-2: /boot/efi raw-size: 260 MiB size: 256 MiB (98.45%) used: 546 KiB (0.2%) fs: vfat 
           dev: /dev/sda1 maj-min: 8:1 
           ID-3: /home raw-size: 457.32 GiB size: 457.32 GiB (100.00%) used: 10.8 GiB (2.4%) fs: btrfs 
           dev: /dev/sda2 maj-min: 8:2 
           ID-4: /var/log raw-size: 457.32 GiB size: 457.32 GiB (100.00%) used: 10.8 GiB (2.4%) fs: btrfs 
           dev: /dev/sda2 maj-min: 8:2 
           ID-5: /var/tmp raw-size: 457.32 GiB size: 457.32 GiB (100.00%) used: 10.8 GiB (2.4%) fs: btrfs 
           dev: /dev/sda2 maj-min: 8:2 
Swap:      Kernel: swappiness: 10 (default 60) cache-pressure: 75 (default 100) 
           ID-1: swap-1 type: partition size: 8.19 GiB used: 0 KiB (0.0%) priority: -2 dev: /dev/sda3 
           maj-min: 8:3 
           ID-2: swap-2 type: zram size: 1.86 GiB used: 5.2 MiB (0.3%) priority: 32767 dev: /dev/zram0 
           ID-3: swap-3 type: zram size: 1.86 GiB used: 5 MiB (0.3%) priority: 32767 dev: /dev/zram1 
Sensors:   System Temperatures: cpu: 52.0 C mobo: N/A 
           Fan Speeds (RPM): N/A 
Info:      Processes: 184 Uptime: 1h 04m wakeups: 1 Memory: 3.72 GiB used: 2.26 GiB (60.8%) Init: systemd 
           v: 247 tool: systemctl Compilers: gcc: 10.2.0 clang: 11.1.0 Packages: pacman: 1201 lib: 301 
           Shell: fish v: 3.2.0 running-in: konsole inxi: 3.3.03 

1 Like

Welcome Sashiro :wave:

To post sys info, go into terminal and enter inxi -Fxxxza then post as text, please

Edit: Beaten to it! :rofl:

1 Like

already done it, updated the main post

1 Like

Found this, haven't got correct fonts installed to check further, I'm afraid

https://wiki.archlinux.org/index.php/Bluetooth

There are three threads on Foxconn Hon Hai, but I don't have the correct fonts installed, to check further.

https://wiki.archlinux.org/index.php?search=foxconn+hon+hai&title=Special%3ASearch&go=Go

3 Likes

Regardless of your problem, the Zen kernel looks a bit antiquated.

2 Likes

Jep, use

upd

in terminal.

1 Like

Have you tried [FN] + [WiFi]? Sign out and sign back in.

1 Like

@Stroke_Finger didn't find anything that could fix the problem
@SGS already did that, system is up-to-date with latest iso & updates

@sunda i already tried to use different kernels - same issue
(linux-mainline 5.12rc3-1 works like charm (no bluetooth/wifi issue), but it f*cks up my touchpad lol, so cant use it)
also i dort have a WiFi FN option on my laptop

nrhg this frustrates me that Bluetooth doesn't wanna work, because on other distros it does :confused:
and i really wanna stay with garuda forever, because of how awesome it is

1 Like

Hate to say it, but could you get a USB adapter? :slightly_smiling_face:

1 Like

haha yeah maybe, or i just stay with wired headphones instead - laptop is pretty old too tho

but its strange that the mainline kernel works, but others not xD

1 Like

Well, others may be leading edge, but Garuda is bleeding-edge.

Yes, it's a workaround, but it would give you time to sort problems at your leisure.

1 Like

ohh well nvm i can stay with mainline i see... just have to use [basic] touchpad functions set in bios/uefi instead of [advanced]

ill try to fix it anyway using the latest garuda kernel (the bluetooth issue), and if i find a solution, ill update the post xD

2 Likes

Please! That helps any who come after experiencing similar issues. :slightly_smiling_face:

3 Likes

You have definitely upgraded your Easynote, because 2048 MB DDR3 RAM is clearly not enough for Garuda KDE Dragonized.

2 Likes

In contrast, 1 Gb DDR2 (+ ReadyBoost) is sufficient for Win10

2 Likes

2048 MB DDR3

it actually is 4096 MB ddr3

the insanely strange thing is :'D

with the previous version (the one be4 hawk eagle) didnt really work with my laptop (laggy as hell, wasnt even able to stream 720p videos in firefox because of the stuttering, freezes and laggs)

but with the hawk eagle upgrade... KDE dragonized is WAY faster and more stable than a fresh ubuntu installation, even video streaming (720p) on the new firefox is way smoother than on KDE multimedia (before hawk eagle edition)
Hawk Eagle Dragonized turned my laptop into a time mashine :smiley: another aspect why i love garuda linux, its so fast on a old trashy laptop (even dragonized since hawk eagle)

If you haven't figured it out yet from your description it's pretty obvious this is a kernel issue not a Garuda issue. The reason it likely works on Ubuntu variants is they generally use older kernels. Perhaps they have applied custom patches to their kernels that Garuda does not do. We use the kernels as they come directly from upstream.

Try installing the older LTS kernel if you haven't tested it already. If that doesn't work there's a dozen other kernels you could try.

Good luck.

3 Likes

Thread is deemed abandoned.

Thread is now closed.

PM a mod if you are the OP and wish the issue reopened.

1 Like