Bluetooth microphone is not working

After connecting bluetooth earphone, audio output is working perfectly, but not input microphone. So I tried to change bluetooth profile from A2DP to HSP/HFP, but after changing, it disconnects automatically. Can anyone help me?

This is a current issue with Pipewire's Bluetooth handling.

If it's too annoying, switch back to Pulseaudio and its Bluetooth stack:

sudo pacman -Syu pulseaudio-bluetooth

should I remove pipewire first?

Run the command above and see what it does.


The above command will automatically remove conflicting packages and install dependencies.

1 Like

Still it is not working, same as before

Empty bumps are discouraged on the forum, if you have further information to add them do so. Otherwise wait until there is actual content worth posing please.

What should I post regarding my bluetooth microphone issue?

Generally your system specifications are always a good idea.

inxi -Fxxxza

Whenever you run into a bluetooth issue the first thing I always recommend is to try at least three alternate kernels.You can install an alternate kernel from the terminal using any of the following commands:

sudo pacman -Syu linux-lts linux-lts-headers
sudo pacman -Syu linux linux-headers
sudo pacman -Syu linux-zen linux-zen-headers
sudo pacman -Syu linux-mainline linux-mainline-headers
sudo pacman -Syu linux-hardened linux-hardened-headers
sudo pacman -Syu linux-rt linux-rt-headers

I would suggest starting at the top of the list and working your way down if your issues haven't improved.


I tried 3 kernels, but it didn't help me
Output of inxi-Fxxxza: System: Kernel: 5.12.0-rc2-1-mainline x86_64 bits: 64 compiler: gcc v: 10.2.1 -