Blank screen after boot

Hello

I am writing this because I'm facing an issue of blank screen after reboot.
The thing is I did try many of the troubleshooting from the forum but had no luck

This is my inxi -Faz output

System:    Kernel: 5.14.15-zen1-1-zen x86_64 bits: 64 compiler: gcc v: 11.1.0
parameters: BOOT_IMAGE=/@/boot/vmlinuz-linux-zen root=UUID=b64c5cce-1c27-4440-b5d7-d411772434ef
rw [email protected] quiet splash rd.udev.log_priority=3 vt.global_cursor_default=0
systemd.unified_cgroup_hierarchy=1 loglevel=3
Desktop: KDE Plasma 5.23.2 tk: Qt 5.15.2 wm: kwin_x11 vt: 1 dm: SDDM Distro: Garuda Linux
base: Arch Linux
Machine:   Type: Laptop System: LENOVO product: 81MT v: Lenovo V145-15AST serial: <filter> Chassis:
type: 10 v: Lenovo V145-15AST serial: <filter>
Mobo: LENOVO model: LNVNB161216 v: No DPK serial: <filter> UEFI-[Legacy]: LENOVO
v: 8ZCN27WW(V2.06) date: 01/12/2021
Battery:   ID-1: BAT1 charge: 23.7 Wh (100.0%) condition: 23.7/30.0 Wh (78.9%) volts: 8.5 min: 7.5
model: 0x53 0x4D 0x50 0x00 0x31 0x PABAS0241231 type: Li-ion serial: <filter> status: Full
cycles: 446
CPU:       Info: Dual Core model: AMD A6-9225 RADEON R4 5 COMPUTE CORES 2C+3G bits: 64 type: MCP
arch: Excavator family: 15 (21) model-id: 70 (112) stepping: 0 microcode: 6006705 cache:
L2: 1024 KiB
flags: avx avx2 lm nx pae sse sse2 sse3 sse4_1 sse4_2 sse4a ssse3 svm bogomips: 10381
Speed: 2141 MHz min/max: 1300/2600 MHz boost: enabled Core speeds (MHz): 1: 2141 2: 2884
Vulnerabilities: Type: itlb_multihit status: Not affected
Type: l1tf status: Not affected
Type: mds status: Not affected
Type: meltdown status: Not affected
Type: spec_store_bypass mitigation: Speculative Store Bypass disabled via prctl and seccomp
Type: spectre_v1 mitigation: usercopy/swapgs barriers and __user pointer sanitization
Type: spectre_v2
mitigation: Full AMD retpoline, IBPB: conditional, STIBP: disabled, RSB filling
Type: srbds status: Not affected
Type: tsx_async_abort status: Not affected
Graphics:  Device-1: AMD Stoney [Radeon R2/R3/R4/R5 Graphics] vendor: Lenovo driver: amdgpu v: kernel
bus-ID: 00:01.0 chip-ID: 1002:98e4 class-ID: 0300
Device-2: Syntek EasyCamera type: USB driver: uvcvideo bus-ID: 1-1.3:4 chip-ID: 174f:241a
class-ID: 0e02
Display: x11 server: X.Org 1.20.13 compositor: kwin_x11 driver: loaded: amdgpu,ati
unloaded: fbdev,modesetting alternate: vesa display-ID: :0 screens: 1
Screen-1: 0 s-res: 1366x768 s-dpi: 96 s-size: 361x203mm (14.2x8.0") s-diag: 414mm (16.3")
Monitor-1: eDP res: 1366x768 hz: 60 dpi: 101 size: 344x193mm (13.5x7.6") diag: 394mm (15.5")
Monitor-2: HDMI-A-0 res: 1366x768 hz: 60 dpi: 57 size: 609x347mm (24.0x13.7")
diag: 701mm (27.6")
OpenGL: renderer: AMD STONEY (DRM 3.42.0 5.14.15-zen1-1-zen LLVM 12.0.1) v: 4.5 Mesa 21.2.4
direct render: Yes
Audio:     Device-1: AMD vendor: Lenovo driver: snd_hda_intel v: kernel bus-ID: 00:01.1 chip-ID: 1002:15b3
class-ID: 0403
Device-2: AMD Family 15h Audio vendor: Lenovo driver: snd_hda_intel v: kernel bus-ID: 00:09.2
chip-ID: 1022:157a class-ID: 0403
Sound Server-1: ALSA v: k5.14.15-zen1-1-zen running: yes
Sound Server-2: JACK v: 1.9.19 running: no
Sound Server-3: PulseAudio v: 15.0 running: no
Sound Server-4: PipeWire v: 0.3.39 running: yes
Network:   Device-1: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet vendor: Lenovo driver: r8169
v: kernel port: 3000 bus-ID: 01:00.0 chip-ID: 10ec:8168 class-ID: 0200
IF: enp1s0 state: up speed: 100 Mbps duplex: full mac: <filter>
Device-2: Realtek RTL8821CE 802.11ac PCIe Wireless Network Adapter vendor: Lenovo
driver: rtw_8821ce v: N/A modules: rtw88_8821ce port: 2000 bus-ID: 02:00.0 chip-ID: 10ec:c821
class-ID: 0280
IF: wlp2s0 state: up mac: <filter>
Bluetooth: Device-1: Realtek Bluetooth Radio type: USB driver: btusb v: 0.8 bus-ID: 1-1.2:3
chip-ID: 0bda:c024 class-ID: e001 serial: <filter>
Report: bt-adapter ID: hci0 rfk-id: 2 state: down bt-service: enabled,running rfk-block:
hardware: no software: yes address: <filter>
Drives:    Local Storage: total: 939.01 GiB used: 18.92 GiB (2.0%)
SMART Message: Unable to run smartctl. Root privileges required.
ID-1: /dev/sda maj-min: 8:0 vendor: Toshiba model: MQ04ABF100 size: 931.51 GiB block-size:
physical: 4096 B logical: 512 B speed: 6.0 Gb/s type: HDD rpm: 5400 serial: <filter> rev: 0E
scheme: MBR
ID-2: /dev/sdb maj-min: 8:16 type: USB model: General size: 7.5 GiB block-size: physical: 512 B
logical: 512 B type: N/A serial: <filter> rev: 5.00 scheme: MBR
SMART Message: Unknown USB bridge. Flash drive/Unsupported enclosure?
Partition: ID-1: / raw-size: 931.51 GiB size: 931.51 GiB (100.00%) used: 18.92 GiB (2.0%) fs: btrfs
dev: /dev/sda1 maj-min: 8:1
ID-2: /home raw-size: 931.51 GiB size: 931.51 GiB (100.00%) used: 18.92 GiB (2.0%) fs: btrfs
dev: /dev/sda1 maj-min: 8:1
ID-3: /var/log raw-size: 931.51 GiB size: 931.51 GiB (100.00%) used: 18.92 GiB (2.0%) fs: btrfs
dev: /dev/sda1 maj-min: 8:1
ID-4: /var/tmp raw-size: 931.51 GiB size: 931.51 GiB (100.00%) used: 18.92 GiB (2.0%) fs: btrfs
dev: /dev/sda1 maj-min: 8:1
Swap:      Kernel: swappiness: 133 (default 60) cache-pressure: 100 (default)
ID-1: swap-1 type: zram size: 3.72 GiB used: 97 MiB (2.5%) priority: 100 dev: /dev/zram0
Sensors:   System Temperatures: cpu: 83.0 C mobo: N/A gpu: amdgpu temp: 83.0 C
Fan Speeds (RPM): N/A
Info:      Processes: 214 Uptime: 34m wakeups: 1 Memory: 3.72 GiB used: 2.21 GiB (59.4%) Init: systemd
v: 249 tool: systemctl Compilers: gcc: 11.1.0 clang: 12.0.1 Packages: pacman: 1890 lib: 548
Shell: fish v: 3.3.1 default: Bash v: 5.1.8 running-in: konsole inxi: 3.3.08


Can I get any help please?

Which?

Do you try "black screen" by jonathon?

If nothing work, use last snapshot (timeshift/snapper).

Yeah
I tried jonathan's post and few others.
If I try snap shot, won't the problem repeat if I reboot it again?

Yes.
Try

Oops, you need AMD.

I have exactly the same laptop model, but I was currently using the linux-lts kernel (which worked fine, so this is a back-up option for you: login from a live usb, chroot into your system and execute sudo pacman -S linux-lts linux-lts-headers).
I just managed to install successfully the 5.14.15-zen1-1-zen, so if you recover a snapshot and repeat the update you should not have any issue.
Alternatively, you could again login with the live USB, chroot and reinstall the zen kernel, probably something went wrong the first time.

2 Likes

Fine I'm in the live usb right now. I tried executing the command but it said package not found.
I'm sorry but can you tell me how to install the 5.14.15-zen1-1-zen kernel?

sudo pacman -S linux-zen linux-zen-headers

Be sure, you are up to date with -Syu

4 Likes

So you are trying to say there was a problem with my kernel.

I now seem to have ''5.14.5-zen1-1-zen" kernel.

I tried rebooting once and everything was fine.

I've got a question though

With the package installer prompt that comes right after you boot up for the first time, are you not supposed to install another kernel?

1 Like

It is up to you. Many users prefer to have more than one kernel on their systems. Sometimes one may have better hardware support than another, or maybe some users just like wearing belts and suspenders. :wink:

2 Likes

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.