Black screen after wake up from sleep/hibernate

Hey I noticed you have linked my issue thread here I am here to just give you a quick update regarding that. The fix didn’t work for a long time for me. Long story short I found out that KDE powerdevil was the issue. It’s an old KDE bug that has supposedly been resolved by KDE devs a while ago but I guess I am an exception. Anyway, the fix to that was

go to settings → Power Management → Energy Saving and there you will find three tabs namely

  1. On AC Power
  2. On Battery
  3. On Low battery

In each of these sections you find this checkbox While asleep, hibernate after a period of inactivity make sure to uncheck it in all three tabs. click apply and you are done.

The only downside to this is you won’t be able to automatically hibernate your system but on the plus side you get to have a working system that doesn’t black screens on you.
Believe me I tried all possible methods on earth to get this option to work and not black screen on me but in the end I just decided to compromise.

1 Like