Black screen after installing

I read all the solutions and tried everything for 2 days but I'm stuck at the black screen after the grub window. Even tty is also not opening. I really wanna use this OS but I'm unable to.

Hi there, welcome!
Let's begin from the beginning.
Please provide from the live USB the output of inxi -Faz as text, formatted with 3 ~ before and after the text block.

3 Likes
System:    Kernel: 5.13.9-zen1-1-zen x86_64 bits: 64 compiler: gcc v: 11.1.0  
parameters: BOOT_IMAGE=/boot/vmlinuz-x86_64 lang=en_US keytable=us tz=UTC misobasedir=garuda  
misolabel=GARUDA_DR460NIZED_SOARING_ quiet systemd.show_status=1 driver=nonfree
nouveau.modeset=0 i915.modeset=1 radeon.modeset=1
Desktop: KDE Plasma 5.22.4 tk: Qt 5.15.2 info: latte-dock wm: kwin_x11 vt: 1 dm: SDDM  
Distro: Garuda Linux base: Arch Linux  
Machine:   Type: Laptop System: Dell product: Inspiron 15-3565 v: 1.10.1 serial: <filter> Chassis:  
type: 10 serial: <filter>  
Mobo: Dell model: Inspiron 15-3565 v: A00 serial: <filter> UEFI: Dell v: 1.10.1  
date: 09/03/2018  
Battery:   ID-1: BAT0 charge: 1.5 Wh (100.0%) condition: 1.5/41.4 Wh (3.6%) volts: 16.7 min: 14.8  
model: LGC-LGC2.8 DELL 991XP75 type: Unknown serial: <filter> status: Unknown  
CPU:       Info: Dual Core model: AMD A9-9400 RADEON R5 5 COMPUTE CORES 2C+3G bits: 64 type: MCP  
arch: Excavator family: 15 (21) model-id: 70 (112) stepping: 0 microcode: 6006704 cache:  
L2: 1024 KiB  
flags: avx avx2 lm nx pae sse sse2 sse3 sse4_1 sse4_2 sse4a ssse3 svm bogomips: 9582  
Speed: 2800 MHz min/max: 1400/2400 MHz boost: enabled Core speeds (MHz): 1: 2800 2: 3041  
Vulnerabilities: Type: itlb_multihit status: Not affected  
Type: l1tf status: Not affected  
Type: mds status: Not affected  
Type: meltdown status: Not affected  
Type: spec_store_bypass mitigation: Speculative Store Bypass disabled via prctl and seccomp  
Type: spectre_v1 mitigation: usercopy/swapgs barriers and __user pointer sanitization  
Type: spectre_v2 mitigation: Full AMD retpoline, STIBP: disabled, RSB filling  
Type: srbds status: Not affected  
Type: tsx_async_abort status: Not affected  
Graphics:  Device-1: AMD Stoney [Radeon R2/R3/R4/R5 Graphics] vendor: Dell driver: amdgpu v: kernel  
bus-ID: 00:01.0 chip-ID: 1002:98e4 class-ID: 0300
Device-2: Realtek Integrated_Webcam_HD type: USB driver: uvcvideo bus-ID: 1-1.1:3
chip-ID: 0bda:5769 class-ID: 0e02 serial: <filter>
Display: x11 server: X.Org 1.20.13 compositor: kwin_x11 driver: loaded: amdgpu,ati
unloaded: modesetting alternate: fbdev,vesa display-ID: :0 screens: 1
Screen-1: 0 s-res: 1366x768 s-dpi: 96 s-size: 361x203mm (14.2x8.0") s-diag: 414mm (16.3")
Monitor-1: eDP res: 1366x768 hz: 60 dpi: 101 size: 344x193mm (13.5x7.6") diag: 394mm (15.5")
OpenGL: renderer: AMD STONEY (DRM 3.41.0 5.13.9-zen1-1-zen LLVM 12.0.1) v: 4.5 Mesa 21.1.6
direct render: Yes
Audio:     Device-1: AMD vendor: Dell driver: snd_hda_intel v: kernel bus-ID: 00:01.1 chip-ID: 1002:15b3
class-ID: 0403
Device-2: AMD Family 15h Audio vendor: Dell driver: snd_hda_intel v: kernel bus-ID: 00:09.2
chip-ID: 1022:157a class-ID: 0403
Sound Server-1: ALSA v: k5.13.9-zen1-1-zen running: yes
Sound Server-2: JACK v: 1.9.19 running: no
Sound Server-3: PulseAudio v: 15.0 running: no
Sound Server-4: PipeWire v: 0.3.33 running: yes
Network:   Device-1: Realtek RTL810xE PCI Express Fast Ethernet vendor: Dell driver: r8169 v: kernel
port: e000 bus-ID: 14:00.0 chip-ID: 10ec:8136 class-ID: 0200
IF: enp20s0 state: down mac: <filter>
Device-2: Intel Wireless 3165 driver: iwlwifi v: kernel port: e000 bus-ID: 16:00.0
chip-ID: 8086:3165 class-ID: 0280
IF: wlp22s0 state: down mac: <filter>
Bluetooth: Device-1: Intel Bluetooth wireless interface type: USB driver: btusb v: 0.8 bus-ID: 2-1:2
chip-ID: 8087:0a2a class-ID: e001
Report: bt-adapter ID: hci0 rfk-id: 1 state: up address: <filter>
Drives:    Local Storage: total: 236.49 GiB used: 0 KiB (0.0%)
SMART Message: Unable to run smartctl. Root privileges required.
ID-1: /dev/sda maj-min: 8:0 vendor: Crucial model: CT250MX500SSD1 size: 232.89 GiB block-size:
physical: 512 B logical: 512 B speed: 6.0 Gb/s type: SSD serial: <filter> rev: 023 scheme: GPT
ID-2: /dev/sdb maj-min: 8:16 type: USB vendor: Kingston model: DataTraveler G3 size: 3.61 GiB
block-size: physical: 512 B logical: 512 B type: N/A serial: <filter> rev: 1.00 scheme: MBR
SMART Message: Unknown USB bridge. Flash drive/Unsupported enclosure?
Swap:      Kernel: swappiness: 133 (default 60) cache-pressure: 100 (default)
ID-1: swap-1 type: zram size: 6.73 GiB used: 0 KiB (0.0%) priority: 100 dev: /dev/zram0
Sensors:   System Temperatures: cpu: 51.0 C mobo: 43.0 C gpu: amdgpu temp: 51.0 C
Fan Speeds (RPM): cpu: 3449
Info:      Processes: 173 Uptime: 2m wakeups: 1 Memory: 6.73 GiB used: 2.33 GiB (34.6%) Init: systemd
v: 249 tool: systemctl Compilers: gcc: 11.1.0 clang: 12.0.1 Packages: pacman: 1158 lib: 291
Shell: fish v: 3.3.1 default: Bash v: 5.1.8 running-in: konsole inxi: 3.3.06~~~
1 Like

I know it's been frustrating, but it could help to have a summary of what you tried.
e.g.

  • in the BIOS, make sure that SATA mode is AHCI, secure and fast boot are disabled
  • installation booting the ISO with free drivers?
  • did you try Garuda boot repair from the live USB?

Thanks for understanding.
I have disabled the secure and fast boot and SATA MODE is also set to AHCI.
I tried installing with the nvidia drivers as well as free drivers , I tried both the ways.
Tty is also not working so I tried chroot but that also doesn't seems to work for me.
I tried boot repair in esp buy it's giving error that unable to find canonical path.
Please help me out with this.

I think you should try following the manual GRUB installation with this tutorial.
It includes more details to check your partitions, EFI mode, etc.

2 Likes

I tried this so many times but that's also not working for me.
this is the output which I am getting after doing these steps and updating grub:

Generating grub configuration file ...
Found theme: /usr/share/grub/themes/garuda-dr460nized/theme.txt
Found linux image: /boot/vmlinuz-linux-zen
Found initrd image: /boot/amd-ucode.img /boot/initramfs-linux-zen.img
Found fallback initrd image(s) in /boot:  amd-ucode.img initramfs-linux-zen-fallback.img
Warning: os-prober will be executed to detect other bootable partitions.
Its output will be used to detect bootable binaries on them and create new boot entries.
grub-probe: error: cannot find a GRUB drive for /dev/sdb1.  Check your device.map.
grub-probe: error: cannot find a GRUB drive for /dev/sdb1.  Check your device.map.
Adding boot menu entry for UEFI Firmware Settings ...
Detecting snapshots ...
Info: Separate boot partition not detected
No snapshots found.
If you think an error has occurred , please file a bug report at " https://github.com/Antynea/grub-btrfs "
Nothing to do. Abort.
Found memtest86+ image: /boot/memtest86+/memtest.bin
done~~~

I don't see real errors there. The linux image is found, sdb should be your USB, so no prob, and at the end no snapshots are found, also no prob.
For me the problem is in the grub installation, not the update.
We should check that part.
Include also the output of

lsblk -f

and

parted -l | grep -iE "^Disk /|esp" | grep -B1 esp

here is the output of grub installation from the above suggested method.

sh-5.1# grub-install --target=x86_64-efi --efi-directory=/boot/efi --bootloader-id=garuda --recheck
Installing for x86_64-efi platform.
Installation finished. No error reported.

For lsblk -f:

NAME FSTYPE FSVER LABEL                 UUID                                 FSAVAIL FSUSE% MOUNTPOINTS
loop0
squash 4.0                                                                    0   100% /run/miso/sfs/live
fs
loop1
squash 4.0                                                                    0   100% /run/miso/sfs/mhwd
fs
loop2
squash 4.0                                                                    0   100% /run/miso/sfs/desk
topfs
loop3
squash 4.0                                                                    0   100% /run/miso/sfs/root
fs
sda
├─sda1
│    btrfs                              4176d7f8-5cf3-488b-9017-856f5cb8b816  208.4G     3% /mnt/broken/@
│                                                                                           /mnt/broken
├─sda2
│    vfat   FAT32 NO_LABEL              6642-0FEC                             498.4M     0% /mnt/broken/@/boot
/efi
│                                                                                           /mnt/broken/@/boot
│                                                                                           /efi
└─sda3
swap   1                           38cefbaa-66af-43ed-aa89-4fe4226b5a7c
sdb  iso966 Jolie GARUDA_DR460NIZED_SOARING_
│                                       2021-08-09-08-13-00-00                     0   100% /run/miso/bootmnt
├─sdb1
│    iso966 Jolie GARUDA_DR460NIZED_SOARING_
│                                       2021-08-09-08-13-00-00
└─sdb2
vfat   FAT12 MISO_EFI              0E41-55AA
zram0
[SWAP]

and this is the output for this command:

sh-5.1# parted -l | grep -iE "^Disk /|esp" | grep -B1 esp
Disk /dev/sdb: 3874MB
2      2469MB  2473MB  4194kB  primary               esp

Please, have a look at it and help me.

There is a problem in the partitioning of sda.
Only sdb (the USB) is recognized as ESP. No ESP partition for sda.
Maybe because you have sda2 mounted as /boot and sda3 as boot/efi. Or maybe sda2 is also boot/efi. But none is esp.
In my opinion you should remove sda3 and format sda2 as esp partition.
Then repeat the chroot peocess, grub installation, etc.



Please have a look at these images and tell me where I'm getting it wrong!

Sorry I'm not at home to check on the system and it's hard to check picture on the run.
You don't need to reinstall, just use gparted, possibly, which can set the ESP flag to the new partition replacing sda2.
I think also KDE partition manager has this possibility if you don't have gparted.
sda1 and sda3 if this is swap can stay as is.
Another thing I can see is that the installer is trying to create a MBR, so you're probably in legacy mode, but you'd better set your BIOS in EFI mode.

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.