Bitwarden breaks update or dependency, actually?

installing electron (20.0.0-1) breaks dependency 'electron19' required by bitwarden

And that's the end of updating, even before it started :wink:

So, maybe wait for Bitwarden to update, then update it, and we're back to business?
On my second system, I just updated with Pamac, removing electron from updates...

You need to install electron19 if bitwarden needs it. But you probably can't until after you update electron.

One easy solution is to remove bitwarden, do your update and then reinstall bitwarden. Your config should stay in place since it is in your home directory.


As it works now, the 20-update removes version 19?
Well, I'll try it tomorrow or at weekend...

Yes, that is how the electron packaging works. The current version is always call electron

sudo pacman -Syu electron19


(Just another solution)

Convenient one-liner for me because several apps were breaking and depending on 3 different electron versions. This command handled it in one swoop.

This explicitly installs electron19 during the upgrade and retains and upgrades the (will now be upgraded to 20*) package electron.

As @dalto stated, the package named simply electron is always the latest.

And just to add method-to-the-madness logic, think of python as well. Python is another example when you may need multiple versions of said pkg to satisfy deps across your system. I'm sure many of us have been bitten by the python.


Well, one always learns new things :wink:
Thanks for explaining.
I will be doing this, when I get home from work!

P.S. This one worked a treat. Thanks for that!


This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.