Bare Metal Encrypted UEFI Instalation FAILED

Bare metal installation attempt ThinkPad T420

With the error message : Boost Python error in job "luksopenswaphook.cfg"

My first attempt with the same result using the Gnome Minimal iso from SourceForge
Second attempt with the latest nightly for BSPWM from SourceForge

The install works without encryption in both Legacy and UEFI

Look forward to your response, thank you

  Kernel: 5.8.5-zen1-1-zen x86_64 bits: 64 compiler: N/A 
  Desktop: GNOME 3.36.4 tk: GTK 3.24.22 wm: gnome-shell dm: GDM 3.34.1 
  Distro: Garuda Linux 
  Type: Laptop System: LENOVO product: 4180H34 v: ThinkPad T420 
  serial: <filter> Chassis: type: 10 serial: <filter> 
  Mobo: LENOVO model: 4180H34 serial: <filter> UEFI: LENOVO 
  v: 83ET67WW (1.37 ) date: 11/28/2011 
  ID-1: BAT0 charge: 60.2 Wh condition: 60.3/71.3 Wh (85%) volts: 12.4/10.8 
  model: SANYO 42T4763 type: Li-ion serial: <filter> status: Unknown 
  Info: Dual Core model: Intel Core i5-2540M bits: 64 type: MT MCP 
  arch: Sandy Bridge rev: 7 L1 cache: 64 KiB L2 cache: 3072 KiB 
  L3 cache: 3072 KiB 
  flags: avx lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx bogomips: 20731 
  Speed: 1847 MHz min/max: 800/3300 MHz volts: 1.2 V ext-clock: 100 MHz 
  Core speeds (MHz): 1: 3154 2: 2272 3: 2689 4: 3198 
  Device-1: Intel 2nd Generation Core Processor Family Integrated Graphics 
  vendor: Lenovo ThinkPad T420 driver: i915 v: kernel bus ID: 00:02.0 
  chip ID: 8086:0126 
  Device-2: Chicony integrated camera type: USB driver: uvcvideo 
  bus ID: 1-1.6:4 chip ID: 04f2:b221 
  Display: server: X.Org 1.20.9 compositor: gnome-shell driver: intel 
  unloaded: modesetting alternate: fbdev,vesa resolution: 1366x768~60Hz 
  s-dpi: 96 
  Message: Unable to show advanced data. Required tool glxinfo missing. 
  Device-1: Intel 6 Series/C200 Series Family High Definition Audio 
  vendor: Lenovo driver: snd_hda_intel v: kernel bus ID: 00:1b.0 
  chip ID: 8086:1c20 
  Sound Server: ALSA v: k5.8.5-zen1-1-zen 
  Device-1: Intel 82579LM Gigabit Network vendor: Lenovo ThinkPad T520 
  driver: e1000e v: 3.2.6-k port: 5080 bus ID: 00:19.0 chip ID: 8086:1502 
  IF: enp0s25 state: down mac: <filter> 
  Device-2: Intel Centrino Advanced-N 6205 [Taylor Peak] driver: iwlwifi 
  v: kernel port: efa0 bus ID: 03:00.0 chip ID: 8086:0085 
  IF: wlp3s0 state: up mac: <filter> 
  Local Storage: total: 133.89 GiB used: 6.46 GiB (4.8%) 
  ID-1: /dev/sda vendor: Samsung model: SSD PM830 2.5 7mm 128GB 
  size: 119.24 GiB speed: 6.0 Gb/s serial: <filter> rev: 3D1Q scheme: GPT 
  ID-2: /dev/sdb type: USB vendor: Samsung model: Generic Flash Disk 
  size: 14.65 GiB serial: <filter> rev: 8.07 scheme: MBR 
  ID-1: / size: 5.74 GiB used: 788.0 MiB (13.4%) fs: overlay source: ERR-102 
  Alert: No Swap data was found. 
  System Temperatures: cpu: 45.0 C mobo: N/A 
  Fan Speeds (RPM): cpu: 3243 
  Processes: 265 Uptime: 38m Memory: 7.66 GiB used: 3.11 GiB (40.7%) 
  Init: systemd v: 246 Compilers: gcc: 10.2.0 clang: 10.0.1 Packages: 
  pacman: 1094 Shell: Zsh (sudo) v: 5.8 default: Bash v: 5.0.18 
  running in: gnome-terminal inxi: 3.1.06
1 Like

I think i got the problem

We miss mkinitcpio-openswap in the root packages

This will be solved in next release

Thank you for letting us know the error


Mind sending me a link for the test build?
I’m heading out of town in a few days and don’t want to travel with an unsecured laptop.



Probably tomorrow.

I can create an test iso.

Which edition do you want


GNOME minimal works. Thank you


Here is the link

This one has calamares 3.2.30

Tell me if you encounter any trouble while installing
Although there should be none


The iso worked!

However, note that a bug with Calamares indicates a failed installation after the initialization of the partitions. This is easily fixed by starting the installation over and choosing to use an existing partition instead of erasing the disk. Afterwards the installation proceeds as normal.

Fantastic work thank you



I attempted to install both KDE editions with encryption and got this same error. Are those ISOs due for a refresh soon to address this issue? Thank you.


Yes next release will have the encryption