Backup snapshots

hey guys i'm trying to backup a snapshot i've made, i used a script to change my KDE look but i would like to keep the snapshot before i did it for the foreseeable future, how do i do that?

  Kernel: 5.17.11-259-tkg-pds arch: x86_64 bits: 64 compiler: gcc v: 12.1.0
    parameters: intel_pstate=passive BOOT_IMAGE=/@/boot/vmlinuz-linux-tkg-pds
    root=UUID=0b8ec9ff-9af6-4372-8dcd-3a81b90a7b8b rw [email protected]
    quiet splash rd.udev.log_priority=3 vt.global_cursor_default=0 loglevel=3
  Desktop: KDE Plasma v: 5.24.5 tk: Qt v: 5.15.4 info: latte-dock
    wm: kwin_x11 vt: 1 dm: SDDM Distro: Garuda Linux base: Arch Linux
  Type: Desktop System: Micro-Star product: MS-7B79 v: 3.0
    serial: <superuser required>
  Mobo: Micro-Star model: X470 GAMING PLUS MAX (MS-7B79) v: 3.0
    serial: <superuser required> UEFI: American Megatrends LLC. v: H.C0
    date: 05/18/2021
  Info: model: AMD Ryzen 7 5800X bits: 64 type: MT MCP arch: Zen 3
    family: 0x19 (25) model-id: 0x21 (33) stepping: 0 microcode: 0xA201009
  Topology: cpus: 1x cores: 8 tpc: 2 threads: 16 smt: enabled cache:
    L1: 512 KiB desc: d-8x32 KiB; i-8x32 KiB L2: 4 MiB desc: 8x512 KiB
    L3: 32 MiB desc: 1x32 MiB
  Speed (MHz): avg: 4274 high: 4275 min/max: N/A cores: 1: 4274 2: 4275
    3: 4275 4: 4275 5: 4275 6: 4275 7: 4275 8: 4275 9: 4275 10: 4275 11: 4275
    12: 4275 13: 4275 14: 4275 15: 4275 16: 4275 bogomips: 136954
  Flags: avx avx2 ht lm nx pae sse sse2 sse3 sse4_1 sse4_2 sse4a ssse3 svm
  Type: itlb_multihit status: Not affected
  Type: l1tf status: Not affected
  Type: mds status: Not affected
  Type: meltdown status: Not affected
  Type: spec_store_bypass
    mitigation: Speculative Store Bypass disabled via prctl
  Type: spectre_v1
    mitigation: usercopy/swapgs barriers and __user pointer sanitization
  Type: spectre_v2 mitigation: Retpolines, IBPB: conditional, IBRS_FW,
    STIBP: always-on, RSB filling
  Type: srbds status: Not affected
  Type: tsx_async_abort status: Not affected
  Device-1: NVIDIA TU104 [GeForce RTX 2080 Rev. A] vendor: ASUSTeK
    driver: nvidia v: 515.43.04 alternate: nouveau,nvidia_drm non-free: 515.xx+
    status: current (as of 2022-05) arch: Turing pcie: gen: 2 speed: 5 GT/s
    lanes: 16 link-max: gen: 3 speed: 8 GT/s bus-ID: 27:00.0
    chip-ID: 10de:1e87 class-ID: 0300
  Display: x11 server: X.Org v: 21.1.3 with: Xwayland v: 22.1.2
    compositor: kwin_x11 driver: X: loaded: nvidia unloaded: modesetting
    alternate: fbdev,nouveau,nv,vesa gpu: nvidia display-ID: :0 screens: 1
  Screen-1: 0 s-res: 2560x1440 s-dpi: 122 s-size: 533x302mm (20.98x11.89")
    s-diag: 613mm (24.12")
  Monitor-1: DP-4 res: 2560x1440 dpi: 123 size: 527x296mm (20.75x11.65")
    diag: 604mm (23.8") modes: N/A
  OpenGL: renderer: NVIDIA GeForce RTX 2080/PCIe/SSE2
    v: 4.6.0 NVIDIA 515.43.04 direct render: Yes
  Device-1: NVIDIA TU104 HD Audio vendor: ASUSTeK driver: snd_hda_intel
    v: kernel pcie: gen: 3 speed: 8 GT/s lanes: 16 bus-ID: 27:00.1
    chip-ID: 10de:10f8 class-ID: 0403
  Device-2: AMD Starship/Matisse HD Audio vendor: Micro-Star MSI
    driver: snd_hda_intel v: kernel pcie: gen: 4 speed: 16 GT/s lanes: 16
    bus-ID: 29:00.4 chip-ID: 1022:1487 class-ID: 0403
  Sound Server-1: ALSA v: k5.17.11-259-tkg-pds running: yes
  Sound Server-2: PulseAudio v: 15.0 running: no
  Sound Server-3: PipeWire v: 0.3.51 running: yes
  Device-1: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet
    vendor: Micro-Star MSI driver: r8169 v: kernel pcie: gen: 1 speed: 2.5 GT/s
    lanes: 1 port: f000 bus-ID: 22:00.0 chip-ID: 10ec:8168 class-ID: 0200
  IF: enp34s0 state: up speed: 1000 Mbps duplex: full mac: <filter>
  Local Storage: total: 1.56 TiB used: 758.69 GiB (47.4%)
  SMART Message: Unable to run smartctl. Root privileges required.
  ID-1: /dev/sda maj-min: 8:0 vendor: Seagate model: ST1000DM003-1CH162
    size: 931.51 GiB block-size: physical: 4096 B logical: 512 B
    speed: 6.0 Gb/s type: HDD rpm: 7200 serial: <filter> rev: CC49
    scheme: MBR
  ID-2: /dev/sdb maj-min: 8:16 vendor: Kingston model: SA400S37480G
    size: 447.13 GiB block-size: physical: 512 B logical: 512 B speed: 6.0 Gb/s
    type: SSD serial: <filter> rev: 1103 scheme: GPT
  ID-3: /dev/sdc maj-min: 8:32 vendor: Kingston model: SUV400S37240G
    size: 223.57 GiB block-size: physical: 4096 B logical: 512 B
    speed: 6.0 Gb/s type: SSD serial: <filter> rev: 37R5 scheme: GPT
  ID-1: / raw-size: 223.27 GiB size: 223.27 GiB (100.00%)
    used: 71.73 GiB (32.1%) fs: btrfs dev: /dev/sdc2 maj-min: 8:34
  ID-2: /boot/efi raw-size: 300 MiB size: 299.4 MiB (99.80%)
    used: 576 KiB (0.2%) fs: vfat dev: /dev/sdc1 maj-min: 8:33
  ID-3: /home raw-size: 223.27 GiB size: 223.27 GiB (100.00%)
    used: 71.73 GiB (32.1%) fs: btrfs dev: /dev/sdc2 maj-min: 8:34
  ID-4: /var/log raw-size: 223.27 GiB size: 223.27 GiB (100.00%)
    used: 71.73 GiB (32.1%) fs: btrfs dev: /dev/sdc2 maj-min: 8:34
  ID-5: /var/tmp raw-size: 223.27 GiB size: 223.27 GiB (100.00%)
    used: 71.73 GiB (32.1%) fs: btrfs dev: /dev/sdc2 maj-min: 8:34
  Kernel: swappiness: 133 (default 60) cache-pressure: 50 (default 100)
  ID-1: swap-1 type: zram size: 15.61 GiB used: 732.8 MiB (4.6%)
    priority: 100 dev: /dev/zram0
  System Temperatures: cpu: N/A mobo: N/A gpu: nvidia temp: 54 C
  Fan Speeds (RPM): cpu: 0 gpu: nvidia fan: 14%
  Processes: 379 Uptime: 14m wakeups: 1 Memory: 15.61 GiB
  used: 5.76 GiB (36.9%) Init: systemd v: 251 tool: systemctl Compilers:
  gcc: 12.1.0 clang: 13.0.1 Packages: pacman: 1866 lib: 507 flatpak: 0
  Shell: Bash v: 5.1.16 running-in: konsole inxi: 3.3.16
Garuda (2.6.3-2):
  System install date:     2022-03-27
  Last full system update: 2022-05-28
  Is partially upgraded:   No
  Relevant software:       NetworkManager
  Windows dual boot:       No/Undetected
  Snapshots:               Snapper
  Failed units:            bluetooth-autoconnect.service 

Backup snapshots - #2 by SGS doesn't help at all, since i have no idea how can i copy from /.snapshot, it gives me an error while i try to create a backup of my 209 folder

Backup snapshots - #3 by BluishHumility it tells me doesn't belong to btrfs mount point

Backup snapshots - #4 by SGS if i understood the wiki i wouldn't be here asking the question, because i already tried to figure it out searching on the wiki and other arch forums too, and why the hell making a backup of a backup folder is so complex

this is exactly why linux will never be popular, simple stuff is made so much harder and not approachable, and when a question is asked you get pushed on a wiki full of mumbojumbo that a new person don't understand, you have to learn a bunch of useless stuff that i will never use again to make a backup of a backup... such a shame because linux is amazing



You can use Btrfs send/receive for this purpose.

sudo btrfs send /path/to/snapshot | sudo btrfs receive /path/to/backup

More here: Btrfs - ArchWiki


That was just a hint to look for yourself.

1 Like

Hmm, we'll have to see the command I think.

Don't forget, for btrfs send to work they have to be read-only snapshots.

Not for nothing, but this "wiki full of mumbojumbo" is the way all of us learn how to do stuff and how stuff works. It's not like there is some Linux school we all went to or something.

I'm going to move this thread out of the bin for now to make it a little easier to interact with. Please post the btrfs send command you tried including the output.


Also post lsblk please.


But you do not post anything about in your first post.

Nor have you communicated what you do not understand.
You do not want to learn, but others should work out a solution tailored to you?

The way you posted it, it was obvious that you want to be spoon-fed.
BTW, what kind of script is that?

It should be easier first to save the data that is to be changed.


Snapper (the snapshotting daemon) does not preserve your home directory by default. If you modified KDE settings and are searching for the moment before you modified them, then I am sorry but that moment is gone. Unless you have backed up your home folder yourself...


But who knows, except him, but he says nothing.

Or rather, it has already been solved.


He says a lot and not nice to read, but he edits/uses the 1st post... :face_with_head_bandage:
Sounds like a rude, ungrateful person that doesn't deserve any support, but I may be wrong, which I rarely am...

Perhaps I made a mistake taking this one out of the bin. :disappointed:

1 Like