Backport openssl

Openssl has recently been upgraded to v. 3.x. Alas, now I use VPN to my office. Until new certs can be distributed is there a way I can backport openssl to v. 1.x which worked fine?

Have you tried installing openssl-1.0

1 Like

It's provided by openssl-git, which Chaotic is currently failing to build :frowning:


Update: it's built, give it a try!


Even if I install openssl-1.0, which I did, openvpn wants to use openssl-3.0.7. How would I make openvpn use an older version of openssl?

Why do you need an older version in the first place? It's not going to use an older version how it seems you might expect.

Back to the original post. I need to be able to VPN into my office. Apparently with openssl being updated to 3.x, I can no longer VPN in. The problem seems to be that I have to issue an new ca cert from the VPN server. Which I can do, if that is what will fix the problem. But in the meantime, it's rather critical that I be able to VPN in.

You would probably have to build a custom version of openvpn that was linked to openssl 1.x.

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.