AX200 disconnect problems

Hey all,

My ax200 intel pcie card that i have in my laptop have disconnect issues randomly.
It just disconnects and reconnects fairly quickly, but its annoying when you download something or watching streams.

Any help?

Thanks for the amazing distro.

PS. Using KDE lite, fresh install of the latest build.

The first thing I would try is disabling IPv6.

Please post:

inxi -Fxxxxza

Please do not post pictures of terminal outputs.

If disabling IPv6 does not help, then try disabling your wifi's power saving features.

Run the following command to auto-generate an iwlwifi driver options configuration file in /etc/modprobe.d/iwlwifi.conf :

echo -e "options iwlwifi power_save=0\noptions iwlmvm power_scheme=1" | sudo tee -a /etc/modprobe.d/iwlwifi.conf

Reboot after the creation of the configuration file.

If the new iwlwifi driver options file produces no improvement after rebooting it may be deleted, as on a laptop battery life is a concern.


2 Likes

It has been some time since your initial post. Have you made any progress with this issue?

If not, I can help with any steps you are unsure about. There are numerous things you could try to help improve your connectivity. Testing alternate iwlwifi firmware is one option. Ensuring your bios is up to date is also a way of eliminating the bios as a factor.

If you need further assistance, be sure to let me know. If your issue has been resolved then please be so kind as to mark your thread as solved.

Hoping you've found your solution.

1 Like

Hey,

So, i was testing the options and some other things, thats why i didnt reply.

Seems like the problem isnt so much on the Garuda's part, but on the network, or how generally linux handle this.
Im in a dorm, which has multiple 2.4 and 5GHz APs, all with the same name. If i fixed the network on a single AP MAC address, the problem seems to dissapear.
So, i concluded that its the way that it "jumps" between different APs trying to choose the closest one or whatever.
My Windows partition dont have this problem, but maybe it has a lower Roaming Aggressiveness so it doesnt change APs this much? Dunno.

Is there a way to reduce the Roaming Aggressiveness so the wifi doesnt try to change APs so much, or even restrict it only to 5GHz?

Thanks.

Did you try this option:

options iwlwifi 11n_disable=1

That option disables the N band.

The less drastic way might be to try using nm-connection-editor. I'm not using WiFi right now, (so I'm not positive), but I think nm-connection-editor lets you select auto, 2.4, or 5 Ghz.

This of course assumes you are using Network Manager. It's been a long time since I've used Connman, so I'm not familiar with whether it has the ability to do the same.