Awesomewm help

Hello.
Here's my inxi-Faz:

╭─[email protected] in ~ took 8s
╰─λ inxi -Faz
System:    Kernel: 5.14.6-zen1-1-zen x86_64 bits: 64 compiler: gcc v: 11.1.0 
parameters: BOOT_IMAGE=/@/boot/vmlinuz-linux-zen root=UUID=d9544bd3-6c1e-446a-bd11-bffba72af3a9 rw 
[email protected] quiet splash rd.udev.log_priority=3 vt.global_cursor_default=0 
systemd.unified_cgroup_hierarchy=1 loglevel=3 
Desktop: awesome 4.3-1148-g87e09f81a vt: 1 dm: SDDM Distro: Garuda Linux base: Arch Linux 
Machine:   Type: Laptop System: LENOVO product: 20Y7CTO1WW v: ThinkPad E14 Gen 3 serial: <filter> Chassis: type: 10 
serial: <filter> 
Mobo: LENOVO model: 20Y7CTO1WW serial: <filter> UEFI: LENOVO v: R1OET28W (1.07 ) date: 07/15/2021 
Battery:   ID-1: BAT0 charge: 46.2 Wh (79.5%) condition: 58.1/57.0 Wh (101.9%) volts: 12.4 min: 11.5 model: Sunwoda 5B11C732 
type: Li-poly serial: <filter> status: Unknown cycles: 6 
CPU:       Info: 8-Core model: AMD Ryzen 7 5700U with Radeon Graphics bits: 64 type: MT MCP arch: Zen 2 family: 17 (23) 
model-id: 68 (104) stepping: 1 microcode: 8608103 cache: L2: 4 MiB 
flags: avx avx2 lm nx pae sse sse2 sse3 sse4_1 sse4_2 sse4a ssse3 svm bogomips: 57490 
Speed: 1397 MHz min/max: 1400/4370 MHz boost: enabled Core speeds (MHz): 1: 1397 2: 1397 3: 1397 4: 1398 5: 1395 
6: 1396 7: 1396 8: 1397 9: 1396 10: 1397 11: 1397 12: 1397 13: 1397 14: 1396 15: 1397 16: 1397 
Vulnerabilities: Type: itlb_multihit status: Not affected 
Type: l1tf status: Not affected 
Type: mds status: Not affected 
Type: meltdown status: Not affected 
Type: spec_store_bypass mitigation: Speculative Store Bypass disabled via prctl and seccomp 
Type: spectre_v1 mitigation: usercopy/swapgs barriers and __user pointer sanitization 
Type: spectre_v2 mitigation: Full AMD retpoline, IBPB: conditional, IBRS_FW, STIBP: conditional, RSB filling 
Type: srbds status: Not affected 
Type: tsx_async_abort status: Not affected 
Graphics:  Device-1: Advanced Micro Devices [AMD/ATI] Lucienne vendor: Lenovo driver: amdgpu v: kernel bus-ID: 04:00.0
chip-ID: 1002:164c class-ID: 0300
Device-2: Chicony Integrated Camera type: USB driver: uvcvideo bus-ID: 1-3:3 chip-ID: 04f2:b725 class-ID: fe01
serial: <filter>
Display: x11 server: X.Org 1.20.13 compositor: picom v: git-de959 driver: loaded: amdgpu,ati unloaded: modesetting
alternate: fbdev,vesa display-ID: :0 screens: 1
Screen-1: 0 s-res: 3840x1080 s-dpi: 96 s-size: 1016x285mm (40.0x11.2") s-diag: 1055mm (41.5")
Monitor-1: eDP res: 1920x1080 hz: 60 dpi: 158 size: 309x174mm (12.2x6.9") diag: 355mm (14")
Monitor-2: HDMI-A-0 res: 1920x1080 hz: 60 dpi: 96 size: 510x287mm (20.1x11.3") diag: 585mm (23")
OpenGL: renderer: AMD RENOIR (DRM 3.42.0 5.14.6-zen1-1-zen LLVM 12.0.1) v: 4.6 Mesa 21.2.2 direct render: Yes
Audio:     Device-1: Advanced Micro Devices [AMD/ATI] vendor: Lenovo driver: snd_hda_intel v: kernel bus-ID: 04:00.1
chip-ID: 1002:1637 class-ID: 0403
Device-2: Advanced Micro Devices [AMD] Raven/Raven2/FireFlight/Renoir Audio Processor vendor: Lenovo driver: N/A
alternate: snd_pci_acp3x, snd_rn_pci_acp3x bus-ID: 04:00.5 chip-ID: 1022:15e2 class-ID: 0480
Device-3: Advanced Micro Devices [AMD] Family 17h HD Audio vendor: Lenovo driver: snd_hda_intel v: kernel
bus-ID: 04:00.6 chip-ID: 1022:15e3 class-ID: 0403
Sound Server-1: ALSA v: k5.14.6-zen1-1-zen running: yes
Sound Server-2: JACK v: 1.9.19 running: no
Sound Server-3: PulseAudio v: 15.0 running: no
Sound Server-4: PipeWire v: 0.3.35 running: yes
Network:   Device-1: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet vendor: Lenovo driver: r8169 v: kernel port: 3000
bus-ID: 02:00.0 chip-ID: 10ec:8168 class-ID: 0200
IF: enp2s0 state: down mac: <filter>
Device-2: Realtek vendor: Lenovo driver: rtw89_pci v: N/A modules: rtw89pci port: 2000 bus-ID: 03:00.0
chip-ID: 10ec:8852 class-ID: 0280
IF: wlp3s0 state: up mac: <filter>
IF-ID-1: virbr0 state: down mac: <filter>
Bluetooth: Device-1: Realtek Bluetooth Radio type: USB driver: btusb v: 0.8 bus-ID: 3-4:2 chip-ID: 0bda:4852 class-ID: e001
serial: <filter>
Report: bt-adapter ID: hci0 rfk-id: 1 state: down bt-service: enabled,running rfk-block: hardware: no software: yes
address: <filter>
Drives:    Local Storage: total: 476.94 GiB used: 171.26 GiB (35.9%)
SMART Message: Unable to run smartctl. Root privileges required.
ID-1: /dev/nvme0n1 maj-min: 259:0 vendor: Samsung model: MZALQ512HBLU-00BL1 size: 476.94 GiB block-size:
physical: 512 B logical: 512 B speed: 31.6 Gb/s lanes: 4 type: SSD serial: <filter> rev: 6L1QFXM7 temp: 31.9 C
scheme: GPT
Partition: ID-1: / raw-size: 80 GiB size: 80 GiB (100.00%) used: 15.91 GiB (19.9%) fs: btrfs dev: /dev/nvme0n1p5
maj-min: 259:5
ID-2: /boot/efi raw-size: 100 MiB size: 96 MiB (96.00%) used: 27.5 MiB (28.6%) fs: vfat dev: /dev/nvme0n1p1
maj-min: 259:1
ID-3: /home raw-size: 196.42 GiB size: 196.42 GiB (100.00%) used: 17.45 GiB (8.9%) fs: btrfs dev: /dev/nvme0n1p6
maj-min: 259:6
ID-4: /var/log raw-size: 80 GiB size: 80 GiB (100.00%) used: 15.91 GiB (19.9%) fs: btrfs dev: /dev/nvme0n1p5
maj-min: 259:5
ID-5: /var/tmp raw-size: 80 GiB size: 80 GiB (100.00%) used: 15.91 GiB (19.9%) fs: btrfs dev: /dev/nvme0n1p5
maj-min: 259:5
Swap:      Kernel: swappiness: 133 (default 60) cache-pressure: 100 (default)
ID-1: swap-1 type: zram size: 13.48 GiB used: 0 KiB (0.0%) priority: 100 dev: /dev/zram0
Sensors:   System Temperatures: cpu: 44.4 C mobo: N/A gpu: amdgpu temp: 44.0 C
Fan Speeds (RPM): fan-1: 1800
Info:      Processes: 354 Uptime: 55m wakeups: 1 Memory: 13.48 GiB used: 4.6 GiB (34.1%) Init: systemd v: 249 tool: systemctl
Compilers: gcc: 11.1.0 clang: 12.0.1 Packages: pacman: 1337 lib: 331 Shell: fish v: 3.3.1 default: Bash v: 5.1.8
running-in: konsole inxi: 3.3.06

I am running Garuda Linux Dr4g0n1zed version, which is using KDE Plasma.
Just recently installed awesome to try out tiling window managers.
Then I go to https://github.com/manilarome/the-glorious-dotfiles, to borrow the setup he made.
Then, when I log in to awesome wm, I found there is no wifi. So, I ran these following commands:

╭─[email protected] in ~ took 340ms
╰─λ sudo wpa_supplicant -B -D nl80211 -i wlp3s0 -c /etc/wpa_supplicant/wpa_supplicant.conf
Successfully initialized wpa_supplicant
nl80211: kernel reports: Match already configured
nl80211: kernel reports: Match already configured
nl80211: kernel reports: Match already configured
nl80211: kernel reports: Match already configured
nl80211: kernel reports: Match already configured
nl80211: kernel reports: Match already configured
nl80211: kernel reports: Match already configured
nl80211: kernel reports: Match already configured
nl80211: kernel reports: Match already configured
nl80211: kernel reports: Match already configured
nl80211: kernel reports: Match already configured
nl80211: kernel reports: Match already configured
nl80211: kernel reports: Match already configured
nl80211: kernel reports: Match already configured
nl80211: kernel reports: Match already configured
nl80211: kernel reports: Match already configured
nl80211: kernel reports: Match already configured
nl80211: kernel reports: Match already configured
nl80211: kernel reports: Match already configured
nl80211: kernel reports: Match already configured
nl80211: kernel reports: Match already configured
nl80211: kernel reports: Match already configured

Following by:

╭─[email protected] in ~ took 54ms
╰─λ sudo dhclient

And then, I've successfully connected to my wifi.
But, the wifi will be disconnected after a short period of time, approximately 5 minutes or so. I have to run sudo dhclient again to connect the wifi.
I've tried these commands to fix this problem:

╭─[email protected] in ~ 
╰─λ sudo systemctl enable wpa_supplicant.service
[sudo] password for jing:          
Created symlink /etc/systemd/system/dbus-fi.w1.wpa_supplicant1.service → /usr/lib/systemd/system/wpa_supplicant.service.
Created symlink /etc/systemd/system/multi-user.target.wants/wpa_supplicant.service → /usr/lib/systemd/system/wpa_supplicant.service.
╭─[email protected] in ~ took 50ms
╰─λ sudo systemctl enable [email protected]
Created symlink /etc/systemd/system/multi-user.target.wants/[email protected] → /usr/lib/systemd/system/[email protected]

And then followed up with a reboot. But they didn't work, I still have to run wpa_supplicant and dhclient again and again.

I hope that someone can give me some help, any is appreciated.
I will keep adding more and more problems I've encountered here, hope that anyone else who is using awesomewm can also get some help.

EDIT 1:
I've encountered another problem about rofi. As state in the screenshots of the github repo, it should be in full screen, with a search bar. But what I got is a half-screen menu with broken icon. After some debugging, I'm sure this is caused by rofi itself, but I don't know how to fix this issue.

Creating another user is recommended for another wm or desktop environment, so it doesn't mess config files.

Try with a new user.

1 Like

Nope, sorry, nothing.
A new user with the same setup from the git repo also have the frequently disconnect problem with the same connecting steps as above.

EDIT 1:
As far as I see, after I've created the new user, connected to wifi, and then log into original user account and remove the new user account's awesomewm config, the network seems to be working now? I'll keep monitoring and keep this thread update.

EDIT 2:
Okay, this edit and the previous one is very close, because it did not work. I still have to run sudo dhclient every since a while, and I've totally no idea what to do now.

Let me preface that I know nothing about awsomevm and just did a quick search on the internet.
Try to have a look here (even if it's very old stuff!).
One thing that makes sense to me is that, since it's a windows manager, maybe NetworkManager's nm-app doesn't work well with it and you have to find some workaround.

1 Like

Thanks for the help, but it unfortunately didn't work.
Let me just say it short, nm-applet disconnected me from my current network, and want me to connect my neighbour's network.

Another workarouund, this time more homemade. :slight_smile:
You could create a systemd service at startup that runs wpa_supplicant and dhclient ?

Should I make it run the commands above? Or just simply wpa_supplicant and dhclient?

I'd create a script, like e.g. here:
https://www.linode.com/docs/guides/start-service-at-boot/
including the commands (without sudo) that you have to launch manually to make things work.
E.g. (I don't know if the wpa_supplicant part is correct, or if it could block the following dhclient, you should make some tests):

wpa_supplicant -B -D nl80211 -i wlp3s0 -c /etc/wpa_supplicant/wpa_supplicant.conf
dhclient
1 Like

I am currently trying to use netctl over networkmanager. Seems to be working with wifi-menu.
But now my key bindings are not functioning at all.

EDIT 1: OK I've fixed the key bindings problem. I accidentally pressed Fn+Win, and that locks Win key on my keyboard.

EDIT 2: So far I haven't encountered any network problems yet. Change from NetworkManger to netctl works for me, as a reference to any other who wants to use awesomewm.

Here's the exact step:

systemctl systemctl stop systemd-networkd.service
sudo pacman -S netctl
sudo pacman -S dialog
sudo systemctl stop NetworkManager.service
sudo systemctl disable NetworkManager.service
sudo systemctl enable netctl.service
sudo systemctl start netctl.service
sudo wifi-menu

Please be caution here. The wlp3s0 is my network card id, which can be different for everyone. Substitude it by your own.

sudo systemctl enable [email protected]

After a re-login, it is stable, with no more further problems AFAIK.

1 Like

I got one last problem. The rofi application launcher only showing at half of the screen but the whole screen. i hope someone who has used or still using rofi can give me some help.

EDIT: I've found the solution for this. This problem is caused by the configuration file conflict between rofi 1.6x (which is used by the author of the-glorious-dotfiles), and rofi 1.7x (which is the current version of rofi).
Here's the fix:
fix for full screen:

window {
	transparency: "real";
	background-color: @transparent;
	text-color: @foreground;
	fullscreen: true;
}

fix for icon placement(if needed):

element-icon {
	horizontal-align: 0.5;
	vertical-align: 0.5;
	background-color: @transparent;
	size: 72px;
}

fix for icon text(if needed):

element-text {
	expand: true;
	horizontal-align: 0.5;
	vertical-align: 0.5;
	margin: 0 10px 0 10px;
	background-color: @transparent;
	text-color: @foreground;
}

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.