Auto-cpufreq --install not working

I have tried to run auto-cpufreq to improve my battery life, my cpu min frequency is 1400,

output:

sudo auto-cpufreq --install

--------------------- Deploying auto-cpufreq as a daemon ----------------------

* Turn off bluetooth on boot

* Deploy auto-cpufreq install script
Traceback (most recent call last):
File "/usr/bin/auto-cpufreq", line 256, in <module>
main()
File "/usr/lib/python3.11/site-packages/click/core.py", line 1157, in __call__
return self.main(*args, **kwargs)
^^^^^^^^^^^^^^^^^^^^^^^^^^
File "/usr/lib/python3.11/site-packages/click/core.py", line 1078, in main
rv = self.invoke(ctx)
^^^^^^^^^^^^^^^^
File "/usr/lib/python3.11/site-packages/click/core.py", line 1434, in invoke
return ctx.invoke(self.callback, **ctx.params)
^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^
File "/usr/lib/python3.11/site-packages/click/core.py", line 783, in invoke
return __callback(*args, **kwargs)
^^^^^^^^^^^^^^^^^^^^^^^^^^^
File "/usr/bin/auto-cpufreq", line 206, in main
deploy_daemon()
File "/usr/lib/python3.11/site-packages/auto_cpufreq/core.py", line 411, in deploy_daemon
shutil.copy(SCRIPTS_DIR / "auto-cpufreq-install.sh", "/usr/bin/auto-cpufreq-install")
File "/usr/lib/python3.11/shutil.py", line 419, in copy
copyfile(src, dst, follow_symlinks=follow_symlinks)
File "/usr/lib/python3.11/shutil.py", line 256, in copyfile
with open(src, 'rb') as fsrc:
^^^^^^^^^^^^^^^
FileNotFoundError: [Errno 2] No such file or directory: '/usr/share/auto-cpufreq/scripts/auto-cpufreq-install.sh'

Please post output of your garuda inxi like this from the terminal :

garuda-inxi 

And please tell what are the steps that you took till now to resolve it and also how did you installed auto-cpufreq.

And welcome to garuda community forum :wink:

4 Likes

You can’t use that install script here it’s for debian, just turn on it’s systemd unit files

systemctl enable --now auto-cpufreq.service

Please read it’s readme it’s documented in the AUR section

You can (not mandatory) make /etc/auto-cpufreq.conf and copy paste the default settings from the github’s readme and edit it as needed. For example I have turned off my turbo boost since that was causing my cpu to stay needlessly hot while giving worse performance than without it. So I disabled it.

If you make changes to this file you need to reload the systemd service file for auto-cpufreq for it to read the changes.

Also do consider installing thermald alongside this and enable it’s systemd unit files as well.

3 Likes

Who knows, maybe he uses Debian?
Could be recognized by the garuda-inxi if he followed the template.

3 Likes
System:
Kernel: 6.1.55-x64v1-xanmod1-1-lts arch: x86_64 bits: 64 compiler: gcc
v: 13.2.1 clocksource: tsc available: hpet,acpi_pm
parameters: BOOT_IMAGE=/@/boot/vmlinuz-linux-xanmod-lts
root=UUID=2c8ab2d6######-98d1-81e0b53c1d60 rw rootflags=subvol=@
quiet quiet rd.udev.log_priority=3 vt.global_cursor_default=0 loglevel=3
ibt=off
Desktop: KDE Plasma v: 5.27.8 tk: Qt v: 5.15.10 wm: kwin_x11 vt: 2
dm: SDDM Distro: Garuda Linux base: Arch Linux
Machine:
Type: Laptop System: ASUSTeK product: VivoBook_ASUSLaptop X509DA_M509DA
v: 1.0 serial: <superuser required>
Mobo: ASUSTeK model: X509DA v: 1.0 serial: <superuser required>
UEFI: American Megatrends v: X509DA.306 date: 10/11/2019
Battery:
ID-1: BAT0 charge: 23.7 Wh (100.0%) condition: 23.7/32.1 Wh (74.0%)
volts: 7.8 min: 7.8 model: ASUSTeK ASUS Battery type: Li-ion serial: N/A
status: not charging cycles: 975
CPU:
Info: model: AMD Ryzen 5 3500U with Radeon Vega Mobile Gfx bits: 64
type: MT MCP arch: Zen/Zen+ note: check gen: 1 level: v3 note: check
built: 2019 process: GF 12nm family: 0x17 (23) model-id: 0x18 (24)
stepping: 1 microcode: 0x8108109
Topology: cpus: 1x cores: 4 tpc: 2 threads: 8 smt: enabled cache:
L1: 384 KiB desc: d-4x32 KiB; i-4x64 KiB L2: 2 MiB desc: 4x512 KiB L3: 4 MiB
desc: 1x4 MiB
Speed (MHz): avg: 1795 high: 2100 min/max: 1400/2100 boost: disabled
scaling: driver: acpi-cpufreq governor: performance cores: 1: 1389 2: 2100
3: 2100 4: 2100 5: 1232 6: 2100 7: 1243 8: 2100 bogomips: 33535
Flags: avx avx2 ht lm nx pae sse sse2 sse3 sse4_1 sse4_2 sse4a ssse3 svm
Vulnerabilities: <filter>
Graphics:
Device-1: AMD Picasso/Raven 2 [Radeon Vega Series / Radeon Mobile Series]
vendor: ASUSTeK driver: amdgpu v: kernel arch: GCN-5 code: Vega
process: GF 14nm built: 2017-20 pcie: gen: 3 speed: 8 GT/s lanes: 16
ports: active: eDP-1 empty: HDMI-A-1 bus-ID: 03:00.0 chip-ID: 1002:15d8
class-ID: 0300 temp: 59.0 C
Device-2: IMC Networks USB2.0 VGA UVC WebCam driver: uvcvideo type: USB
rev: 2.0 speed: 480 Mb/s lanes: 1 mode: 2.0 bus-ID: 3-2.2:5
chip-ID: 13d3:5a11 class-ID: 0e02
Display: x11 server: X.Org v: 21.1.8 with: Xwayland v: 23.2.0
compositor: kwin_x11 driver: X: loaded: amdgpu unloaded: modesetting
alternate: fbdev,vesa dri: radeonsi gpu: amdgpu display-ID: :0 screens: 1
Screen-1: 0 s-res: 1920x1080 s-dpi: 96 s-size: 508x285mm (20.00x11.22")
s-diag: 582mm (22.93")
Monitor-1: eDP-1 mapped: eDP model: BOE Display 0x07f1 built: 2018
res: 1920x1080 hz: 60 dpi: 142 gamma: 1.2 size: 344x193mm (13.54x7.6")
diag: 394mm (15.5") ratio: 16:9 modes: max: 1920x1080 min: 640x480
API: OpenGL v: 4.6 Mesa 23.1.7-arch1.1 renderer: AMD Radeon Vega 8
Graphics (raven LLVM 16.0.6 DRM 3.49 6.1.55-x64v1-xanmod1-1-lts)
direct-render: Yes
Audio:
Device-1: AMD Raven/Raven2/Fenghuang HDMI/DP Audio driver: snd_hda_intel
v: kernel pcie: gen: 3 speed: 8 GT/s lanes: 16 bus-ID: 03:00.1
chip-ID: 1002:15de class-ID: 0403
Device-2: AMD ACP/ACP3X/ACP6x Audio Coprocessor driver: snd_pci_acp3x
v: kernel alternate: snd_rn_pci_acp3x, snd_pci_acp5x, snd_pci_acp6x,
snd_acp_pci, snd_rpl_pci_acp6x, snd_pci_ps, snd_sof_amd_renoir,
snd_sof_amd_rembrandt pcie: gen: 3 speed: 8 GT/s lanes: 16 bus-ID: 03:00.5
chip-ID: 1022:15e2 class-ID: 0480
Device-3: AMD Family 17h/19h HD Audio vendor: ASUSTeK
driver: snd_hda_intel v: kernel pcie: gen: 3 speed: 8 GT/s lanes: 16
bus-ID: 03:00.6 chip-ID: 1022:15e3 class-ID: 0403
API: ALSA v: k6.1.55-x64v1-xanmod1-1-lts status: kernel-api with: aoss
type: oss-emulator tools: N/A
Server-1: PipeWire v: 0.3.80 status: active with: 1: pipewire-pulse
status: active 2: wireplumber status: active 3: pipewire-alsa type: plugin
4: pw-jack type: plugin tools: pactl,pw-cat,pw-cli,wpctl
Network:
Device-1: Intel Wireless 8265 / 8275 driver: iwlwifi v: kernel pcie: gen: 1
speed: 2.5 GT/s lanes: 1 bus-ID: 01:00.0 chip-ID: 8086:24fd class-ID: 0280
IF: wlp1s0 state: up mac: <filter>
Bluetooth:
Device-1: Intel Bluetooth wireless interface driver: btusb v: 0.8 type: USB
rev: 2.0 speed: 12 Mb/s lanes: 1 mode: 1.1 bus-ID: 3-2.1:4
chip-ID: 8087:0a2b class-ID: e001
Report: btmgmt ID: hci0 rfk-id: 3 state: up address: <filter> bt-v: 4.2
lmp-v: 8 status: discoverable: no pairing: no class-ID: 6c010c
Drives:
Local Storage: total: 1.38 TiB used: 58.59 GiB (4.2%)
SMART Message: Unable to run smartctl. Root privileges required.
ID-1: /dev/nvme0n1 maj-min: 259:0 vendor: Intel model: SSDPEKNW512G8
size: 476.94 GiB block-size: physical: 512 B logical: 512 B speed: 31.6 Gb/s
lanes: 4 tech: SSD serial: <filter> fw-rev: 002C temp: 31.9 C scheme: GPT
ID-2: /dev/sda maj-min: 8:0 vendor: Western Digital
model: WD10JPVX-60JC3T1 size: 931.51 GiB block-size: physical: 4096 B
logical: 512 B speed: 6.0 Gb/s tech: HDD rpm: 5400 serial: <filter>
fw-rev: 1A02 scheme: GPT
Partition:
ID-1: / raw-size: 235.16 GiB size: 235.16 GiB (100.00%)
used: 58.56 GiB (24.9%) fs: btrfs dev: /dev/nvme0n1p6 maj-min: 259:6
ID-2: /boot/efi raw-size: 260 MiB size: 256 MiB (98.46%)
used: 32.7 MiB (12.8%) fs: vfat dev: /dev/nvme0n1p1 maj-min: 259:1
ID-3: /home raw-size: 235.16 GiB size: 235.16 GiB (100.00%)
used: 58.56 GiB (24.9%) fs: btrfs dev: /dev/nvme0n1p6 maj-min: 259:6
ID-4: /var/log raw-size: 235.16 GiB size: 235.16 GiB (100.00%)
used: 58.56 GiB (24.9%) fs: btrfs dev: /dev/nvme0n1p6 maj-min: 259:6
ID-5: /var/tmp raw-size: 235.16 GiB size: 235.16 GiB (100.00%)
used: 58.56 GiB (24.9%) fs: btrfs dev: /dev/nvme0n1p6 maj-min: 259:6
Swap:
Kernel: swappiness: 133 (default 60) cache-pressure: 50 (default 100)
zswap: no
ID-1: swap-1 type: zram size: 9.66 GiB used: 0 KiB (0.0%) priority: 100
comp: zstd avail: lzo,lzo-rle,lz4,lz4hc,842 max-streams: 8 dev: /dev/zram0
ID-2: swap-2 type: partition size: 1.95 GiB used: 0 KiB (0.0%)
priority: -2 dev: /dev/nvme0n1p5 maj-min: 259:5
Sensors:
System Temperatures: cpu: 60.1 C mobo: N/A gpu: amdgpu temp: 60.0 C
Fan Speeds (rpm): cpu: 2500
Info:
Processes: 277 Uptime: 11m wakeups: 1 Memory: total: 12 GiB note: est.
available: 9.66 GiB used: 3.08 GiB (31.9%) Init: systemd v: 254
default: graphical tool: systemctl Compilers: gcc: 13.2.1 Packages:
pm: pacman pkgs: 2096 libs: 558 tools: octopi,pamac,paru,yay Shell: fish
v: 3.6.1 default: Bash v: 5.1.16 running-in: konsole inxi: 3.3.29
Garuda (2.6.16-1):
System install date:     2023-08-06
Last full system update: 2023-09-26
Is partially upgraded:   Yes
Relevant software:       snapper NetworkManager dracut
Windows dual boot:       Probably (Run as root to verify)
Failed units:
systemctl enable --now auto-cpufreq.service

I have tried it, it works but whenever I want to change performance to powersaving, it says to run --install command

That’s what the config file is for. By default the governer is powersaving while on battery and performance while charging. Create the /etc/auto-cpufreq.conf and change this behaviour as needed and reload the systemd unit to apply changes.

An example config on the project readme GitHub - AdnanHodzic/auto-cpufreq: Automatic CPU speed & power optimizer for Linux

2 Likes

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.