Authentification error after Installation

Hello Garuda world,
I installed Garuda Sway these days and had the issue after installation and reboot: I failed at login screen with Authentification error

My password was like x_xxxxxxxxx! with x = upper and lowercase letters.

first thought: I typed it wrong during install (but it is the same password I used for a long time and you have to type it two times)

I did a complete new install again and typed my password very "concentrated" during installation -> same result can't login

second thought: problem with keyboard language? Unfortunately there is no "eye" button to check what I typed in.

Installation #3: password = "a" (very simple, same position on US / Germany keyboard -> it works!

Now at least I can play around with Garuda Sway.

I added a test user -> password = x_xxxxxxxxx! -> su test and the password works -> logout and tryied to login with user test and password x_xxxxxxxxx! : same result Authentication error.

I tried "q" -> works
I tried "z" -> works with su test in terminal but not at login screen

Any ideas?

1 Like

Hi there, welcome!
I'm not a sway user, this is just an idea from some reading on the internet...
I think this means that your keymap after login (which is ok, if I understand correctly) is not the one used at login.
The former should be here
The latter maybe could be here
and maybe could be adjusted to be aligned with the former.


Welcome to the community, and I will spin up a vm of the lastest sway iso to see if I get the same issue. @Rotor

Update: no a issue with us keyboard as default.. I would go with @filo suggestion!

1 Like

Hi filo,

my ~/.config/sway/config.d/input shows:

input type:keyboard xkb_layout "us"
exec_always {
'swaymsg input type:keyboard xkb_layout "$(localectl status | grep "X11 Layout" | sed -e "s/^.*X11 Layout://")"'
'swaymsg input type:keyboard xkb_variant "$(localectl status | grep "X11 Variant" | sed -e "s/^.*X11 Variant://")"'

Terminal with localectl status shows:
System Locale: LANG=de_DE.UTF-8
VC Keymap: de
X11 Layout: de

the input type:keyboard xkb_layout "us"
I changed to
the input type:keyboard xkb_layout "de"
with no effect (it will be over written by swaymsg?)

in /etc/sway/config.d/ is only one file:
50-systemd-user.conf with no Keymap entries

I checked /etc/qtgreet/
config.ini / users.conf / wayfire.ini
but there is nothing about Keymap

Perhaps I should look for another Login Manager. QtGreet is not my favorite so far, even without Authentification Error.

Thanks so far

Maybe you could try just to add it, like here

Hi filo,

I'm now pretty sure it is a Keymap problem.

My testuser "test" with password "z" can login with password "y"
"z" and "y" are swapped between us and de keyboard layout.

In your link above the last paragraph states at least wayfire uses us keyboard layout.

I tried
xkb_layout = de

in /etx/qtgreet/
config.ini / users.conf and wayfire.ini

But without success

thanks a lot!


I tried SDDM and LightDM with the same result.
At SDDM there is a language "selector" at the top left side.
US is already selected and in the drop down menu is US the only item.
It seams my language selection is after the login screen.

I never had this issue with Linux before.

Best regards Rotor

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.