Audio not working! Please help!

Kernel: 6.5.9-zen2-1-zen arch: x86_64 bits: 64 compiler: gcc v: 13.2.1
clocksource: tsc available: acpi_pm
parameters: BOOT_IMAGE=/@/boot/vmlinuz-linux-zen
root=UUID=fbbed090-28b1-4da3-9e06-f34a42d405c2 rw rootflags=subvol=@
quiet loglevel=3 ibt=off
Desktop: KDE Plasma v: 5.27.9 tk: Qt v: 5.15.11 wm: kwin_wayland vt: 1
dm: SDDM Distro: Garuda Linux base: Arch Linux
Type: Laptop System: ASUSTeK product: Vivobook_ASUSLaptop K5504VA_S5504VA
v: 1.0 serial: <superuser required>
Mobo: ASUSTeK model: K5504VA v: 1.0 serial: <superuser required>
UEFI: American Megatrends LLC. v: K5504VA.301 date: 07/11/2023
ID-1: BAT0 charge: 54.2 Wh (72.2%) condition: 75.1/75.0 Wh (100.1%)
power: 9.8 W volts: 8.0 min: 8.0 model: ASUSTeK ASUS Battery type: Li-ion
serial: N/A status: discharging cycles: 4
Info: model: 13th Gen Intel Core i9-13900H bits: 64 type: MST AMCP
arch: Raptor Lake gen: core 13 level: v3 note: check built: 2022+
process: Intel 7 (10nm) family: 6 model-id: 0xBA (186) stepping: 2
microcode: 0x4119
Topology: cpus: 1x cores: 14 mt: 6 tpc: 2 st: 8 threads: 20 smt: enabled
cache: L1: 1.2 MiB desc: d-8x32 KiB, 6x48 KiB; i-6x32 KiB, 8x64 KiB
L2: 11.5 MiB desc: 6x1.2 MiB, 2x2 MiB L3: 24 MiB desc: 1x24 MiB
Speed (MHz): avg: 464 high: 1212 min/max: 400/5200:5400:4100 scaling:
driver: intel_pstate governor: powersave cores: 1: 400 2: 400 3: 400 4: 400
5: 1212 6: 400 7: 400 8: 400 9: 400 10: 400 11: 810 12: 400 13: 400
14: 400 15: 400 16: 476 17: 400 18: 400 19: 400 20: 400 bogomips: 119807
Flags: avx avx2 ht lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx
Vulnerabilities: <filter>
Device-1: Intel Raptor Lake-P [Iris Xe Graphics] vendor: ASUSTeK
driver: i915 v: kernel arch: Gen-13 process: Intel 7 (10nm) built: 2022+
ports: active: eDP-1 empty: DP-1,DP-2,HDMI-A-1 bus-ID: 0000:00:02.0
chip-ID: 8086:a7a0 class-ID: 0300
Device-2: [] driver: uvcvideo type: USB rev: 2.0 speed: 480 Mb/s lanes: 1
mode: 2.0 bus-ID: 3-3:2 chip-ID: 3277:0022 class-ID: 0e02
Display: wayland server: v: with: Xwayland v: 23.2.2
compositor: kwin_wayland driver: X: loaded: modesetting
alternate: fbdev,intel,vesa dri: iris gpu: i915 display-ID: 0
Monitor-1: eDP-1 res: 1646x926 size: N/A modes: N/A
API: EGL v: 1.5 hw: drv: intel iris platforms: device: 0 drv: iris
device: 1 drv: swrast surfaceless: drv: iris wayland: drv: iris x11:
drv: iris inactive: gbm
API: OpenGL v: 4.6 compat-v: 4.5 vendor: intel mesa v: 23.2.1-arch1.2
glx-v: 1.4 direct-render: yes renderer: Mesa Intel Graphics (RPL-P)
device-ID: 8086:a7a0 memory: 14.89 GiB unified: yes display-ID: :1.0
API: Vulkan v: 1.3.269 layers: 3 device: 0 type: integrated-gpu
name: Intel Graphics (RPL-P) driver: mesa intel v: 23.2.1-arch1.2
device-ID: 8086:a7a0 surfaces: xcb,xlib,wayland device: 1 type: cpu
name: llvmpipe (LLVM 16.0.6 256 bits) driver: mesa llvmpipe
v: 23.2.1-arch1.2 (LLVM 16.0.6) device-ID: 10005:0000
surfaces: xcb,xlib,wayland
Device-1: Intel Raptor Lake-P/U/H cAVS vendor: ASUSTeK
driver: sof-audio-pci-intel-tgl
alternate: snd_hda_intel,snd_sof_pci_intel_tgl bus-ID: 0000:00:1f.3
chip-ID: 8086:51ca class-ID: 0401
API: ALSA v: k6.5.9-zen2-1-zen status: kernel-api tools: N/A
Server-1: PipeWire v: 0.3.83 status: active with: 1: pipewire-pulse
status: active 2: wireplumber status: active 3: pipewire-alsa type: plugin
4: pw-jack type: plugin tools: pactl,pw-cat,pw-cli,wpctl
Device-1: Intel Raptor Lake PCH CNVi WiFi driver: iwlwifi v: kernel
bus-ID: 0000:00:14.3 chip-ID: 8086:51f1 class-ID: 0280
IF: wlo1 state: up mac: <filter>
Device-1: Intel [] driver: btusb v: 0.8 type: USB rev: 2.0 speed: 12 Mb/s
lanes: 1 mode: 1.1 bus-ID: 3-10:4 chip-ID: 8087:0033 class-ID: e001
Report: btmgmt ID: hci0 rfk-id: 2 state: up address: <filter> bt-v: 5.3
lmp-v: 12 status: discoverable: no pairing: no class-ID: 7c010c
Hardware-1: Intel Volume Management Device NVMe RAID Controller Intel
driver: vmd v: 0.6 port: N/A bus-ID: 0000:00:0e.0 chip-ID: 8086:a77f rev:
class-ID: 0104
Local Storage: total: 953.87 GiB used: 12.01 GiB (1.3%)
SMART Message: Unable to run smartctl. Root privileges required.
ID-1: /dev/nvme0n1 maj-min: 259:0 vendor: Western Digital model: WD PC
SN560 SDDPNQE-1T00-1102 size: 953.87 GiB block-size: physical: 512 B
logical: 512 B speed: 63.2 Gb/s lanes: 4 tech: SSD serial: <filter>
fw-rev: 74114000 temp: 31.9 C scheme: GPT
ID-1: / raw-size: 375 GiB size: 375 GiB (100.00%) used: 11.95 GiB (3.2%)
fs: btrfs dev: /dev/nvme0n1p7 maj-min: 259:7
ID-2: /boot/efi raw-size: 260 MiB size: 256 MiB (98.46%)
used: 65.8 MiB (25.7%) fs: vfat dev: /dev/nvme0n1p1 maj-min: 259:1
ID-3: /home raw-size: 375 GiB size: 375 GiB (100.00%)
used: 11.95 GiB (3.2%) fs: btrfs dev: /dev/nvme0n1p7 maj-min: 259:7
ID-4: /var/log raw-size: 375 GiB size: 375 GiB (100.00%)
used: 11.95 GiB (3.2%) fs: btrfs dev: /dev/nvme0n1p7 maj-min: 259:7
ID-5: /var/tmp raw-size: 375 GiB size: 375 GiB (100.00%)
used: 11.95 GiB (3.2%) fs: btrfs dev: /dev/nvme0n1p7 maj-min: 259:7
Kernel: swappiness: 133 (default 60) cache-pressure: 100 (default) zswap: no
ID-1: swap-1 type: zram size: 15.25 GiB used: 0 KiB (0.0%) priority: 100
comp: zstd avail: lzo,lzo-rle,lz4,lz4hc,842 max-streams: 20 dev: /dev/zram0
System Temperatures: cpu: 41.0 C mobo: N/A
Fan Speeds (rpm): N/A
Processes: 358 Uptime: 7m wakeups: 935 Memory: total: 16 GiB note: est.
available: 15.25 GiB used: 3.43 GiB (22.5%) Init: systemd v: 254
default: graphical tool: systemctl Compilers: gcc: 13.2.1 Packages:
pm: pacman pkgs: 1341 libs: 399 tools: octopi,paru Shell: fish v: 3.6.1
running-in: konsole inxi: 3.3.30
Garuda (2.6.17-1):
System install date:     2023-10-31
Last full system update: 2023-11-01
Is partially upgraded:   No
Relevant software:       snapper NetworkManager dracut
Windows dual boot:       Probably (Run as root to verify)
Failed units:

First, in your device’s setup utility aka UEFI menu make sure your SATA controller is set to AHCI mode and not RAID mode. It has been a cause of a lot of issues on forum as of late and some have been unable to boot as well.

Next, if the issue persists please describe it. Are you facing some random lack of sound when you boot up? that is it sometimes works some times doesn’t, or you have sound crackling issues, or you can’t hear anything at all no matter what you do no matter how many times you reboot, etc… A proper description of the issue and what all has been attempted would be nice.

Thanks for responding so quickly! Funny thing is i just ran garuda-update and now I see speaker+headphones options appearing in Audio.

Before this all of a sudden audio went off, i tried running youtube on Brave and FireDragon. I couldn’t hear any audio whatsoever.

I then tried following few options that you recommended in one of the posts here:

but i was getting similar errors:
λ systemctl --user disable --now pulseaudio.socket pulseaudio.service
Failed to disable unit: Unit file pulseaudio.socket does not exist.

There also seemed to be conflicts between pulse-media-session and wireplumber

I then came across the below post and first thing i did is run garuda-update and I see spearker+headphones option appearing (which went missing).

Let me check on UEFI menu as well.

The issue you are describing happens to me as well sometimes. But for me restarting the pipewire server mostly does the job and the issue happens quite scantly for me like once a blue moon.

Despite this I have made myself a keybind to restart the audio server and it’s much easier to press meta+r to do this action than to open the terminal and type the command.

If you just have pure pipewire for your audio output needs and are not using some audio sink like jamesdsp or easyeffects then, in your kde settingsshortcuts click on add command at the bottom and in the dialog box that opens enter this command

systemctl restart --user pipewire-pulse.socket pipewire.socket wireplumber.service

Click add, then click on add custom shortcut for this command you just added and make a keybind you want.

Or if you have some audio sink like easyeffects it will be easier to do this with a shell script. Eg, create

place the following contents in it.

:warning: Note: Please look at proper command to restart your audio sink. This example only covers easyeffects if you are using jamesdsp or something else look around to find out what’s needed for it to be launched as a daemon.

pkill easyeffects
systemctl restart --user pipewire-pulse.socket pipewire.socket wireplumber.service
easyeffects --gapplication-service

save the script, make it executable

chmod 755

Execute and check it works properly.
Then add a keybind to execute this script without having to open a terminal. goto settingsshortcuts click on add command at bottom and in the dialog box that opens click on choose and select the script we made. Click Add and then create it’s custom shortcut.

Ofcourse, this is all assuming that restarting the audio server is all that you need to do to resolve your issue like me.


Thanks a lot! I have created this shortcut command! I don’t think I’m using easyeffects so next time if something goes wrong I’ll simply hit this meta+r key :smile: . Fingers crossed :crossed_fingers: Thanks a lot for your support!!

Also dealing with a microphone issue. Unable to take teams meeting with laptop hardware. Forced to use Bluetooth headset to use a microphone to respond. Not sure how to resolve that.

Please open new help request and follow the template.

This topic is solved.