Audio Mixmatch

Hello :smiley:
Id love to get some help with fixing my audio issue. Im using kde gaming edition and everything works like a charm. Thanks to the great support provided here, i fell in love with my first linux distro. My issue is, i use an nvidia gpu and i have this audio error everytime i boot up my pc,it gets reset. i use an external speaker. as listed below
https://drive.google.com/file/d/1wM2FpgVc2xK8lqscdhoZswQpoQFDGI_B/view?usp=sharing
the GP106 is the nvidia audio driver thing i guess.
Issue is everytime i turn off and turn on the pc, it turns on GP106 automatically and i have to manually shift to "Family 17th Audo Contorller", there is no option to save the settings.
and also my speakers are connected to motherboard audio jack( behind ).
https://drive.google.com/file/d/1sw19OABeVongy4bKPerMJm-AesDg3OZ9/view?usp=sharing
and also everytime the Headphones go into Line Out mode. I have to change that to Headphones unplugged. Btw my headphones are connected to the speakers.
Any help to disable the GP106 thingy and to fix the line out issue would be highly appriciated
I hope ive given enough info on the issue
Thank You :slight_smile:

Greetings, since nobody replied or helped, i dug deeper and found a fix myself.
I came here to share it as it might be of help to people who got stuck like me. So here goes!

  • As there is no save option for pulse audio menu in settings, we have to manually configure the default loading script of pulse audio. It's fairly simple.

  • Fire up your terminal and type cd /etc/pulse/
    Now edit the default.pa file using editor of your choice,
    search for the line telling load-module module-switch-on-port-available and put a # at the begining of the line to comment it.

  • This stops the auto port switching. Now configure your pulse audio settings (like line out or headphones) and it will remain saved from next boot. And you're Done!! :smiley:
    Hope this helps ,

Happy Browsing!!
Cheers from INDIA :heart:

5 Likes

Thanks for sharing :slight_smile:

MSS Manti2k

5 Likes

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.