Audio issues with PulseAudio, and no audio with PipeWire

install package plasma-pa

This probably means your devices are configured to use the "Pro Audio" profile rather than e.g. "Analog Output". Check your audio device settings.

(The Pro Audio profile is intended for use with hardware mixers etc.)

4 Likes

install package plasma-pa

This brought be back missing audio category, and control.
Thank you!

This probably means your devices are configured to use the "Pro Audio" profile rather than e.g. "Analog Output". Check your audio device settings.

I have nothing called "Pro", but I got the audio on my laptop back on the internal speaker, and trough the jack port.
But I still have the issue when I open certain apps, that break the audio, but I'm still using PulseAudio, I'll try PipeWire. (I'll change on PipeWire trough the System configurator, in the Garuda Assistant.)

2 Likes

After installing PipeWire, I do get audio... only trough the HDMI ports.
It showed some with "Pro" in the settings for the Family 17h HD Audio thing, but when I tried to change it, it disapeared, even after a reboot.

Hi guys,
I have a very similar issue, which I described here along with some system info.

Basically no audio, not even playback devices, only mics.
It suddendly happened when I unplugged my USB headset during a google meet meeting.
If I plug it back I get its mic, but no playback sound :smiley:

Also, running inxi -Faz:

System:
Kernel: 5.16.2-zen1-1-zen x86_64 bits: 64 compiler: gcc v: 11.1.0
parameters: BOOT_IMAGE=/@/boot/vmlinuz-linux-zen
root=UUID=f4a20d63-c4e3-4b28-b0b0-d2b451d0cb18 rw [email protected]
quiet splash rd.udev.log_priority=3 vt.global_cursor_default=0
systemd.unified_cgroup_hierarchy=1
resume=UUID=44001575-ec3e-40c7-adb0-5fd96fe574f7 loglevel=3
Desktop: KDE Plasma 5.23.5 tk: Qt 5.15.2 info: latte-dock wm: kwin_x11
vt: 1 dm: SDDM Distro: Garuda Linux base: Arch Linux
Machine:
Type: Laptop System: Acer product: Aspire A515-52 v: V1.14
serial: <superuser required>
Mobo: WL model: Raticate_WL v: V1.14 serial: <superuser required>
UEFI: Insyde v: 1.14 date: 05/24/2019
Battery:
ID-1: BAT1 charge: 21.9 Wh (63.1%) condition: 34.7/48.9 Wh (71.0%)
volts: 14.8 min: 15.2 model: LG PABAS0241231 type: Li-ion serial: <filter>
status: Discharging
Device-1: hidpp_battery_1 model: Logitech Craft Advanced Keyboard
serial: <filter> charge: 55% (should be ignored) rechargeable: yes
status: Discharging
CPU:
Info: model: Intel Core i7-8565U bits: 64 type: MT MCP arch: Whiskey Lake
family: 6 model-id: 0x8E (142) stepping: 0xB (11) microcode: 0xEA
Topology: cpus: 1x cores: 4 tpc: 2 threads: 8 smt: enabled cache:
L1: 256 KiB desc: d-4x32 KiB; i-4x32 KiB L2: 1024 KiB desc: 4x256 KiB
L3: 8 MiB desc: 1x8 MiB
Speed (MHz): avg: 3572 high: 4027 min/max: 400/4600 scaling:
driver: intel_pstate governor: powersave cores: 1: 4027 2: 3882 3: 3466
4: 3297 5: 3503 6: 3402 7: 3502 8: 3500 bogomips: 31999
Flags: avx avx2 ht lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx
Vulnerabilities:
Type: itlb_multihit status: KVM: VMX disabled
Type: l1tf status: Not affected
Type: mds mitigation: Clear CPU buffers; SMT vulnerable
Type: meltdown status: Not affected
Type: spec_store_bypass
mitigation: Speculative Store Bypass disabled via prctl
Type: spectre_v1
mitigation: usercopy/swapgs barriers and __user pointer sanitization
Type: spectre_v2 mitigation: Full generic retpoline, IBPB: conditional,
IBRS_FW, STIBP: conditional, RSB filling
Type: srbds mitigation: Microcode
Type: tsx_async_abort status: Not affected
Graphics:
Device-1: Intel WhiskeyLake-U GT2 [UHD Graphics 620]
vendor: Acer Incorporated ALI driver: i915 v: kernel bus-ID: 00:02.0
chip-ID: 8086:3ea0 class-ID: 0300
Device-2: Chicony HD User Facing type: USB driver: uvcvideo bus-ID: 1-7:3
chip-ID: 04f2:b64f class-ID: 0e02 serial: <filter>
Display: x11 server: X.Org 1.21.1.3 compositor: kwin_x11 driver:
loaded: modesetting display-ID: :0 screens: 1
Screen-1: 0 s-res: 5760x2160 s-dpi: 96 s-size: 1520x570mm (59.8x22.4")
s-diag: 1623mm (63.9")
Monitor-1: eDP-1 res: 1920x1080 hz: 60 dpi: 142
size: 344x194mm (13.5x7.6") diag: 395mm (15.5")
Monitor-2: HDMI-1 res: 3840x2160 hz: 30 dpi: 122
size: 800x335mm (31.5x13.2") diag: 867mm (34.1")
Message: Unable to show advanced data. Required tool glxinfo missing.
Audio:
Device-1: Intel Cannon Point-LP High Definition Audio
vendor: Acer Incorporated ALI driver: snd_hda_intel v: kernel
alternate: snd_soc_skl,snd_sof_pci_intel_cnl bus-ID: 00:1f.3
chip-ID: 8086:9dc8 class-ID: 0403
Sound Server-1: ALSA v: k5.16.2-zen1-1-zen running: yes
Sound Server-2: PulseAudio v: 15.0 running: no
Sound Server-3: PipeWire v: 0.3.43 running: yes
Network:
Device-1: Intel Cannon Point-LP CNVi [Wireless-AC] driver: iwlwifi
v: kernel bus-ID: 00:14.3 chip-ID: 8086:9df0 class-ID: 0280
IF: wlp0s20f3 state: down mac: <filter>
Device-2: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet
vendor: Acer Incorporated ALI driver: r8169 v: kernel port: 3000
bus-ID: 01:00.1 chip-ID: 10ec:8168 class-ID: 0200
IF: enp1s0f1 state: up speed: 1000 Mbps duplex: full mac: <filter>
IF-ID-1: lxdbrtest0 state: down mac: <filter>
IF-ID-2: minanto state: unknown speed: N/A duplex: N/A mac: N/A
Bluetooth:
Device-1: Intel Bluetooth 9460/9560 Jefferson Peak (JfP) type: USB
driver: btusb v: 0.8 bus-ID: 1-10:7 chip-ID: 8087:0aaa class-ID: e001
Report: bt-adapter ID: hci0 rfk-id: 4 state: up address: <filter>
RAID:
Hardware-1: Intel 82801 Mobile SATA Controller [RAID mode] driver: ahci
v: 3.0 port: 4060 bus-ID: 00:17.0 chip-ID: 8086:282a rev: N/A
class-ID: 0104
Drives:
Local Storage: total: 465.76 GiB used: 80.03 GiB (17.2%)
SMART Message: Unable to run smartctl. Root privileges required.
ID-1: /dev/sda maj-min: 8:0 vendor: Samsung model: SSD 850 EVO 500GB
size: 465.76 GiB block-size: physical: 512 B logical: 512 B speed: 6.0 Gb/s
type: SSD serial: <filter> rev: 2B6Q scheme: GPT
Partition:
ID-1: / raw-size: 448.44 GiB size: 448.44 GiB (100.00%)
used: 80.03 GiB (17.8%) fs: btrfs dev: /dev/sda2 maj-min: 8:2
ID-2: /boot/efi raw-size: 300 MiB size: 299.4 MiB (99.80%)
used: 576 KiB (0.2%) fs: vfat dev: /dev/sda1 maj-min: 8:1
ID-3: /home raw-size: 448.44 GiB size: 448.44 GiB (100.00%)
used: 80.03 GiB (17.8%) fs: btrfs dev: /dev/sda2 maj-min: 8:2
ID-4: /var/log raw-size: 448.44 GiB size: 448.44 GiB (100.00%)
used: 80.03 GiB (17.8%) fs: btrfs dev: /dev/sda2 maj-min: 8:2
ID-5: /var/tmp raw-size: 448.44 GiB size: 448.44 GiB (100.00%)
used: 80.03 GiB (17.8%) fs: btrfs dev: /dev/sda2 maj-min: 8:2
Swap:
Kernel: swappiness: 133 (default 60) cache-pressure: 100 (default)
ID-1: swap-1 type: partition size: 17.02 GiB used: 0 KiB (0.0%)
priority: -2 dev: /dev/sda3 maj-min: 8:3
ID-2: swap-2 type: zram size: 15.48 GiB used: 0 KiB (0.0%) priority: 100
dev: /dev/zram0
Sensors:
System Temperatures: cpu: 56.0 C pch: 56.0 C mobo: N/A
Fan Speeds (RPM): N/A
Info:
Processes: 324 Uptime: 8m wakeups: 34 Memory: 15.48 GiB
used: 4.87 GiB (31.5%) Init: systemd v: 250 tool: systemctl Compilers:
gcc: 11.1.0 clang: 13.0.0 Packages: 1627 pacman: 1617 lib: 377 flatpak: 10
Shell: fish v: 3.3.1 default: Bash v: 5.1.16 running-in: konsole
inxi: 3.3.12

I have a red speaker icon with a red minus sign beside It.
I tried the solutions you recommend here but nothing worked, the only thing left to try is switching from pipewire to pulseaudio. Is it worth trying?