Audio driver chuwi gemibook

Hi,
I installed GARUDA DRAGONIZED on a CHUWY GEMIBOOK GEMI PRO ( a cheap brand. ok )

Everything it's ok except for audio ( and touchpad)

AUDIO says : JASPER LAKE HD AUDIO but not sound at all comes out

I just got sound from USB-C with earphones

BELOW the command you requested

( PULESEAUDIO running : NO ) ?

WHY?

If someone has some ideas and can help me i'll be grateful
THANX in ADVANCE

Alex

System:
Kernel: 6.1.2-zen1-1-zen arch: x86_64 bits: 64 compiler: gcc v: 12.2.0
parameters: BOOT_IMAGE=/@/boot/vmlinuz-linux-zen
root=UUID=9c880935-afbb-4e45-b531-3432852e562b rw [email protected]
quiet quiet splash rd.udev.log_priority=3 vt.global_cursor_default=0
loglevel=3 ibt=off
Desktop: KDE Plasma v: 5.26.4 tk: Qt v: 5.15.7 info: latte-dock
wm: kwin_x11 vt: 1 dm: SDDM Distro: Garuda Linux base: Arch Linux
Machine:
Type: Laptop System: CHUWI Innovation And (ShenZhen)c0.
product: GemiBook Pro v: JS131_V0.18.20 serial: <superuser required>
Mobo: JS131 model: N/A serial: <superuser required> UEFI: American
Megatrends LLC. v: JS131_V0.18.20 date: 10/15/2022
Battery:
ID-1: BAT0 charge: 38.0 Wh (100.0%) condition: 38.0/38.0 Wh (100.0%)
volts: 7.6 min: N/A model: Intel SR 1 SR Real Battery type: Unknown
serial: <filter> status: charging
CPU:
Info: model: Intel Celeron N5100 bits: 64 type: MCP arch: Alder Lake
level: v2 built: 2021+ process: Intel 7 (10nm ESF) family: 6
model-id: 0x9C (156) stepping: 0 microcode: 0x24000023
Topology: cpus: 1x cores: 4 smt: <unsupported> cache: L1: 256 KiB
desc: d-4x32 KiB; i-4x32 KiB L2: 1.5 MiB desc: 1x1.5 MiB L3: 4 MiB
desc: 1x4 MiB
Speed (MHz): avg: 800 min/max: 800/2800 scaling: driver: intel_pstate
governor: powersave cores: 1: 800 2: 800 3: 800 4: 800 bogomips: 8908
Flags: ht lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx
Vulnerabilities: <filter>
Graphics:
Device-1: Intel JasperLake [UHD Graphics] vendor: nCipher Security
driver: i915 v: kernel arch: Gen-11 process: Intel 10nm built: 2019-21
ports: active: eDP-1 empty: DP-1,HDMI-A-1,HDMI-A-2 bus-ID: 00:02.0
chip-ID: 8086:4e61 class-ID: 0300
Device-2: Sunplus Innovation Hy HD Camera type: USB driver: uvcvideo
bus-ID: 1-6:3 chip-ID: 1bcf:2ced class-ID: 0e02
Display: x11 server: X.Org v: 21.1.6 with: Xwayland v: 22.1.7
compositor: kwin_x11 driver: X: loaded: modesetting
alternate: fbdev,intel,vesa dri: iris gpu: i915 display-ID: :0 screens: 1
Screen-1: 0 s-res: 2160x1440 s-dpi: 96 s-size: 571x381mm (22.48x15.00")
s-diag: 686mm (27.03")
Monitor-1: eDP-1 model: BOE Display 0x0893 built: 2019 res: 2160x1440
hz: 60 dpi: 185 gamma: 1.2 size: 296x197mm (11.65x7.76") diag: 356mm (14")
ratio: 3:2 modes: 2160x1440
API: OpenGL v: 4.6 Mesa 22.3.2 renderer: Mesa Intel UHD Graphics (JSL)
direct render: Yes
Audio:
Device-1: Intel Jasper Lake HD Audio driver: sof-audio-pci-intel-icl
alternate: snd_hda_intel,snd_sof_pci_intel_icl bus-ID: 00:1f.3
chip-ID: 8086:4dc8 class-ID: 0401
Sound API: ALSA v: k6.1.2-zen1-1-zen running: yes
Sound Server-1: PulseAudio v: 16.1 running: no
Sound Server-2: PipeWire v: 0.3.63 running: yes
Network:
Device-1: Intel Wi-Fi 6 AX201 160MHz driver: iwlwifi v: kernel
bus-ID: 00:14.3 chip-ID: 8086:4df0 class-ID: 0280
IF: wlo1 state: up mac: <filter>
Device-2: Realtek RTL8153 Gigabit Ethernet Adapter type: USB driver: r8152
bus-ID: 2-4.4:4 chip-ID: 0bda:8153 class-ID: 0000 serial: <filter>
IF: enp0s20f0u4u4 state: down mac: <filter>
Bluetooth:
Device-1: Intel AX201 Bluetooth type: USB driver: btusb v: 0.8 bus-ID: 1-8:6
chip-ID: 8087:0026 class-ID: e001
Report: bt-adapter ID: hci0 rfk-id: 0 state: up address: <filter>
Drives:
Local Storage: total: 253.03 GiB used: 37.53 GiB (14.8%)
SMART Message: Unable to run smartctl. Root privileges required.
ID-1: /dev/sda maj-min: 8:0 model: G521N 256GB size: 238.47 GiB
block-size: physical: 512 B logical: 512 B speed: 6.0 Gb/s type: SSD
serial: <filter> rev: 227I scheme: GPT
ID-2: /dev/sdb maj-min: 8:16 type: USB vendor: SanDisk model: Cruzer Pop
size: 14.56 GiB block-size: physical: 512 B logical: 512 B type: N/A
serial: <filter> rev: 1.27 scheme: MBR
SMART Message: Unknown USB bridge. Flash drive/Unsupported enclosure?
Partition:
ID-1: / raw-size: 106.31 GiB size: 106.31 GiB (100.00%)
used: 37.53 GiB (35.3%) fs: btrfs dev: /dev/sda2 maj-min: 8:2
ID-2: /boot/efi raw-size: 300 MiB size: 299.4 MiB (99.80%)
used: 608 KiB (0.2%) fs: vfat dev: /dev/sda1 maj-min: 8:1
ID-3: /home raw-size: 106.31 GiB size: 106.31 GiB (100.00%)
used: 37.53 GiB (35.3%) fs: btrfs dev: /dev/sda2 maj-min: 8:2
ID-4: /var/log raw-size: 106.31 GiB size: 106.31 GiB (100.00%)
used: 37.53 GiB (35.3%) fs: btrfs dev: /dev/sda2 maj-min: 8:2
ID-5: /var/tmp raw-size: 106.31 GiB size: 106.31 GiB (100.00%)
used: 37.53 GiB (35.3%) fs: btrfs dev: /dev/sda2 maj-min: 8:2
Swap:
Kernel: swappiness: 133 (default 60) cache-pressure: 100 (default)
ID-1: swap-1 type: zram size: 7.5 GiB used: 350.8 MiB (4.6%) priority: 100
dev: /dev/zram0
Sensors:
System Temperatures: cpu: 90.0 C mobo: N/A
Fan Speeds (RPM): N/A
Info:
Processes: 245 Uptime: 23m wakeups: 1 Memory: 7.51 GiB
used: 5.52 GiB (73.6%) Init: systemd v: 252 default: graphical
tool: systemctl Compilers: gcc: 12.2.0 Packages: pm: pacman pkgs: 1300
libs: 348 tools: octopi,paru Shell: fish v: 3.5.1 default: Bash v: 5.1.16
running-in: konsole inxi: 3.3.24
Garuda (2.6.13-1):
System install date:     2022-12-24
Last full system update: 2023-01-03
Is partially upgraded:   No
Relevant software:       snapper NetworkManager mkinitcpio
Windows dual boot:       No/Undetected
Failed units:

Seems to be a known problem with Linux and Jasper Lake audio: Not Search

Let me see if I can find anything useful to make it work.

This is normal, PipeWire is the "main" sound server and PulseAudio is actually the pipewire-pulse compatibility layer.

Meanwhile, would you mind fixing your post a little?
Remove the leftover template (the "Hello Garuda users" stuff) and wrap the terminal output with ~~~ like:

~~~
(garuda-inxi here)
~~~

edit: Intel Jasper Lake HD Audio reports it as functioning since kernel 5.6 :thinking:

3 Likes

yes

it's true it's a known problem

I've to say Garuda only distro that at least recognizes drivers
ubunt gives 'dummy'
THANX

I see this: sound - Dummy Output on Intel Jasper Lake N5100 - elementary OS Stack Exchange
I'm not entirely sure it's applicable but I think so.

2 Likes

i found this post in past days too
ok Manjaro it-s an Arche so it should work even if sincerly I dnidm't undesrtand what I 've to do..

Giving command
sudo tee /etc/modprobe.d/dspcfg.conf <<< 'options snd-intel-dspcfg dsp_driver=1'

I got error:

ish: Expected a string, but found a redirection
sudo tee /etc/modprobe.d/dspcfg.conf <<< 'options snd-intel-dspcfg dsp_driver=1

It-s correct to do it?
thanx

Try

echo "options snd-intel-dspcfg dsp_driver=1" | sudo tee /etc/modprobe.d/dspcfg.conf
1 Like

the command now worked, but at the contrary

Now , no sound card at all

also jasper disappeared ...

Should I restore with

echo "options snd-intel-dspcfg dsp_driver=0" | sudo tee /etc/modprobe.d/dspcfg.conf  

?

this cheap chinese brand at the end just big headache


Should I restore with

echo "options snd-intel-dspcfg dsp_driver=0" | sudo tee /etc/modprobe.d/dspcfg.conf 

?
it was a question..


yes restored at previous situation

audio doesn;'t work as before

I'm reading SOF Project intel_debug but I've yet to find anything specifically about your platform.
Though I see that in SOF Project platforms one device with Jasper is listed, so I guess there's hope.
It all depends on the motherboard and its firmware as far as I can tell.

  • Is there anything about "DSP" (or anything related to audio) in the BIOS configuration?

  • A possible work-around: if you have a Windows (:poop:) try booting it once, just to let their drivers configure the audio chip (source: SOF Project intel_debug suggestions, "A classic example of such issues is when headphone playback works, but speaker playback does not").
    Some "live CD" may or may not do. https://www.hirensbootcd.org/ maybe.

  • Also, looks like it may be worth trying with options snd-intel-dspcfg dsp_driver=3.
    Though I guess it will make no difference (the sof driver is already used).
    If it doesn't work, just revert it as you have done before (+1 for finding out yourself) or remove the file (it was created with the "sudo tee" thing).

Sadly, most hardware is made with Window compatibility in mind and no regard for Linux, and the drivers are closed source so on Linux they have to be rewritten from scratch with a lot of guesswork.


P.S.
I forgot to mention, the above command is for the bash shell, fish does not support most of the bash redirection syntax.

And yes, while (judging by online comments) the Chuwi is a good buy for its price, they cut all possible corners to get that price, leading to headaches like this.

Lastly, if all else fails, I guess you may pair it with a cheapo speaker plugged to the earphone and call it a day. Yeah I know, it sucks.


edit: also look on https://forum.chuwi.com, there's plenty of posts dealing with audio and trackpad on Linux. Although their official statement is "Our products are designed for Microsoft Windows and are based on this operating system. Users are free to install third-party operating systems. However, we are unable to provide technical support for third-party systems" some users do provide solutions.

2 Likes

I haven't checked, but I guess it's possible that a newer kernel may offer better support.

Try installing the linux-mainline kernel as it has the newest kernel improvements.

2 Likes

I tried also it, nothing good

i'm giving up everything...

In any case thanx , at least someone answered me

Is there anything about "DSP" (or anything related to audio) in the BIOS configuration?

.. mm , i Tried something, but non effects

Did you try boot the Windows live CD?
Sounds (pun intended) like that may fix it.

1 Like

the options +3 no effects

if you restart fron windows audio it doesn't work ..

it needs just an iso that chuwy sends to you with theyr windows drive, something really embarassing...

yes you're right it works just with windows closed drivers

NB earphone also doesn't work...

i'm giving up , I hope that this experience could be useful for everybody have the idea to buy this stuff

THANK YOU VERY MUCH FOR YOU EFFORTS TO HELP ME

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.