Audient id4 audio interface profiles off

after update linux-zen 5.19.9-zen1-1 or other kernel 5.19.9
audio interface audient id4 is inactive

in systemsettings audio

inactive cards
audient id4 profiles --> off

garuda-inix
Device-4: Audient iD4 type: USB driver: hid-generic,snd-usb-audio,usbhid
bus-ID: 1-7:6 chip-ID: 2708:0009 class-ID: fe01
Sound Server-1: ALSA v: k5.19.9-zen1-1-zen running: yes
Sound Server-2: PulseAudio v: 16.1 running: no
Sound Server-3: PipeWire v: 0.3.58 running: yes

how to rollback old kernel or correct for new kernel

for rolling back to an old kernel you can use sudo pacman -S linux-zen linux-zen-headers and choose the desired kernel and appropriate headers, and when prompted choose yes to block the kernel from future update.
the best advice will be not to downgrade but to use the linux-lts kerne :innocent:.

report the kernel developers.

1 Like

thank you
linux-lts 5.15.68-1 or other kernel 5.15.68-1
same problem :disappointed_relieved: :disappointed_relieved:

Then try a kernel that was working before, or use a snapshot where the device was working fine.

1 Like

Most of your inxi output is missing somehow; practically no system information is visible. Can you try pasting again?

1 Like

before linux-zen 5.19.9 or lts 5.15.68 it's work
after 5.19.9 or lts 5.15.68 profile --> off
maybe have some change in kernel

garuda-inxi

System:
  Kernel: 5.19.9-zen1-1-zen arch: x86_64 bits: 64 compiler: gcc v: 12.2.0
    parameters: BOOT_IMAGE=/@/boot/vmlinuz-linux-zen
    root=UUID=1a9a0a75-d8c6-46ca-bdfe-b450f1c3fb39 rw [email protected]
    quiet quiet splash rd.udev.log_priority=3 vt.global_cursor_default=0
    loglevel=3
  Desktop: KDE Plasma v: 5.26.80 tk: Qt v: 5.15.6 wm: kwin_x11 vt: 2
    dm: SDDM Distro: Garuda Linux base: Arch Linux
Machine:
  Type: Desktop System: HP product: HP Z240 Tower Workstation v: N/A
    serial: <superuser required> Chassis: type: 3 serial: <superuser required>
  Mobo: HP model: 802F serial: <superuser required> UEFI: HP v: N51 Ver.
    01.83 date: 03/08/2022
CPU:
  Info: model: Intel Core i7-6700 bits: 64 type: MT MCP arch: Skylake-S
    gen: core 6 level: v3 built: 2015 process: Intel 14nm family: 6
    model-id: 0x5E (94) stepping: 3 microcode: 0xF0
  Topology: cpus: 1x cores: 4 tpc: 2 threads: 8 smt: enabled cache:
    L1: 256 KiB desc: d-4x32 KiB; i-4x32 KiB L2: 1024 KiB desc: 4x256 KiB
    L3: 8 MiB desc: 1x8 MiB
  Speed (MHz): avg: 1837 high: 3400 min/max: 800/4000 scaling:
    driver: intel_pstate governor: powersave cores: 1: 900 2: 900 3: 900 4: 900
    5: 3400 6: 3400 7: 897 8: 3400 bogomips: 54398
  Flags: avx avx2 ht lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3
  Vulnerabilities:
  Type: itlb_multihit status: KVM: VMX unsupported
  Type: l1tf mitigation: PTE Inversion
  Type: mds mitigation: Clear CPU buffers; SMT vulnerable
  Type: meltdown mitigation: PTI
  Type: mmio_stale_data mitigation: Clear CPU buffers; SMT vulnerable
  Type: retbleed mitigation: IBRS
  Type: spec_store_bypass mitigation: Speculative Store Bypass disabled via
    prctl
  Type: spectre_v1 mitigation: usercopy/swapgs barriers and __user pointer
    sanitization
  Type: spectre_v2 mitigation: IBRS, IBPB: conditional, RSB filling,
    PBRSB-eIBRS: Not affected
  Type: srbds mitigation: Microcode
  Type: tsx_async_abort mitigation: TSX disabled
Graphics:
  Device-1: NVIDIA GP107GL [Quadro P620] driver: nvidia v: 515.65.01
    alternate: nouveau,nvidia_drm non-free: 515.xx+ status: current (as of
    2022-08) arch: Pascal code: GP10x process: TSMC 16nm built: 2016-21 pcie:
    gen: 3 speed: 8 GT/s lanes: 16 bus-ID: 01:00.0 chip-ID: 10de:1cb6
    class-ID: 0300
  Display: x11 server: X.Org v: 21.1.4 with: Xwayland v: 22.1.3
    compositor: kwin_x11 driver: X: loaded: nvidia unloaded: modesetting
    alternate: fbdev,nouveau,nv,vesa gpu: nvidia display-ID: :0 screens: 1
  Screen-1: 0 s-res: 6486x2160 s-dpi: 80 s-size: 2059x686mm (81.06x27.01")
    s-diag: 2170mm (85.44")
  Monitor-1: DP-4 pos: right res: 3840x2160 hz: 60 dpi: 163
    size: 600x340mm (23.62x13.39") diag: 690mm (27.15") modes: N/A
  Monitor-2: DP-6 pos: primary,left res: 2560x1080 hz: 60 dpi: 81
    size: 798x334mm (31.42x13.15") diag: 865mm (34.06") modes: N/A
  Message: Unable to show GL data. Required tool glxinfo missing.
Audio:
  Device-1: Intel 100 Series/C230 Series Family HD Audio
    vendor: Hewlett-Packard driver: snd_hda_intel bus-ID: 1-2:3 v: kernel
    bus-ID: 00:1f.3 chip-ID: 0b05:17f5 chip-ID: 8086:a170 class-ID: 0300
    class-ID: 0403
  Device-2: NVIDIA GP107GL High Definition Audio driver: snd_hda_intel
    v: kernel pcie: gen: 3 speed: 8 GT/s lanes: 16 bus-ID: 01:00.1
    chip-ID: 10de:0fb9 class-ID: 0403
  Device-3: ASUSTek Xonar U5 sound card type: USB
    driver: hid-generic,snd-usb-audio,usbhid
  Device-4: Audient iD4 type: USB driver: hid-generic,snd-usb-audio,usbhid
    bus-ID: 1-7:6 chip-ID: 2708:0009 class-ID: fe01
  Sound Server-1: ALSA v: k5.19.9-zen1-1-zen running: yes
  Sound Server-2: PulseAudio v: 16.1 running: no
  Sound Server-3: PipeWire v: 0.3.58 running: yes
Network:
  Device-1: Intel Ethernet I219-LM vendor: Hewlett-Packard driver: e1000e
    v: kernel port: N/A bus-ID: 00:1f.6 chip-ID: 8086:15b7 class-ID: 0200
  IF: eno1 state: up speed: 100 Mbps duplex: full mac: <filter>
RAID:
  Hardware-1: Intel SATA Controller [RAID mode] driver: ahci v: 3.0
    port: 4020 bus-ID: 00:17.0 chip-ID: 8086:2822 rev: N/A class-ID: 0104
Drives:
  Local Storage: total: 1.36 TiB used: 46.52 GiB (3.3%)
  SMART Message: Unable to run smartctl. Root privileges required.
  ID-1: /dev/nvme0n1 maj-min: 259:0 vendor: Western Digital
    model: WDS500G3XHC-00SJG0 size: 465.76 GiB block-size: physical: 512 B
    logical: 512 B speed: 31.6 Gb/s lanes: 4 type: SSD serial: <filter>
    rev: 102000WD temp: 44.9 C scheme: GPT
  ID-2: /dev/sda maj-min: 8:0 vendor: Western Digital
    model: WDS500G2B0A-00SM50 size: 465.76 GiB block-size: physical: 512 B
    logical: 512 B speed: 6.0 Gb/s type: SSD serial: <filter> rev: 20WD
    scheme: GPT
  ID-3: /dev/sdb maj-min: 8:16 vendor: Toshiba model: DT01ACA050
    size: 465.76 GiB block-size: physical: 4096 B logical: 512 B
    speed: 6.0 Gb/s type: HDD rpm: 7200 serial: <filter> rev: A800
    scheme: MBR
Partition:
  ID-1: / raw-size: 265.47 GiB size: 265.47 GiB (100.00%) used: 46.52 GiB
    (17.5%) fs: btrfs dev: /dev/nvme0n1p2 maj-min: 259:2
  ID-2: /boot/efi raw-size: 300 MiB size: 299.4 MiB (99.80%) used: 760 KiB
    (0.2%) fs: vfat dev: /dev/nvme0n1p1 maj-min: 259:1
  ID-3: /home raw-size: 265.47 GiB size: 265.47 GiB (100.00%) used: 46.52
    GiB (17.5%) fs: btrfs dev: /dev/nvme0n1p2 maj-min: 259:2
  ID-4: /var/log raw-size: 265.47 GiB size: 265.47 GiB (100.00%) used: 46.52
    GiB (17.5%) fs: btrfs dev: /dev/nvme0n1p2 maj-min: 259:2
  ID-5: /var/tmp raw-size: 265.47 GiB size: 265.47 GiB (100.00%) used: 46.52
    GiB (17.5%) fs: btrfs dev: /dev/nvme0n1p2 maj-min: 259:2
Swap:
  Kernel: swappiness: 133 (default 60) cache-pressure: 100 (default)
  ID-1: swap-1 type: zram size: 31.27 GiB used: 0 KiB (0.0%) priority: 100
    dev: /dev/zram0
Sensors:
  System Temperatures: cpu: 37.0 C pch: 67.5 C mobo: N/A gpu: nvidia
    temp: 54 C
  Fan Speeds (RPM): N/A gpu: nvidia fan: 42%
Info:
  Processes: 246 Uptime: 4m wakeups: 0 Memory: 31.27 GiB used: 2.19 GiB
  (7.0%) Init: systemd v: 251 default: graphical tool: systemctl Compilers:
  gcc: 12.2.0 alt: 11 Packages: pm: pacman pkgs: 1630 libs: 430
  tools: pamac,paru Shell: Bash v: 5.1.16 running-in: konsole inxi: 3.3.21
Garuda (2.6.7.r0.g59d794d-1):
  System install date:     2022-09-22
  Last full system update: 2022-09-22
  Is partially upgraded:   No
  Relevant software:       NetworkManager
  Windows dual boot:       No/Undetected
  Snapshots:               Snapper
  Failed units:

You probably already came across this. Just in case...

To downgrade a package or the kernel
https://wiki.archlinux.org/title/Downgrading_packages#Downgrading_the_kernel
Or use the downgrade command (see Automation in that wiki page).
But also switching, maybe temporarily, to pulseaudio could be an option.

1 Like

I test by install garuda-kde-lite
linux-zen 5.19.7zen2-1 pipewire 3.57 alsa-card-profile 3.57
it's work
after upgrade only linux-zen 5.19.9zen1-1
linux-zen 5.19.9zen1-1 pipewire 3.57 alsa-card-profile 3.57
inactive card audient id4 profile --> off
now I use linux-rt for aviod upgrad kernel

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.