Audacity Audio recording not working

Hi, audacity has never worked but I need it for my job and I would like to have it working on my daily-driver, does anybody know of the issue that I'm having?
image
I always get the same loud static when recording anything at all from any mic. Do you know what I'm doing wrong?
Because I keep getting this error but I'm not quite sure how to resolve this:

22:36:25: Debug: PortAudio stream error creating device list: JACK Audio Connection Kit:Built-in Audio Analog Stereo: Invalid sample rate
22:36:25: Debug: PortAudio stream error creating device list: JACK Audio Connection Kit:easyeffects_filter: Invalid sample rate
22:36:25: Debug: PortAudio stream error creating device list: JACK Audio Connection Kit:spotify: Invalid sample rate
22:36:25: Debug: PortAudio stream error creating device list: JACK Audio Connection Kit:Built-in Audio Analog Stereo Monitor: Invalid sample rate
22:36:25: Debug: PortAudio stream error creating device list: JACK Audio Connection Kit:HDA NVidia Digital Stereo (HDMI) Monitor: Invalid sample rate
22:36:25: Debug: PortAudio stream error creating device list: JACK Audio Connection Kit:JamesDSP Sink Monitor: Invalid sample rate

Also, garuda-inxi:

System:
  Kernel: 5.18.5-zen1-1-zen arch: x86_64 bits: 64 compiler: gcc v: 12.1.0
    parameters: BOOT_IMAGE=/@/boot/vmlinuz-linux-zen
    root=UUID=5411b7ff-d53c-4780-9b50-82a7b4183826 rw [email protected]
    quiet splash rd.udev.log_priority=3 vt.global_cursor_default=0 loglevel=3
    ibt=off
  Desktop: KDE Plasma v: 5.25.1 tk: Qt v: 5.15.5 info: latte-dock
    wm: kwin_x11 vt: 1 dm: SDDM Distro: Garuda Linux base: Arch Linux
Machine:
  Type: Laptop System: Acer product: Nitro AN515-57 v: V1.10
    serial: <superuser required>
  Mobo: TGL model: Scala_TLS v: V1.10 serial: <superuser required>
    UEFI: Insyde v: 1.10 date: 09/19/2021
Battery:
  ID-1: BAT1 charge: 24.1 Wh (42.9%) condition: 56.2/57.5 Wh (97.8%)
    volts: 14.9 min: 15.4 model: LGC AP18E8M type: Li-ion serial: <filter>
    status: discharging cycles: 202
  Device-1: hidpp_battery_0 model: Logitech Wireless Mouse serial: <filter>
    charge: 5% (should be ignored) rechargeable: yes status: discharging
CPU:
  Info: model: 11th Gen Intel Core i7-11800H bits: 64 type: MT MCP
    arch: Tiger Lake gen: core 11 built: 2020 process: Intel 10nm family: 6
    model-id: 0x8D (141) stepping: 1 microcode: 0x3E
  Topology: cpus: 1x cores: 8 tpc: 2 threads: 16 smt: enabled cache:
    L1: 640 KiB desc: d-8x48 KiB; i-8x32 KiB L2: 10 MiB desc: 8x1.2 MiB
    L3: 24 MiB desc: 1x24 MiB
  Speed (MHz): avg: 1237 high: 2977 min/max: 800/4600 scaling:
    driver: intel_pstate governor: powersave cores: 1: 933 2: 1072 3: 984
    4: 1584 5: 1327 6: 801 7: 801 8: 1340 9: 1552 10: 1168 11: 1022 12: 840
    13: 2977 14: 788 15: 1614 16: 1001 bogomips: 73728
  Flags: avx avx2 ht lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx
  Vulnerabilities:
  Type: itlb_multihit status: Not affected
  Type: l1tf status: Not affected
  Type: mds status: Not affected
  Type: meltdown status: Not affected
  Type: mmio_stale_data status: Not affected
  Type: spec_store_bypass
    mitigation: Speculative Store Bypass disabled via prctl
  Type: spectre_v1
    mitigation: usercopy/swapgs barriers and __user pointer sanitization
  Type: spectre_v2
    mitigation: Enhanced IBRS, IBPB: conditional, RSB filling
  Type: srbds status: Not affected
  Type: tsx_async_abort status: Not affected
Graphics:
  Device-1: Intel TigerLake-H GT1 [UHD Graphics]
    vendor: Acer Incorporated ALI driver: i915 v: kernel arch: Gen12.1
    process: Intel 10nm built: 2020-21 ports: active: eDP-1 empty: DP-1,DP-2
    bus-ID: 0000:00:02.0 chip-ID: 8086:9a60 class-ID: 0300
  Device-2: NVIDIA GA107M [GeForce RTX 3050 Mobile]
    vendor: Acer Incorporated ALI driver: nvidia v: 515.48.07
    alternate: nouveau,nvidia_drm non-free: 515.xx+
    status: current (as of 2022-06) arch: Ampere process: TSMC n7 (7nm)
    built: 2020-22 bus-ID: 0000:01:00.0 chip-ID: 10de:25a2 class-ID: 0300
  Device-3: Quanta HD User Facing type: USB driver: uvcvideo bus-ID: 3-9:3
    chip-ID: 0408:a061 class-ID: 0e02
  Display: x11 server: X.Org v: 21.1.3 with: Xwayland v: 22.1.2
    compositor: kwin_x11 driver: X: loaded: intel,nvidia
    unloaded: modesetting,nouveau,vesa alternate: fbdev,nv gpu: i915
    display-ID: :0 screens: 1
  Screen-1: 0 s-res: 3840x1080 s-dpi: 96 s-size: 1013x285mm (39.88x11.22")
    s-diag: 1052mm (41.43")
  Monitor-1: HDMI-1-0 pos: primary,right res: 1920x1080 dpi: 81
    size: 600x340mm (23.62x13.39") diag: 690mm (27.15") modes: N/A
  Monitor-2: eDP1 pos: primary,left res: 1920x1080 hz: 144 dpi: 143
    size: 340x190mm (13.39x7.48") diag: 389mm (15.33") modes: N/A
  OpenGL: renderer: Mesa Intel UHD Graphics (TGL GT1) v: 4.6 Mesa 22.1.2
    direct render: Yes
Audio:
  Device-1: Intel Tiger Lake-H HD Audio driver: snd_hda_intel v: kernel
    alternate: snd_sof_pci_intel_tgl bus-ID: 0000:00:1f.3 chip-ID: 8086:43c8
    class-ID: 0403
  Device-2: NVIDIA vendor: Acer Incorporated ALI driver: snd_hda_intel
    v: kernel bus-ID: 0000:01:00.1 chip-ID: 10de:2291 class-ID: 0403
  Sound Server-1: ALSA v: k5.18.5-zen1-1-zen running: yes
  Sound Server-2: sndio v: N/A running: no
  Sound Server-3: PulseAudio v: 16.1 running: no
  Sound Server-4: PipeWire v: 0.3.52 running: yes
Network:
  Device-1: Intel Tiger Lake PCH CNVi WiFi vendor: Rivet Networks
    driver: iwlwifi v: kernel bus-ID: 0000:00:14.3 chip-ID: 8086:43f0
    class-ID: 0280
  IF: wlp0s20f3 state: up mac: <filter>
  Device-2: Realtek vendor: Acer Incorporated ALI driver: r8169 v: kernel
    port: 3000 bus-ID: 0000:2c:00.0 chip-ID: 10ec:2600 class-ID: 0200
  IF: enp44s0 state: down mac: <filter>
Bluetooth:
  Device-1: Intel AX201 Bluetooth type: USB driver: btusb v: 0.8
    bus-ID: 3-14:4 chip-ID: 8087:0026 class-ID: e001
  Report: bt-adapter ID: hci0 rfk-id: 3 state: up address: <filter>
RAID:
  Hardware-1: Intel Volume Management Device NVMe RAID Controller driver: vmd
    v: 0.6 port: N/A bus-ID: 0000:00:0e.0 chip-ID: 8086:9a0b rev:
    class-ID: 0104
Drives:
  Local Storage: total: 2.29 TiB used: 1.05 TiB (46.1%)
  SMART Message: Unable to run smartctl. Root privileges required.
  ID-1: /dev/nvme0n1 maj-min: 259:0 vendor: SK Hynix model: HFM512GD3JX016N
    size: 476.94 GiB block-size: physical: 512 B logical: 512 B
    speed: 31.6 Gb/s lanes: 4 type: SSD serial: <filter> rev: 41020C20
    temp: 43.9 C scheme: GPT
  ID-2: /dev/sda maj-min: 8:0 vendor: Samsung model: SSD 870 QVO 2TB
    size: 1.82 TiB block-size: physical: 512 B logical: 512 B speed: 6.0 Gb/s
    type: SSD serial: <filter> rev: 2B6Q scheme: MBR
Partition:
  ID-1: / raw-size: 297.4 GiB size: 297.4 GiB (100.00%)
    used: 242.64 GiB (81.6%) fs: btrfs dev: /dev/nvme0n1p4 maj-min: 259:4
  ID-2: /boot/efi raw-size: 100 MiB size: 96 MiB (96.00%)
    used: 50.5 MiB (52.6%) fs: vfat dev: /dev/nvme0n1p1 maj-min: 259:1
  ID-3: /home raw-size: 297.4 GiB size: 297.4 GiB (100.00%)
    used: 242.64 GiB (81.6%) fs: btrfs dev: /dev/nvme0n1p4 maj-min: 259:4
  ID-4: /var/log raw-size: 297.4 GiB size: 297.4 GiB (100.00%)
    used: 242.64 GiB (81.6%) fs: btrfs dev: /dev/nvme0n1p4 maj-min: 259:4
  ID-5: /var/tmp raw-size: 297.4 GiB size: 297.4 GiB (100.00%)
    used: 242.64 GiB (81.6%) fs: btrfs dev: /dev/nvme0n1p4 maj-min: 259:4
Swap:
  Kernel: swappiness: 133 (default 60) cache-pressure: 100 (default)
  ID-1: swap-1 type: zram size: 15.41 GiB used: 0 KiB (0.0%) priority: 100
    dev: /dev/zram0
Sensors:
  System Temperatures: cpu: 27.8 C mobo: N/A
  Fan Speeds (RPM): N/A
Info:
  Processes: 366 Uptime: 14m wakeups: 4 Memory: 15.41 GiB
  used: 4.32 GiB (28.1%) Init: systemd v: 251 default: graphical
  tool: systemctl Compilers: gcc: 12.1.0 clang: 13.0.1 Packages: pacman: 2055
  lib: 529 Shell: Bash v: 5.1.16 running-in: terminator inxi: 3.3.18
Garuda (2.6.4-1):
  System install date:     2022-02-16
  Last full system update: 2022-06-22
  Is partially upgraded:   No
  Relevant software:       NetworkManager
  Windows dual boot:       Probably (Run as root to verify)
  Snapshots:               Snapper
  Failed units:       

The wiki gets a little dense here, but if you manage to stick with it this page describes how to change the sample rate in PipeWire: PipeWire - ArchWiki

4 Likes

The issue still persists but sample rate is no longer the problem

lilv_world_add_plugin(): warning: Duplicate plugin <http://lv2plug.in/plugins/eg-amp>
lilv_world_add_plugin(): warning: ... found in file:///usr/lib64/lv2/eg-amp.lv2/
lilv_world_add_plugin(): warning: ... and      file:///usr/lib/lv2/eg-amp.lv2/ (ignored)
lilv_world_add_plugin(): warning: Duplicate plugin <http://lv2plug.in/plugins/eg-fifths>
lilv_world_add_plugin(): warning: ... found in file:///usr/lib64/lv2/eg-fifths.lv2/
lilv_world_add_plugin(): warning: ... and      file:///usr/lib/lv2/eg-fifths.lv2/ (ignored)
lilv_world_add_plugin(): warning: Duplicate plugin <http://lv2plug.in/plugins/eg-metro>
lilv_world_add_plugin(): warning: ... found in file:///usr/lib64/lv2/eg-metro.lv2/
lilv_world_add_plugin(): warning: ... and      file:///usr/lib/lv2/eg-metro.lv2/ (ignored)
lilv_world_add_plugin(): warning: Duplicate plugin <http://lv2plug.in/plugins/eg-midigate>
lilv_world_add_plugin(): warning: ... found in file:///usr/lib64/lv2/eg-midigate.lv2/
lilv_world_add_plugin(): warning: ... and      file:///usr/lib/lv2/eg-midigate.lv2/ (ignored)
lilv_world_add_plugin(): warning: Duplicate plugin <http://lv2plug.in/plugins/eg-params>
lilv_world_add_plugin(): warning: ... found in file:///usr/lib64/lv2/eg-params.lv2/
lilv_world_add_plugin(): warning: ... and      file:///usr/lib/lv2/eg-params.lv2/ (ignored)
lilv_world_add_plugin(): warning: Duplicate plugin <http://lv2plug.in/plugins/eg-sampler>
lilv_world_add_plugin(): warning: ... found in file:///usr/lib64/lv2/eg-sampler.lv2/
lilv_world_add_plugin(): warning: ... and      file:///usr/lib/lv2/eg-sampler.lv2/ (ignored)
lilv_world_add_plugin(): warning: Duplicate plugin <http://lv2plug.in/plugins/eg-scope#Mono>
lilv_world_add_plugin(): warning: ... found in file:///usr/lib64/lv2/eg-scope.lv2/
lilv_world_add_plugin(): warning: ... and      file:///usr/lib/lv2/eg-scope.lv2/ (ignored)
lilv_world_add_plugin(): warning: Duplicate plugin <http://lv2plug.in/plugins/eg-scope#Stereo>
lilv_world_add_plugin(): warning: ... found in file:///usr/lib64/lv2/eg-scope.lv2/
lilv_world_add_plugin(): warning: ... and      file:///usr/lib/lv2/eg-scope.lv2/ (ignored)
lilv_world_add_plugin(): warning: Duplicate plugin <http://vital.audio>
lilv_world_add_plugin(): warning: ... found in file:///usr/lib64/lv2/Vital.lv2/
lilv_world_add_plugin(): warning: ... and      file:///usr/lib/lv2/Vital.lv2/ (ignored)
ALSA lib pcm.c:2664:(snd_pcm_open_noupdate) Unknown PCM cards.pcm.rear
ALSA lib pcm.c:2664:(snd_pcm_open_noupdate) Unknown PCM cards.pcm.center_lfe
ALSA lib pcm.c:2664:(snd_pcm_open_noupdate) Unknown PCM cards.pcm.side
ALSA lib pcm_route.c:877:(find_matching_chmap) Found no matching channel map
ALSA lib pcm_route.c:877:(find_matching_chmap) Found no matching channel map
ALSA lib pcm_route.c:877:(find_matching_chmap) Found no matching channel map
ALSA lib pcm_route.c:877:(find_matching_chmap) Found no matching channel map
ALSA lib pcm_oss.c:397:(_snd_pcm_oss_open) Cannot open device /dev/dsp
ALSA lib pcm_oss.c:397:(_snd_pcm_oss_open) Cannot open device /dev/dsp
ALSA lib pcm_a52.c:1001:(_snd_pcm_a52_open) a52 is only for playback
ALSA lib confmisc.c:160:(snd_config_get_card) Invalid field card
ALSA lib pcm_usb_stream.c:482:(_snd_pcm_usb_stream_open) Invalid card 'card'
ALSA lib confmisc.c:160:(snd_config_get_card) Invalid field card
ALSA lib pcm_usb_stream.c:482:(_snd_pcm_usb_stream_open) Invalid card 'card'
14:58:13: Debug: ScreenToClient cannot work when toplevel window is not shown
14:58:13: Debug: ScreenToClient cannot work when toplevel window is not shown
14:58:13: Debug: ScreenToClient cannot work when toplevel window is not shown
14:58:13: Debug: ScreenToClient cannot work when toplevel window is not shown
14:58:13: Debug: ScreenToClient cannot work when toplevel window is not shown
14:58:13: Debug: ScreenToClient cannot work when toplevel window is not shown
14:58:13: Debug: ScreenToClient cannot work when toplevel window is not shown
14:58:13: Debug: ScreenToClient cannot work when toplevel window is not shown
14:58:13: Debug: ScreenToClient cannot work when toplevel window is not shown
14:58:13: Debug: ScreenToClient cannot work when toplevel window is not shown
14:58:13: Debug: ScreenToClient cannot work when toplevel window is not shown
14:58:13: Debug: ScreenToClient cannot work when toplevel window is not shown
14:58:13: Debug: ScreenToClient cannot work when toplevel window is not shown
14:58:13: Debug: ScreenToClient cannot work when toplevel window is not shown
14:58:13: Debug: ScreenToClient cannot work when toplevel window is not shown
14:58:13: Debug: ScreenToClient cannot work when toplevel window is not shown
14:58:13: Debug: ScreenToClient cannot work when toplevel window is not shown
14:58:13: Debug: ScreenToClient cannot work when toplevel window is not shown
14:58:13: Debug: ScreenToClient cannot work when toplevel window is not shown
14:58:13: Debug: ScreenToClient cannot work when toplevel window is not shown
14:58:13: Debug: ScreenToClient cannot work when toplevel window is not shown
14:58:13: Debug: ScreenToClient cannot work when toplevel window is not shown
14:58:13: Debug: ScreenToClient cannot work when toplevel window is not shown
14:58:13: Debug: ScreenToClient cannot work when toplevel window is not shown
14:58:13: Debug: ScreenToClient cannot work when toplevel window is not shown
14:58:13: Debug: ScreenToClient cannot work when toplevel window is not shown
14:58:13: Debug: ScreenToClient cannot work when toplevel window is not shown
14:58:13: Debug: ClientToScreen cannot work when toplevel window is not shown
14:58:13: Debug: ClientToScreen cannot work when toplevel window is not shown
14:58:13: Debug: ClientToScreen cannot work when toplevel window is not shown
14:58:13: Debug: ClientToScreen cannot work when toplevel window is not shown
14:58:13: Debug: ClientToScreen cannot work when toplevel window is not shown
14:58:13: Debug: ClientToScreen cannot work when toplevel window is not shown
14:58:13: Debug: ClientToScreen cannot work when toplevel window is not shown
14:58:13: Debug: ClientToScreen cannot work when toplevel window is not shown
14:58:13: Debug: ClientToScreen cannot work when toplevel window is not shown
14:58:13: Debug: Warning: command doesn't exist: 'Cut'
14:58:13: Debug: Warning: command doesn't exist: 'Copy'
14:58:13: Debug: Warning: command doesn't exist: 'Paste'
14:58:13: Debug: Warning: command doesn't exist: 'Trim'
14:58:13: Debug: Warning: command doesn't exist: 'Silence'
14:58:13: Debug: Warning: command doesn't exist: 'Undo'
14:58:13: Debug: Warning: command doesn't exist: 'Redo'
14:58:13: Debug: Warning: command doesn't exist: 'ZoomIn'
14:58:13: Debug: Warning: command doesn't exist: 'ZoomOut'
14:58:13: Debug: Warning: command doesn't exist: 'ZoomToggle'
14:58:13: Debug: Warning: command doesn't exist: 'ZoomSel'
14:58:13: Debug: Warning: command doesn't exist: 'FitInWindow'
14:58:13: Debug: ClientToScreen cannot work when toplevel window is not shown
14:58:13: Debug: ClientToScreen cannot work when toplevel window is not shown
14:58:13: Debug: ClientToScreen cannot work when toplevel window is not shown
14:58:13: Debug: ClientToScreen cannot work when toplevel window is not shown
14:58:13: Debug: ClientToScreen cannot work when toplevel window is not shown
14:58:13: Debug: ClientToScreen cannot work when toplevel window is not shown
14:58:13: Debug: ClientToScreen cannot work when toplevel window is not shown
14:58:13: Debug: ClientToScreen cannot work when toplevel window is not shown
14:58:13: Debug: ClientToScreen cannot work when toplevel window is not shown
14:58:13: Debug: "Left" must use modifiers to be used as a keyboard accelerator with GTK
14:58:13: Debug: "Right" must use modifiers to be used as a keyboard accelerator with GTK
14:58:13: Debug: "Up" must use modifiers to be used as a keyboard accelerator with GTK
14:58:13: Debug: "Down" must use modifiers to be used as a keyboard accelerator with GTK
14:58:13: Debug: Unrecognized accel key 'NUMPAD_ENTER', accel string ignored.
14:58:13: Debug: "Left" must use modifiers to be used as a keyboard accelerator with GTK
14:58:13: Debug: "Right" must use modifiers to be used as a keyboard accelerator with GTK
14:58:16: Debug: AudioIO::GetBestRate() for capture
14:58:16: Debug: GetBestRate() suggested rate 44100 Hz
14:58:17: Debug: GetBestRate() Returning 44100 Hz

This is not an issue with audacity I don't think because Discord has the same issue, but only more recently