ASUS AC1200 USB-AC53 Nano Adapter not working

Hi, I’m newer to Garuda and can’t get my wireless adapter working (ASUS AC1200 USB-AC53 Nano). They are no officially supported drivers for Linux but I also can’t seem to make the windows drivers work through ndiswrapper. (I assume just because the device is newer).

Running Kernel 5.11.1 on the most updated version of Garuda dragonized.

If anyone knows any drivers out for this or ways to get ndis to accept the drivers that would be great.

I also do have access to the internet on the system via dragging it 10 feet from the router but would prefer not to sit on the floor next to it for the rest of its use

Try installing this driver from the Chaotic AUR:

rtl88x2bu-dkms-git

Welcome to Garuda.

4 Likes

Thank you, do I need to add these drivers to a specific folder or config file? I downloaded/installed them like any AUR package and I’m just trying to make sure that it’s not something on my end before I go try and scout out new drivers

The package is in the ChaoticAUR repository so you can install them like any standard package. You can use the AUR package if you want. But, once installed, that should be it.

If something isn't working then post details, steps, and output.

2 Likes

I installed the package like normal,

git clone https://aur.archlinux.org/packages/rtl88x2bu-dkms-git/
cd rtl88x2bu-dkms-git
makepkg -si

Package installed with no failures.
my output from ipLink is

lo: <LOOPBACK,UP,LOWER_UP> mtu 65536 qdisc noqueue state UNKNOWN mode DEFAULT group default qlen 1000
link/loopback 00:00:00:00:00:00 brd 00:00:00:00:00:00
2: enp5s0: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc fq_codel state UP mode DEFAULT group default qlen 1000
link/ether a8:a1:59:49:2f:57 brd ff:ff:ff:ff:ff:ff
3: wlp2s0f0u2: <NO-CARRIER,BROADCAST,MULTICAST,UP> mtu 1500 qdisc mq state DOWN mode DORMANT group default qlen 1000
link/ether 22:fc:0d:d6:74:3a brd ff:ff:ff:ff:ff:ff permaddr a8:5e:45:ee:c7:18

My outputs from lsusb

Bus 004 Device 001: ID 1d6b:0003 Linux Foundation 3.0 root hub
Bus 003 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 002 Device 001: ID 1d6b:0003 Linux Foundation 3.0 root hub
Bus 001 Device 002: ID 0b05:184c ASUSTek Computer, Inc. 802.11ac NIC
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub

If there is any other output you guys would like or would make troubleshooting easier let me know.

1 Like

Wow. Someone who actually calls normal the Arch normal. :star_struck: :grin:

So, check:

  1. dkms status to make sure the module is installed;

  2. inxi -Nxxxz to make sure it's the correct package for the chipset;

  3. rfkill list to make sure the wifi card is available (i.e. not "blocked").

3 Likes
  1. dkms status gives me no output, i also tried
    dkms rtl88x2bu-dkms-git/ status
    and also got no output.
  2. inxi -Nxxxz outputs
v: kernel port: f000 bus ID: 05:00.0 chip ID: 10ec:8168 class ID: 0200
Device-2: ASUSTek 802.11ac NIC type: USB driver: rtl88x2bu bus ID: 1-2:2 chip ID: 0b05:184c
class ID: 0000 serial: <filter>
  1. rfkill list outputs
0: phy0: Wireless LAN
Soft blocked: no
Hard blocked: no

So from what I can see nothings being blocked, I am not sure if I properly used dkms but I cant get any output from it regardless.

Weird. What do you get from dkms autoinstall ?

1 Like

dkms autoinstall gives me

Your kernel headers for kernel 5.11.1-zen1-1-zen cannot be found at
/usr/lib/modules/5.11.1-zen1-1-zen/build or /usr/lib/modules/5.11.1-zen1-1-zen/source.
You can use the --kernelsourcedir option to tell DKMS where it's located.

sorry if some of this troubleshooting seems basic, I have done a few pure arch installs but this is the first time I have tried to daily an arch platform.

1 Like

OK, make sure that you have the base development tools and kernel headers installed, then try again:

sudo pacman -Syu base-devel linux-zen-headers --needed
sudo dkms autoinstall

I suspect headers is all that's needed.

3 Likes

That got me to the point where connections are now showing up, but now it is getting stuck in a weird loop where it can't authenticate.

Just to rule out transitory issues, remove the connection, reboot, re-add the connection.

1 Like

I take that back, just took a few more attempts at the handshake for it to auth. Thank you so much! I can now finally stop sitting on the floor.

2 Likes

Just reboot :stuck_out_tongue_winking_eye:

That won't help if it's Network Manager being weird. :wink:

1 Like

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.