Are all linux kernel versions uniform? (steering wheel trouble)

hey

im new to linux
got everything running after few days

except my steering wheel(g923 trueforce(xbox/pc) )
it isn,t detected by oversteer
but it does show when i run dmesg

{397.575048] usb 5-2: new full-speed USB device number 7 using xhci_hcd
[  397.740084] usb 5-2: New USB device found, idVendor=046d, idProduct=c26d, bcdDevice=39.01
[  397.740087] usb 5-2: New USB device strings: Mfr=1, Product=2, SerialNumber=3
[  397.740088] usb 5-2: Product: G923 Racing Wheel for Xbox One and PC
[  397.740089] usb 5-2: Manufacturer: Logitech
[  397.740090] usb 5-2: SerialNumber: 00007b8a5505faa8
[  636.850670] BTRFS info: devid 1 device path /dev/disk/by-uuid/c977e049-2932-49d5-b727-a143f329dd33 changed to /dev/nvme0n1p2 scanned by mount (27195)
[ 3614.945182] usb 5-2: USB disconnect, device number 7}

oversteer mentions it being supported by a in-kernal hidpp after a patch would be upstreamed
but no clear conformation can be found on that

after a lot of time i found this
[GIT PULL] HID for 6.3 — Linux Kernel

which mentions it for 6.3

the zen kernel (which i run) shows 6.3.3.zen1-1
is that the same as the linux 6.3 version?

i mean maby cus it already shows it is connected

but then i am completly stuck on why it won,t work
should i not be looking toward oversteer due to this hidpp thingy ?

am i missing something here ??
i would love any advice on it

much love
Sky

I'm not a specialist, but if they were all the same, there would only be one kernel.

Much more important for us as

would be if you would follow the template and post your garuda-inxi.

Ending posts with your name is neither necessary, it is already next to your post, nor desirable. :slight_smile:

ah my bad sorry bout that
it was not my intention

i do it right

i hope this is more proper

  1. The issue
    my steering wheel (g923 trueforce(xbox/pc) is not working
    oversteer does not reconise it and games do not see it

  2. Attempts to solve it
    i reinstalled oversteer
    reinstalled hidapi
    installed linux lts and linux kernel
    have done a lot of searching for a way to get it working
    i tried new-lg4ff but it wasn,t for this wheel
    read on oversteer github that there was a patch for it waiting
    found patch note aka pull request
    tried steam controller settings
    tried to find device in garuda game controllers (it was not there )
    tried to find oversteer alternative on opticy but no luck

  3. System information

System:
Kernel: 6.3.3-zen1-1-zen arch: x86_64 bits: 64 compiler: gcc v: 13.1.1
parameters: BOOT_IMAGE=/@/boot/vmlinuz-linux-zen
root=UUID=c977e049-2932-49d5-b727-a143f329dd33 rw [email protected]
quiet quiet splash rd.udev.log_priority=3 vt.global_cursor_default=0
loglevel=3 ibt=off
Desktop: KDE Plasma v: 5.27.5 tk: Qt v: 5.15.9 wm: kwin_x11 dm: SDDM
Distro: Garuda Linux base: Arch Linux
Machine:
Type: Desktop System: Gigabyte product: X570S AORUS ELITE AX v: -CF
serial: N/A
Mobo: Gigabyte model: X570S AORUS ELITE AX v: x.x serial: N/A
UEFI: American Megatrends LLC. v: F6b date: 03/23/2023
CPU:
Info: model: AMD Ryzen 7 5800X3D socket: AM4 bits: 64 type: MT MCP
arch: Zen 3+ gen: 4 level: v3 note: check built: 2022 process: TSMC n6 (7nm)
family: 0x19 (25) model-id: 0x21 (33) stepping: 2 microcode: 0xA20120A
Topology: cpus: 1x cores: 8 tpc: 2 threads: 16 smt: enabled cache:
L1: 512 KiB desc: d-8x32 KiB; i-8x32 KiB L2: 4 MiB desc: 8x512 KiB
L3: 96 MiB desc: 1x96 MiB
Speed (MHz): avg: 3665 high: 4450 min/max: N/A base/boost: 3400/3400
volts: 1.1 V ext-clock: 100 MHz cores: 1: 3574 2: 3597 3: 3602 4: 3584
5: 3597 6: 3600 7: 3599 8: 3799 9: 3559 10: 3597 11: 3644 12: 3594
13: 3597 14: 3848 15: 4450 16: 3400 bogomips: 108798
Flags: avx avx2 ht lm nx pae sse sse2 sse3 sse4_1 sse4_2 sse4a ssse3 svm
Vulnerabilities: <filter>
Graphics:
Device-1: NVIDIA GA102 [GeForce RTX 3080 Lite Hash Rate] vendor: PNY
driver: nvidia v: 530.41.03 alternate: nouveau,nvidia_drm non-free: 530.xx+
status: current (as of 2023-05) arch: Ampere code: GAxxx
process: TSMC n7 (7nm) built: 2020-22 pcie: gen: 4 speed: 16 GT/s
lanes: 16 bus-ID: 0a:00.0 chip-ID: 10de:2216 class-ID: 0300
Display: x11 server: X.Org v: 21.1.8 with: Xwayland v: 23.1.1
compositor: kwin_x11 driver: X: loaded: nvidia gpu: nvidia display-ID: :0
screens: 1
Screen-1: 0 s-res: 2560x1440 s-dpi: 92 s-size: 707x402mm (27.83x15.83")
s-diag: 813mm (32.02")
Monitor-1: DP-0 res: 2560x1440 hz: 144 dpi: 93
size: 698x393mm (27.48x15.47") diag: 801mm (31.54") modes: N/A
API: OpenGL v: 4.6.0 NVIDIA 530.41.03 renderer: NVIDIA GeForce RTX
3080/PCIe/SSE2 direct-render: Yes
Audio:
Device-1: NVIDIA GA102 High Definition Audio vendor: PNY
driver: snd_hda_intel v: kernel pcie: gen: 4 speed: 16 GT/s lanes: 16
bus-ID: 0a:00.1 chip-ID: 10de:1aef class-ID: 0403
Device-2: AMD Starship/Matisse HD Audio vendor: Gigabyte
driver: snd_hda_intel v: kernel pcie: gen: 4 speed: 16 GT/s lanes: 16
bus-ID: 0c:00.4 chip-ID: 1022:1487 class-ID: 0403
Device-3: Corsair VOID PRO Wireless Gaming Headset
driver: hid-generic,snd-usb-audio,usbhid type: USB rev: 1.1 speed: 12 Mb/s
lanes: 1 mode: 1.1 bus-ID: 3-3.3:5 chip-ID: 1b1c:0a1a class-ID: 0300
API: ALSA v: k6.3.3-zen1-1-zen status: kernel-api with: aoss
type: oss-emulator tools: N/A
Server-1: PipeWire v: 0.3.71 status: n/a (root, process) with:
1: pipewire-pulse status: active 2: wireplumber status: active
3: pipewire-alsa type: plugin 4: pw-jack type: plugin
tools: pactl,pw-cat,pw-cli,wpctl
Network:
Device-1: Realtek RTL8125 2.5GbE vendor: Gigabyte driver: r8169 v: kernel
pcie: gen: 2 speed: 5 GT/s lanes: 1 port: f000 bus-ID: 05:00.0
chip-ID: 10ec:8125 class-ID: 0200
IF: enp5s0 state: up speed: 1000 Mbps duplex: full mac: <filter>
Device-2: MEDIATEK MT7921K Wi-Fi 6E 80MHz driver: mt7921e v: kernel pcie:
gen: 2 speed: 5 GT/s lanes: 1 bus-ID: 06:00.0 chip-ID: 14c3:0608
class-ID: 0280
IF: wlp6s0 state: down mac: <filter>
Bluetooth:
Device-1: MediaTek Wireless_Device driver: btusb v: 0.8 type: USB rev: 2.1
speed: 480 Mb/s lanes: 1 mode: 2.0 bus-ID: 5-5:2 chip-ID: 0e8d:0608
class-ID: e001 serial: <filter>
Report: bt-adapter ID: hci0 rfk-id: 0 state: down
bt-service: enabled,running rfk-block: hardware: no software: yes
address: <filter>
Drives:
Local Storage: total: 2.73 TiB used: 524.71 GiB (18.8%)
ID-1: /dev/nvme0n1 maj-min: 259:0 vendor: Samsung model: SSD 980 PRO 1TB
size: 931.51 GiB block-size: physical: 512 B logical: 512 B speed: 63.2 Gb/s
lanes: 4 tech: SSD serial: <filter> fw-rev: 5B2QGXA7 temp: 38.9 C
scheme: GPT
SMART: yes health: PASSED on: 51d 4h cycles: 399
read-units: 13,878,673 [7.10 TB] written-units: 29,198,436 [14.9 TB]
ID-2: /dev/sda maj-min: 8:0 vendor: Western Digital
model: WD2003FZEX-00SRLA0 family: Black size: 1.82 TiB block-size:
physical: 4096 B logical: 512 B sata: 3.1 speed: 6.0 Gb/s tech: HDD
rpm: 7200 serial: <filter> fw-rev: 1A01 temp: 37 C scheme: GPT
SMART: yes state: enabled health: PASSED on: 1y 174d 6h cycles: 2692
Partition:
ID-1: / raw-size: 931.22 GiB size: 931.22 GiB (100.00%)
used: 147.31 GiB (15.8%) fs: btrfs block-size: 4096 B dev: /dev/nvme0n1p2
maj-min: 259:2
ID-2: /boot/efi raw-size: 300 MiB size: 299.4 MiB (99.80%)
used: 576 KiB (0.2%) fs: vfat block-size: 512 B dev: /dev/nvme0n1p1
maj-min: 259:1
ID-3: /home raw-size: 931.22 GiB size: 931.22 GiB (100.00%)
used: 147.31 GiB (15.8%) fs: btrfs block-size: 4096 B dev: /dev/nvme0n1p2
maj-min: 259:2
ID-4: /var/log raw-size: 931.22 GiB size: 931.22 GiB (100.00%)
used: 147.31 GiB (15.8%) fs: btrfs block-size: 4096 B dev: /dev/nvme0n1p2
maj-min: 259:2
ID-5: /var/tmp raw-size: 931.22 GiB size: 931.22 GiB (100.00%)
used: 147.31 GiB (15.8%) fs: btrfs block-size: 4096 B dev: /dev/nvme0n1p2
maj-min: 259:2
Swap:
Kernel: swappiness: 133 (default 60) cache-pressure: 100 (default)
ID-1: swap-1 type: zram size: 31.24 GiB used: 2.5 MiB (0.0%) priority: 100
dev: /dev/zram0
Sensors:
System Temperatures: cpu: 52.9 C mobo: N/A gpu: nvidia temp: 38 C
Fan Speeds (RPM): N/A gpu: nvidia fan: 35%
Info:
Processes: 423 Uptime: 2h 42m wakeups: 0 Memory: available: 31.24 GiB
used: 6.48 GiB (20.8%) Init: systemd v: 253 default: graphical
tool: systemctl Compilers: gcc: 13.1.1 Packages: pm: pacman pkgs: 1763
libs: 542 tools: octopi,paru Shell: garuda-inxi (sudo) default: Bash
v: 5.1.16 running-in: konsole inxi: 3.3.27
Garuda (2.6.16-1):
System install date:     2023-05-23
Last full system update: 2023-05-24
Is partially upgraded:   No
Relevant software:       snapper NetworkManager dracut nvidia-dkms
Windows dual boot:       No/Undetected
Failed units:

sorry bout the 50 edits had some trouble there

Apologies if this is a dumb question, but did you actually boot the LTS kernel? Installing it doesn't have any effect on its own, you have to select the kernel from the advanced boot options of the Grub menu.

2 Likes

This minute...

linux 6.3.4
linux-zen 6.3.4
linux-lts 6.1.30

2 Likes