Archlinux-appstream-data-pamac and archlinux-appstream-data are in conflict

looking for conflicting packages...
:: archlinux-appstream-data-pamac and archlinux-appstream-data are in conflict. Remove archlinux-appstream-data? [y/N] N
error: unresolvable package conflicts detected
error: failed to prepare transaction (conflicting dependencies)
:: archlinux-appstream-data-pamac and archlinux-appstream-data are in conflict

Result INXI:

System:    Kernel: 5.10.42-1-lts x86_64 bits: 64 compiler: gcc v: 11.1.0 
parameters: BOOT_IMAGE=/@/boot/vmlinuz-linux-lts root=UUID=017f6204-0483-4365-a104-5c12b37f9938 
rw [email protected] quiet splash rd.udev.log_priority=3 vt.global_cursor_default=0 
systemd.unified_cgroup_hierarchy=1 loglevel=3 
Desktop: KDE Plasma 5.21.5 tk: Qt 5.15.2 info: latte-dock wm: kwin_x11 vt: 1 dm: SDDM 
Distro: Garuda Linux base: Arch Linux 
Machine:   Type: Portable System: Dell product: Inspiron 5735 v: A02 serial: <filter> Chassis: type: 8 
v: A02 serial: <filter> 
Mobo: Dell model: 04VD0G v: A00 serial: <filter> UEFI: Dell v: A02 date: 08/23/2016 
Battery:   ID-1: BAT1 charge: 19.7 Wh (100.0%) condition: 19.7/66.6 Wh (29.6%) volts: 12.7 min: 11.1 
model: LGC DELL 0MF693AA type: Li-ion serial: <filter> status: Full 
CPU:       Info: Quad Core model: AMD A8-5545M APU with Radeon HD Graphics bits: 64 type: MCP 
arch: Piledriver family: 15 (21) model-id: 13 (19) stepping: 1 microcode: 6001119 cache: 
L2: 2 MiB 
flags: avx lm nx pae sse sse2 sse3 sse4_1 sse4_2 sse4a ssse3 svm bogomips: 13574 
Speed: 1552 MHz min/max: 1100/1700 MHz boost: enabled Core speeds (MHz): 1: 1552 2: 1540 
3: 1497 4: 1404 
Vulnerabilities: Type: itlb_multihit status: Not affected 
Type: l1tf status: Not affected 
Type: mds status: Not affected 
Type: meltdown status: Not affected 
Type: spec_store_bypass mitigation: Speculative Store Bypass disabled via prctl and seccomp 
Type: spectre_v1 mitigation: usercopy/swapgs barriers and __user pointer sanitization 
Type: spectre_v2 mitigation: Full AMD retpoline, STIBP: disabled, RSB filling 
Type: srbds status: Not affected 
Type: tsx_async_abort status: Not affected 
Graphics:  Device-1: AMD Richland [Radeon HD 8510G] vendor: Dell driver: radeon v: kernel bus-ID: 00:01.0 
chip-ID: 1002:9999 class-ID: 0300 
Device-2: Suyin Laptop_Integrated_Webcam_HD type: USB driver: uvcvideo bus-ID: 2-5:3 
chip-ID: 064e:812e class-ID: 0e02 
Display: x11 server: X.Org 1.20.11 compositor: kwin_x11 driver: loaded: ati,radeon 
unloaded: modesetting alternate: fbdev,vesa display-ID: :0 screens: 1 
Screen-1: 0 s-res: 1600x900 s-dpi: 96 s-size: 423x238mm (16.7x9.4") s-diag: 485mm (19.1") 
Monitor-1: eDP res: 1600x900 hz: 60 dpi: 106 size: 382x215mm (15.0x8.5") diag: 438mm (17.3") 
OpenGL: renderer: AMD ARUBA (DRM 2.50.0 / 5.10.42-1-lts LLVM 11.1.0) v: 4.3 Mesa 21.1.1 
compat-v: 3.1 direct render: Yes 
Audio:     Device-1: AMD Trinity HDMI Audio vendor: Dell driver: snd_hda_intel v: kernel bus-ID: 00:01.1 
chip-ID: 1002:9902 class-ID: 0403 
Device-2: AMD FCH Azalia vendor: Dell driver: snd_hda_intel v: kernel bus-ID: 00:14.2 
chip-ID: 1022:780d class-ID: 0403 
Sound Server-1: ALSA v: k5.10.42-1-lts running: yes 
Sound Server-2: JACK v: 0.125.0 running: no 
Sound Server-3: PulseAudio v: 14.2 running: no 
Sound Server-4: PipeWire v: 0.3.29 running: yes 
Network:   Device-1: Realtek RTL810xE PCI Express Fast Ethernet vendor: Dell driver: r8169 v: kernel 
port: 2000 bus-ID: 01:00.0 chip-ID: 10ec:8136 class-ID: 0200 
IF: enp1s0 state: down mac: <filter> 
Device-2: Qualcomm Atheros QCA9565 / AR9565 Wireless Network Adapter vendor: Dell driver: ath9k 
v: kernel port: 2000 bus-ID: 02:00.0 chip-ID: 168c:0036 class-ID: 0280 
IF: wlp2s0 state: up mac: <filter> 
Bluetooth: Device-1: Qualcomm Atheros AR9462 Bluetooth type: USB driver: btusb v: 0.8 bus-ID: 3-2:7 
chip-ID: 0cf3:0036 class-ID: e001 
Report: bt-adapter ID: hci0 rfk-id: 4 state: down bt-service: enabled,running rfk-block: 
hardware: no software: yes address: <filter> 
Drives:    Local Storage: total: 298.09 GiB used: 87.14 GiB (29.2%) 
SMART Message: Unable to run smartctl. Root privileges required. 
ID-1: /dev/sda maj-min: 8:0 vendor: Hitachi model: HTS545032B9A300 size: 298.09 GiB block-size:
physical: 512 B logical: 512 B speed: 3.0 Gb/s rotation: 5400 rpm serial: <filter> rev: C60F
scheme: GPT
Partition: ID-1: / raw-size: 75 GiB size: 75 GiB (100.00%) used: 18.73 GiB (25.0%) fs: btrfs
dev: /dev/sda1 maj-min: 8:1
ID-2: /boot/efi raw-size: 1024 MiB size: 1022 MiB (99.80%) used: 560 KiB (0.1%) fs: vfat
dev: /dev/sda3 maj-min: 8:3
ID-3: /home raw-size: 210.09 GiB size: 209.98 GiB (99.95%) used: 68.41 GiB (32.6%) fs: xfs
dev: /dev/sda4 maj-min: 8:4
ID-4: /var/log raw-size: 75 GiB size: 75 GiB (100.00%) used: 18.73 GiB (25.0%) fs: btrfs
dev: /dev/sda1 maj-min: 8:1
ID-5: /var/tmp raw-size: 75 GiB size: 75 GiB (100.00%) used: 18.73 GiB (25.0%) fs: btrfs
dev: /dev/sda1 maj-min: 8:1
Swap:      Kernel: swappiness: 10 (default 60) cache-pressure: 75 (default 100)
ID-1: swap-1 type: partition size: 12 GiB used: 0 KiB (0.0%) priority: -2 dev: /dev/sda2
maj-min: 8:2
ID-2: swap-2 type: zram size: 1.74 GiB used: 26.6 MiB (1.5%) priority: 32767 dev: /dev/zram0
ID-3: swap-3 type: zram size: 1.74 GiB used: 26.5 MiB (1.5%) priority: 32767 dev: /dev/zram1
ID-4: swap-4 type: zram size: 1.74 GiB used: 26.5 MiB (1.5%) priority: 32767 dev: /dev/zram2
ID-5: swap-5 type: zram size: 1.74 GiB used: 26.6 MiB (1.5%) priority: 32767 dev: /dev/zram3
Sensors:   System Temperatures: cpu: 56.5 C mobo: N/A gpu: radeon temp: 55.0 C
Fan Speeds (RPM): cpu: 3200
Info:      Processes: 225 Uptime: 7d 9h 07m wakeups: 3 Memory: 6.97 GiB used: 4.25 GiB (61.0%)
Init: systemd v: 248 tool: systemctl Compilers: gcc: 11.1.0 clang: 11.1.0 Packages:
pacman: 1434 lib: 356 Shell: fish v: 3.2.2 running-in: konsole inxi: 3.3.04

After that whole -- resent -- pacman issue, I was finally able to update my system; so I thought.

After fixing my pacman.conf file with pacman issue, I started to update (pacman -Syu); but a ALSA LIB conflict came up; enabling multi-lib in pacman.conf resolved that.

As Steam uses a 32-bit library for ALSA, I enabled using "multi-lib" in my pacman.conf file; resolved.

Then this error came up: "archlinux-appstream-data-pamac and archlinux-appstream-data are in conflict"; as posted above...

After resolving the pacman and ALSA lib issue, I still can't update my system.

Searching Arch and Garuda forums were not helpful, nor was searching the internet. The only thing I found were bug reports, general information about appstream-data, and other not-helpful stuff.

I found this thread here on the Garuda forums, but doesn't seem to address the concern I'm having.
(1) Add / Remove software doesn't show anything
(2) FIXED Pamac (Add/Remove Software) does not launch

Other than bug reports (non-relevant), or AUR pages regarding appstream; I haven't found anything useful.

Any suggestions?


Uhm, this is actually meant to be this way - archlinux-appstream-data was replaced by archlinux-appstream-data-pamac for pamac-aur depends to get the "Browse" tab working. :slight_smile:
Also added this to the FIXED banner so nobody else has to search for it :wink:


Thanks for the update! @dr460nf1r3

Downloading 91 updates... :wink: yay

1 Like

You may want to add (for newbies like me), that you need to enable chaotic-aur in pacman.conf (as described here) to see the new pamac.
pamac by default uses aur, but pacman isn't if you don't update pacman.conf...

1 Like

I think you mean, as described in a dozen(s) of posts detailing how to update pacman.conf since this whole update catastrophe for the search impaired began. Anyone with the most rudimentary of search skills should have no problem finding the endless posts regarding how to update the pacman.conf file.

I'm beginning to wonder how all the countless new users managed to find out about Garuda to install it in the first place, as that must have involved some degree of searching online. How is it that all these new users have managed to find out about Garuda, yet once Garuda is installed the search capacity has been mysteriously removed from all their devices.

Learn to search people.


F***ing distrowatch. . . .


Number 11 with a bang! buddy. :smiley:


I just clicked it for you. Gotta break the top 10 and really bring the sheep to the yard!


See? I told you there were such a thing as stupid questions.

I propose a simple test to join. Something they'd be forced to reference the Garuda or Arch wikis to answer. If they answer correctly, they've proven they can search and allowed to join but with the stipulation they must read and inculcate the Help Vampire guide.

It wouldn't be the first forum to do something.


Arch does that to join their forum, and verify you are actually using Arch. . . . Put a hidden key in the install - use terminal - with a command they had to search for on the forum.

Then they can join.

1 Like

Show me the add-on/plugin (or source-code) for this forum software, please :slight_smile:



1 Like

Yeah we skip chat , but we mean test before you got a member in this forum .

IIRC :smiley:


Are you bored?
Be happy if nothing is going on in the forum.
You could devote yourself to other things ... Oh no, let's leave that ...

Just made fun :grinning_face_with_smiling_eyes:


I don't even want to, thats already the thing I love doing in my free time ! :grin:


I also keep the forum tab open all the time, hoping something will happen :slightly_smiling_face:

Edit: Before I forget it again: respect for your performance. Not just here.
And thanks for the Firedragon as it is!


Doing the same, just in case :stuck_out_tongue:

Thanks I guess :relaxed: I'm just very happy that I can contribute something which gets used by peopled in the spirit of open source rather than just doing it for myself only :slight_smile:


You are honored to be selflessly providing useful things to the public.
Not just you alone. Everyone who works on the Garuda project omits good vibrations, including the odd one from Canada and the scratchy one from Hellas.
All give good vibrations. Thank you for everything.


As in any good family, the characters balance each other out.


You put it really nicely :+1: