Apps randomly lagging

Hi there, another random issue for me today. Lately for the past week or two I've been having problems with my system where certain apps will randomly start to lag completely out of the blue. This usually happens to Firefox and Firedragon fairly regularly, which is often fixed by resetting them, but it sometimes affects Steam as well as the Latte dock from time to time, thus making navigating quite the pain. The lag usually starts happening whenever I use picture-in-picture or if I open the calendar at the top right in the dock, but it seems to just be random when it happens. Every other app works without a hitch as far as I can tell and I still have tons of system resources to spare so I'm quite stumped right now.

I was hoping if anyone else who's experienced these issues might know how to solve this as I'm very certain it was caused by one of my system updates and is likely a KDE issue, after hearing how buggy it's recent release has been, but I don't quite know where to start. Would changing my kernel help alleviate this problem? Or is there an easier solution that doesn't require rejigging the system?

System:
Kernel: 5.18.12-zen1-1-zen arch: x86_64 bits: 64 compiler: gcc v: 12.1.0
parameters: BOOT_IMAGE=/@/boot/vmlinuz-linux-zen
root=UUID=b359195e-7f80-4045-8f69-cfa2953add39 rw [email protected]
quiet quiet splash rd.udev.log_priority=3 vt.global_cursor_default=0
loglevel=3
Desktop: KDE Plasma v: 5.25.3 tk: Qt v: 5.15.5 info: latte-dock
wm: kwin_x11 vt: 1 dm: SDDM Distro: Garuda Linux base: Arch Linux
Machine:
Type: Desktop System: Tactus product: Custom v: N/A
serial: <superuser required>
Mobo: ASUSTeK model: ROG STRIX X570-E GAMING WIFI II v: Rev X.0x
serial: <superuser required> UEFI: American Megatrends v: 4101
date: 09/10/2021
Battery:
Device-1: hidpp_battery_0
model: Logitech G305 Lightspeed Wireless Gaming Mouse serial: <filter>
charge: 100% (should be ignored) rechargeable: yes status: discharging
CPU:
Info: model: AMD Ryzen 9 5900X bits: 64 type: MT MCP arch: Zen 3 gen: 4
built: 2021-22 process: TSMC n7 (7nm) family: 0x19 (25) model-id: 0x21 (33)
stepping: 2 microcode: 0xA201204
Topology: cpus: 1x cores: 12 tpc: 2 threads: 24 smt: enabled cache:
L1: 768 KiB desc: d-12x32 KiB; i-12x32 KiB L2: 6 MiB desc: 12x512 KiB
L3: 64 MiB desc: 2x32 MiB
Speed (MHz): avg: 3899 high: 3900 min/max: 2200/3900 boost: disabled
scaling: driver: acpi-cpufreq governor: performance cores: 1: 3900 2: 3900
3: 3900 4: 3900 5: 3898 6: 3900 7: 3900 8: 3900 9: 3897 10: 3899 11: 3899
12: 3899 13: 3900 14: 3900 15: 3900 16: 3900 17: 3900 18: 3900 19: 3900
20: 3900 21: 3898 22: 3900 23: 3900 24: 3900 bogomips: 187212
Flags: avx avx2 ht lm nx pae sse sse2 sse3 sse4_1 sse4_2 sse4a ssse3 svm
Vulnerabilities:
Type: itlb_multihit status: Not affected
Type: l1tf status: Not affected
Type: mds status: Not affected
Type: meltdown status: Not affected
Type: mmio_stale_data status: Not affected
Type: spec_store_bypass
mitigation: Speculative Store Bypass disabled via prctl
Type: spectre_v1
mitigation: usercopy/swapgs barriers and __user pointer sanitization
Type: spectre_v2 mitigation: Retpolines, IBPB: conditional, IBRS_FW,
STIBP: always-on, RSB filling
Type: srbds status: Not affected
Type: tsx_async_abort status: Not affected
Graphics:
Device-1: AMD Navi 21 [Radeon RX 6800/6800 XT / 6900 XT] vendor: Gigabyte
driver: amdgpu v: kernel arch: RDNA 2 process: TSMC n7 (7nm) built: 2020-22
pcie: gen: 4 speed: 16 GT/s lanes: 16 ports: active: HDMI-A-2 off: DP-2
empty: DP-1,HDMI-A-1 bus-ID: 0c:00.0 chip-ID: 1002:73bf class-ID: 0300
Device-2: Valve 3D Camera type: USB driver: uvcvideo bus-ID: 2-1.1:3
chip-ID: 28de:2400 class-ID: 0e02 serial: <filter>
Display: x11 server: X.Org v: 21.1.4 with: Xwayland v: 22.1.3
compositor: kwin_x11 driver: X: loaded: amdgpu unloaded: modesetting,radeon
alternate: fbdev,vesa gpu: amdgpu display-ID: :0 screens: 1
Screen-1: 0 s-res: 1920x1080 s-dpi: 96 s-size: 508x285mm (20.00x11.22")
s-diag: 582mm (22.93")
Monitor-1: HDMI-A-1 res: 1920x1080 hz: 60 dpi: 82
size: 598x336mm (23.54x13.23") diag: 686mm (27.01") modes: N/A
OpenGL: renderer: AMD Radeon RX 6800 XT (sienna_cichlid LLVM 14.0.6 DRM
3.46 5.18.12-zen1-1-zen)
v: 4.6 Mesa 22.1.3 direct render: Yes
Audio:
Device-1: AMD Navi 21/23 HDMI/DP Audio driver: snd_hda_intel v: kernel
bus-ID: 1-1.3.2:8 pcie: gen: 4 chip-ID: 28de:2102 speed: 16 GT/s
class-ID: 0a00 serial: <filter> lanes: 16 bus-ID: 0c:00.1
chip-ID: 1002:ab28 class-ID: 0403
Device-2: AMD Starship/Matisse HD Audio vendor: ASUSTeK
driver: snd_hda_intel v: kernel pcie: gen: 4 speed: 16 GT/s lanes: 16
bus-ID: 0e:00.4 chip-ID: 1022:1487 class-ID: 0403
Device-3: Valve VR Radio type: USB driver: cdc_acm,hid-generic,usbhid
Device-4: Valve VR Radio & HMD Mic type: USB
driver: hid-generic,snd-usb-audio,usbhid bus-ID: 1-1.3.3:11
chip-ID: 28de:2102 class-ID: 0102 serial: <filter>
Device-5: RODE Microphones NT-USB type: USB
driver: hid-generic,snd-usb-audio,usbhid bus-ID: 1-3:3 chip-ID: 19f7:0003
class-ID: 0300
Sound Server-1: ALSA v: k5.18.12-zen1-1-zen running: yes
Sound Server-2: PulseAudio v: 16.1 running: no
Sound Server-3: PipeWire v: 0.3.55 running: yes
Network:
Device-1: MEDIATEK MT7921K Wi-Fi 6E 80MHz driver: mt7921e v: kernel pcie:
gen: 2 speed: 5 GT/s lanes: 1 bus-ID: 04:00.0 chip-ID: 14c3:0608
class-ID: 0280
IF: wlp4s0 state: up mac: <filter>
Device-2: Realtek RTL8125 2.5GbE vendor: ASUSTeK driver: r8169 v: kernel
pcie: gen: 2 speed: 5 GT/s lanes: 1 port: e000 bus-ID: 05:00.0
chip-ID: 10ec:8125 class-ID: 0200
IF: enp5s0 state: down mac: <filter>
Device-3: Intel I211 Gigabit Network vendor: ASUSTeK driver: igb
v: kernel pcie: gen: 1 speed: 2.5 GT/s lanes: 1 port: d000 bus-ID: 06:00.0
chip-ID: 8086:1539 class-ID: 0200
IF: enp6s0 state: up speed: 100 Mbps duplex: full mac: <filter>
Bluetooth:
Device-1: MediaTek Wireless_Device type: USB driver: btusb v: 0.8
bus-ID: 1-6:9 chip-ID: 0e8d:0608 class-ID: e001 serial: <filter>
Report: bt-adapter ID: hci0 rfk-id: 0 state: up address: <filter>
Drives:
Local Storage: total: 8.19 TiB used: 2.96 TiB (36.1%)
SMART Message: Unable to run smartctl. Root privileges required.
ID-1: /dev/nvme0n1 maj-min: 259:0 vendor: Seagate
model: FireCuda 530 ZP1000GM30013 size: 931.51 GiB block-size:
physical: 512 B logical: 512 B speed: 63.2 Gb/s lanes: 4 type: SSD
serial: <filter> rev: SU6SM001 temp: 50.9 C scheme: GPT
ID-2: /dev/sda maj-min: 8:0 vendor: Samsung model: SSD 870 QVO 2TB
size: 1.82 TiB block-size: physical: 512 B logical: 512 B speed: 6.0 Gb/s
type: SSD serial: <filter> rev: 2B6Q
ID-3: /dev/sdb maj-min: 8:16 vendor: Seagate model: ST2000DM008-2FR102
size: 1.82 TiB block-size: physical: 4096 B logical: 512 B speed: 6.0 Gb/s
type: HDD rpm: 7200 serial: <filter> rev: 0001
ID-4: /dev/sdc maj-min: 8:32 vendor: Seagate model: ST4000NE001-2MA101
size: 3.64 TiB block-size: physical: 4096 B logical: 512 B speed: 6.0 Gb/s
type: HDD rpm: 7200 serial: <filter> rev: EN01
Partition:
ID-1: / raw-size: 931.22 GiB size: 931.22 GiB (100.00%)
used: 453.76 GiB (48.7%) fs: btrfs dev: /dev/nvme0n1p2 maj-min: 259:2
ID-2: /boot/efi raw-size: 300 MiB size: 299.4 MiB (99.80%)
used: 576 KiB (0.2%) fs: vfat dev: /dev/nvme0n1p1 maj-min: 259:1
ID-3: /home raw-size: 931.22 GiB size: 931.22 GiB (100.00%)
used: 453.76 GiB (48.7%) fs: btrfs dev: /dev/nvme0n1p2 maj-min: 259:2
ID-4: /var/log raw-size: 931.22 GiB size: 931.22 GiB (100.00%)
used: 453.76 GiB (48.7%) fs: btrfs dev: /dev/nvme0n1p2 maj-min: 259:2
ID-5: /var/tmp raw-size: 931.22 GiB size: 931.22 GiB (100.00%)
used: 453.76 GiB (48.7%) fs: btrfs dev: /dev/nvme0n1p2 maj-min: 259:2
Swap:
Kernel: swappiness: 133 (default 60) cache-pressure: 100 (default)
ID-1: swap-1 type: zram size: 62.71 GiB used: 2.5 MiB (0.0%)
priority: 100 dev: /dev/zram0
Sensors:
System Temperatures: cpu: N/A mobo: N/A gpu: amdgpu temp: 62.0 C
mem: 62.0 C
Fan Speeds (RPM): N/A gpu: amdgpu fan: 0
Info:
Processes: 477 Uptime: 1d 12h 4m wakeups: 66 Memory: 62.71 GiB
used: 9.06 GiB (14.4%) Init: systemd v: 251 default: graphical
tool: systemctl Compilers: gcc: 12.1.0 clang: 14.0.6 Packages: pacman: 1965
lib: 555 Shell: fish v: 3.4.1 default: Bash v: 5.1.16 running-in: konsole
inxi: 3.3.19
Garuda (2.6.5-1):
System install date:     2022-04-15
Last full system update: 2022-07-18 ↻
Is partially upgraded:   No
Relevant software:       NetworkManager
Windows dual boot:       No/Undetected
Snapshots:               Snapper
Failed units:

Your inxi shows you haven't rebooted since your previous update. Have you tried simply rebooting since these problems started?

2 Likes

That's odd, I've actually logged out and rebooted my system a couple of times since my last update this morning. But I have tried rebooting several times after previous updates and nothing's really changed. So it's safe to say that hasn't solved my issue unfortunately.

image

Check your temps, check BIOS update, check GPU power cable, use htop in terminal.
Did you change some hardware last time?

It's a server? :slight_smile:

Did you OC the GPU/CPU?

Edit:
At least, enough PSU power?

2 Likes

Temps are fine, I'm rendering a video now and it's only hit 72C for my CPU while my GPU sits at 55C, which isn't bad at all with me being in a heatwave at the moment. GPU power cable seems perfectly fine, but as for BIOS, I'm not quite sure how to update that.

No hardware changes, it's still the same setup ever since I first installed Garuda and no it's not a server, it's my daily PC for gaming, work and general computer use. And no overclocking neither. My PSU is a Corsair RM850 80 PLUS Gold 850W PSU, which I've had no issues with as far as I can tell.

One issue I can think of is my monitor, which is a ten year old BenQ GW2760 27 inch and it seems to cause tearing and stuttering, especially in games. Its speakers also seems to have audio problems with pipewire, often having a slight static effect for a brief split second when playing a video and also has a delayed "pop" at times when changing volume with a key press, which doesn't appear to affect my headphones. I plan to change that out really soon but I was wondering if a monitor can be the cause of lagging a system? If not then is there a way to reset software like KDE and Latte to their default settings, if that will help fix these issues?

Easy on ASUS :slight_smile:

Check if it is your model than Ez Update in BIOS.
https://www.asus.com/de/SupportOnly/ROG%20STRIX%20X570-E%20GAMING%20WIFI%20II/HelpDesk_BIOS/

IDK, too.
Apart from the delay, everything seems to be in order.

With my one-year-old system, the separate power plug on the GPU has already come loose twice, for whatever reason. A red light then flashes like crazy on the graphics card. Unplugging and plugging it in again solved the problem.
I don't know if it's the same with AMD, with the indicator light. You should possibly check all the plug connections and, if possible, reconnect/replace the HDMI/display port cable.

1 Like

Ahhh thank you for the link, I'll have a look at that for sure :slight_smile:

Well if my monitor solves a lot more than just stuttering and tearing, I'll certainly try to relay that here for everyone! I can certainly try to unplug and replug for sure as my machine is due for a cleanout regardless, though I'm not sure if it would be the GPU as games still run perfectly fine in terms of framerates, but it never hurts to try a bunch of different things of course.

If none of that works, should I try the "reinstall all packages" in the Garuda Assistance menu? If you have any other things I can try then I'd appreciate you letting me know :slight_smile:

Restore configs, you mean?
Did you change things? :slight_smile:

I never saw a restore configs setting but I assume reinstall all packages is the same thing right? Or is that just reinstalling software but keeping those old configs? I'm very unsure as a Linux noob haha.

And not really, I only played around with compositor settings to get it just right for my display and only have a few things installed like Firefox, Brave, OBS and that's about it. Otherwise I just had everything I needed out of the box with the Dr460nized gaming edition ISO :+1: Haven't tinkered much beyond that.

No.

Big difference between restore settings and install all packages again.

I had a feeling that would be the case, well if I continue to run into issues with all the previous suggestions then I'll certainly try that restore settings section for sure :+1: