Appimage WriteorDie terminated by signal SIGSEGV (Address boundary error)

Im trying to run this app:
https://writeordie.com/

i download the appimage and im getting this error:
fish: Job 1, './writeordie3-3.0.6-x86_64.AppI…' terminated by signal SIGSEGV (Address boundary error)

what can i do to fix it?
Thanks.

Please always follow the template and post your garuda-inxi.

What is this horror website?
Closed source? I can’t even find the app image :rofl:

This forum is not a general tech support forum.

Please ask the developer for help.

1 Like

https://transactions.sendowl.com/orders/133132213/download/8695afd9fa6a0a8e40304a4b02924578

garuda-inxi
System:
  Kernel: 6.5.3-zen1-1-zen arch: x86_64 bits: 64 compiler: gcc v: 13.2.1
    clocksource: tsc available: acpi_pm
    parameters: BOOT_IMAGE=/@/boot/vmlinuz-linux-zen
    root=UUID=a3aaae26-ab38-4149-85a1-09c9afda9c1e rw rootflags=subvol=@
    rd.udev.log_priority=3 vt.global_cursor_default=0 loglevel=3 ibt=off
  Desktop: GNOME v: 44.5 tk: GTK v: 3.24.38 wm: gnome-shell dm: GDM v: 44.1
    Distro: Garuda Linux base: Arch Linux
Machine:
  Type: Laptop System: EXO S.A. product: EXO Smart XQ3h v: N/A
    serial: <superuser required>
  Mobo: EXO S.A. model: CT15Q5-S serial: <superuser required> UEFI: WEIBU
    v: YHSM-BI-15.6-XU133TR120-TA60B-328-C date: 11/23/2021
Battery:
  ID-1: BAT0 charge: 10.9 Wh (23.9%) condition: 45.6/45.6 Wh (100.0%)
    power: 17.1 W volts: 8.1 min: N/A model: WB SR 1 WB Lion Battery
    type: Li-ion serial: <filter> status: charging
CPU:
  Info: model: 11th Gen Intel Core i3-1115G4 bits: 64 type: MT MCP
    arch: Tiger Lake gen: core 11 level: v4 note: check built: 2020
    process: Intel 10nm family: 6 model-id: 0x8C (140) stepping: 1
    microcode: 0xAC
  Topology: cpus: 1x cores: 2 tpc: 2 threads: 4 smt: enabled cache:
    L1: 160 KiB desc: d-2x48 KiB; i-2x32 KiB L2: 2.5 MiB desc: 2x1.2 MiB
    L3: 6 MiB desc: 1x6 MiB
  Speed (MHz): avg: 1687 high: 2475 min/max: 400/4100 scaling:
    driver: intel_pstate governor: powersave cores: 1: 1498 2: 2475 3: 2375
    4: 400 bogomips: 23961
  Flags: avx avx2 ht lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx
  Vulnerabilities: <filter>
Graphics:
  Device-1: Intel Tiger Lake-LP GT2 [UHD Graphics G4] driver: i915 v: kernel
    arch: Gen-12.1 process: Intel 10nm built: 2020-21 ports: active: eDP-1
    empty: DP-1,HDMI-A-1 bus-ID: 00:02.0 chip-ID: 8086:9a78 class-ID: 0300
  Device-2: Sunplus Innovation Hy-UXGA-Camera driver: uvcvideo type: USB
    rev: 2.0 speed: 480 Mb/s lanes: 1 mode: 2.0 bus-ID: 3-7:4 chip-ID: 1bcf:2ced
    class-ID: 0e02
  Display: wayland server: X.org v: 1.21.1.8 with: Xwayland v: 23.2.1
    compositor: gnome-shell driver: X: loaded: modesetting
    alternate: fbdev,intel,vesa dri: iris gpu: i915 display-ID: 0
  Monitor-1: eDP-1 model-id: STA 0xafc9 built: 2020 res: 1920x1080 dpi: 142
    gamma: 1.2 size: 344x194mm (13.54x7.64") diag: 395mm (15.5") ratio: 16:9
    modes: 1920x1080
  API: EGL v: 1.5 hw: drv: intel iris platforms: device: 0 drv: iris
    device: 1 drv: swrast surfaceless: drv: iris wayland: drv: iris x11:
    drv: iris inactive: gbm
  API: OpenGL v: 4.6 compat-v: 4.5 vendor: intel mesa v: 23.2.1-arch1.1
    glx-v: 1.4 direct-render: yes renderer: Mesa Intel UHD Graphics (TGL GT2)
    device-ID: 8086:9a78 memory: 7.33 GiB unified: yes display-ID: :0.0
  API: Vulkan v: 1.3.264 layers: 3 device: 0 type: integrated-gpu name: Intel
    UHD Graphics (TGL GT2) driver: mesa intel v: 23.2.1-arch1.1
    device-ID: 8086:9a78 surfaces: xcb,xlib,wayland device: 1 type: cpu
    name: llvmpipe (LLVM 16.0.6 256 bits) driver: mesa llvmpipe
    v: 23.2.1-arch1.1 (LLVM 16.0.6) device-ID: 10005:0000
    surfaces: xcb,xlib,wayland
Audio:
  Device-1: Intel Tiger Lake-LP Smart Sound Audio driver: snd_hda_intel
    v: kernel alternate: snd_sof_pci_intel_tgl bus-ID: 00:1f.3
    chip-ID: 8086:a0c8 class-ID: 0403
  API: ALSA v: k6.5.3-zen1-1-zen status: kernel-api tools: N/A
  Server-1: PipeWire v: 0.3.80 status: active with: 1: pipewire-pulse
    status: active 2: wireplumber status: active 3: pipewire-alsa type: plugin
    4: pw-jack type: plugin tools: pactl,pw-cat,pw-cli,wpctl
Network:
  Device-1: Qualcomm Atheros QCA9377 802.11ac Wireless Network Adapter
    vendor: AzureWave driver: ath10k_pci v: kernel pcie: gen: 1 speed: 2.5 GT/s
    lanes: 1 bus-ID: 01:00.0 chip-ID: 168c:0042 class-ID: 0280
  IF: wlp1s0 state: up mac: <filter>
  Device-2: Intel Ethernet I225-V driver: igc v: kernel pcie: gen: 2
    speed: 5 GT/s lanes: 1 port: N/A bus-ID: 02:00.0 chip-ID: 8086:15f3
    class-ID: 0200
  IF: enp2s0 state: down mac: <filter>
Bluetooth:
  Device-1: IMC Networks driver: btusb v: 0.8 type: USB rev: 1.1
    speed: 12 Mb/s lanes: 1 mode: 1.1 bus-ID: 3-1:2 chip-ID: 13d3:3503
    class-ID: e001
  Report: btmgmt ID: hci0 rfk-id: 0 state: up address: <filter> bt-v: 4.1
    lmp-v: 7 status: discoverable: no pairing: no class-ID: 6c010c
Drives:
  Local Storage: total: 238.47 GiB used: 118.13 GiB (49.5%)
  SMART Message: Required tool smartctl not installed. Check --recommends
  ID-1: /dev/sda maj-min: 8:0 vendor: Patriot model: P210 256GB
    size: 238.47 GiB block-size: physical: 512 B logical: 512 B speed: 6.0 Gb/s
    tech: SSD serial: <filter> fw-rev: 3A0 scheme: GPT
Partition:
  ID-1: / raw-size: 134.12 GiB size: 134.12 GiB (100.00%)
    used: 118.1 GiB (88.1%) fs: btrfs dev: /dev/sda6 maj-min: 8:6
  ID-2: /boot/efi raw-size: 100 MiB size: 96 MiB (96.00%)
    used: 27.7 MiB (28.9%) fs: vfat dev: /dev/sda1 maj-min: 8:1
  ID-3: /home raw-size: 134.12 GiB size: 134.12 GiB (100.00%)
    used: 118.1 GiB (88.1%) fs: btrfs dev: /dev/sda6 maj-min: 8:6
  ID-4: /var/log raw-size: 134.12 GiB size: 134.12 GiB (100.00%)
    used: 118.1 GiB (88.1%) fs: btrfs dev: /dev/sda6 maj-min: 8:6
  ID-5: /var/tmp raw-size: 134.12 GiB size: 134.12 GiB (100.00%)
    used: 118.1 GiB (88.1%) fs: btrfs dev: /dev/sda6 maj-min: 8:6
Swap:
  Kernel: swappiness: 133 (default 60) cache-pressure: 100 (default) zswap: no
  ID-1: swap-1 type: zram size: 7.5 GiB used: 1.49 GiB (19.9%) priority: 100
    comp: zstd avail: lzo,lzo-rle,lz4,lz4hc,842 max-streams: 4 dev: /dev/zram0
Sensors:
  System Temperatures: cpu: 51.0 C mobo: N/A
  Fan Speeds (rpm): N/A
Info:
  Processes: 250 Uptime: 3h 31m wakeups: 1 Memory: total: 8 GiB note: est.
  available: 7.5 GiB used: 4.74 GiB (63.2%) Init: systemd v: 254
  default: graphical tool: systemctl Compilers: gcc: 13.2.1 Packages: 1477
  pm: pacman pkgs: 1470 libs: 438 tools: pamac,paru pm: flatpak pkgs: 7
  Shell: fish v: 3.6.1 default: Bash v: 5.1.16 running-in: gnome-terminal
  inxi: 3.3.30
Garuda (2.6.16-1):
  System install date:     2023-09-15
  Last full system update: 2023-10-01 ↻
  Is partially upgraded:   No
  Relevant software:       snapper NetworkManager mkinitcpio
  Windows dual boot:       Probably (Run as root to verify)
  Failed units:

Your link goes to closed source commercial software. Ask them for help. You paid for it, right?

I notice it is Beta software and you should expect bugs. Again, it’s up to them to provide help.

1 Like

Nop, it is free.
Ok, thanks, I thought that maybe this could be something that can be fixed just knowing the error im getting. But anyway, thanks.

If someone could help, they would need the entire terminal output including the input command.
But why, you can’t open an issue on some git page.

1 Like

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.