ANyway to disable plymouth for garuda?

Hey so i wanted to disable the plymouth boot screen i dont want to follow guides for ubuntu and other distro's a black screen instead of plymouth will be acceptable a splash screen will be great

Try masking it

sudo systemctl mask plymouth-start.service
2 Likes

Now the plymouth screen appears for like 2 seconds after the dragon splash screen appears.

Also get rid of the plymouth in /etc/mkinitcpio.conf & remove splash & quiet from /etc/default/grub. Then run mkinitcpio -P && sudo update-grub and reboot afterwards.

2 Likes

I did the following but still get plymouth

Thats not possible (afaik), did you reboot?

2 Likes

yes thats how i checked if its still there

Also remove any package containing plymouth from the system (pacman -Qs plymouth lists those). Even though it should not show up anymore since its kernel parameters are disabled :eyes:
Just to be sure, output of cat /etc/mkinitcpio.conf | grep plymouth & cat /etc/default/grub | grep splash?

1 Like

I'd suggest you spend some time familiarising yourself with the resources available for Arch and Arch-derived distributions:

https://wiki.archlinux.org/title/Plymouth

The majority of questions you have asked so far have been answered already, whether on this forum, forums of other Arch-derived distros, or within the Arch wiki.

Also keep in mind that you are asking for help dismantling the defaults crafted by the Garuda maintainers so if (when) you break your setup don't expect any sympathy.

7 Likes

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.