Another NVIDIA Laptop and Arch Won't Play Nice Thread

New to Garuda but I see I'm not the only one having an issue with it and an NVIDIA laptop working. I cannot get NVIDIA working at all, actually.

I've tied the auto-installer as well as reviewed the "NVIDIA drivers don't work" thread and "Nvidia-settings ERROR" thread and have tried the various solutions to no-avail. When I reboot after installing it hits grub as normal, I select Garuda and then it gives me two lines about loading kernel, etc. Then nothing, It just hangs.

I've reverted to an earlier snapshot to get back in the system but the below is my system before I reboot after adding the NVIDIA drivers. I've also tried the LTS kernel and experience the same hang.

I'd love to stick with Gaurda if I can just get NVIDIA and Zen working correctly.

At a quick glance and not being a Nvidia user, I think that with the zen kernel you still need the ibt=off kernel boot parameter. See e.g.

Not sure why the lts doesn't work (not affected by that bug).

PS: I must say that being a first topic you might have used a different title. It doesn't sound nice to me, for the due respect to developers (I'm not one of them) and also the so many happy Nvidia users here.

Kernel: 5.19.2-zen1-2-zen arch: x86_64 bits: 64 compiler: gcc v: 12.2.0
parameters: BOOT_IMAGE=/@/boot/vmlinuz-linux-zen
root=UUID=139262e5-b3c8-4a92-915f-215f684e0f8e rw [email protected]
quiet quiet splash rd.udev.log_priority=3 vt.global_cursor_default=0
Desktop: KDE Plasma v: 5.25.5 tk: Qt v: 5.15.6 info: latte-dock
wm: kwin_x11 vt: 1 dm: SDDM Distro: Garuda Linux base: Arch Linux
Type: Laptop System: Alienware product: Alienware x17 R2 v: 1.6.0
serial: <superuser required> Chassis: type: 10 serial: <superuser required>
Mobo: Alienware model: 0FHD6K v: A01 serial: <superuser required>
UEFI: Alienware v: 1.6.0 date: 06/06/2022
ID-1: BAT1 charge: 84.4 Wh (100.0%) condition: 84.4/87.0 Wh (97.0%)
volts: 13.1 min: 11.4 model: COMPAL PABAS0241231 type: Li-ion
serial: <filter> status: full cycles: 43
Info: model: 12th Gen Intel Core i9-12900HK bits: 64 type: MST AMCP
arch: Alder Lake gen: core 12 built: 2021 process: Intel 7 (10nm ESF)
family: 6 model-id: 0x9A (154) stepping: 3 microcode: 0x421
Topology: cpus: 1x cores: 14 mt: 6 tpc: 2 st: 8 threads: 20 smt: enabled
cache: L1: 1.2 MiB desc: d-8x32 KiB, 6x48 KiB; i-6x32 KiB, 8x64 KiB
L2: 11.5 MiB desc: 6x1.2 MiB, 2x2 MiB L3: 24 MiB desc: 1x24 MiB
Speed (MHz): avg: 2900 min/max: 400/5000:3800 scaling:
driver: intel_pstate governor: performance cores: 1: 2900 2: 2900 3: 2900
4: 2900 5: 2900 6: 2900 7: 2900 8: 2900 9: 2900 10: 2900 11: 2900
12: 2900 13: 2900 14: 2900 15: 2900 16: 2900 17: 2900 18: 2900 19: 2900
20: 2900 bogomips: 116736
Flags: avx avx2 ht lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx
Type: itlb_multihit status: Not affected
Type: l1tf status: Not affected
Type: mds status: Not affected
Type: meltdown status: Not affected
Type: mmio_stale_data status: Not affected
Type: retbleed status: Not affected
Type: spec_store_bypass mitigation: Speculative Store Bypass disabled via
Type: spectre_v1 mitigation: usercopy/swapgs barriers and __user pointer
Type: spectre_v2 mitigation: Enhanced IBRS, IBPB: conditional, RSB
filling, PBRSB-eIBRS: SW sequence
Type: srbds status: Not affected
Type: tsx_async_abort status: Not affected
Device-1: Intel Alder Lake-P Integrated Graphics vendor: Dell driver: i915
v: kernel arch: Gen-12.2 process: Intel 10nm built: 2021-22+ ports:
active: eDP-1 empty: DP-1, DP-2, DP-3, HDMI-A-1, HDMI-A-2, HDMI-A-3
bus-ID: 0000:00:02.0 chip-ID: 8086:46a6 class-ID: 0300
Device-2: NVIDIA GA103M [GeForce RTX 3080 Ti Laptop GPU] vendor: Dell
driver: N/A alternate: nouveau, nvidia_drm, nvidia non-free: 515.xx+
status: current (as of 2022-07) arch: Ampere code: GAxxx process: TSMC n7
(7nm) built: 2020-22 bus-ID: 0000:01:00.0 chip-ID: 10de:2460
class-ID: 0300
Device-3: Realtek Integrated_Webcam_HD type: USB driver: uvcvideo
bus-ID: 3-7:4 chip-ID: 0bda:551d class-ID: fe01 serial: <filter>
Display: x11 server: X.Org v: 21.1.4 with: Xwayland v: 22.1.3
compositor: kwin_x11 driver: X: loaded: modesetting
alternate: fbdev,intel,vesa gpu: i915 display-ID: :0 screens: 1
Screen-1: 0 s-res: 1920x1080 s-dpi: 96 s-size: 508x285mm (20.00x11.22")
s-diag: 582mm (22.93")
Monitor-1: eDP-1 model: AU Optronics 0xbd90 built: 2021 res: 1920x1080
hz: 60 dpi: 128 gamma: 1.2 size: 382x215mm (15.04x8.46")
diag: 438mm (17.3") ratio: 16:9 modes: 1920x1080
OpenGL: renderer: Mesa Intel Graphics (ADL GT2) v: 4.6 Mesa 22.1.7
direct render: Yes
Device-1: Intel Alder Lake PCH-P High Definition Audio vendor: Dell
driver: sof-audio-pci-intel-tgl
alternate: snd_hda_intel,snd_sof_pci_intel_tgl bus-ID: 0000:00:1f.3
chip-ID: 8086:51c8 class-ID: 0401
Device-2: NVIDIA driver: snd_hda_intel v: kernel bus-ID: 0000:01:00.1
chip-ID: 10de:2288 class-ID: 0403
Sound Server-1: ALSA v: k5.19.2-zen1-2-zen running: yes
Sound Server-2: PulseAudio v: 16.1 running: no
Sound Server-3: PipeWire v: 0.3.57 running: yes
Device-1: Intel Alder Lake-P PCH CNVi WiFi vendor: Rivet Networks
driver: iwlwifi v: kernel bus-ID: 0000:00:14.3 chip-ID: 8086:51f0
class-ID: 0280
IF: wlo1 state: up mac: <filter>
Device-2: Realtek Killer E3000 2.5GbE vendor: Dell driver: r8169
v: kernel port: 3000 bus-ID: 0000:2c:00.0 chip-ID: 10ec:3000 class-ID: 0200
IF: enp44s0 state: down mac: <filter>
Device-1: Intel type: USB driver: btusb v: 0.8 bus-ID: 3-10:6
chip-ID: 8087:0033 class-ID: e001
Report: bt-adapter ID: hci0 rfk-id: 1 state: up address: <filter>
Hardware-1: Intel Volume Management Device NVMe RAID Controller driver: vmd
v: 0.6 port: N/A bus-ID: 0000:00:0e.0 chip-ID: 8086:467f rev:
class-ID: 0104
Local Storage: total: 953.87 GiB used: 21.38 GiB (2.2%)
SMART Message: Unable to run smartctl. Root privileges required.
ID-1: /dev/nvme0n1 maj-min: 259:0 vendor: Western Digital model: PC SN810
NVMe WDC 1024GB size: 953.87 GiB block-size: physical: 512 B
logical: 512 B speed: 63.2 Gb/s lanes: 4 type: SSD serial: <filter>
rev: 61520012 temp: 47.9 C scheme: GPT
ID-1: / raw-size: 440.77 GiB size: 440.77 GiB (100.00%) used: 21.28 GiB
(4.8%) fs: btrfs dev: /dev/nvme0n1p3 maj-min: 259:3
ID-2: /boot/efi raw-size: 240 MiB size: 236 MiB (98.33%) used: 107 MiB
(45.3%) fs: vfat dev: /dev/nvme0n1p1 maj-min: 259:1
ID-3: /home raw-size: 440.77 GiB size: 440.77 GiB (100.00%) used: 21.28
GiB (4.8%) fs: btrfs dev: /dev/nvme0n1p3 maj-min: 259:3
ID-4: /var/log raw-size: 440.77 GiB size: 440.77 GiB (100.00%) used: 21.28
GiB (4.8%) fs: btrfs dev: /dev/nvme0n1p3 maj-min: 259:3
ID-5: /var/tmp raw-size: 440.77 GiB size: 440.77 GiB (100.00%) used: 21.28
GiB (4.8%) fs: btrfs dev: /dev/nvme0n1p3 maj-min: 259:3
Kernel: swappiness: 133 (default 60) cache-pressure: 100 (default)
ID-1: swap-1 type: zram size: 31.03 GiB used: 0 KiB (0.0%) priority: 100
dev: /dev/zram0
Message: No sensor data found. Is lm-sensors configured?
Processes: 412 Uptime: 43m wakeups: 3 Memory: 31.03 GiB used: 4.15 GiB
(13.4%) Init: systemd v: 251 default: graphical tool: systemctl
Compilers: gcc: 12.2.0 Packages: pacman: 1814 lib: 514 Shell: fish v: 3.5.1
default: Bash v: 5.1.16 running-in: konsole inxi: 3.3.20
Garuda (2.6.7-1):
System install date:     2022-09-10
Last full system update: 2022-09-10 ↻
Is partially upgraded:   No
Relevant software:       NetworkManager
Windows dual boot:       Probably (Run as root to verify)
Snapshots:               Snapper
Failed units:
fish: Job 1, 'sudo modprobe -a nvidia' terminated by signal SIGSEGV (Address boundary error)
System install date:     2022-09-10
Last full system update: 2022-09-10 ↻
Is partially upgraded:   No
Relevant software:       NetworkManager
Windows dual boot:       Probably (Run as root to verify)
Snapshots:               Snapper
Failed units:
fish: Job 1, 'sudo modprobe -a nvidia' terminated by signal SIGSEGV (Address boundary error)
1 Like

To install Nvidia Drivers on Garuda Cinnamon edition I installed this package:

also enables switching between Intel and Nvidia GPUs

1 Like

I think you read too much negativity into my statement friend. It's apparently a common problem with Arch and I also pointed out the two other threads here mentioning the shared issue. No disrespect was intended.

Ok, I see. Sorry but we come from a battle over a GRUB bug where the finger has been pointed too many times at Garuda for something totally out of our responsibility. :handshake:

1 Like

Gave this a shot and it executed/installed. I then rebooted and could log in but it doesn't appear to actually have done anything, still no NVIDIA. Thanks for the suggestion though!

Have you tried checking if your dGPU is disabled in the BIOS?
I guess also relevant settings in Windows, if dual booting, might play a role in such cases...

Have you started the Optimus Manager?

Looks a little bit better to me :slight_smile:

1 Like

Tried but got the following message:

[email protected] in ~
╰─λ optimus-manager
ERROR: the latest GPU setup attempt failed at Xorg pre-start hook.
Log at /var/log/optimus-manager/switch/switch-20220910T140232.log
Cannot execute command because of previous errors.

I've tried with the dGPU both on and off in bios. If I turn it off, it just stalls at "Loading zen linux, loading ramdisk."

Optimus-manager log: It mentions not seeing the NVIDIA GPU on the PCbus but it does list the NVIDIA GPU in elsewhere such as on the terminal screen when I open that, it shows both GPUs.

Did you try adding ibt=off kernel parameter?


I had something similar on my second laptop, try to:

  1. Download driver from here (select OS: Linux 64bit): Official Drivers | NVIDIA
  2. Remove current Nvidia drivers (video-nvidia-dkms or similar)
  3. Reboot and during booting select advanced options, Recovery
  4. When prompt write your sudo password (you will be logged in as root)
  5. Get into folder where are your downloaded drivers in console, eg.:
cd /home/YourUsername/Downloads
  1. Use command (increase permissions of file):
chmod +xrw ./NameOfYourNvidiaDriver
  1. Run installer (just type the NameOfYourNvidiaDriver and enter)
  1. You will get 2 prompts for kernel and modules when installing : select yes
  2. Reboot after installation

After above I'am able to use Garuda with Zen (I have GTX 1650)

Haven't, will give it a shot.

I'm going to try this as well, thanks!