Amdgpu problem

Hello everyone!
I'm using KDE and Zen kernel.
I want to use vulkan but the radeon module doesn't support it,I config all the settings that were mentioned in the arch wiki, but the system still uses the radeon module.
lspci ouput:

VGA compatible controller: Advanced Micro Devices, Inc. [AMD/ATI] Thames [Radeon HD 7500M/7600M Series] (prog-if 00 [VGA controller])
        Subsystem: Dell Radeon HD 7670M
        Flags: bus master, fast devsel, latency 0, IRQ 34
        Memory at a0000000 (64-bit, prefetchable) [size=256M]
        Memory at c0000000 (64-bit, non-prefetchable) [size=128K]
        I/O ports at 3000 [size=256]
        Expansion ROM at c0020000 [disabled] [size=128K]
        Capabilities: [50] Power Management version 3
        Capabilities: [58] Express Legacy Endpoint, MSI 00
        Capabilities: [a0] MSI: Enable+ Count=1/1 Maskable- 64bit+
        Capabilities: [100] Vendor Specific Information: ID=0001 Rev=1 Len=010 <?>
        Capabilities: [150] Advanced Error Reporting
        Kernel driver in use: radeon
        Kernel modules: radeon, amdgpu

dmesg output:

[    4.235620] [drm] amdgpu kernel modesetting enabled.
[    4.235643] amdgpu: vga_switcheroo: detected switching method \_SB_.PCI0.GFX0.ATPX handle
[    4.236097] amdgpu: CRAT table not found
[    4.236108] amdgpu: Virtual CRAT table created for CPU

Hi there, welcome to the forum.
Please provide your garuda-inxi, as requested in the template.
Additionally, please describe more precisely what you did according to the Arch wiki.
What you installed, if you performed the checks in 2 Verification, etc.

1 Like

Thank you, unfortunately garuda-inxi is not installed on my system and I deleted the garuda repository, so I used the inxi command:

  Host: Scorpion Kernel: 6.2.11-zen1-1-zen arch: x86_64 bits: 64
    Desktop: KDE Plasma v: 5.27.4 Distro: Arch Linux
  Type: Portable System: Dell product: Inspiron 5521 v: A16
    serial: <superuser required>
  Mobo: Dell model: 0CH6TM v: A02 serial: <superuser required>
    UEFI-[Legacy]: Dell v: A16 date: 05/24/2018
  Info: dual core Intel Core i5-3337U [MT MCP] speed (MHz): avg: 2082
    min/max: 800/2700
  Device-1: Intel 3rd Gen Core processor Graphics driver: i915 v: kernel
  Device-2: AMD Thames [Radeon HD 7500M/7600M Series] driver: radeon
    v: kernel
  Device-3: Microdia Dell Laptop Integrated Webcam HD type: USB
    driver: uvcvideo
  Display: x11 server: X.Org v: 21.1.8 driver: X: loaded: modesetting,radeon
    dri: crocus,r600 gpu: i915 s-res: 1366x768 resolution: 1366x768
  API: OpenGL v: 4.2 Mesa 23.0.2 renderer: Mesa Intel HD Graphics 4000 (IVB
  Device-1: Realtek RTL810xE PCI Express Fast Ethernet driver: r8169
  Device-2: Intel Centrino Wireless-N 2230 driver: iwlwifi
  Local Storage: total: 465.76 GiB used: 215.08 GiB (46.2%)
  Processes: 226 Uptime: 7h 29m Memory: 11.57 GiB used: 6.76 GiB (58.4%)
  Shell: Bash inxi: 3.3.26

I followed this tutorial , I created radeon and amdgpu files in etc/modprobe.d and recompiled the kernel with mkinitcpio command.
my mkinitcpio config:

# vim:set ft=sh
# The following modules are loaded before any boot hooks are
# run.  Advanced users may wish to specify all system modules
# in this array.  For instance:
#     MODULES=(crc32c-intel intel_agp i915 amdgpu  nouveau)
MODULES=(crc32c-intel intel_agp i915 amdgpu)

# This setting includes any additional binaries a given user may
# wish into the CPIO image.  This is run last, so it may be used to
# override the actual binaries included by a given hook
# BINARIES are dependency parsed, so you may safely ignore libraries

# This setting is similar to BINARIES above, however, files are added
# as-is and are not parsed in any way.  This is useful for config files.

# This is the most important setting in this file.  The HOOKS control the
# modules and scripts added to the image, and what happens at boot time.
# Order is important, and it is recommended that you do not change the
# order in which HOOKS are added.  Run 'mkinitcpio -H <hook name>' for
# help on a given hook.
# 'base' is _required_ unless you know precisely what you are doing.
# 'udev' is _required_ in order to automatically load modules
# 'filesystems' is _required_ unless you specify your fs modules in MODULES
# Examples:
##   This setup specifies all modules in the MODULES setting above.
##   No raid, lvm2, or encrypted root is needed.
#    HOOKS=(base)
##   This setup will autodetect all modules for your system and should
##   work as a sane default
#    HOOKS=(base udev autodetect block filesystems)
##   This setup will generate a 'full' image which supports most systems.
##   No autodetection is done.
#    HOOKS=(base udev block filesystems)
##   This setup assembles a pata mdadm array with an encrypted root FS.
##   Note: See 'mkinitcpio -H mdadm' for more information on raid devices.
#    HOOKS=(base udev block mdadm encrypt filesystems)
##   This setup loads an lvm2 volume group on a usb device.
#    HOOKS=(base udev block lvm2 filesystems)
##   NOTE: If you have /usr on a separate partition, you MUST include the
#    usr, fsck and shutdown hooks.
HOOKS="base udev autodetect modconf block keyboard keymap consolefont filesystems fsck"

# Use this to compress the initramfs image. By default, zstd compression
# is used. Use 'cat' to create an uncompressed image.

# Additional options for the compressor

When I blacklist radeon, gpu is not recognized.

This could be a big problem in the future (not necessarily linked to this issue).
I'd go asap for a:

garuda-update remote fix

Then you should check this wiki article:


I read this article but it will be useful when the amdgpu driver is loaded. My problem is the switch between radeon and amdgpu.

Have you regenerated the initramfs images with:

mkinitcpio -P

Alternatively, have you tried with the kernel boot parameters:

mkinitcpio -P


kernel boot parameters

Yes, I did, but it doesn't work

I had R290 earlier, it needed those boot parameters set, to have proper support...
Can't remember anymore what it was. Apply both or try each one separately...

Though, if you look here:

It seems to NOT support Vulkan... It's generation is Northern Islands.


This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.