All desktop environments disappeared

System:    Kernel: 5.11.11-zen1-1-zen x86_64 bits: 64 compiler: gcc v: 10.2.0 
parameters: BOOT_IMAGE=/boot/vmlinuz-x86_64 lang=en_US keytable=us tz=UTC misobasedir=garuda 
misolabel=GARUDA_DR460NIZEDBLACKARCH_SOARI quiet systemd.show_status=1 
systemd.unified_cgroup_hierarchy=1 driver=nonfree nouveau.modeset=0 i915.modeset=1 
radeon.modeset=1 
Desktop: KDE Plasma 5.21.4 tk: Qt 5.15.2 info: latte-dock wm: kwin_x11 vt: 1 dm: SDDM 
Distro: Garuda Linux base: Arch Linux 
Machine:   Type: Desktop Mobo: ASRock model: 4X4-4000 Series serial: <filter> UEFI: American Megatrends 
v: P1.30 date: 11/27/2020 
Battery:   Device-1: hidpp_battery_0 model: Logitech M720 Triathlon Multi-Device Mouse serial: <filter> 
charge: 55% (should be ignored) rechargeable: yes status: Discharging 
CPU:       Info: 6-Core model: AMD Ryzen 5 4500U with Radeon Graphics bits: 64 type: MCP arch: Zen 2 
family: 17 (23) model-id: 60 (96) stepping: 1 microcode: 8600103 cache: L2: 3 MiB 
flags: avx avx2 lm nx pae sse sse2 sse3 sse4_1 sse4_2 sse4a ssse3 svm bogomips: 28447 
Speed: 2371 MHz min/max: N/A Core speeds (MHz): 1: 2371 2: 2371 3: 2371 4: 1843 5: 2371 6: 2371 
Vulnerabilities: Type: itlb_multihit status: Not affected 
Type: l1tf status: Not affected 
Type: mds status: Not affected 
Type: meltdown status: Not affected 
Type: spec_store_bypass mitigation: Speculative Store Bypass disabled via prctl and seccomp 
Type: spectre_v1 mitigation: usercopy/swapgs barriers and __user pointer sanitization 
Type: spectre_v2 
mitigation: Full AMD retpoline, IBPB: conditional, IBRS_FW, STIBP: disabled, RSB filling 
Type: srbds status: Not affected 
Type: tsx_async_abort status: Not affected 
Graphics:  Device-1: AMD Renoir driver: amdgpu v: kernel bus-ID: 05:00.0 chip-ID: 1002:1636 class-ID: 0300 
Display: x11 server: X.Org 1.20.10 compositor: kwin_x11 driver: loaded: amdgpu,ati 
unloaded: modesetting alternate: fbdev,vesa display-ID: :0 screens: 1 
Screen-1: 0 s-res: 4652x1565 s-dpi: 96 s-size: 1227x412mm (48.3x16.2") s-diag: 1294mm (51") 
Monitor-1: DisplayPort-0 res: 1920x1080 hz: 60 dpi: 30 size: 1600x900mm (63.0x35.4") 
diag: 1836mm (72.3") 
Monitor-2: DisplayPort-1 res: 1366x768 hz: 60 dpi: 60 size: 575x323mm (22.6x12.7") 
diag: 660mm (26") 
Monitor-3: DisplayPort-3 res: 1366x768 hz: 60 dpi: 60 size: 575x323mm (22.6x12.7") 
diag: 660mm (26") 
OpenGL: renderer: AMD RENOIR (DRM 3.40.0 5.11.11-zen1-1-zen LLVM 11.1.0) v: 4.6 Mesa 21.0.1 
direct render: Yes 
Audio:     Device-1: AMD vendor: ASRock driver: snd_hda_intel v: kernel bus-ID: 05:00.1 chip-ID: 1002:1637 
class-ID: 0403 
Device-2: AMD Raven/Raven2/FireFlight/Renoir Audio Processor vendor: ASRock driver: N/A 
alternate: snd_pci_acp3x, snd_rn_pci_acp3x bus-ID: 05:00.5 chip-ID: 1022:15e2 class-ID: 0480 
Device-3: AMD Family 17h HD Audio vendor: ASRock driver: snd_hda_intel v: kernel 
bus-ID: 05:00.6 chip-ID: 1022:15e3 class-ID: 0403 
Device-4: Logitech H600 [Wireless Headset] type: USB driver: hid-generic,snd-usb-audio,usbhid 
bus-ID: 2-2.1.4:9 chip-ID: 046d:0a29 class-ID: 0300 serial: <filter> 
Device-5: JMTek LLC. TKGOU PnP USB Microphone type: USB 
driver: hid-generic,snd-usb-audio,usbhid bus-ID: 2-3:4 chip-ID: 0c76:1467 class-ID: 0300 
serial: <filter> 
Sound Server-1: ALSA v: k5.11.11-zen1-1-zen running: yes 
Sound Server-2: JACK v: 0.125.0 running: no 
Sound Server-3: PulseAudio v: 14.2 running: yes 
Sound Server-4: PipeWire v: 0.3.25 running: no 
Network:   Device-1: Realtek RTL8125 2.5GbE vendor: ASRock driver: r8169 v: kernel port: f000 
bus-ID: 01:00.0 chip-ID: 10ec:8125 class-ID: 0200 
IF: enp1s0 state: down mac: <filter> 
Device-2: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet vendor: ASRock driver: r8169 
v: kernel port: ec00 bus-ID: 02:00.0 chip-ID: 10ec:8168 class-ID: 0200 
IF: enp2s0f0 state: down mac: <filter> 
Device-3: Intel Wi-Fi 6 AX200 driver: iwlwifi v: kernel port: e000 bus-ID: 03:00.0 
chip-ID: 8086:2723 class-ID: 0280 
IF: wlp3s0 state: down mac: <filter> 
Bluetooth: Device-1: Intel AX200 Bluetooth type: USB driver: btusb v: 0.8 bus-ID: 4-3:2 chip-ID: 8087:0029 
class-ID: e001 
Report: ID: hci0 state: up address: <filter> 
Drives:    Local Storage: total: 10.06 TiB used: 3.28 TiB (32.6%)
SMART Message: Unable to run smartctl. Root privileges required.
ID-1: /dev/nvme0n1 maj-min: 259:0 vendor: Crucial model: CT500P2SSD8 size: 465.76 GiB
block-size: physical: 512 B logical: 512 B speed: 31.6 Gb/s lanes: 4 rotation: SSD
serial: <filter> rev: P2CR010 scheme: GPT
ID-2: /dev/sda maj-min: 8:0 vendor: Crucial model: CT500MX500SSD1 size: 465.76 GiB block-size:
physical: 4096 B logical: 512 B speed: 6.0 Gb/s rotation: SSD serial: <filter> rev: 020
scheme: GPT
ID-3: /dev/sdb maj-min: 8:16 type: USB vendor: Western Digital model: WD easystore 25FB
size: 9.1 TiB block-size: physical: 4096 B logical: 512 B serial: <filter> rev: 3004
ID-4: /dev/sdc maj-min: 8:32 type: USB vendor: SanDisk model: Ultra Trek size: 57.28 GiB
block-size: physical: 512 B logical: 512 B serial: <filter> rev: 1.00 scheme: GPT
SMART Message: Unknown USB bridge. Flash drive/Unsupported enclosure?
Swap:      Kernel: swappiness: 10 (default 60) cache-pressure: 75 (default 100)
ID-1: swap-1 type: zram size: 5.05 GiB used: 0 KiB (0.0%) priority: 32767 dev: /dev/zram0
ID-2: swap-2 type: zram size: 5.05 GiB used: 0 KiB (0.0%) priority: 32767 dev: /dev/zram1
ID-3: swap-3 type: zram size: 5.05 GiB used: 0 KiB (0.0%) priority: 32767 dev: /dev/zram2
ID-4: swap-4 type: zram size: 5.05 GiB used: 0 KiB (0.0%) priority: 32767 dev: /dev/zram3
ID-5: swap-5 type: zram size: 5.05 GiB used: 0 KiB (0.0%) priority: 32767 dev: /dev/zram4
ID-6: swap-6 type: zram size: 5.05 GiB used: 0 KiB (0.0%) priority: 32767 dev: /dev/zram5
Sensors:   System Temperatures: cpu: 44.2 C mobo: N/A gpu: amdgpu temp: 30.0 C
Fan Speeds (RPM): N/A
Info:      Processes: 254 Uptime: 4h 04m wakeups: 42 Memory: 30.29 GiB used: 5.54 GiB (18.3%)
Init: systemd v: 248 tool: systemctl Compilers: gcc: 10.2.0 clang: 11.1.0 Packages:
pacman: 1767 lib: 336 Shell: fish v: 3.2.1 running-in: konsole inxi: 3.3.03

Hello,

Let me just lead off by saying that due to the circumstances, I cannot post my inxi -Faz, as I can't access any desktop, nor can I connect to the internet for some reason with wpa_supplicant (says there's no config file and creating one, even with sudo leads to "permission denied") which leaves the only way I could feasibly include it being to take a picture, which is understandably against forum rules.

I hope you'll consider offering whatever form of assistance that you can all the same.

I've also looked in this forum and all over Google for examples of other people experiencing this issue with very little luck, however, I'm severely hampered by only being able to use my phone.

As the subject of this post indicates when I get to the login screen, I have no desktop environments with which to log into with the one exception being Kodi, which obviously isn't very helpful for providing any way of getting back at working system. Also, I'm not certain what the normal login screen/greeter is but the one that I'm greeted with now is sddm, I believe.

In case your gut instinct is to instruct me to restore a previously created snapshot, that was my very first move. However, for some reason, despite the fact that Snapper is the very package responsible for creating the snapshots available in grub upon boot, when I enter the desktop environment after login and try to restore said snapshot, I'm greeted with a message from snapper instructing me to use Timeshift in order to restore that particular snapshot. Which is strange, because Timeshift no longer exists on my machine so it has to be Snapper that's creating them. I attributed this to (possibly) being due to the fact that when the move was made to Snapper, the name and location of the snapshots didn't change, however that hasn't kept Snapper from creating them and storing them in that very location.

Even still, I tried to boot into a snapshot that was created before Garuda moved away from Timeshift in favor of Snapper, thinking that worst case scenario, I'd just have a bunch of updating to do. However, even with Timeshift, I'm unable to get anywhere. I get a message saying the restoration completed successfully but upon reboot it's as if nothing happened at all. Same greeter. Same lack of desktop environments to log into with the exception of Kodi.

I'm kind of at a loss here, especially since I'm unable to connect to Wi-Fi and don't have any way of connecting via ethernet cable readily available to me. If that's the option I have to go then so be it. But it seems to me there's got to be some options outside of relocating my entire setup etc.

I can't remember the name of it off hand, but I did find a post somewhere where someone was having difficulty accessing their WPA supplicant config file and the eventual conclusion was that it's no longer necessary to modify, as it's handled by another package, the name of which escapes me at the moment. But upon trying to go that route it appeared as though the packaging question existed on my machine. However, getting any further than that was a fail. As such, with my fairly limited knowledge set, at least for the issue at hand, dropping to a tty doesn't do me much good.

I'm sorry to ask for assistance without providing the normal prerequisite info, as I don't really like to reach out to others for assistance with my setup at all if I can help it, but I'm really up Shit Creek here.

If you boot the liveusb you will be able to then provide inxi -Faz which will help us

3 Likes

Ok that I can do. I was under the impression that providing it after booting into a live USB would provide different results because I wasn't booting into my main NVMe drive, but you would know better than I so if it will help then I will do it.

I updated my OP to include the inxi -Faz

You use the plural for "desktop environments". Exactly how many desktop environments do you have installed on your Garuda system?

In case you were unaware, Garuda does not recommend installing multiple desktops as it can lead to issues that are not easily resolved.

Which desktops have you installed?

Have you installed all these desktops on the same user account and partition?

1 Like

I never installed any additional other than what came out of the box but if I remember correctly, Mate and maybe at one point Gnome were available from the dropdown at login. Wayland was also an option if memory serves correctly but honestly I rarely looked at them because I only ever used KDE Plasma and more recently I saved my password for automatic login because I have other safeguards in place, so I haven't even seen the greeter in a while until this happened...

Edit - after closer examination of the live environment I'm in, which is Garuda Blackarch, I honestly can't remember the last time i saw the dropdown mentioned above. All I know is that the greeter in met with now is a much different version of sddm then the one that came with the dr460nized version of Garuda that I've been running without issue for... However long it's been since it was first released.

[quote="Boognish_Mang, post:1, topic:14104"]
Hidden because I can't find any strikethrough format option but ddn't want to remove it altogether: Let me just lead off by saying that due to the circumstances, I cannot post my inxi -Faz, as I can't access any desktop, nor can I connect to the internet for some reason with wpa_supplicant (says there's no config file and creating one, even with sudo leads to "permission denied") which leaves the only way I could feasibly include it being to take a picture, which is understandably against forum rules.
[/quote]

strikethrough
regards

That's 3 Desktop Environments. Look, if you expect any help you need to tell us a whole lot more. What you did and what you did not do.

If you don't know or won't disclose, then this entire thread is meaningless. We can't help you if you cannot help us.

1 Like

Warlock!

How'd ya do it? I suspect it's the same across boards but my system issues were keeping me from going on fun little jaunts/falling down rabbit holes like that atm

Discourse makes it easy. s and /s each between closed brackets

See the edit to my previous post no additional desktop environments were installed. Maybe a better title would have been "ANY desktop environments" or even just "my desktop environment disappeared"

Point is, at login. The greeter has a dropdown, from which Kodi is the only option. At the very least, KDE Plasma was also there before because that's what I've been using exclusively since as long as I can remember but now it's not

I'm not trying to be difficult. Please let me know what I can do to help or shed any more light. I'm an open book and will not purposely hold back anything from disclosure of it will help get me back to a working state

Edited to say that I've been trying to go back through my memory to figure out what I might've done... The only thing that sticks out is that I tried to reinstall pulseaudio and a pipewire-pulse package as I was getting conflicts keeping me from upgrading, so I can fairly confidently say that an outright upgrade isn't what caused the problem

Kodi is a totally different entertainment environment YOU installed. Actually, there's a very easy way to get back to KDE. Unfortunately, I cannot remember it. Guess you'll have to do a little research. And don't install things you don't understand, then expect others to fix it for you.

I'm Day 4 Smoke Free.

EDIT: Start here Kodi - ArchWiki

2 Likes

Go to tty and install plasma-workspace

2 Likes

First off, congrats on day 4 off cigs. I can totally sympathize and won't hold any grumpiness against you.

That said, I understand what Kodi is. The only reason I mentioned it at all is that currently, it's the only thing I'm able to log into (normally I only ever access Kodi as a program and never log into it in this way)

It's as if kwin and KDE no longer exist.

I really didn't install anything. I normally know what's happened when issues arise because I have enough computer savvy at this point to know when what I'm doing might cause me to bork my setup but I didn't do anything but remove a couple of packages that were conflicting...

kodi and kodi-standalone are two different beasts. :wink:

Look, I haven't done what you just did in years. But I did do it, too. I have made more dumb mistakes than any other person in this forum, I would bet, dollars for donuts. That's why I understand.

Look, there's a spirit of being in charge of your operating system among Arch or other advanced Linux users. We try to understand what we are going to do before we do it, generally understand the procedures and consequences, and own what happens.

When we do ask for help--which is absolutely the last thing we do, we have done exhaustive research and tell everyone all about it. Everything we have searched, tried, read, we provide journals, yada, yada, yada. In brief, we do everything within our power to help others help us.

This problem could have been solved by the 4th post. @tbg's.

You have been here awhile. You'll get it. You will. :wink:

2 Likes

I have to move the my machine to someplace where I can access an Ethernet cable. I'll report back once I've done so.

Thank you

I'd start booting to tty and uninstalling Kodi and any other package you'll find after starting with that name.
I see it is a very extensive and complex "environment", that can be run in several ways and even with no DE at all, which sounded to me as a hint of guilt.
Then I'd reinstall plasma as said.

2 Likes

I get what you're saying and in my first post I tried to express that I genuinely do hate to reach out to others for any kind of assistance, because like most of those here I'm sure, I prefer to roll up my sleeves and figure out whatever problem I'm up against for myself. Not just with my computer/OS but with everything I own and anything I use. There's nothing that falls outside of this DIY mindset umbrella. The shit of it is, chances are good that had I been just a bit more patient, my nearly perfect stretch of solving any issues that crop up since day 1 of becoming a Linux user on my own could have remained completely in tact. In fact, despite the fact that I created this post, it hasn't really helped anything (not for a lack of trying, and I thank all of you that have) so I may well still be able to wear the "100% self sufficient Linux user of X years" badge but damnit, I was tired and lacking resources or a clue and had a moment of weakness. But I get it and I know that help vampires abound, so it's all gravy.

One of the inherent downsides of being entirely self-sufficient with no safety net or phone a friend to speak of, is that there's no standardization in how one learns the ins and outs of how to properly maintain a Linux operating system, so while one might become proficient at one difficult to surmount task, they might be lacking in another area that might seem like a cakewalk to others because they simply hadn't been faced with an issue like it before. Sure, Arch-wiki will always be there for you but A) it's a little drab and B) while extensive, doesn't always have all the answers in the same way a dynamic community of other like-minded and well-experienced people do. I never expect anyone to do anything for me, far from it. It's more like I'm shocked if/when it were to happen. But beaten and downtrodden, I was looking for some pointers. If I came across as so many do, entitled or unwilling to put forth effort of my own, I assure you it was simply a failure to communicate properly. Such is the way with text-based communication.

All of that said, I was able to chroot from the USB live environment to circumvent the no internet within tty on my main setup issue. On that note, @librewish - plasma-workspace was still present but I thank you for the suggestion.

My inaccessible system is in the midst of a full upgrade/update, so fingers crossed once that's done, I'll have a working system again. Provided it completes the process before encountering any unexpected errors :crossed_fingers:

1 Like

Hey, I apologize if I come at you with full teeth bared. Everyone needs a little help from time to time. Everyone.

I tend to find voluminous posts tl:dr. They either fail to adequately describe the real problem, or there is so much text the problem is hidden amongst it. Yours were both.

Many of us like descriptive stuff:

  1. I did A and my system boots to a GRUB prompt.
  2. I did B and tried to reverse it. It failed.
  3. II read this--here's the link
  4. It failed.
  5. I tried that--here's the link.
  6. It failed.
  7. Here's my inxi
  8. Here's my journal.

This community is jam packed with very knowledgeable people and outputs so much in the way of solutions and bug reports, it's rare that someone can't be helped right away, if helpers can discern the root of the problem. If.

Arch can be a real bear. Fortunately for you, you run Garuda and it's well put together for you.
Kodi can be a real bear. We had no idea even what DE(s) you had installed--we saw kwin in your inxi--but you talked of Mate & GNOME. And then Plasma. It wasn't until late in the game you disclosed you had installed Kodi.Then and only then could we begin trying to help. It was like pulling teeth.

I know I'm old and I'm grumpy. Most people don't care for me much at all. But I'll help anyone that tries to help themselves a bit. I even help little old ladies (like my wife) across street corners. And most of us here will, too. Regardless of experience. That's how we get experience. Fail, fail, fail, OMG--it worked! It means we're not afraid of Linux.

You will, too.
:slight_smile:

EDIT: Just wanted to remark--for the record--that the reason fairly experienced (terminology) Linux users rarely post in help columns is not because they are "100% self sufficient Linux users of X years."

It means we did not research the problem and solutions well enough. It means we fell flat on our face and had a Homer moment. Doh! (i.e. the Archlinux Forums where I'm the baby.)

I certainly understand that and appreciate you not being one. It is all gravy.
:smiley:

2 Likes

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.