Alacritty failed

Alacritty doesnt open on my lxqt-kwin garuda

Welcome :slight_smile:

Use other terminal/konsole and start alacritty

alacritty

Post the (error) log, please.

BTW, work fine here in i3wm.

1 Like

Possibly because your GPU is not capable to run it.

  • If you have dual GPU, try to run it with the strongest one. For example:
# With a nvidia GPU with nvidia driver, use prime-run
prime-run alacritty
# With an AMD GPU, or a nvidia GPU with nouveau driver, use DRI_PRIME
DRI_PRIME=1 alacritty
  • If you have no powerful GPU, try this:
LIBGL_ALWAYS_SOFTWARE=1 alacritty
  • Or don't use alacritty and use qterminal, which works fine for me.
1 Like

Thank you guys

I solve it with:

nano /etc/environment

This file is parsed by pam_env module

Syntax: simple "KEY=VAL" pairs on separate lines

adding this line:

LIBGL_ALWAYS_SOFTWARE=true

Thank you so much

Be aware that this setting affects the whole system, it's not alacritty specific.
The proper way is to create a local desktop file with this prepended to the command.
Better investigate the other options I posted to find a better method, if there is one.

2 Likes

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.