Age Old Enigma --- Mouse Cursor / Pointer Invisible In A Virtual Machine

Hello.

INXI

Is it acceptable to post my inxi ^^^ as a link instead of plain text/block? I will know for future reference. thanks

I am having the age old enigma of the infamous mouse /curosr pointer invisibility in a virtual machine.

I haven't had to research this in a year or so. Any help would be appreciated. This invisible cursor issue happens on gnome-boxes and virt-manager on my machine here now. Fresh install of Garuda KDE Dr460nized. I've tried virt-manager and gnome-boxes with the same result. Invisible mouse pointer. I'm posting this as I am leaving out for errands and will check back in very very soon here to see replies and hopefully instant fixes. :wink: This is so agitating. Happens on any distro so I've learned. I've had to deal with this before and I can not remember the FIX right off hand. uuggghh

My searches proved empty so far. I find millions of posts online from people with the same issue... but no real solutions that work for me. Seems ridiculous. I will report back here with everything I have tried. SO far in gnome-boxed there are no settings to even edit in the GUI. virt-manager: I have added a usb device ... tried using a tablet... and a few other things. I will give more perfect details of what I've tried. Right now it has given me a headache. I've tried using an Apple Magic Trackpad 2 and several run of the mill usb mice. No dice with any of them.

If you need more info I will certainly provide it.

Thank You for checking out this post.

Enjoy,
-Cannabis

If you're running Garuda in a VM, you were forewarned about performance issues before you even downloaded it. It's plastered everywhere. Your post is so full of "PANIC" it is hard to tell where you are coming from.

Anyway, Garuda is not at its best in a VM and is not 'officially' supported which mean you won't get official support but that does not preclude help from non-team members. :slight_smile:

VMs and Dual-boots. Verboten! :wink:

Just for testing purposes, are you willing to try VirtualBox? Never had one single issue with cursor for all distros and Garuda is BLAZING fast in VMs with 3D acceleration turned on (at least in VirtualBox it is).

1 Like

Ok, noted for sure. Indeed poor performance in a VM. I am only testing some things and it is any distro I install in VM at this point. I have tried garuda-sway/KDE & debian stable and testing & fedora... nothing. No pointer. but the mouse IS working. I can blindly click on items. No cursor visible. :frowning:

NOTE: I only use VMs for checking out some new configs for ( for XYX Application ) and so on. I expect poor performance in a VM. But I need them for testing.

Thank for the info @c00ter

Enjoy,
-Cannabis

Yes. I will install virtualbox and give it a go. I shall report back here in a couple of hours with results in virtualbox.

Thank & Enjoy,
Cannabis

The poor performance is mostly cuz 3D acceleration is not turned on, or you have either some quite slow hardware or really bad VM configuration. I tested this feature (3D, OpenGL) and made comparison not long ago, including in Proxmox which is QEMU based too (Proxmox doesn't have OpenGL capabilities, I opened an enhancement on that).
VirtManager had a bug recently and it couldn't be turned on, not sure if it's fixed.
GnomeBoxes I can't remember if it uses good acceleration.

Awesome man and plz turn on that one and only checkbox for 3D Acceleration in VBox, you'll see what I mean. :smiley:
If you need guidance on where to find, lemme know!

1 Like

just to chip in - been using virtualbox for years, and in addition to 3d acceleration not being check by default, its worth checking how many cores of your processor are used too, 'cause the default seems to be just one (I always put it up to half the actual cores, so i use 4 when the laptop actually has 8, no noticeable effect on the actual os, but the vm works a lot better!)

3 Likes

Update

  • Tried virtualbox [ same exact issue - invisible cursor ]
These are the front ends I've tried
  • Gnome Boxes
  • virt-manager
  • virtualbox
hmmmph
  • I've changed so many settings now... So, I start afresh and go into trouble-shooting mode.
Still no obvious solution.
Thoughts (light-bulb-moment) :bulb:
  • What spice/vda agents (package names ?) are to be installed on the Guest?
  • I wonder if this could be related to my Host GPU/Driver? amdgpu with Radeon

Moving right along. I will do more research and report back. Thanks for all the suggestions so far. Seems to point to something other than the specific virt front-end. IE: Gnome-Boxes / virt-manager / virtualbox

Now I am not so much looking in the settings for the front-ends as much as looking into a system-wide cause for the invisible cursor/pointer in every virtual machine I have using virt-manager / gnome-boxes / virtualbox

1 Like

I see what you mean by "Age Old Enigma"--a quick web search for this issue yields what seems like a million hits, going back a decade. :face_with_spiral_eyes:

Does the cursor remain invisible if you force it to take a new shape? (Grab a window border to move the window is the first thing that comes to mind.)

1 Like

Yes. It remains invisible in that case as well as any case/condition at all so far.

And that is not an eternity in Linux? Hmm?

Oh yeah--that was OT. Sorry.

1 Like

You're right, it's definitely not related to QEMU, Virt or whatever, it seems no matter the Type 2 Hypervisor technology you use you get the same issue. Daaaaamn, that sucks.

What mouse settings are you using in your VM softwares, PS/2, USB-alike, other?
Have you tried playing with those default settings?

Yes, I've tried mouse settings as USB & EV Tablet as well as deleting hardware and reAdding items such as mice / input / tablet in virtualbox and virt-manager.

Note: No detailed choices in gnome-boxes AFAIK

Yeah Gnome Boxes is meant to be very very simple so no surprise there doesn't seem to be any specific settings for that.

I totally understand your frustration, I use VMs every single day and would have killed someone with such a problem.

Maybe it's related to your mouse on your real hardware, if you use a Bluetooth mouse maybe you could try a USB (wireless or wired, whichever) and vice-versa?

2 Likes

I've tried BT and USB with several brands Mice / Tablets. All the same result - Invisible Cursor Pointer. Invisible, but still working.

Okok, that's a tough one, man. I'm not ready to give up yet. Couple of more questions fired up:

  • Long shot, but do you have access to another iMac to try that out?
  • Could it be iMac related? You know with the BIOS and stuff...
  • Very long shot, could it be related to crypting your disk?
  • Wha'bout trying a different kernel?
  • You fixed this issue in the past, as you said. Any reason you think brought it back?
  • And by any chance, you really do not remember any detail of what you did to fix it? In case that would give us a hint, even as small as it could be.
1 Like

No.

Ruled Out. No.

Same result with several kernels.

Fresh OS Install & Initial Setup of virtual machine front-ends.

It has been a few years since this last crept up on me. If memory serves these items
come to mind:

  • $USER not belonging to the proper groups
  • libvirtd.service not running or throwing errors
  • kvm / qemu not [ properly installed | installed ] something something...
  • Settings in the front ends virt-manager gnome-boxes virtualbox
  • Now you have me thinking...

I have some things to check.

Peace! :peace_symbol:

1 Like

Update: Houston, we have visible pointer! We are a go. :grin:

Good News / Bad News...

  • good: We have pointer!

  • bad: It will be difficult to point to one magic bullet that solved this.

I will post the best Summary I can here including some of the steps
I took while troubleshooting.

  • Where I am now...

[ Tested with several different distros & ISOs in all three frontends ]

gnome-boxes --- 100% --- Yes Pointer

virt-manager --- 100% --- Yes Pointer

virtualbox --- Fail --- Still No Pointer

For now, I'm good!
I hardly ever use virtualbox anyways.
But I will continue to try to solve this.

I basically followed this outline to start fresh troubleshooting:

Thanks especially -> @FGD for making me think harder.

:bulb: Steps I should have taken:

  1. Install frontend of choice: virtualbox virt-manager gnome-boxes

  2. Garuda Assistant -> System Components -> Virtualization Section
    and check/tick everything.

    If you don't plan on using virtualbox you can leave the two related virtualbox
    tick boxes un-ticked.

  3. Click Apply

  4. Reboot...

Basically it slipped my mind concerning Garuda Assistant having Virtualization settings.
I suspect this would have went much smoother using the provided tool to begin with.

Enjoy,
-Cannabis

2 Likes

You would if you'd see how fast Guests are with 3D Acceleration enabled. :smiley:

It's awesome you made it work, finally! I'm still puzzled as to how it happened, when I install a fresh Garuda or any other distro I install Virtualbox and I don't need to tick anything anywhere in the KDE System Settings or any other distro settings and it works OOTB. I don't need to add the user to any group as well.

I just can't picture why this kept hitting on you. :frowning:

But now you know the solution so next time if you forget again, just come back on this thread for the solution. lollll

Happy VMing, man! :smiley:

3 Likes

I use 3d accel in virt-manager & gnome-boxes. I feel quite @home in either.

Somehow, someway... virtualbox alway has some kinks/quirks for me...
call it voodoo. :magic_wand: :slight_smile:

So I stick to what works and move on.
tbh, I've never spent too much time troubleshooting/setting-up virtualbox.

Not sure but I always have to tweak/check something on a fresh OS/linux install
concerning setting up virt. gnome-boxes will just run for me, usually.
At least a reboot is needed to start the libvirt daemon and so on. :man_shrugging: : Anyhoo...

Remember, I have had this Invisible Cursor In A Virtual Machine curse hit me many many times on this machine. Always on a Fresh OS Install + Setting up virt.
Maybe this is a GPU thing. Something particular to this machine for sure.

  • I'm curious to compare the groups your $USER belongs to my $USER, for kicks and grins.
 ╰─λ groups
sys scanner vboxusers cups libvirt sambashare realtime video lp kvm input wheel
  • Note: Thinking outloud here... I am starting to suspect that my GPU/driver combination, which does have it's quirks... [ AMD Amythest R9 m395 m395x Radeon using amdgpu kernel driver ] ...may be playing some part here.

Peace

1 Like