After updating NVIDIA Drivers system stops booting

After updating to the latest NVIDIA Drivers from 495.46-2 to 510.47.03-3 my system stops booting at "loading Linux linux-zen ... loading initial ramdisk ..."
my only solution was to restore the latest snapshot before updating.

What can I do?

System:
Kernel: 5.16.4-zen1-1-zen x86_64 bits: 64 compiler: gcc v: 11.1.0
parameters: BOOT_IMAGE=/@/boot/vmlinuz-linux-zen
root=UUID=4f0eab9e-11eb-46b1-9225-e06b0439042f rw [email protected]
quiet splash rd.udev.log_priority=3 vt.global_cursor_default=0 loglevel=3
Desktop: KDE Plasma 5.23.5 tk: Qt 5.15.2 info: latte-dock wm: kwin_x11
vt: 1 dm: SDDM Distro: Garuda Linux base: Arch Linux
Machine:
Type: Desktop Mobo: ASRock model: Z370 Pro4 serial: <superuser required>
UEFI-[Legacy]: American Megatrends v: P1.70 date: 01/29/2018
Battery:
ID-1: hidpp_battery_0 charge: 24% condition: N/A volts: 3.7 min: N/A
model: Logitech G903 LIGHTSPEED Wireless Gaming Mouse w/ HERO type: N/A
serial: <filter> status: Discharging
CPU:
Info: model: Intel Core i7-8086K bits: 64 type: MT MCP arch: Coffee Lake
family: 6 model-id: 0x9E (158) stepping: 0xA (10) microcode: 0xEA
Topology: cpus: 1x cores: 6 tpc: 2 threads: 12 smt: enabled cache:
L1: 384 KiB desc: d-6x32 KiB; i-6x32 KiB L2: 1.5 MiB desc: 6x256 KiB
L3: 12 MiB desc: 1x12 MiB
Speed (MHz): avg: 4352 high: 4399 min/max: 800/5000 scaling:
driver: intel_pstate governor: performance cores: 1: 4301 2: 4386 3: 4399
4: 4399 5: 4348 6: 4379 7: 4399 8: 4301 9: 4299 10: 4300 11: 4364
12: 4356 bogomips: 95999
Flags: avx avx2 ht lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx
Vulnerabilities:
Type: itlb_multihit status: KVM: VMX disabled
Type: l1tf
mitigation: PTE Inversion; VMX: conditional cache flushes, SMT vulnerable
Type: mds mitigation: Clear CPU buffers; SMT vulnerable
Type: meltdown mitigation: PTI
Type: spec_store_bypass
mitigation: Speculative Store Bypass disabled via prctl
Type: spectre_v1
mitigation: usercopy/swapgs barriers and __user pointer sanitization
Type: spectre_v2 mitigation: Full generic retpoline, IBPB: conditional,
IBRS_FW, STIBP: conditional, RSB filling
Type: srbds mitigation: Microcode
Type: tsx_async_abort mitigation: TSX disabled
Graphics:
Device-1: NVIDIA TU106 [GeForce RTX 2070] vendor: Gigabyte driver: nvidia
v: 495.46 alternate: nouveau,nvidia_drm bus-ID: 01:00.0 chip-ID: 10de:1f02
class-ID: 0300
Display: x11 server: X.Org 1.21.1.3 compositor: kwin_x11 driver:
loaded: nvidia unloaded: modesetting alternate: fbdev,nouveau,nv,vesa
display-ID: :0 screens: 1
Screen-1: 0 s-res: 3440x1440 s-dpi: 109 s-size: 802x333mm (31.6x13.1")
s-diag: 868mm (34.2")
Monitor-1: DP-0 res: 3440x1440 dpi: 87376 size: 1x1mm (0.0x0.0")
diag: 1mm (0.1")
OpenGL: renderer: NVIDIA GeForce RTX 2070/PCIe/SSE2
v: 4.6.0 NVIDIA 495.46 direct render: Yes
Audio:
Device-1: Intel 200 Series PCH HD Audio vendor: ASRock
driver: snd_hda_intel v: kernel bus-ID: 00:1f.3 chip-ID: 8086:a2f0
class-ID: 0403
Device-2: NVIDIA TU106 High Definition Audio vendor: Gigabyte
driver: snd_hda_intel v: kernel bus-ID: 01:00.1 chip-ID: 10de:10f9
class-ID: 0403
Device-3: Logitech G935 Gaming Headset type: USB
driver: hid-generic,snd-usb-audio,usbhid bus-ID: 1-1:2 chip-ID: 046d:0a87
class-ID: 0300
Sound Server-1: ALSA v: k5.16.4-zen1-1-zen running: yes
Sound Server-2: PulseAudio v: 15.0 running: no
Sound Server-3: PipeWire v: 0.3.44 running: yes
Network:
Device-1: Intel Ethernet I219-V vendor: ASRock driver: e1000e v: kernel
port: N/A bus-ID: 00:1f.6 chip-ID: 8086:15b8 class-ID: 0200
IF: enp0s31f6 state: up speed: 1000 Mbps duplex: full mac: <filter>
IF-ID-1: nordlynx state: unknown speed: N/A duplex: N/A mac: N/A
Drives:
Local Storage: total: 3.64 TiB used: 268.46 GiB (7.2%)
SMART Message: Unable to run smartctl. Root privileges required.
ID-1: /dev/nvme0n1 maj-min: 259:0 vendor: Crucial model: CT1000P1SSD8
size: 931.51 GiB block-size: physical: 512 B logical: 512 B
speed: 31.6 Gb/s lanes: 4 type: SSD serial: <filter> rev: P3CR013
temp: 31.9 C scheme: MBR
ID-2: /dev/sda maj-min: 8:0 vendor: Toshiba model: DT01ACA200
size: 1.82 TiB block-size: physical: 4096 B logical: 512 B speed: 6.0 Gb/s
type: HDD rpm: 7200 serial: <filter> rev: ABB0 scheme: GPT
ID-3: /dev/sdb maj-min: 8:16 vendor: Samsung model: SSD 860 EVO 1TB
size: 931.51 GiB block-size: physical: 512 B logical: 512 B speed: 6.0 Gb/s
type: SSD serial: <filter> rev: 3B6Q scheme: MBR
Partition:
ID-1: / raw-size: 492.06 GiB size: 492.06 GiB (100.00%)
used: 268.46 GiB (54.6%) fs: btrfs dev: /dev/nvme0n1p2 maj-min: 259:2
ID-2: /home raw-size: 492.06 GiB size: 492.06 GiB (100.00%)
used: 268.46 GiB (54.6%) fs: btrfs dev: /dev/nvme0n1p2 maj-min: 259:2
ID-3: /var/log raw-size: 492.06 GiB size: 492.06 GiB (100.00%)
used: 268.46 GiB (54.6%) fs: btrfs dev: /dev/nvme0n1p2 maj-min: 259:2
ID-4: /var/tmp raw-size: 492.06 GiB size: 492.06 GiB (100.00%)
used: 268.46 GiB (54.6%) fs: btrfs dev: /dev/nvme0n1p2 maj-min: 259:2
Swap:
Kernel: swappiness: 133 (default 60) cache-pressure: 100 (default)
ID-1: swap-1 type: zram size: 31.29 GiB used: 2.5 MiB (0.0%)
priority: 100 dev: /dev/zram0
Sensors:
System Temperatures: cpu: 43.0 C mobo: N/A gpu: nvidia temp: 50 C
Fan Speeds (RPM): N/A gpu: nvidia fan: 0%
Info:
Processes: 300 Uptime: 9m wakeups: 2 Memory: 31.29 GiB
used: 4.6 GiB (14.7%) Init: systemd v: 250 tool: systemctl Compilers:
gcc: 11.1.0 clang: 13.0.0 Packages: pacman: 1842 lib: 546 Shell: fish
v: 3.3.1 default: Bash v: 5.1.16 running-in: konsole inxi: 3.3.12
Garuda (2.5.4-1):
System install date:     2022-01-13
Last full system update: 2022-02-01
Is partially upgraded:   Yes
Relevant software:       NetworkManager
Windows dual boot:       <superuser required>
Snapshots:               Snapper
Failed units:

Hi there, welcome.
Have you tried anything from this tutorial? To further update, but especially to see errors appearing after startx or sudo dkms autoinstall from TTY.

3 Likes

I'd install the frogging family drivers. They have never failed me.

I have the same issue. Neither current nor previous nvidia-dkms module is compiling against the new kernel.

#Realtalk, Garuda uses cutting-edge kernel. Zen always just a step behind the mainline.

That means Nvidia is not fast enough regarding the release of their proprietary drivers to keep up. It is just the nature of the beast, as the driver is behind closed doors @Nvidia and not a community project.

So I really want to highlight here what Linux Torvalds feels about Nvidia: Linus Torvalds: Nvidia, Fuck You! - YouTube <-- 10 years old video now, never gets old.

5 Likes

This still has legendary status, I absolutely agree! :face_with_hand_over_mouth:

3 Likes

Same problem here. Did you find a solution?

Hi, it is working perfectly fine here, on NVIDIA RTX 3060 mobile. My inxi

So, this problem is device specific. Kindly open a new topic for help, with output of

garuda-inxi

attached.

2 Likes

That driver is out of date nvidia 510.54-1 is in testing

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.